2 Probleme

Dieses Thema im Forum "Hardware" wurde erstellt von sndryczuk, 10. Februar 2002.

  1. sndryczuk

    sndryczuk New Member

    Ich kann nicht mehr unter 10.1 auf meiner externen FW-Platte starten.
    Es erscheint ein schwarzer Bildschirm mit der Info:

    /etc/master.passwd: No such file or directory
    IoKernelDebugger: Debugger attached

    Was ist das jetzt?

    Gut, fsck sagt mir, dass das Volume okay ist. Bei reboot startet 10.1.2 von meiner internen Platte.

    Eine andere Sache:
    Meine FW-Platte schaltet sich nach einer bis zwei Stunden , obwohl das Volume mit iTunes im Betrieb ist, selbstständig aus. Ich hatte das Problem schon einmal. Wurde aber gelöst mit einem neuen Jumper. Sie lief wie am Schnürchen.

    Ich glaube, beide Probleme haben nichts miteinander zu tun, oder?
     
  2. kegon

    kegon New Member

    Hallo,

    hmmm, das FW-Volume würde ich mal mit DiskWarrior behandeln. Wann hast Du auf dem externen Volume das letzte mal das Prebinding erneuert? Gibts auf dem Volume viel traffic?

    Tja, zu dem iTunes Problem kann ich nur mutmaßen... Kann es sein, dass Du soviel RAM hast, dass fast die ganze Playlist geladen werden kann ? Oder wird die eh ins VM geswapt wenn iTunes gestartet wird? Hört iTunes auf zu spielen wenn die Platte in den Ruhezustand übergeht? Gruss kegon
     
  3. sndryczuk

    sndryczuk New Member

    Hi kegon,
    nein, dass war es nicht. Es war ein Verzeichnisfehler. Das heisst die Aliasse cores, etc, mach, var... waren zum Teil verschwunden. Warum weiß ich nicht, da ich das FW-Volume als Backup für X verwende.
    Gut, ein Freund hat das Online für mich hingebügelt - mit meiner IP-Nummer und seinem UNIX-Wissen.

    Hierzu der Text

    Welcome to Darwin!
    [localhost:~] hartmut% cd /Volumes/[fw]Kopie X
    [localhost:/Volumes/[fw]Kopie X] hartmut% cd private
    [localhost:/Volumes/[fw]Kopie X/private] hartmut% ls
    Drivers cores etc tmp var
    [localhost:/Volumes/[fw]Kopie X/private] hartmut% ln -fhs var /Volumes/[fw]Kopie X
    [localhost:/Volumes/[fw]Kopie X/private] hartmut% ln -fhs tmp /Volumes/[fw]Kopie X
    [localhost:/Volumes/[fw]Kopie X/private] hartmut%

    Das Alias-Verzeichnis verwies nicht mehr auf dem Originalordner "private". Also musste alles neu verlinkt werden.

    Zu iTunes: nein mit RAM hat das nichts zu tun. Ja, iTunes hörte auf zu spielen, als sich die Festplatte ausgeschaltet hat.

    Merkwürdigerweise läuft sie aber jetzt wieder wie am Schnürchen - seit Stunden. Zum Glück.

    Warum das passiert ist, würde ich auch gern wissen. Am Energiesparmodus liegt es nicht . Der ist aus.

    Der Freund, der das online hingebogen hat, mutmasst den Grund des Verschwinden der Aliasse im 9er System. (Aber er hat ohnehin die Meinung, dass 9 auf die Dauer das Xer-System beschädigt). Fragt mich aber nicht warum.

    Wie dem auch sei: es funktioniert wieder alles. Also auf zu neuen Problemen.
     
  4. kegon

    kegon New Member

    Moin,

    na gut, dass das wieder in Ordnung ist. Die Aussage Deines Freundes/Bekannten ist hoch interessant. Bin der gleichen Meinung wie er. Es ist glaube ich so, dass viele Pflegetools und andere Anwendungen unter 9 keine UNIX-Aliase (anderes Verfahren) erkennen und diese daher (sicher ist sicher;) löschen oder überschreiben. Wahrscheinlich war das auch bei Dir der Fall. Habe mir schon lange abgewöhnt, den Classicmode zu starten, eben wegen diesem blöden Gefühl, dass hinterher das X zickt. Zum Glück brauche ich Classic auch nicht mehr.

    Vielen Dank für das Feedback

    Gruss kegon
     
  5. sndryczuk

    sndryczuk New Member

    Obwohl nach wie vor alles läuft, muss ich doch seriöserweise mich selbst korrigieren: der UNIX-Text den ich für das Verlinken der Alias-Dateien eingegeben habe, ist falsch.
    Mein guter UNIX-Geist hat meine eingegebenen Kommandos hier gelesen und gesagt: so stimmt das nicht. Vielleicht sendet er mir mal seine Korrekturen und den richtigen Kommando-Text.
     
  6. Giadello

    Giadello New Member

    Wäre bestimmt auch für andere interessant - ich spiele auch mit dem Gedanken, mir irgendwann mit Feuerdraht mehr Luft zu verschaffen. Und dann wüßte ich schon, wo ein Feuerlöscher steht ;) ...
     
  7. Kate

    Kate New Member

    Die Aliasdateien des X Filesystemes sind eigentlich unsichtbar, da kann man selber gar nichts machen, jedoch gewisse Tools der OS9 Seite könnten da die Aliasse löschen, z.B. Norton ist so ein Kandidat. Es empfiehlt sich grundsätzlich keine Reparaturtools zu verwenden, die mehr als nur das Filesystem reparieren. DiskWarrior ist prima, Norton eben für X noch nicht. Selbst Norton für X macht da z.Zt. einiges falsch.
    Ansonsten ist ein FW Disk eine feine Sache unter X, sicher, schnell, stabil und bootfähig.

    ach ja, um die Links wiederherzustellen muss man etwa folgendes (im Terminal) tun:
    Ins Verzeichnis des FireWireLaufwerkes wechseln:
    cd /Volumes/NamederFWDisk
    und dann:
    ln -s private/etc etc
    ln -s private/etc var
    ln -s private/cores cores
    ln -s private/tmp tmp
    mkdir /Volumes/NamederFWDisk/dev /Volumes/NamederFWDisk/Volumes

    NamederFWDisk ist natürlich der Name Deiner FireWire Disk.
     
  8. sndryczuk

    sndryczuk New Member

    Danke. (Mit der Korrektur hätte wahrscheinlich noch gedauert).
    Einer der Vorteile von Tinker Tools ist, dass man bei solchen Konflikten unsichtbare Dateien sichtbar machen kann. (Im Normalfall nicht zu empfehlen, da das nur irritiert). Man kann den Ordner "private" auch öffnen, indem man oben im Menü "Gehe zu Ordner" anklickt und dann den Ordner "/private" eingibt.

    Praktisch haben wir das so gelöst, dass wir die unsichtbaren Dateien beider Festplatten (Startvolumes X) verglichen haben . Bei dem Backup-System auf der FW-Platte wurde dann schnell klar, dass die wichtigen Aliasdateien fehlten, die auf der internen natürlich da waren (sonst hätte ich ja nicht starten können).
     
  9. kegon

    kegon New Member

    Hallo Kate,

    Du scheinst ja echt fit zu sein, daher die folgende Frage:

    Wenn man nem Windowsuser den Zugriff auf eine der eigenen Partitionen erlaubst, können die alles sehen. Das verwirrt die Brüder (alles gedungene IT-Berater) arg und sie fangen an wild hin und her zu kopieren und zu korrigieren. Kann man die Ansicht von aussen auch verschlanken? Wenn ja, wie?

    mata nee

    kegon
     
  10. Kate

    Kate New Member

    Hast Du AppleShare auf X oder X-Server?

    Bei AppleShare auf normalem X kannst Du die freigegebenen Ordner über die Permissions so einstellen, dass nur ein Ordner, bzw. eine Datei sichbar (lesbar) ist.

    Dazu kann man einen längeren Ausflug ins Terminal unternehmen, oder die Freeware BatCHmod nutzen, die das gleiche etwas intuitiver leistet. Weitere Hilfe kann man mit SharePoints (auch kostenlos) leisten, da kann man ganz einfach einen bestimmten Ordner auf der Platte für das Filesharing freigeben und die Rechte gleich mitverwalten. Ist allerdings etwas unübersichtlich und in Englisch.

    Bei beiden Tools muss man aber aufpassen was man macht, sonst stimmen die Rechte hinterher nicht und man muss mit den Gruppen, Benutzern und Shares jonglierren. User sollte man lieber mit NetInfo anlegen und ändern, aber da muss man auch etwas aufpassen. Es ist alles ein wenig unübersichtlicher als das alte Benutzer/Gruppen-Kontrollfeld.

    Wenn Du X-Server hast kannst Du das ja mit dem AdminTool ganz prima machen.

    Falls dies Deine Frage nicht beantwortet hab ich's nicht verstanden was Du gerne machen willst, dann beschreibe es etwas genauer, wie Du arbeitetst und welches System mit welchen Einstellungen gerade läuft. ;-)
     
  11. sndryczuk

    sndryczuk New Member

    Geht das nicht über Tinker Tools und "Versteckte und Systemdateien" ausklicken? Oder ist das jetzt zu einfach?
     
  12. sndryczuk

    sndryczuk New Member

    Ich kann nicht mehr unter 10.1 auf meiner externen FW-Platte starten.
    Es erscheint ein schwarzer Bildschirm mit der Info:

    /etc/master.passwd: No such file or directory
    IoKernelDebugger: Debugger attached

    Was ist das jetzt?

    Gut, fsck sagt mir, dass das Volume okay ist. Bei reboot startet 10.1.2 von meiner internen Platte.

    Eine andere Sache:
    Meine FW-Platte schaltet sich nach einer bis zwei Stunden , obwohl das Volume mit iTunes im Betrieb ist, selbstständig aus. Ich hatte das Problem schon einmal. Wurde aber gelöst mit einem neuen Jumper. Sie lief wie am Schnürchen.

    Ich glaube, beide Probleme haben nichts miteinander zu tun, oder?
     
  13. kegon

    kegon New Member

    Hallo,

    hmmm, das FW-Volume würde ich mal mit DiskWarrior behandeln. Wann hast Du auf dem externen Volume das letzte mal das Prebinding erneuert? Gibts auf dem Volume viel traffic?

    Tja, zu dem iTunes Problem kann ich nur mutmaßen... Kann es sein, dass Du soviel RAM hast, dass fast die ganze Playlist geladen werden kann ? Oder wird die eh ins VM geswapt wenn iTunes gestartet wird? Hört iTunes auf zu spielen wenn die Platte in den Ruhezustand übergeht? Gruss kegon
     
  14. sndryczuk

    sndryczuk New Member

    Hi kegon,
    nein, dass war es nicht. Es war ein Verzeichnisfehler. Das heisst die Aliasse cores, etc, mach, var... waren zum Teil verschwunden. Warum weiß ich nicht, da ich das FW-Volume als Backup für X verwende.
    Gut, ein Freund hat das Online für mich hingebügelt - mit meiner IP-Nummer und seinem UNIX-Wissen.

    Hierzu der Text

    Welcome to Darwin!
    [localhost:~] hartmut% cd /Volumes/[fw]Kopie X
    [localhost:/Volumes/[fw]Kopie X] hartmut% cd private
    [localhost:/Volumes/[fw]Kopie X/private] hartmut% ls
    Drivers cores etc tmp var
    [localhost:/Volumes/[fw]Kopie X/private] hartmut% ln -fhs var /Volumes/[fw]Kopie X
    [localhost:/Volumes/[fw]Kopie X/private] hartmut% ln -fhs tmp /Volumes/[fw]Kopie X
    [localhost:/Volumes/[fw]Kopie X/private] hartmut%

    Das Alias-Verzeichnis verwies nicht mehr auf dem Originalordner "private". Also musste alles neu verlinkt werden.

    Zu iTunes: nein mit RAM hat das nichts zu tun. Ja, iTunes hörte auf zu spielen, als sich die Festplatte ausgeschaltet hat.

    Merkwürdigerweise läuft sie aber jetzt wieder wie am Schnürchen - seit Stunden. Zum Glück.

    Warum das passiert ist, würde ich auch gern wissen. Am Energiesparmodus liegt es nicht . Der ist aus.

    Der Freund, der das online hingebogen hat, mutmasst den Grund des Verschwinden der Aliasse im 9er System. (Aber er hat ohnehin die Meinung, dass 9 auf die Dauer das Xer-System beschädigt). Fragt mich aber nicht warum.

    Wie dem auch sei: es funktioniert wieder alles. Also auf zu neuen Problemen.
     
  15. kegon

    kegon New Member

    Moin,

    na gut, dass das wieder in Ordnung ist. Die Aussage Deines Freundes/Bekannten ist hoch interessant. Bin der gleichen Meinung wie er. Es ist glaube ich so, dass viele Pflegetools und andere Anwendungen unter 9 keine UNIX-Aliase (anderes Verfahren) erkennen und diese daher (sicher ist sicher;) löschen oder überschreiben. Wahrscheinlich war das auch bei Dir der Fall. Habe mir schon lange abgewöhnt, den Classicmode zu starten, eben wegen diesem blöden Gefühl, dass hinterher das X zickt. Zum Glück brauche ich Classic auch nicht mehr.

    Vielen Dank für das Feedback

    Gruss kegon
     
  16. sndryczuk

    sndryczuk New Member

    Obwohl nach wie vor alles läuft, muss ich doch seriöserweise mich selbst korrigieren: der UNIX-Text den ich für das Verlinken der Alias-Dateien eingegeben habe, ist falsch.
    Mein guter UNIX-Geist hat meine eingegebenen Kommandos hier gelesen und gesagt: so stimmt das nicht. Vielleicht sendet er mir mal seine Korrekturen und den richtigen Kommando-Text.
     
  17. Giadello

    Giadello New Member

    Wäre bestimmt auch für andere interessant - ich spiele auch mit dem Gedanken, mir irgendwann mit Feuerdraht mehr Luft zu verschaffen. Und dann wüßte ich schon, wo ein Feuerlöscher steht ;) ...
     
  18. Kate

    Kate New Member

    Die Aliasdateien des X Filesystemes sind eigentlich unsichtbar, da kann man selber gar nichts machen, jedoch gewisse Tools der OS9 Seite könnten da die Aliasse löschen, z.B. Norton ist so ein Kandidat. Es empfiehlt sich grundsätzlich keine Reparaturtools zu verwenden, die mehr als nur das Filesystem reparieren. DiskWarrior ist prima, Norton eben für X noch nicht. Selbst Norton für X macht da z.Zt. einiges falsch.
    Ansonsten ist ein FW Disk eine feine Sache unter X, sicher, schnell, stabil und bootfähig.

    ach ja, um die Links wiederherzustellen muss man etwa folgendes (im Terminal) tun:
    Ins Verzeichnis des FireWireLaufwerkes wechseln:
    cd /Volumes/NamederFWDisk
    und dann:
    ln -s private/etc etc
    ln -s private/etc var
    ln -s private/cores cores
    ln -s private/tmp tmp
    mkdir /Volumes/NamederFWDisk/dev /Volumes/NamederFWDisk/Volumes

    NamederFWDisk ist natürlich der Name Deiner FireWire Disk.
     
  19. sndryczuk

    sndryczuk New Member

    Danke. (Mit der Korrektur hätte wahrscheinlich noch gedauert).
    Einer der Vorteile von Tinker Tools ist, dass man bei solchen Konflikten unsichtbare Dateien sichtbar machen kann. (Im Normalfall nicht zu empfehlen, da das nur irritiert). Man kann den Ordner "private" auch öffnen, indem man oben im Menü "Gehe zu Ordner" anklickt und dann den Ordner "/private" eingibt.

    Praktisch haben wir das so gelöst, dass wir die unsichtbaren Dateien beider Festplatten (Startvolumes X) verglichen haben . Bei dem Backup-System auf der FW-Platte wurde dann schnell klar, dass die wichtigen Aliasdateien fehlten, die auf der internen natürlich da waren (sonst hätte ich ja nicht starten können).
     
  20. kegon

    kegon New Member

    Hallo Kate,

    Du scheinst ja echt fit zu sein, daher die folgende Frage:

    Wenn man nem Windowsuser den Zugriff auf eine der eigenen Partitionen erlaubst, können die alles sehen. Das verwirrt die Brüder (alles gedungene IT-Berater) arg und sie fangen an wild hin und her zu kopieren und zu korrigieren. Kann man die Ansicht von aussen auch verschlanken? Wenn ja, wie?

    mata nee

    kegon
     

Diese Seite empfehlen