5. Kernel Panic seit Panther ... ;-( !

Dieses Thema im Forum "Software" wurde erstellt von Chriss, 10. Dezember 2003.

  1. Chriss

    Chriss New Member

    .... unter Jaguar hatte ich ein Jahr lang (!) keinen Absturz – mit Ausnahme von VirtualPC 6, das des öfteren das ganze System mitgerissen hat.

    Nun aber habe ich – OHNE VPC - seit Panther (clean Install !) in etwa 3 Wochen den fünften oder gar sechsten Absturz ! Der letzte vor 2 Minuten. Die „Panic“ sieht ja aus wie auf einem Windows-Rechner: weißer Text auf schwarzem Hintergrund einfach quer über den aktuellen Desktop geschrieben ! Der ganze Text sagt mir natürlich nix. Und Festplattendienstprogramm o.ä. finden auch nix.

    Was kann/soll ich denn da unternehmen ... ?!

    Thanks !
     
  2. Tsujoshi

    Tsujoshi New Member

    Schon im Single-Boot Modus "fsck -f" gemacht?
     
  3. Chriss

    Chriss New Member

    nee, ich kenn mich mit dem ganzen Unix-Zeugs überhaupt nicht aus - und mach immer einen Riesenbogen drum, sobald ich´s lese....

    Sollt ich mich besser doch mal drum kümmern.
    Was mach ich da jetzt genau, auch wenn´s schon irgendwo zig mal stand ?

    DANKE !
     
  4. Tsujoshi

    Tsujoshi New Member

    Neustart, Apfel-s drücken, wenn das Terminal geladen ist fsck -f eingeben (aufpassen wg. amerik. tastaturbelegung: nimm das "-" von dem Zahlenblock rechts), Return drücken.

    Entweder, er sagt am Ende: "Dein Volumen" appears to be OK
    -dann tipp: reboot und drück return

    ...oder er findet einen fehler im Filesystem den er repariert: "Filesystem has been modified" in diesem Fall tippst Du nochmal "fsck -f" und bestätigst bis er dir irgendwann sagt das alles OK ist und du reboot eigeben kannst.

    hope 2 help! ;)
     
  5. gratefulmac

    gratefulmac New Member

    Eine Kernel panic tritt in der Regel auf, wenn irgendeine Erweiterung für Hardware nicht gefunden wird.
    Möglicherweise verursacht ein Peripheriegerät oder ein nachträglich eingebautes Teil den Absturz.
    Es empfiehlt sich, alle Geräte abzustöpseln und dann wie oben beschrieben einen File System Check zu machen.
    Man startet mit gehaltener Apfel und -s Taste in den Singel User Modus und landet auf der Kommandozeilenebene.
    Nachdem einige Infos über den Bildschirm gelaufen sind, stoppt der Vorgang und man gibt "fsck -f" ein.
    Damit wird ein Prozess in Gang gesetzt, welcher die Dateistruktur auf Fehler überprüft und repariert.
    Am Ende der Procedur muß eine Meldung kommen: these volume are ok. (oder so ähnlich)

    Zur Sicherheit sollte man "fsck" mehrmal wiederholen.

    Um nach erfolgreicher Reparatur wieder auf die Aquaeben zu gelangen ,tippt man"reboot" ein,sodaß nach wenigen Augenblicken der Desktop erscheint.
    -
    Um den Hardwareübeltäter zu erkennen, schließt man ein Gerät nach dem anderen wieder an.
    Wenn bei einem bestimmten Hardwareteil die Panic wieder auftritt, ist der Verursacher erkannt.
     
  6. Macci

    Macci ausgewandert.

    kleine Korrektur: unter Panther musst du fsck -f eingeben, also mit deutscher Tastatur fsck(leerzeichen)ßf

    Das hat mit dem Journaling-System zu tun, das ist in Panther standardmäßig aktiviert.
     
  7. Tsujoshi

    Tsujoshi New Member

    Wieso Korrektur?:rolleyes:
     
  8. Chriss

    Chriss New Member

    ... so, allerbesten Dank für Euren Support.

    Hab alles so gemacht - es kam schon beim ersten Mal die Meldung: "The Volume OS X seems to be ok"

    Na da bin ich jetzt nicht unbedingt weiter, oder ;-) ?
    Hab präventiv mal noch PRAM gelöscht, mit dem Effekt, daß Safari & Co. jetzt ganz unscharf geworden ist. Was hat sich denn da nun wieder verstellt oder zurückgesetzt ... ? Achje .....

    @gratefulmac
    "Um den Hardwareübeltäter zu erkennen, schließt man ein Gerät nach dem anderen wieder an.
    Wenn bei einem bestimmten Hardwareteil die Panic wieder auftritt, ist der Verursacher erkannt."

    hmmm ... wie soll ich das denn machen. Hab jetzt alle wieder dranhängen und es läuft erst mal. Es funzt ja tagelang ....

    Danke an alle im voraus !
     
  9. ks23

    ks23 Ohne Lobby

    Was sagen den die console.log und system.log?
    Hast du nur den original RAM von Apple drin?

    Wenn nein, kann dies die Ursache sein, obwohl es unter Jaguar keine Probleme machte.

    Gruss
    Kalle
     
  10. Chriss

    Chriss New Member

    hab 2 zusätzliche Riegel drin, die "100% Apple-kompatibel" sind. Angaben sind von Cyberport und MacTrade - also Händler, deren Angaben stimmen sollten, denk ich.

    es gibt noch so ein MiniTool das den RAM checkt, da kam auch "ok"

    Wie prüfe ich denn console.log und system.log ?

    DANKE !
     
  11. ks23

    ks23 Ohne Lobby

    "Apple Menü" -> "Über diesen Mac" -> "Weitere Informationen" -> "Protokolldateien".

    Gruss
    Kalle
     
  12. Chriss

    Chriss New Member

    ... ist ja nicht möglich, hatte schon wieder eine Kernel Panic – innerhalb von 2 Stunden. Sehr interessante und sehr verdächtige Meldung jetzt nach dem Neustart:
    XUSBTAdrv.kext sei nicht richtig installiert. Das ist mein Vigor128-Treiber ! Witz ist nur, dass ich diese angegebene Datei nirgendwo finden kann. Werde mich jedenfalls mal um den Vigor kümmern – scheint mir jetzt der Hauptverdächtige zu sein ... ;-) !


    Danke, da hab ich reingeschaut, aber was ist da wichtig, bzw. wo kommt es drauf an... ? Erscheint ja ein ellenlanger Text ..........
     
  13. gratefulmac

    gratefulmac New Member

    Da haben wir den Übeltäter.
    .kext Dateien sind Kernelerweiterungen.
    Deine scheint beschädigt zu sein, oder Du mußt nach aktuellen Treibern suchen.
    .kext Dateien findest Du in hd/system/library/extensions.

    Such Dir die genannte heraus und lege sie auf den Schreibtisch.
    Mach dann nen Neustart und siehe nach ob das System eine neue Datei angelegt hat.
    Die müßte dann in Ordnung sein.

    Alternativ würde ich mich mal nach Treibern umschauen.
     
  14. Eduard

    Eduard New Member

    Der neueste Vigor-Treiber war auf der letzten Macwelt-CD.
    Damit sollte es dann gehen.
     
  15. Chriss

    Chriss New Member

    Also ich hatte gleich nach der Panic nach allem gesucht, was nach vigor klang ... ;-)
    Der Witz war dann nur, dass OSX nur die Hälfte gefunden hat, obwohl ich „auf allen Volumes“ gesucht hatte – wie geht das denn ?! Jedenfalls hab ich dann unter OS9 alles gesucht und gefunden und rausgeschmissen (für mich einfacher als über Unix in OSX). Unter 10.3. dann neu installiert. Ich hab noch den älteren Adapter (Vigor128), da gibt´s keine neuere Version als die von 10/2002. Vielleicht ist der auch nicht „pantherfreundlich“ – aber die Leute mit den neuen Treibern für den miniVigor berichten exakt dieselben Probleme. Naja, mal sehen – vielleicht hab ich jetzt erst mal Ruhe ...

    Danke noch mal ... ;-) !

    @Eduard
    nein, ich hab den Vigor128, nicht miniVigor, s.o

    Danke dennoch
     
  16. hfenner

    hfenner New Member

    Die Duplizität der Ereignisse: Vigor + Speicher habe ich gerade erlebt. Mein Hilfsmittel war, den Zusatz 1 Giga-Speicher mit Dank an Gravis in meinem Falle zurückzugeben. Keine panik mehr auf der T...
     
  17. Chriss

    Chriss New Member

    ... ich glaube, das Problem beim Vigor ist, dass er wirklich sauber installiert sein muß ! Den neuen Treiber einfach drüberbrezeln funktioniert schlecht und mit dem Uninstaller kriegt man den alten Treiber in der Regel nicht (richtig) entfernt. Also ist Handarbeit angesagt ....

    Und machst Du nun alternativ – ohne Adapter?
     
  18. hm

    hm New Member

    Also ich hab jetzt zweimal die Erfahrung gemacht (einmal von der amerikanischen-, und ein zweites Mal von der Deutschen Web-Side des Herstellers gesogen) das der aktuelle Treiber des MiniVigors (2.6) obwohl ausdrücklich für 10.3 freigegeben, auf meinem G5 absolut nicht funktioniert. Er erkennt einfach die Hardware nicht (..die LEDs des Vigors bleiben dunkel). Zudem, die Deinstallation dieses >aktuellen Treibers< wird mit einer Fehlermeldung abgebrochen. Der ältere, (..glaube 2.2x) funktioniert dagegen soweit.
    Weiter, - zu einem Totalabsturz kam es schon öfters auch mit dem älteren Treiber, wenn der Rechner aus dem Tiefschlafmodus hochgefahren wird und ich mich dann Versuch in´s Internet einzuwählen. Allerdings, das muss ich auch ausdrücklich noch erwähnen passierte dies auch schon unter 10.2.7(8) Es ist besser zunächst einen Neustart zu machen.

    Grüsse Heinz
     
  19. Chriss

    Chriss New Member

    @Heinz
    wie ich schon oben schrieb, die De-installation haut selten oder überhaupt nie hin. Besser ist es, MANUELL zu löschen, auch wenn natürlich nicht im Sinne des Erfinders. Aber so klappt´s dann wenigstens. Es muß wirklich alles gelöscht sein.
    WÄHREND der Neuinstallation darf der Adapter NICHT angeschlossen sein, NACH der Neuinstallation NICHT (wie vorgegeben) Neustarten, sondern Mac ausschalten und dann wieder einschalten, NACH dem Hochfahren den Adapter mit dem Mac verbinden. Ein Versuch ist es wert, bei sehr vielen läuft er ja auch rund - ist halt etwas penibel ;o)

    Die Krankheit nach dem Ruhezustand lässt sich wohl leider nicht abstellen (war schon mein nervigster JaguarBug). Hier reicht bei mir aber fast immer ein „USB-Neustart“, d.h. Adapter aus- und wieder einstöpseln. Wenn ich einfach so verbinde, ist es zu spät, dann läuft ein Endlosband +++verbinden+++verbinden+++verbinden+++verbinden+++

    Beneide dich trotzdem um Deinen G5 ... ;o) !

    Viel Glück.
     
  20. hm

    hm New Member

    @Chriss

    ..den >neuen< Treiber hab ich natürlich wieder manuell deinstaliert. Danach den alten wieder aufgespielt und er funzt auch soweit.
    Unverständlich ist nur, das der neue, obwohl für 10.3, überhaupt nicht geht.

    Grüsse Heinz
     

Diese Seite empfehlen