Airport: Netzwerkproblem

Dieses Thema im Forum "Software" wurde erstellt von AndreasG, 28. August 2004.

  1. AndreasG

    AndreasG Active Member

    Gestern habe ich Airport Express bekommen. Eingesteckt - läuft. So macht OSX wirklich Spss :D

    Ein kleines Problem habe ich aber noch, es hat vermutlich nicht mal was mit Airport zu tun.

    Mein G4/933 hängt über einen Switch am ADSL-Router. An diesem Switch ist auch Airport Express eingesteckt. Mit meinem Airport-iBook kann ich nun sowohl surfen als auch Laufwerke auf meinem G4/933 verbinden (afp://192.168.1.2)

    Nur den umgekehrten Weg bekomme ich nicht hin: Wenn ich auf dem G4 nach Servern suche (Apfel-K), findet er das iBook nicht (afp://10.0.1.2)

    Was mich irritiert, ist die IP-Adressvergabe: Das ADSL-Modem (DHCP-Server) hat 192.168.1.1, mein G4 hat 192.168.1.2 und die Airport-Basisstation selber hat 192.168.1.3.

    Die Airport-Basisstation ist nun aber offenbar selber ein DHCP-Server und teilt dem iBook die Adresse 10.0.1.2 zu. Irgendwo kann ich den Adressbereich im Airport-Admin-Dienstprogramm sogar wählen.

    Aber wie muss ich es anstellen, dass ich das iBook von meinem G4 aus verbinden kann?

    Gruss
    Andreas
     
  2. MacELCH

    MacELCH New Member

    Damit sie sich per afp sehen, müssen sie im gleichen Subnetz sein also z.b. 192.0.0.x und 192.0.0.y

    Alternativ kannst Du glaube ich den beiden ein eigenes Appletalk Netzwerk zuordnen, wie das funktioniert weiß ich aber nicht.

    Du kannst aber auch einfach unter Apfel+k die IPnummer eingeben, bei mir geht das zumindest - ich werde es aber demnächst mal ändern, da ich sonst kein Itunes Sharing machen kann.
     
  3. AndreasG

    AndreasG Active Member

    Danke für Deine Antwort. Das ist ja das Problem: Wenn ich die Airport-Express so konfiguriere, dass er dem iBook eine Adresse im Bereich 192.168.1.x zuteilt, bekommt das iBook 192.168.1.2 - das ist aber die gleiche Adresse, die ja schon mein G4/933 vom ADSL-Router zugeteilt bekommt. Wenn ich diese IP-Adresse auf meinem G4 eingebe, findet er nicht das iBook, sondern sich selber. Das ist ja auch schön, aber nicht das, was ich will ;)

    Wenn ich auf dem G4/933 direkt die IP-Adresse des iBook eingebe (afp://10.0.1.2), findet er wie gesagt nichts. Ok, ist ja nicht im gleichen Adressbereich, wie Du ja schon gesagt hast.

    Wie ist das eigentlich mit der Subnet-Mask? Die kann und muss man ja unter Windows immer auch angeben. Unter OSX habe ich die aber noch nie gesehen.

    Tja, was Networking angeht, verstehe ich eher was unter Windows, unter OSX habe ich bisher noch kein so hoch komplexes Netzwerk zusammengestellt ;).

    Wer hat noch eine Idee?

    Gruss
    Andreas
     
  4. MacELCH

    MacELCH New Member

    Ich bin gerade in der Arbeit, aber wenn ich spaeter wieder Zuhause bin ca. 18 Uhr, also mitten in der Nacht bei Dir, schaue ich mal wie mein setup ist und schick Dir ein paar Screenshots. Oder stell sie auf meine Webpage.

    NUch was anders hast Du mal versucht bei Deinen afp Versuchen den User mit anzugeben ?

    also afp://DeinUser@10.0.0.2
     
  5. sandretto

    sandretto Gast

    Und genau das ist dein Problem! Du hast die Base als Router konfiguriert, und somit kann der G4 das iBook nicht "sehen", da es hinter der Base (Router) ist. Du könntest zwar ein Port-Forwarding in der Base konfigurieren, damit der G4 das iBook sieht, was aber in diesem Fall Unfug wäre. Du musst ganz einfach die Base als Bridge konfigurieren (IP-Adressen NICHT gemeinsam nutzen), und somit erhält das iBook dann vom DHCP-Server des ADSL-Routers eine IP zugeteilt, und nicht mehr von der Base! Dann kann der G4 auch das iBook sehen. Die Base werkelt dann als Bridge (Vermittler) zwischen dem AirPortNetz, und dem lokalen Netz. Die ganze Steuerung der Datenpakete übernimmt dann einzig und alleine der ADSL-Router.

    Mit Teilnetzmasken (Subnet-Mask) lässt sich ein grosses Netzwerk, in mehrere kleinere Netzwerke unterteilen. Das ist aber für den Privatuser, der fast immer nur ein einziges, kleineres Netzwerk betreibt, nicht von Bedeutung.
     
  6. AndreasG

    AndreasG Active Member

    Super! Genau das wars! Danke für Deine kompetente Hilfe!

    Fies ist halt, dass Airport Express in der Grundkonfiguration als Router daher kommt. Also irgendwie genau verkehrt, denn ich denke, die Mehrheit der Benutzer wird mit Airport Express ein Netzwerk wie meines aufbauen, also mit einem ADSL-Router und ein bis zwei mobilen und stationären Rechnern.

    Aber viellieicht wäre das auch in dem beigefügten Manual nachzulesen gewensen - aber welcher Mac-User liest schon Manuals ;)

    Dank auch an MacElch. Man kann halt nicht alles wissen gell. Geht mir genau so :D

    Gruss
    Andreas
     
  7. MacELCH

    MacELCH New Member

    Hier noch nachgereicht mein Setup.
     
  8. MacELCH

    MacELCH New Member

    Und meine Einstellung von der Airport Express Station

    So wie ich das sehe geht es bei mir auch ohne die deaktivierung als Router - klärt mich auf, wenn ich da falsch liegen sollte.

    Und ich kann egal von welchem Mac aus per folgendem Befehl zugreifen:

    afp://Username@RechnerIP

     
  9. AndreasG

    AndreasG Active Member

    Ich hatte meine APE-Settings erst genau wie Du. Bei mir klappte aber der Zugriff mit afp://user@IP nicht. Ich konnte auch in der Richtung iBook-G4, wo das Sharing zwar klappte, nicht mit afp://user.local/ verbinden, sondern nur mit afp://192.168.1.2.

    Gruss
    Andreas
     
  10. MacELCH

    MacELCH New Member

    Das mit user.local ist klar, da Du in verschiedenen Netzen bist 192.x.x.x und 10.x.x.x

    Aber ansonsten weiß ich nicht warum es nicht bei Dir ging - ist ja auch egal, Hauptsache Dein Problem ist gelöst.
     

Diese Seite empfehlen