An die OS X- und UNIX Profis !

Dieses Thema im Forum "Hardware" wurde erstellt von alex.goe, 16. Januar 2003.

  1. alex.goe

    alex.goe New Member

    Habe meinen Rechner heute mal im SingleUser-Modus gestartet und dabei folgendes festgestellt:

    Couldn't alloc class "NVDANV10Hal"

    kann mir jemand sagen was das bedeuten soll?

    Bin auf die ganze Sache überhaupt nur gekommen, da ich Probs mit der 2D Darstellung in der Classic-Umgebung habe. Die ist seit dem Update von 10.2.2 auf 10.2.3 lahm geworden.
    Meine Vermutung ist, das Classic nicht den richtigen Treiber/Treiberschnittstelle für die NVdia MX 4 in meinem Dual G4 867 findet, und somit alles an den Prozessor abgibt. Da Classic ja bekanntlich nicht Mehrprozessor-fähig ist, wird es dann wohl zäh.

    Was meint Ihr Profis nun dazu ?
    Irgendwelche Diagnose Ideen ?

    Gruß Alex
    (*sichaufeineAntwortfreuend*)
     
  2. Die Meldunh kenne ich nicht - kann dir da also nicht weiterhelfen

    Du kannst aber mal im terminal ein fsck machen, um weitere Infos zu erhalten.

    Hier sind die Kommandos dafür:

    Last login: Thu Jan 16 13:26:29 on console
    Welcome to Darwin!
    [Porter:~] andryczuk% mount
    /dev/disk0s9 on / (local)
    devfs on /dev (local)
    fdesc on /dev (union)
    <volfs> on /.vol (read-only)
    /dev/disk0s10 on /Volumes/Archiv (local)
    /dev/disk0s11 on /Volumes/Ablage (local)
    automount -fstab [408] on /Network/Servers (automounted)
    automount -static [408] on /automount (automounted)
    [Porter:~] andryczuk% sudo fsck_hfs /dev/disk0s9
    Password:
    ** /dev/rdisk0s9
    ** Root file system
    ** Checking HFS Plus volume.
    ** Checking Extents Overflow file.
    ** Checking Catalog file.
    ** Checking multi-linked files.
    ** Checking Catalog hierarchy.
    ** Checking volume bitmap.
    ** Checking volume information.
    ** The volume Aqua appears to be OK.
    [Porter:~] andryczuk%
     
  3. cpp

    cpp programmierKnecht

    dmesg > dmesg.txt'
    dmesg.txt kannst du auch anders benennen.
    schau doch mal im ordner /System/Libraries/Extensions nach, ob es eine NVDANV10Hal.kext gibt, dort liegen alle kernelmodule für das system.
    falls dein system dieses modul für deine grafikkarte braucht und es nicht funktioniert, dann müsste aber auch dein OS X probleme bei der grafikdarstellung haben, da klassik ja keinen eigenen treiber für die ausgabe braucht, sondern auf die x resourcen zurückgreift.

    cpp
     
  4. hakru

    hakru New Member

  5. alex.goe

    alex.goe New Member

    Habe mal das Protokoll gesichert. Die Extension ist vorhanden. Weiß irgendwie auch nicht weiter. Scheint ja auch kein anderer das Problem zu haben, das sein FH 9 in der Classic-Umgebung von 10.2.3 lahmer ist als mit 10.2.2
     
  6. cpp

    cpp programmierKnecht

    habe bei apple folgendes gefunden:
    discussions.info.apple.com/WebX?13@45.WzSjaFjWgbH.2@.3bbc2bbb/7

    interessant wird es dann ganz unten, wo ein link zu einem firmwareupdate für nvidiakarten steht.

    cpp

    p.s.: konnte leider keinen link dazu machen, weil sonst nur müll angezeigt wird.
     
  7. alex.goe

    alex.goe New Member

    Vielen Dank für die Bemühungen. Der Apple Discussion-Link war sehr auschlußreich. Scheint also ein Problem mit OpenGL und der NVidia Karte/Treiber zu sein. Wird Apple dann wohl auch bekannt sein und man munkelt ja schon über ein 10.2.4 Update, in dem das hoffentlich behoben wird.

    Vielen Dank, jetzt habe ich wenigstens ne Ahnung von der Ursache des Probs !

    Gruß Alex
     

Diese Seite empfehlen