apache als proxy konfigurieren????

Dieses Thema im Forum "Hardware" wurde erstellt von MACrama, 9. August 2001.

  1. MACrama

    MACrama New Member

    hallo

    nur probleme...nachdem ich mit squid gescheichtert bin und auch scache net funkt...probier ich mal apache..

    das man den apache als proxy benutzen kann weiß ich ja...
    nur wie das geht????
    hab in der httpd.conf das proxy modul aktiviert...
    auf die proxy optionen...

    nur es tut sich nix...ich mein der server läßt sich starten und läuft auch, nur druchgehen tut nix...

    kann mir jemand verraten was ich vergessen haben könnte???

    bitte um hilfe

    ra.ma.
     
  2. MacGhost

    MacGhost Active Member

    Hallo MacRAMA,

    wußte ich noch gar das der Apache einen Proxyserver enthält.
    Dann wäre ja Squid auf allen Linux/Unix Rechner völlig überflüssig.

    Schau zum Thema Squid doch mal bei Suse vorbei die haben eine recht taugliche Knowledge Base !
    Mein Problem ist eher das ist nicht ins OS X übersetzt bekomme, wahrscheinlich da die Developer CD nicht bei der OEM OS X dabei ist.
    Sonst könnte man sich etliche teure Software ersparen.
    Da es diese unter Linux bzw. unter FreeBSD/NetBSD kostenlos gibt. Zumindest in ähnlicher Form.
    Z.B. das K-Office !
    Ich glaube das muß noch eine Menge passieren bis OS X den Status erreicht wie das klassische OS. Und erst recht auch die Akzeptanz diverse Linux/Unix Jünger.
    Ich war auch reichlich entäuscht, als ich versuchte dieverse BSD Software zum Laufen zu bekommen, aber nix war da zu machen.

    Joern
     
  3. goldfinger

    goldfinger New Member

    Ich denke mal das Du inzwischen schon dein Problem gelöst hast?
    Falls nicht scheib mal kurz was Du für eine Disbu benutzt.

    Apache geht schon als Proxy.
    Stimmt der Port?

    Immer die Logfiles anschauen.
     
  4. MACrama2

    MACrama2 New Member

    jup geht...

    in der httpd.conf gibts zwei module die man aktivieren muß...
    und ein paar option "freischalten"...

    nur happerts irgendwie!?!?

    hab ich eigentlich schonmal gesagt das mir vi ziemlich auf die socken geht..;-)

    und squid genauso...zwei macs osx 10.0.4..bei dem einem gehts zum installieren und starten beim anderen nicht..das blöde ist der andere ist der server;-)

    ra.ma.
     
  5. MACrama2

    MACrama2 New Member

    ne probs noch nicht gelöst...
    os x apache...

    er startet normal, die ports sind ok, 80 für intranet website, 8080 fürn proxy...

    die anforderung vom user kommt, seh ich in den logs, nur er tut nix damit-> er gibt sie nicht weiter, oder er läßt einfach nix durch...hmpf...

    muß ich noch irgendwo, was einstellen?
    hab ja eigentlich null ahnung von unix..;-)

    ra.ma.
     
  6. goldfinger

    goldfinger New Member

    Fangen wir mal von vorne an.

    Du möchtest einen DSL Router aufziehen unter OsX?

    Läuft da noch eine Firewall?

    `Welche Probleme gabs mit Squid?
     
  7. MACrama2

    MACrama2 New Member

    nein keinen dsl router..

    also von vorne:
    wir haben in der firma eine standleitung, und einen w2K proxy, nur die macs nicht über den proxy surfen , (wegen fehlender domainanmeldung)

    ich hatte bisher die webstar suite als proxy...nun hab ich den server auf macosx umgestellt, aus performance gründen...
    deswegen apache als proxy...

    firewall läuft auch, die ip des servers ist offen...ports auch...

    squid: es lies sich nicht "installieren", habs nach der anleitung gestartet, nur er hat immer abgebrochen mit irgendeiner fehlermeldung(hab ich nicht im kopf)...
    bei einem anderen mac gings aber ohne probs :-???

    so bin ich zum apache gekommen, war auch überrascht das es die option gibt...

    nur funken gehts halt nicht?..

    gibts im unix irgendwo die möglichkeit im den domainserver zu sagen?

    thx for help...
    ra.ma.
     
  8. MacGhost

    MacGhost Active Member

    Moin,

    wieso Domainanmeldung für Proxy ?
    Nutzt ihr den MS Proxy ? Geht auch mit dem Mac, zumindest mit IE und Netscape. Da kommt dann ein Fenster hoch in dem man sich am Proxy indetifizieren muß.

    Für die Kommunikation zwischen OS X und Win kannst Du Samba nehmen oder unter 10.0.4 das kostenlose Dave.
    Zum Browsen im Winnetz geht auch Sharity, kostet aber und ist ein wenig hakelig in der Bedienung.

    Joern
     
  9. MACrama

    MACrama New Member

    hi...

    ja der NT funktioniert schon, allerdings nur mit Iexplorer und den verwenden wir nicht, da unser intranet für netscape ausgelegt ist...
    und bei netscape kann man sich nicht anmelden, nada...geht nicht...

    außerdem herscht krieg zwischen uns und unserer EDV abteilung :-(

    warum den domainserver, tja das problem hatte ich mit dem webstar auch, erst als ich im TCP kf die ip von diesem eingetragen hab lief es:-??

    ra.ma.
     
  10. rehkot

    rehkot New Member

  11. MACrama

    MACrama New Member

    hobs scho....

    bin ja ein genie *stolz*
    (jaja ich weiß selbstlob stinkt, aber was solls, stink ich halt;-)
     
  12. MACrama

    MACrama New Member

    prob gelöst..

    er läuft....

    ProxyDomain in der http.conf
    hat gefehlt..

    ra.ma.
     

Diese Seite empfehlen