Apache hilfe!!!!

Dieses Thema im Forum "Software" wurde erstellt von baumpaul, 9. Februar 2004.

  1. baumpaul

    baumpaul New Member

    Hallo,

    ich habe ein HTML Dokument angelegt mir einem Textfeld das den Wert in eine PHP datei übergibt und ihn dort nur mit einem echo befehl ausgeben soll. Es wird aber nichts angezeigt.
    Hat jemand eine ahnung warum?

    Ich benutze den Apache von Apple.
     
  2. Zack2002

    Zack2002 Active Member

    liegt alles schön im verzeichniss macintosh hd > library > webserver > documents

    ?
     
  3. hakru

    hakru New Member

    " ... Hat jemand eine ahnung warum?" .... Tja, weil Du vielleicht was falsch gemacht hast? ;-)) Easy, ich mein's nicht böse - aber hellsehen können wir noch nicht.

    Um helfen zu können, müsstest Du wohl etwas Code posten, wenigstens den Inhalt des <FORM> tags und die Script.php - Datei ...

    ... läuft ein unschuldiges test.php (mit z.B. einem phpinfo() call) okay?

    hakru
     
  4. taysano

    taysano New Member

    Welches PHP verwendest Du?
    Mal ins Blau raten -> es liegt nicht an Dir sondern an PHP.
    Versuch doch mal (wenn nicht schon gemacht) das PHP-Modul von www.entropy.ch (inkl. Anleitung). Viel Glück
     
  5. baumpaul

    baumpaul New Member

    naja der quellcode der 2 Dateien ist richtig und im richtigen Verzeichnis liegt auch alles.

    Der eintrag wird auch bestens in eine SQL Datenbank übergeben. Man sieht nur nichts im Browser.

    Habe alles auch auf Windows mit xamp getestet: funktioniert bestens.

    Gruß
    PhB
     
  6. hakru

    hakru New Member

    so ... und funktioniert ein test.php, mit etwa folgendem Code:

    <?php
    phpinfo();
    ?>


    hakru
     
  7. baumpaul

    baumpaul New Member

    ja komischerweise schon
     
  8. RaMa

    RaMa New Member

    rück mal den code rüber, aber formatiert wenn geht :)

    ra.ma.
     
  9. RaMa

    RaMa New Member

    achja warums nicht funktionert...

    register_globals = off...

    ra.ma.
     
  10. avw

    avw New Member

    RaMa hat wohl recht. Daran wird's liegen.

    Bei der php Installation wird üblicherweise auf register_globals = Off konfiguriert.

    Schau mal in die php.ini:

    " // snip
    - register_globals = Off [Security, Performance]
    ; Global variables are no longer registered for input data (POST, GET, cookies,
    ; environment and other server variables). Instead of using $foo, you must use
    ; you can use $_REQUEST["foo"] (includes any variable that arrives through the
    ; request, namely, POST, GET and cookie variables), or use one of the specific
    ; $_GET["foo"], $_POST["foo"], $_COOKIE["foo"] or $_FILES["foo"], depending
    ; on where the input originates. Also, you can look at the
    ; import_request_variables() function.
    ; Note that register_globals is going to be depracated (i.e., turned off by
    ; default) in the next version of PHP, because it often leads to security bugs.
    ; Read http://php.net/manual/en/security.registerglobals.php for further
    ; information.

    // snip

    ; You should do your best to write your scripts so that they do not require
    ; register_globals to be on; Using form variables as globals can easily lead
    ; to possible security problems, if the code is not very well thought of.
    register_globals = Off

    "

    Vielleicht hilft das weiter
    Gruss
    avw.
     
  11. baumpaul

    baumpaul New Member

    Servus,

    ich habe die stelle gefunden und bei mir schaut das so aus

    in Libary > PHP4 > lib > php.ini

    ; to possible security problems, if the code is not very well thought of.
    register_globals = Off
     
  12. baumpaul

    baumpaul New Member

    Servus,

    Thy a lot!!!! Ist habe es auf on gestellt und nun funktioniert es.

    Für was war dieser Eintrag genau? Und wieso ist so etwas wichtiges off?
     
  13. avw

    avw New Member

Diese Seite empfehlen