apache und php ohne variablen

Dieses Thema im Forum "Software" wurde erstellt von oli, 17. August 2004.

  1. oli

    oli New Member

    hi leuts,

    ich hab mir mal php installiert und hab jetzt folgendes problem.
    die variablen die ich über die url übergebe, mit post oder get ist egal, sind leer. auch umgebungsvariablen wie "$self_php" sind ohne wert. was muss ich den noch einstellen, damit das wieder klappt?
    ich hatte das anno 10.1.5 schonmal laufen und da ging es. bin jetzt bei 10.3.5
     
  2. avw

    avw New Member

    Ich könnte mir vorstellen, dass es deshalb nicht funktioniert, da bei neueren php Installationen auf register_globals = Off konfiguriert wird.

    Schau mal in die php.ini, dort solltest Du folgendes finden:

    Schau mal in die php.ini:

    " // snip
    - register_globals = Off [Security, Performance]
    ; Global variables are no longer registered for input data (POST, GET, cookies,
    ; environment and other server variables). Instead of using $foo, you must use
    ; you can use $_REQUEST["foo"] (includes any variable that arrives through the
    ; request, namely, POST, GET and cookie variables), or use one of the specific
    ; $_GET["foo"], $_POST["foo"], $_COOKIE["foo"] or $_FILES["foo"], depending
    ; on where the input originates. Also, you can look at the
    ; import_request_variables() function.
    ; Note that register_globals is going to be depracated (i.e., turned off by
    ; default) in the next version of PHP, because it often leads to security bugs.
    ; Read http://php.net/manual/en/security.registerglobals.php for further
    ; information.

    // snip

    ; You should do your best to write your scripts so that they do not require
    ; register_globals to be on; Using form variables as globals can easily lead
    ; to possible security problems, if the code is not very well thought of.
    register_globals = Off

    "

    Die Infos sind natürlich auch Deutsch verfügbar.

    Grüsse
     
  3. Achmed

    Achmed New Member

    Erster Anlaufpunkt wäre die bereits genannte php.ini

    Erstelle eine Datei mit folgendem Inhalt:

    PHP:
    <?php
    phpinfo
    ();
    ?>
    Hier siehst du die parameter.
    Hier auf den oben genannte Einstellung register_globals achten.
    Desweiteren sollte am Anfang der phpinfo
    der Eintrag stehen:
    Configuration File (php.ini) Path
    /usr/local/php/lib/php.ini

    Ist in dem Pfad eine php.ini vorhanden?? Kann natürlich je nach installation anders sein.

    Ein weiterer Punkt ist die php version.
    $self_php gibt es nicht mehr.
    Neu müsste das heissen:
    $_SERVER["PHPSELF"]
     
  4. oli

    oli New Member

    danke an alle.
    folgendes war: man muss die globals auf on stellen in der php.ini. ich habe die entropy version installiert und die erwartet eine ini-datei im etc ordner. warum auch immer.
     

Diese Seite empfehlen