Booten vom Raid

Dieses Thema im Forum "Hardware" wurde erstellt von John L., 5. Mai 2004.

  1. John L.

    John L. Active Member

    Hallo allerseits,

    hab mir mit 2x 9 GB SCSI an ner Adaptec 29160 ein Raid 0 gebaut und mit CCC das System drauf geklont.
    Systemeinstellungen -> Startvolume erkennt das System auch, nur beim Booten vom Raid findet er kein System und nimmt nach ner Weile wieder das System von der IDE Platte. Wenn ich IDE abstecke, bleibt er beim Systemordner suchen stehen.

    Ich hab keinen zusätzlichen Treiber für die Karte installiert, 10.3.3 erkannte die Karte anstandslos.

    PRAM hab ich schon gelöscht, SCSI IDs passen, Termi ist auch drauf


    Hat jemand ne Idee...? THX

    John L.
     
  2. AndreasG

    AndreasG Active Member

    Von einem OSX-Soft-RAID-0 (Striped)-Array kann man nicht booten, weil dieses Array erst aktiviert werden kann, wenn OSX schon läuft. Es gibt offenbar keinen Mini-Treiber, der das RAID-0 aktiviert.

    Dieses Problem wurde gerade kürzlich hier dikutiert. Einige meinen zwar, es müsste klappen, tut es aber offenbar tatsächlich nicht.

    Ev. kannst Du das mit SoftRAID (http://www.softraid.com/) machen, musst Dich mal durch die Spezifikation durchlesen).

    Gruss
    Andreas
     
  3. John L.

    John L. Active Member

    Hi Andreas,

    Wieder ne Antwort von Dir (hast mir bei meinem letzten Prob schon ganz gut geholfen) ....DANKE!

    Werd mal mit Softraid rumspielen, die haben grad erst ne neue Version rausgebracht, glaub ich....

    THX

    John L.
     
  4. mausbiber

    mausbiber New Member

    Ist aber seltsam.... warum bootet dann mein Softraid??

    Hab am internen ATA66 des QS 2 IBM Platten hängen und über OSX als RAID konfiguriert - Bootet einwandfrei !

    Dürfte doch dann auch nicht gehen oder?
     
  5. AndreasG

    AndreasG Active Member

    Was für ein RAID? Striped oder Mirrored? Wenn Striped, würde das bedeuten, dass OSX im Falle von IDE wohl einen Mini-Treiber auf das RAID spielt. Im Fall von SCSI ist das eventuell anders.

    Aber wie gesagt: Einige sagen, es geht, andere wiederum sagen, es geht nicht. Mit meiner Adaptec 29160 geht es übrigens definitiv nicht, zuletzt habe ich das mit Jaguar ausprobiert. Vielleicht wäre es heute unter Panther ja anders, wer weiss.

    Tatsache ist einfach: Bootet der Mac nicht ab dem RAID kann man realtiv wenig machen. Es gibt nirgendwo was einzustellen, was dieses Problem lösen könnte. Auch Treiber der Hersteller nüzten nichts, denn die müssten ja erst mal vom RAID geladen werden. Vielleicht ist das auch ein Problem der Firmware der jeweiligen Adapter.

    Gruss
    Andreas
     
  6. ks23

    ks23 Ohne Lobby

    Dazu hab ich auch noch ne Frage!

    Hab folgende Aussage auf Barefeats gefunden:
    Warum wird der Rechner denn nicht schneller gestartet?
    RAID 0 is doch aus zwei mach eine oder :confused:
    Die Programme sollen auch nicht schneller starten. Warum? Der Durchsatz is doch doppelt so hoch! Klar, das Netzwerk wird deswegen nicht schneller initialisiert, aber schneller müsste es doch sein??

    Und warum soll man Panther nicht als RAID 0 installieren, wollte ich nämlich machen?!

    Gruss
    Kalle
     
  7. AndreasG

    AndreasG Active Member

    Das irritiert mich: Bei einem Striped-RAID sind die Daten ja gleichmässig auf beide Platten verteilt. Die Daten auf einer einzelnen Platte sind nicht verwertbar. Um von einem solchen RAID zu booten muss das Array also bereits aktiv sein.

    Das setzt aber voraus, das die Firmware der Adapterkarte (im Falle einer SCSI- oder ATA-Karte) oder in der Firmware des Mac vorhanden ist.

    Und sollte das so sein, erreicht das Array auch bereits seine doppelt so hohe Geschwindigkeit. Also mich würde bald mal interessieren, wie genau so ein Striped-Array aufgebaut ist und zu welchem Zeitpunkt es wirklich aktiviert wird.

    Gruss
    Andreas
     
  8. ks23

    ks23 Ohne Lobby

    Also kannst du dir die Aussage von oben auch nicht erklären?

    Gruss
    Kalle
     
  9. mausbiber

    mausbiber New Member

    Mein RAID ist Stripe - und funktioniert einfach.

    Anfangs wollte es zwar auch nicht booten - aber als ich dann mit CCC mein anderes ACARD HardRAID (auch Stripe) darauf geclont habe lief es.....

    Und das ging schon unter Jaguar - liegt also nicht an Panther.

    Aber vielleicht ist das bei SCSI ja auch alles ganz anders....
     
  10. AndreasG

    AndreasG Active Member

    Nein, nicht wirklich. Apple's RAID ist halt so eine Sache. Die Erfahrungen, die Kate mit Apple-RAID gemacht hat, lassen übrigens ebenfalls die Alarmglocken läuten: Ein System-Update kann das gesamte RAID unbrauchbar werden lassen, d.h. sie musste das Array auflösen und neu zusammenstellen. Dabei gehen natürlich alle Daten verloren.

    Ich denke mal, wer es ernst mit RAID meint, sollte vielleicht besser ein Profi-Produkt wie SoftRAID nehmen (www.softraid.com) oder gleich ein Hardware-RAID in Betracht ziehen. Ich selber verwendete Apple-RAID immer nur als Daten-Disk mit einem guten Backup-Konzept.

    Gruss
    Andreas
     
  11. hapu

    hapu New Member

    Zitat aus der Features-Seite von softraid.com

    Starts up from a Mirror volume:
    SoftRAID: Coming soon
    Apple's RAID: Some hardware


    Also würde mich jetzt interessieren, welchen Mac mausbiber da von einem RAID-0 bootet ...

    Und außerdem fiebere ich dem "Soon" entgegen - noch lieber würde ich ja überhaupt von 3 Platten booten (RAID-5) - und dafür aber nix zahlen ...


    HaPu
     
  12. AndreasG

    AndreasG Active Member

    Von einem Mirror volume zu booten müsste noch eine leichte Übung sein, denn die Platten sind ja jede für sich auch ohne RAID lesbar. Ist ja schliesslich der Witz von RAID 1. Aber gemäss SoftRAIDs Aussage sei ja noch nicht mal booten ab RAID1 möglich.

    Eine einzelne RAID 0-Platte aber ist zur Boot-Zeit nichts anderes als ein ungültiges Volume. Da ist nicht mal HFS+ drauf. Erst ein Treiber macht aus zwei RAID-0-Platten ein Volume. Aber woher soll denn der Treiber kommen, wenn OSX noch nicht läuft?

    Entweder aus der Open-Firmware des Mac oder aus der Firmware einer PCI-Karte? Oder aber Apples RAID-Software legt eine Mini-Bootpartition auf dem RAID an, die nicht Striped ist und die den RAID-Treiber enthält, der das RAID zusammenstellt und danach OSX bootet.

    Letzteres ist für mich am wahrscheinlichsten. Gibt es denn hier niemanden, der uns das definitiv und unmissverständlich erklären/bestätigen kann? Würde mich wirklich interessieren. Das wurde hier schon so oft diskutiert...

    Gruss
    Andreas
     
  13. krahni

    krahni New Member

    wuerde mich jetzt auch mal interessieren, ich habe gerade meinen g5/1.8/2gb mit 2x250gb-platten bestellt und wuerde den gern gleich als raid0 installieren ...
     
  14. henningl

    henningl Bei den Verwirrten

    Salü,

    kein Problem.
    Habe meinen G5 auch mit 2 Platten gekauft
    und bei der Inst als Stripe angelegt.
    Läuft seither ohne Probs.

    Gruß
    Henning
     
  15. krahni

    krahni New Member

    wuerde mich jetzt auch mal interessieren, ich habe gerade meinen g5/1.8/2gb mit 2x250gb-platten bestellt und wuerde den gern gleich als raid0 installieren ...
     
  16. henningl

    henningl Bei den Verwirrten

    Salü,

    kein Problem.
    Habe meinen G5 auch mit 2 Platten gekauft
    und bei der Inst als Stripe angelegt.
    Läuft seither ohne Probs.

    Gruß
    Henning
     
  17. krahni

    krahni New Member

    wuerde mich jetzt auch mal interessieren, ich habe gerade meinen g5/1.8/2gb mit 2x250gb-platten bestellt und wuerde den gern gleich als raid0 installieren ...
     
  18. henningl

    henningl Bei den Verwirrten

    Salü,

    kein Problem.
    Habe meinen G5 auch mit 2 Platten gekauft
    und bei der Inst als Stripe angelegt.
    Läuft seither ohne Probs.

    Gruß
    Henning
     
  19. krahni

    krahni New Member

    wuerde mich jetzt auch mal interessieren, ich habe gerade meinen g5/1.8/2gb mit 2x250gb-platten bestellt und wuerde den gern gleich als raid0 installieren ...
     
  20. krahni

    krahni New Member

    wuerde mich jetzt auch mal interessieren, ich habe gerade meinen g5/1.8/2gb mit 2x250gb-platten bestellt und wuerde den gern gleich als raid0 installieren ...
     

Diese Seite empfehlen