Canon Pixma als Netzwerkdrucker an neuer Airport-Station

Dieses Thema im Forum "Hardware" wurde erstellt von oherling, 17. April 2007.

  1. oherling

    oherling New Member

    Hallo Forum,

    zu meiner eigenen Überraschung kann ich meinen Pixma MP 780 via USB-Port der neuen Airport-Station (811.n) als Netzwerkdrucker zumindest für alle Macs nutzen.
    Einziges Problem: Mehrseitige Ausdrucke von mehr als 3 Seiten werden mittendrin abgebrochen, als würde der Drucker "überlaufen" (hat er natürlich vorher nicht gemacht, als er noch lokal an einem Mac hing und über "Printer Sharing" angesteuert wurde).
    Habe von Canon den neuesten Druckertreiber geladen, half aber auch nichts. Konfigurationsmöglichkeiten gibt es so gut wie keine.

    Hat jemand eine Idee?

    Olaf
     
  2. DominoXML

    DominoXML New Member

    Hi Olaf,

    habe es hier einmal mit einem Brother MFC getestet und keine Probleme.

    Das gelbe Blinken sollte normalerweise auf Verbindungsprobleme hinweisen.

    Mich würde interessieren wieviele Rechner Du am Airport Netz hast, d.h. vieviel Traffic darüber läuft.

    BTW, läuft den iMac wieder?

    Gruß

    Volker
     
  3. oherling

    oherling New Member

    Hi Volker,

    ja, wenigstens Airport am iMac läuft wieder (bis auf Weiteres…). Habe radikal sämtliche Preferences aus der Haupt- und der Benutzer-Library gelöscht, inklusive aller SysConfigs.
    Dann endlich konnte ich die Airport-Einstellungen im Netzwerk neu definieren, und das wird´s hoffentlich gewesen sein.

    An der Airport-Station hängen 3 Macs und ein PC-Laptop, meist aber nur zwei der vier gleichzeitig im Netz, also kein wilder Traffic.

    Gruß

    Olaf
     
  4. DominoXML

    DominoXML New Member

    Hi Olaf,

    die Extreme hat drei normale Ethernet Ports. Kannst Du mal schaun ob du einen der Rechner daran mal anschließt und dafür Airport abschaltest.

    Dann mal eine grosse Datei drucken. Interessiert mich ob das Problem dann noch auftaucht.

    Danke

    Volker
     
  5. oherling

    oherling New Member

    Hi Volker,

    werde ich probieren. Komme aber erst morgen Nachmittag dazu.

    Werde berichten.

    Gruß
    Olaf
     
  6. oherling

    oherling New Member

    Hi Volker,

    Problem besteht auch, wenn ich mich per Ethernet-Kabel dranhänge.
    3-4 Seiten Text schafft er, bei mehr Seiten schmiert der Drucker ab.

    Einzige Lösung bisher: Größere Datei in Häppchen à 3 Seiten (einzelne Druckjobs aufteilen, die jeweils auch rauskommen; die Warteschlangenfunktion geht also.

    Vom PC aus gibt es beim Pixma-Druckertreiber noch die Einstellmöglichkeit, den Spooler abzuschalten und auf "direkten Druck" zu stellen; vielleicht würde der Drucker dann nur häppchenweise beliefert werden und bekommt keinen Overload. Diese Einstellmöglichkeit gibt es vom Mac aus aber blöderweise nicht. Direkt am Gerät übers Menü ist auch nichts Derartiges zu finden.

    Gruß
    Olaf
     
  7. DominoXML

    DominoXML New Member

    Hi Olaf,

    da ich zumindest einen Drucker so benutzen möchte habe ich gegoogelt und festgestellt daß das Problem vorallem bei Canon-Duckern bekannt ist.

    Danke, daß Du es mal mit nem Lan-Kabel probiert hast. So war der Einfluß des WLAN's auszuschliesen.

    Das Problem liegt daran, daß die Airport die Daten schneller an den USB des Druckers schickt als er diese erwartet. Du lagst mit der Vermutung eines "Overflows" also goldrichtig.

    Die Airport sendet die Daten wohl mit mehr als 12 MBit die der Drucker erwartet.
    Das Problem scheint schon an Apple und an Canon übermittelt worden zu sein.

    Ich habe darauf hin nach einem Workarround gesucht und folgendes im Apple Hardwareforum gefunden:


    In a Terminal window type:

    sudo ipfw add pipe 1 ip from any to <IP Address of AirPort Base Station> 10000

    (filling in the IP Address of the Airport Base Station that the printer is connected to ) (the system will also ask for your login password) and then type:

    sudo ipfw pipe 1 config bw 12Mbit/s

    which allows modern printers to work at the more normal USB printer speed of 12Mbit/s. (You can always try the fall back 1Mbit/s, if the connection is still too fast.)

    Das Dumme ist ,daß die Einstellung beim Reboot der Station verloren geht.

    Ich hoffe, daß Apple ein Update bringt mit dem man die Geschwindigkeit des USB-Ports bei Problemen limitieren kann.

    Ein Trick könnte sein einen langsamen USB 1.1 Hub zwischen Airport und Drucker zu stecken um so die Verbindunggsgeschwindigkeit runter zu regeln.

    Mit ein bischen Glück könnten dann auch mehrere Drucker über den Hub an der Extreme stabil laufen.

    Kanns leider hier nicht testen, habe zwei Brother, die das Problem nicht haben.

    Gruß

    Volker
     
  8. oherling

    oherling New Member

    Hi Volker,

    vielen Dank für die Info!
    War übers Wochenende weg, deshalb kann ich mich erst heute drum kümmern.

    Ich hoffe, Dein Tipp klappt – wäre schade, wenn nicht, denn die Pixma MP 780 ist ansonsten ein wirklich gutes Gerät.

    Ich werde berichten……

    Gruß Olaf
     
  9. oherling

    oherling New Member

    … ist der beschriebene Workaround. Erst druckte der Pixma ein zwölfseitiges Dokument ohne Abbruch, ein Foto mit 800 KB schaffte er auch, doch dann scheiterte er an einer DINA4-Seite, von der ich zwei Kopien (!) wollte …

    Die Lösung mit dem USB1-Hub klingt am einfachsten, blöderweise schneide ich (wenn es denn funktioneren Würde) mir damit ins eigene Fleisch, da an die USB-Schnittstelle auch noch eine externe Festplatte (USB 2.0) als Backup-Lösung für alle Rechner dran soll, die ich auch schon gekauft habe.

    Habe jetzt überlegt, mir einen einfachen S/W-Laserdrucker mit Ethernet anzuschaffen, die alte Airport Extreme als Access Point zusätzlich wieder ins Netz zu bringen und sie als Printserver zu nutzen, indem ich den Laserdrucker an die Ethernet-Schnittstelle der alten AE hänge (müsste technisch eigentlich gehen).
    Dann könnte ich den Pixma als Scanner, Kopierer und Fax sowie für Einzelausdrucke weiter nutzen und größere Druckjobs auf den Laserdrucker senden.

    Nicht gerade die einfachste und schon gar nicht die preiswerteste Lösung – aber die derzeitige Lösung als einzige Print-Möglichkeit macht mir doch etwas Bauchschmerzen…

    Grüße
    Olaf
     
  10. derbaer

    derbaer New Member

    Hmm...wirklich ärgerlich mit dem Canon...sogar mein uralter Epson Photo läuft problemlos an der Extreme.

    Aber die Hub-Lösung hätte etwas, nur würde ich einen passiven USB2.0 Hub zwischen die Extreme und den USB1.1-Hub hängen. Da der 2.0 Hub die Geschwindigkeit zum 1.1-Hub herunterskalieren sollte, ohne seinen anderen Anschlüssen die volle USB 2.0 Geschwindigkeit zu verlieren, könnte es klappen. Du hättest quasi den USB2.0 der Extreme in enen 2.0 und einen 1.1-Zweig aufgespalten.

    An den 2.0-Hub die HD und an den 1.1-Hub den Canon. Gedanklich sollte es klappen, käme auf einen RL-Versuch an.

    Obwohl, mit einem Laser im Netz kannst Du nichts falsch machen.
     
  11. DominoXML

    DominoXML New Member

    Hi Olaf,

    bevor Du noch mehr Geld ausgibst probiere erst mal das mit dem USB 1.1 Hub.

    Ich habe mal eine externe Festplatte an den USB der Extreme gesteckt und kurz die Performance gemessen.

    Ich komme hier auf 4 bis 4,5 MB/s. Mit meinem Linux Server erreiche ich beim Backup übers Netz (GBit-Ethernet) zwischen 45 und 85 MB/s.

    Fürs Backup wäre die Extreme in meinem Fall also ein echter Rückschritt.

    Ich denke mit nem gebrauchten PC mit Linux , einer GBit-Netzwerkkarte, einem günstigen GBit-Switch gibst Du auch nicht mehr Geld aus und kannst deine externe Festplatte weiter verwenden.
    Alternativ käme natürlich auch ein "alter" Mac in Frage.

    Die Performance ist sicher deutlich besser.

    Gruß

    Volker
     
  12. oherling

    oherling New Member

    Danke für die Tipps!

    Werde heute mal losgehen und USB-Hubs besorgen – vielleicht hab ich ja Glück.
    Ein zweiter Drucker ist ja nie falsch – aber eben doch ein bisschen sehr Luxus……

    Wenn es nicht klappen sollte, werde ich es vielleicht riskieren, nur einen "normalen" USB-Tintenstrahler von HP oder Epson zu kaufen und den an den USB-Port meiner alten Extreme (die dann als Access Point mit ins Netz) zu hängen. Die scheinen ja mit der Bonjour-Technologie weniger Probleme zu haben als Canon…

    Olaf
     
  13. DominoXML

    DominoXML New Member

    Hi Olaf,

    ein Freund hat mir heute einen PIXMA IP5000 zur Reparatur vorbeigebracht.

    Bin zwar mächtig im Projektendstreß aber denke ich kann Dich die nächste Woche beim Testen unterstützen, sofern das noch nötig ist.

    Gruß

    Volker
     
  14. oherling

    oherling New Member

    Hi Volker,

    sehr nett von Dir – wird aber nicht mehr nötig sein. Dafür gibt es neue Probleme……

    Nachdem alles Ausprobieren nichts brachte, habe ich mir heute einen nagelneuen HP Photosmart C6180 All-in-one angeschafft, nachdem ich einen Abnehmer für den Pixma gefunden hatte.
    Der HP hängt an der Ethernet-Buchse derzeit noch an meiner alten Airport Extreme, die mit WDS ins Drahtlos-Netz eingebunden ist.
    Netzwerkmäßig klappt das auch tadellos, nur das Drucker-Dienstprogramm findet beim Anlegen des Druckers über "automatisch" keinen passenden Druckertreiber. Bei manueller Auswahl bleibt dann für die Photosmart-Serie nur ein Beta-GimpPrint-Treiber, der zum OS X gehört und im Ordner "hp" liegt; der arbeitet zwar, aber unsauber. So hält er z.B. die Randangaben der Druckseiten nicht ein und kann nicht gescheit auf dem Blatt zentrieren.
    Kann doch wohl nicht sein, dass bei der Installation per HP-CD kein entsprechender Druckertreiber mit installiert wird?

    Olaf
     
  15. oherling

    oherling New Member

    Jetzt kauf ich mir extra einen Netzwerk-Drucker, um das Elend mit dem AE-USB-Anschluss loszuwerden, und jetzt das:

    Nach einem Neustart ließ sich der Drucker mit dem Original HP-Treiber "HP All-in-One 4.0" (aktuellste Version von der HP-Website) automatisch installieren – und druckt seitdem gar nicht mehr. Alle Druckaufträge werden sofort gestoppt und sitzen in der Warteschlange. Auch der Versuch, den Drucker nicht als Bonjour-Drucker, sondern via "HP TCP/IP" anzulegen (was auch ging), brachte auch nichts.

    Zurück also zum Gimp-Print von OS X. Jetzt läuft er wenigstens wieder, aber DAS KANN ES WIRKLICH NICHT SEIN!

    Kennt jemand das Problem mit dem HP-Treiber??

    Olaf
     

Diese Seite empfehlen