Cyberport-Problem bei Safari + Co

Dieses Thema im Forum "Software" wurde erstellt von printecki, 2. Februar 2005.

  1. printecki

    printecki Schumi-Fan

    Hallo, Leute,

    habe nur bei Cyberport-Webseiten das Problem, dass sie sich nicht richtig aufbauen, soll heißen, ich krieg nicht 1 richtige Seite angezeigt, im http-Balken oben rödelt's immer vor sich hin. Bei Safari + IE, mit + ohne Pop-up's.

    Wat kann dat sein :confused:
     
  2. mausbiber

    mausbiber New Member

    Auf jeden Fall liegt es nicht an der Webseite.

    Bei meinem Safari mit geblocken Pop-ups funktioniert es tadellos.
     
  3. macixus

    macixus Hofrat & Traktorist

    Mal den Cache leeren. Wirkt oft Wunder.
     
  4. menz

    menz New Member

    Gleiches Problem hab ich hier auch sein ein paar Tagen :(

    menz
     
  5. printecki

    printecki Schumi-Fan

    Ist klar, auch gemacht. Nutzt aber nix, siehe:

    Text-Codierungen auch schon versucht
     
  6. Macziege

    Macziege New Member

    Gerade probiert mit Safari, die Site wird schnell und vollständig angezeigt. Ich habe allerdings auch DSL.
     
  7. printecki

    printecki Schumi-Fan

    Ja, DSL ist natürlich auch vorhanden :confused:
     
  8. Mäkki

    Mäkki New Member

    Der html-Code ist nicht korrekt:
    <FRAME SRC=...>
    <FRAMESET COLS=...>
    <FRAME SRC=...>
    <FRAME SRC=...>
    </FRAMESET>
    </FRAMESET>

    Der einleitende Tag <FRAMESET> fehlt...
     
  9. printecki

    printecki Schumi-Fan

    Da bin ich überfordert (html). wird aber doch automatisch aufgerufen, wenn ich www.cyberport.de anwähle.
    Auf welche Stelle muss ich gehen, um den Quellcode zu sehen, den Du beschreibst? Oder was soll/kann ich da machen???
     
  10. Mäkki

    Mäkki New Member

    Hab ich wieder nur mit einem Auge hingesehen -
    den ersten Tag schreiben sie mit Javascript:
    <SCRIPT LANGUAGE="JavaScript">
    <!--
    B_NS4a = (document.layers) ? true : false;
    B_Mac = (navigator.appVersion.indexOf("Mac") != -1);
    B_NS4 = B_NS4a && !B_Mac;
    B_Op = (navigator.userAgent.indexOf("Opera")>-1);
    if(B_Op || B_NS4){
    document.write("<FRAMESET ROWS='112,*' BORDER='0'>");
    }else{
    document.write("<FRAMESET ROWS='107,*' BORDER='0'>");
    }
    // -->
    </SCRIPT>

    Ist bei dir Javascript deaktiviert?
     
  11. printecki

    printecki Schumi-Fan

    Nein, aber damit bin ich nochmehr überfordert.
     
  12. mausbiber

    mausbiber New Member

    Schau mal in der Menueleiste von Safari unter Hilfe->installierte plug-ins

    Da sollte unter anderem
    Java 1.4.2 Plug-in (Cocoa) — von der Datei „JavaPluginCocoa.bundle
    und
    Java 1.3.1 Plug-in — von der Datei „Java Applet.plugin
    stehen.

    Vielleicht mal unter Programme-Dienstprogramme-Java in den Einstellungen die Caches löschen.

    Vielleicht bringt das was.
     
  13. printecki

    printecki Schumi-Fan


    Alles kontrolliert + gefunden
    In Dienstprog>Java Caches gelöscht, Safari-Neustart > cyberport > NIX ISS
    ;(
     
  14. Ganimed

    Ganimed New Member

    Versuch mal das:

    Safari beenden
    Festplatte
    Benutzer
    Haus(dein Name)
    Library
    Preferences
    dort löschst du "com.apple.Safari.plist"

    danach Safari wieder starten. Deine Lesezeichen bleiben erhalten, aber die Darstellung von Safari musst du dann ggf wieder anpassen. Viel Erfolg!
     
  15. bastigs

    bastigs New Member

    in der neuen Macwelt gibt's den Ratschlag:

    eventuell Java neu installieren
     
  16. printecki

    printecki Schumi-Fan

    Ausgeführt = NIX WARS ;(

    Das mit Java neu istallieren, muss ich mal in Ruhe probieren, melde ich aber wieder
     
  17. Spanni

    Spanni New Member

    die seite hat aber auch ein paar fehler. nicht nur das <framset> fehlt.
    das javascript ist in <html> tag! sollte eigentlich nach <head> kommen.
     
  18. printecki

    printecki Schumi-Fan

    @ alle

    Java-Update ohne Probleme gemacht,
    alles funzt . . außer cyberport !!!!!!!!!!


    @spanni
    Was sagt mir das?
    Haben die von cyberport was falsch oder wie entsteht die falsche Programmierung?
     
  19. Mäkki

    Mäkki New Member

    Also:
    Wenn du die Seite in Mozilla öffnest und dann oben in der Adresszeile "javascript:" (ohne "") eingibst, siehst du das es auf der Seite JavaScript-Fehler gibt. (Javascript hat übrigens mit Java überhaupt nix zu tun)

    Diese Fehler können dazu führen, dass JavaScript überhaupt nicht ausgeführt wird.

    Wenn das der Fall ist, fehlt im Frameset der Seite ein <Frameset>-Tag, weil der nach Abfrage des Browsers, mit Hilfe von JavaScript ins Dokument geschrieben wird.
     

Diese Seite empfehlen