Datei nicht löschbar

Dieses Thema im Forum "Software" wurde erstellt von Lis-a-pple, 30. Oktober 2008.

  1. Lis-a-pple

    Lis-a-pple New Member

    Hallo ihr Lieben,

    ich habe auf meinem PC ein Lied gefunden, dass ich gerne löschen würden, da ich noch nicht einmal weiß, wie es auf meinen PC gekommen ist. Ich habe versucht, es aus iTunes zu löschen, was erst nicht ging. Dann habe ich es probeweise mal auf den Desktop gezogen und habe es probiert in den Papierkorb zu verschieben. Ging auch, aber der wollte sich dann nicht mehr leeren lassen. Das habe ich dann aber mit "Sicher löschen" bei OnyX hinbekommen. Aber jetzt habe ich dieses Lied noch auf meinem Desktop... Es will sich jetzt auch nicht mehr verschieben lassen, es erscheinen Fehlermeldungen, dass ich keine Rechte habe und dass andere Programme Probleme bekommen könnten usw... Und jetzt???
    Ach ja, als ich auf Informationen gegangen bin, konnte ich den Haken bei "Geschützt" auch nicht rausmachen.


    Liebe Grüße und Danke schon mal im Voraus,
    Lisa
     
  2. edwin

    edwin New Member

    Wie heißt diese Datei (und Endung)?
     
  3. Lis-a-pple

    Lis-a-pple New Member

    Die Datei heißt "Akon - Ghetto RMX1.mp3"; ist jedoch 0KB groß...

    Ich hänge mal ein Bild mit den Informationen an
     

    Anhänge:

  4. Mathias

    Mathias New Member

    Vielleicht geht es mit dem Terminal:

    sudo rm -i zu_löschende_Datei

    Nach dem -i machst du einen Leerschlag, ziehst die zu löschende Datei auf das Terminalfenster und drückst Enter.

    Das Terminal fragt dich, ob du diese Datei wirklich löschen willst. Wenn du das willst, tippe y und drücke Enter.


    edit: Im Bild steht übrigens dein Name. Ich würde den entfernen. ;)
     
  5. Lis-a-pple

    Lis-a-pple New Member

    Danke, habe meinen Namen entfernt, total vergessen.

    Wo soll ich denn den Terminal eingeben? Bei OnyX? Habe es dort mal versucht, es gab "sudo rm -i" nicht, nur "sudo".
     
  6. MACaerer

    MACaerer Active Member

    Zur Ergänzung, da fehlt etwas: Der Unix-Befehl "sudo" ist die Abkürzung für "superuser do". Das heißt, dass nach dem Befehl die Eingabe des Admin-Passwortes erwartet wird.

    MACaerer
     
  7. Mathias

    Mathias New Member

    stimmt... :klimper:

    @ Lis-a-pple: Du kannst den Befehl im Programm "Terminal" eingeben. Das Programm befindet sich im Ordner "Dienstprogramme".
     
  8. Lis-a-pple

    Lis-a-pple New Member

    Das habe ich jetzt auch gemacht, wie ihr gesagt habt.
    Ich habe einen neuen Befehl geöffnet und "superuser do rm -i Datei" eingegeben. Dann hat sich ein Fenster geöffnet, ich habe "y" eingegeben und Enter gedrückt...

    "-bash: y: command not found" erschien.

    Dann hab ich das "y" hinter den Befehl gesetzt, es erschien ein Fenster mit dem Totel "bash". Das Passwort sollte ich einmal auch eingeben, jedoch konnte ich in dem Fenster nicht tippen.

    Was mach ich denn diesmal noch falsch??
    Danke schon mal für eure (geduldigen) Ratschläge!
    Lisa
     
  9. MACaerer

    MACaerer Active Member

    Bitte nochmals richtig lesen. Der Befehl lautet:
    sudo rm -i
    Zwischen sudo und rm muss ein Leerzeichen stehen, ebenso zwischen rm und -i und nach dem i ebenfalls. Bitte penibel auf die Schreibweise achten. Anschließend musst du die zu löschende Datei mit der Maus in das Terminalfenster ziehen, wodurch der Dateipfad in den Terminalbefehl übernommen wird. Anschließend den Befehl mit der Returntaste absenden. Anschließend wirst du nach dem Admin-Passwort gefragt. Nach dem Eingeben und Absenden desselben mit Return sollte die Datei gelöscht sein. Damit das ganze funktioniert musst du als Administrator angemeldet sein.

    MACaerer
     
  10. Lis-a-pple

    Lis-a-pple New Member

    Ich habe das schon richtig gelesen, da jedoch sudo nicht funktioniert, habe ich auch mal superuser do ausprobiert, da jemand vorher geschrieben hat, dass sudo nur die Abkürzung ist.

    Habe noch mal alles wie beschrieben gemacht, Passwort eingegeben und bestätigt. Die Datei ist noch da und im Fenster erschien folgendes:

    rm: ft.: No such file or directory
    rm: Ali-B: No such file or directory
    [Prozess abgebrochen - Ergebnis 1]

    Was ist denn jetzt noch falsch?!

    Liebe Grüße
     
  11. MACaerer

    MACaerer Active Member

    Der "sudo-Befehl" ist ein bissel kompliziert. Er funktioniert entweder mit dem root-Passwort oder mit dem Admin-Passwort. Du kannst ihn nicht als normaler Benutzer ohne Verwaltungsrechte verwenden. Versuche doch mal den remove-Befehl ohne sudo zu verwenden. Das sollte eigentlich dann gehen, wenn die zu löschende Datei auch von dem angemeldeten Benutzer erstellt wurde.
    Also:
    rm -i "Pfad der zu löschenden Datei"
    Den Pfad der zu löschenden Datei erhältst du, wenn du die Datei mit der Maus in das Terminalfenster ziehst. Wichtig ist die Schreibweise der Befehlszeile, insbesonders das Leerzeichen nach dem Befehl rm und nach dem Parameter -i.
    Nach der Eingabe kommt die Frage: remove "Pfad der zu löschenden Datei"? und du musst diese Frage mit "y" quittieren (Natürlich ohne "").
    Falls du die Rückfrage nicht willst, kannst du anstelle des Parameters "-i" auch "-r" eingeben. Dann wird die Datei ohne Rückfrage gelöscht.

    btw.
    sudo ist nicht die Abkürzung des Befehls "superuser do" sondern bedeutet Superuser do. Das habe ich weiter oben missverständlich formuliert, sorry.

    MACaerer
     

Diese Seite empfehlen