Der Berg ruft…

Dieses Thema im Forum "Software" wurde erstellt von smarund, 10. Januar 2005.

  1. smarund

    smarund New Member

    …Forumsgemeinde,

    mittlerweile bin ich fast reif für Klapse. Habe mich durch alle möglichen Threads in diesem Forum zu dem Thema "mount point" gearbeitet und eine Menge Tipps zur Fehlerbehebung gelesen. Allein sie wollen nicht das gewünschte Ergebnis einer wieder gemounteten Partition zeitigen…-((

    Das Festplatten-Dienstprogramm listet mir scheinbar alle nötigen Infos über die Partition auf:

    1. Den Namen (OSX)
    2. Den Typ (Volume)
    3. Die Medien-Identifikation (disk1s6)
    4. Den NICHT aktivierten Mount-Point
    5. Das Dateisystem (Mac OS Extended)
    6. Den Verbindungs-Bus (ATA)
    7. Den I/O-Iinhalt (Apple_HFS)
    8. Den Gerätebaum (ide/@0:6)
    9. Daß sie beschreibar ist
    10. Die Kapazität (6,9 GB)
    11. Die NICHT aktivierten Zugriffsrechte
    u.s.w.

    Sagt aber auch, daß die Überprüfung fehlgeschlagen sei, weil der Schlüssel nicht sortiert sei (Der Mount-Point fehlt und das Programm weiß nicht wo es anfangen soll) und der Prozess mit dem Fehler -9972 abgebrochen wurde (ich nehme mal an, daß das was mit den nicht zugeteilten Zugriffsrechten zu tun hat?)

    Der Terminalbefehl - df - gibt folgendes aus:

    Basisstation:~ basis$ df
    Filesystem 512-blocks Used Avail Capacity Mounted on
    /dev/disk0s7 13310752 8006544 5171104 61% /
    devfs 195 195 0 100% /dev
    fdesc 2 2 0 100% /dev
    <volfs> 1024 1024 0 100% /.vol
    /dev/disk0s6 1535784 846400 689384 55% /Volumes/OS9
    /dev/disk0s8 63322688 55491816 7830872 88% /Volumes/Aktuell
    /dev/disk1s7 63640080 55499968 8140112 87% /Volumes/Aedificium 1
    automount -nsl [287] 0 0 0 100% /Network
    automount -fstab [314] 0 0 0 100% /automount/Servers
    automount -static [314] 0 0 0 100% /automount/static

    Da nicht gemounted, wundert es nicht daß "OSX" dort nicht gelistet wird. Gebe ich den Terminalbefehl - diskutil list - ein bekomme ich folgendes Ergebnis:

    /dev/disk1
    #: type name size identifier
    0: Apple_partition_scheme *37.3 GB disk0
    1: Apple_partition_map 31.5 KB disk0s1
    2: Apple_Driver_ATA 27.0 KB disk0s2
    3: Apple_Driver_ATA 37.0 KB disk0s3
    4: Apple_Driver_IOKit 256.0 KB disk0s4
    5: Apple_Patches 256.0 KB disk0s5
    6: Apple_HFS OS9 749.9 MB disk0s6
    7: Apple_HFS OS-X 6.3 GB disk0s7
    8: Apple_HFS Aktuell 30.2 GB disk0s8

    /dev/disk1
    #: type name size identifier
    0: Apple_partition_scheme *37.3 GB disk1
    1: Apple_partition_map 31.5 KB disk1s1
    2: Apple_Driver_ATA 27.0 KB disk1s2
    3: Apple_Driver_ATA 37.0 KB disk1s3
    4: Apple_Driver_IOKit 256.0 KB disk1s4
    5: Apple_Patches 256.0 KB disk1s5
    6: Apple_HFS OSX 6.9 GB disk1s6
    7: Apple_HFS Aedificium 1 30.3 GB disk1s7

    Hier taucht die vermißte Partition auf. Gebe ich

    - sudo mount -t hfs /dev/disk0s6 - ein

    bekomme ich nach Eingabe des Passsworts

    usage: mount [-dfruvw] [-o options] [-t ufs | external_type] special node
    mount [-adfruvw] [-t ufs | external_type]
    mount [-dfruvw] special | node

    zu sehen. Erstelle ich mit:

    sudo mkdir /Volumes/OSX

    ein neues Verzeichnis und will mit:

    sudo mount -t hfs /dev/disk1s6/Volumes/OSX

    die Partition mounten bekomme ich:

    mount_hfs: No such file or directory

    als Fehlermeldung vom Terminal zurückgegeben. Tippe ich einfach:

    sudo mount /dev/disk1s6

    erzählt mir das Terminal nach Eingabe des Passworts folgendes:

    mount: /dev/disk1s6: unknown special file or file system

    Wenn ich diese Meldungen richtig interpretiere, dann ist mindestens ein Eintrag des "volume header" in A… Wie komme ich jetzt an diesen "volume header" ran. Ich vermute, daß der Eintrag "lastMountedVersion" nicht korrekt ist. Dieser Eintrag ist wohl sehr wichitg u.a. auch für das "Festplatten-Dienstprogramm" um Problem zu beseitigen. Wie müßte denn ein korrekter Eintrag aussehen. damit die Partition zumindest wieder vom Festplatten-Dienstprogramm so erkannt wird, daß es dieses reparieren kann und in der Folge auch wieder gemountet werden kann? Haben wir nicht unter uns einen Datenformat-Guru, der uns/mir weiterhelfen kann? Ich mag mich einfach noch nicht geschlagen geben und die Platte einfach neu formartieren. Nicht, wenn das System scheinbar "alles" hat, was es braucht um die Partition zu mounten,grrrr-(

    Besten Dank im voraus
     
  2. Mäkki

    Mäkki New Member

    Aus deinem Profil kann ich's net sehen -
    Kannst du aus 9 starten und da Erste Hilfe ausführen?
     
  3. tabi

    tabi New Member

    Ansonsten: Data Rescue X. Damit kriegst du deine Daten zurück und kannst dann die Platte initialisieren und die Daten zurück spielen.

    Grüße,

    tabi
     
  4. smarund

    smarund New Member

    Jupp,

    gabe ich gemacht. Erste Hilfe sagt:

    "Keys out of order, 4, 4471

    Fehlerhaftes Volume und Erste Hilfe kann das Problem nicht beheben.

    Platte ist aber auf dem Desktop zu sehen…
     
  5. smarund

    smarund New Member

    Mit TechTool bin ich auch schon mal ganz am Anfang drübergegangen. dort war die Platte ebenfalls nicht zu mounten und die Datenrettung hat "nur" die Files des OS 9 gerettet. Die OSX Files sind aber unberührt gelassen worden…
     
  6. smarund

    smarund New Member

    Abend Kinners,

    wie schon berichtet, unter OS 9 keine Fehlerreparatur. Dann ist mir beim Aktivieren von Fileshiarung die Kiste abgekackt. Neustart unter OS X und die Platte war wieder gemounted!!!

    I werd narrisch…

    Das Festplatten-Dienstprogramm konnte die Zugriffrechte reparieren, die Volumereparatur war trotzdem nicht möglich. Soweit so gut. Lege mir gerade mit CCC eine Kopie der Partition in ein Image an… 7GB; das wir wohl einen Moment dauern.

    Ich versteh das alles nicht…

    Grüße und Dank Martin
     

Diese Seite empfehlen