der Mailer-Daemon lässt grüßen

Dieses Thema im Forum "Software" wurde erstellt von gschwieb, 25. August 2006.

  1. gschwieb

    gschwieb Member

    Seit einer Woche erhalte ich bei Mails an gmx-Nutzer (fast permanent) und t-online-Nutzer (gelegentlich) Nachrichten vom Mailer-Daemon@mac.com etwa folgenden Inhalts. Habt Ihr ähnliche Probleme derzeit auch oder schon mal gehabt? Kann das an meiner Konfiguration liegen? eigenltich habe ich nichts verändert. Setze das Programm Mail ein und habe accounts bei .mac und 1&1. Fehler tritt unabhängig davon auf, welchen account ich als Absender einsetze.

    The original message was received at Thu, 24 Aug 2006 22:34:44 -0700 (PDT)
    from smtpin02-en2 [10.13.10.147]

    ----- Transcript of session follows -----
    ... while talking to mx0.gmx.de.:
    <<< 421-4.3.2 {mx088} Too many bad recipients. Are you an address harvester? Try again in 8 hour(s) 28 minute(s)
    <<< 421 4.3.2 and see( http://www.gmx.net/serverrules )
    ... while talking to mx0.gmx.net.:
    QUIT
    <<< 421-4.3.2 {mx060} Too many bad recipients. Are you an address harvester? Try again in 8 hour(s) 28 minute(s)
    <<< 421 4.3.2 and see( http://www.gmx.net/serverrules )
    <hier stand die Mail-Adresse@gmx.de>... Deferred: Invalid argument
    Warning: message still undelivered after 4 hours
    Will keep trying until message is 4 days old
    Reporting-MTA: dns; smtpout.mac.com
    Arrival-Date: Thu, 24 Aug 2006 22:34:44 -0700 (PDT)

    Final-Recipient: RFC822; hier stand die Mail-Adresse@gmx.de
    Action: delayed
    Status: 4.5.0
    Diagnostic-Code: SMTP;
    Last-Attempt-Date: Fri, 25 Aug 2006 05:11:43 -0700 (PDT)
    Will-Retry-Until: Mon, 28 Aug 2006 22:34:44 -0700 (PDT)
     
  2. mac-christian

    mac-christian Active Member

    Die Meldung ist selbsterklärend.

    Da steht, dass du zu viele Mails an ungültige Adressen zu schicken versucht hast. "Are you a harvester" bezieht sich darauf, dass Spammer-Programme selber Adressen "erfinden" in der Hoffnung, dass ab und zu mal eine wirklich existiert.

    Mehr kann ich dir auch nicht sagen; vielleicht erkundigst du dich mal bei den Leuten, denen du schreiben willst, wie ihre Adressen wirklich heissen.

    Christian.
     
  3. gschwieb

    gschwieb Member

    Im Prinzip hast Du recht. De facto aber überhaupt nicht.
    1. Die verwendeten Mailadressen sind richtig, sämtlich an gute Bekannte bzw. Freunde.
    2. Mein Mailversand hält sich nun wirklich in sehr zivilen Grenzen. Sagen wir mal 1 bis 3 pro Tag (natürlich nicht an die gleichen Personen).

    Ich glaube beim Mac nun mal nicht an Viren, hatte mir aber trotzdem mal in einem Anflug von was auch immer Virus Barrier X4 gekauft und natürlich das Programm auch mal über die Festplatte huschen lassen. War aber nix. Ich habe eine DSL flat-Verbindung über Kabel, die ich mit dem Mac meiner Frau teile. Dritte haben keinen Zugriff zur Hardware. sollte ich mal das Kennwort zu meinem Provider ändern?
    Frage an die Experten: Kann sich ein Dritter eingenistet haben und meine Rechner missbrauchen? Wenn ja. Wie kriege ich das raus bzw. kann das verhindern?
    Ist hierbei NetBarrier X4 (habe ich ebenfalls) hilfreich? Ich werde mir wohl mal das Handbuch durchlesen müssen. Stöhn
     
  4. mac-christian

    mac-christian Active Member

    Also ich denke, der Mailserver weiss schon, welche Adressen es gibt und welche nicht, oder?

    In deiner Fehlermeldung stand doch auch, dass du in "8 hour(s) 28 minute(s)" erst wieder versuchen darfst, Mails zu schicken. Hast du so lange gewartet? Mein Mailserver sperrt auch Mails, wenn zuviele fehlerhafte Adressen vorkommen. Mit jedem neuerlichen Sendeversuch vor Ablauf wird die Sperrzeit weiter heraufgesetzt...

    Könnte es sein, dass es ein Virus ist, aber eben nicht einer auf deinem Mac, sondern einer sonstwo, der unter deiner Adresse sich weiterverbreiten will? Weisst du, welches Mail vom Mailserver beanstandet wird? Sind Mails an deine Bekannten schon mal nicht angekommen?

    Es gibt nämlich so hinterhältige Viren, die nisten sich ein, lesen das Adressbuch, geben sich eine der vorhandenen Adressen als Absender und verschicken sich selber an alle andern im Adressbuch vorhandenen Adressen wie auch eventuell an selber generierte Adressen (die natürlich zu 80-90% ungültig sind). Zum Beispiel werden alle vorhandenen Postfachnamen (also alles vor dem "@"-Zeichen) mit allen vorhandenen Domains kombiniert.

    "Nützt es nichts, so schadet es nichts", würde ich da sagen. Einen Versuch ist es allemal wert.

    Beste Grüsse, Christian
     
  5. gschwieb

    gschwieb Member

    Hallo Christian,
    vielen Dank für Deine Hilfestellung. Vielleicht interessiert die Vorgeschichte:
    Alles (ob Zufall oder nicht) fing damit an, als ich vor ca. 1 1/2 Wochen eine Pishing-eBay-Mail bekam, übrigens über mein .mac Account, das bei ebay vor Jahren hinterlegt war aber jetzt dort nicht mehr vorliegt . Den darauf befindlichen Link habe ich nicht geöffnet, die Mail weitergeleitet an ebay (so wie von ebay erbeten) und nach der offiziellen Bestätigung seitens ebay (= Pishing) die Mail gelöscht, den Papierkorb geleert und auch vom Server gelöscht. Natürlich auch vorsichtshalber mein ebay-Passwort geändert.

    Die seltsamen Antworten auf Mails (bisher gmx, web und t-online) erhielten zeitlich etwa parallel sowohl meine Frau als auch ich (beide Rechner sind am gleichen Router auf die 1&1 DSL-Leitung geschaltet).
    Bei allen Mails, die von meiner Frau oder mir versandt wurden, waren die Mail-Adressen definitiv richtig. Die von mir geschilderten Mailer-Daemon-Rückläufe erfolgten unabhängig davon, ob ich meine .mac oder meine 1&1 Mail-Adresse als Absender verwendete. Auch ein dienstliches Mail an eine private Adresse vom iMac meiner Frau (gesteuert über Safari bzw. den Schulaccount auf dem Server des Landes Nordrhein-Westfalen) ereilte das gleiche Schicksal.
    Das zur Vorgeschichte.
    Ich habe in der Tat nicht immer die vom Daemon gesetzte Vorlaufzeit eingehalten; denn da meine Zieladressen definitiv richtig waren, ging ich davon aus, dass halt der gmx/web-Server spinnt.
    Teilweise sind die Mails mit erheblicher Verspätung zugestellt worden, teilweise aber auch nie angekommen.
    Nun habe ich mein Internetpasswort bei 1&1 sowie das Passwort zum Einloggen in das 1&1 Control-Center geändert und den Router so geschaltet, das er die Internetverbindung nach 3 Minuten Leerlauf trennt.
    Seitdem funktioniert es wieder (ob Zufall oder dauerhaft, sei mal dahingestellt).
     
  6. mac-christian

    mac-christian Active Member

    Grundsätzlich glaube ich nicht, dass die "Phisher" irgendwelche Mailadressen von EBay-Nutzern kennen - sonst müsste ich ja Zweifel an der Sicherheit meiner Daten bei EBay haben. An deine @mac.com-Adresse sind sie vermutlich auf andere Art gekommen.

    Was hast du denn als SMTP-Server eingestellt? Die POP-Server sind ja wohl für beide Konten richteg, denn Mail-Empfang funktioniert ja.

    Warum nimmst du als SMTP-Server nicht den deines Zugangsproviders - das ist meist die problemloseste Variante. Du musst dafür einfach bei jedem Postfach im Mailprogramm (welches?) einstellen - vermutlich ist das "smtp.1und1.de" oder so was Ähnliches. Versuch mal, dann eine Mitteilung zu schicken.

    Das erscheint einigermassen logisch. Dem SMTP-Server ist es egal, welchen Absender du brauchst - genauso wie es der Post egal ist, welchen Absender du auf den Briefumschlag schreibst, den du einwirfst. Wichtig ist bloss, dass die Briefmarke und die Adresse gültig sind. Wenn du aber eine französische Briefmarke aufklebst und den Brief in einen deutschen Briefkasten wirfst, gibts Probleme. Und auch, wenn die Empfängeradresse nicht stimmt.

    Das versteh ich jetzt nicht ganz. Hat deine Frau einen Webmail-Zugang zum Postfach ihrer Dienststelle? Dann sollte ja deren SMTP-Server "zuständig" sein und nicht das, was im Mailprogramm eingestellt ist. Und ich nehme kaum an, dass eine Schule oder Verwaltung GMX oder .mac nutzt...
    :confused:

    Auch das ist nichts Aussergewöhnliches. Manchmal ist ein Mailserver "unterwegs" oder der Empfangs-Mailserver nicht verfügbar, da kann es schon vorkommen, dass Mails mal ein paar Stunden hängen bleigen. Nicht-Zustellung ist eher selten, aber auch das hab ich schon erlebt.

    Das ist zwar gut zu hören, aber das Problem ist damit ja noch nicht gelöst.

    Schreib doch mal hier, was du in den Einstellungen deiner Mailkonten so stehen hast (und in jenen deiner Frau auch) - und den Namen des Mailprogramms. Die Benutzernamen und Passwörter solltest du hier aber nicht grad im Klartext hisnchreiben, sonder vielleicht eher durch irgendwelche Zeichen ersetzen. Und dann solltest du noch sagen, wer den Zugangsprovider ist (ist das wirklich 1&1? - ich dachte die machen nur Hosting?).

    Beste Grüsse, Christian.
     
  7. gschwieb

    gschwieb Member

    Vielen Dank für Deine Antwort Christian.

    Zu Deinen Fragen:
    Meine Frau und ich nutzen auf unseren über den gleichen Router mit DSL verbundenen Macs (G5 bzw. iMac G4) als Mail-Programm ausschließlich Apples Mail Version 2.1 (752.752.2)
    In beiden Fällen sind die SMTP-Server analog zu den Eingangsservern eingestellt.
    Also bei .Mac ist das
    Server-Port 25 (das war vom Programm vorgegeben)
    Server-Typ: .Mac
    smtp.mac.com
    Identifizierung: Kennwort
    Benutzername: xxxxxx
    Kennwort: yyyyyy
    und bei 1 & 1:
    Server-Port 25
    Server-Typ: pop
    smtp.1und1.com
    Identifizierung: Kennwort
    Benutzername: xxxxxx
    Kennwort: yyyyyy
    Ich kann mich zwar dunkel daran erinnern, dass zu Beginn der .mac Mailadressen (da war das noch kostenlos) ein eigener .mac-SMTP.Server gar nicht existierte, so dass man den SMTP.Server des Zugangsproviders nehmen musste. Ich dachte jedoch (nachdem Apple eigene SMTP-Server anbot) dass dies der logischere und problemlosere Weg sei.
    Ich kann es gerne wieder ändern - aber wieso hälst Du den Weg über den Zugangsprovider für problemloser?

    Meine Verwunderung darüber, dass beide Mailausgänge an .web, gmx und t-online Adressen nicht zuverlässig funktionierten, stützte sich ja gerade darauf, dass ich unterschiedliche Ausgangs-Server eingestellt habe (um bei Deinem Bild zu bleiben: es war also einmal die Deutsche Post und einmal UPS). Dennoch ging es schief. Das heißt aber nicht, dass sämtliche Mail-Ausgänge vom Fluch des Daemon befallen waren. Viele liefen problemlos durch.
    Meine Frau (die ausschließlich eine .mac Mailadresse hat) versuchte, eine dienstliche Information an eine gmx Adresse (da es über das Programm Mail nicht klappte) über Safari durchzugeben. Vielleicht habe ich mich da falsch ausgedrückt: Nehme folgende Adresse:
    http://www.schule.nrw.de/
    Wenn Du Leiter einer Schule in NRW wärest, kenntest Du natürlich Deine Schulnummer und das Passwort und könntest dann an die Schule gerichtete Mails abrufen bzw. im Namen der Schule auch Mails versenden. Als meine Frau über diesen Weg besagte gmx-Adresse anmailte, meldete sich hier (wenn auch erst Stunden später) der gefürchtete Daemon.
    Das war ja auch der Grund, warum ich davon ausging, dass dann eher die gmx-Server nen Schaden haben müssten, als mein Computer (oder der meiner Frau) die Urheber für diese Fehler wären.
    Nur nachdem uns das Problem erhalten blieb und in Foren eben nichts von Störungen der gmx, web oder t-online Server berichtet wurde, meinte ich den Fehler bei uns suchen zu müssen.

    Zugangsprovider ist übrigens in der Tat 1&1. Alles was mit meiner DSL-Verbindung zu tun hat wird auch über 1&1 abgerechnet. Dennoch funktioniert die ganze Geschichte nicht ohne die fürs Telefon eine Grundgebühr kassierende Telekom. Ich könnte z. B. nicht das Telefon kündigen, ohne meine DSL-Verbindung hiermit aufzugeben. Aber ich habe z.B. keinerlei Benutzernamen, Passwörter oder Kennungen die bei der Telekom oder einer ihrer Konzerntöchter registriert wären.

    Im Moment scheint aber (nachdem ich das Internetpasswort geändert habe und die online-Verbindung durch den Router nach einem gewissen Leerlauf kappen lasse) alles wieder problemlos zu funktionieren. Vielleicht wäre das Umstellen der Mac-Adresse auf den Ausgangsserver von 1&1 noch eine gute Maßnahme.

    Nochmals vielen Dank für Deine Hilfestellung

    Günter
     
  8. mac-christian

    mac-christian Active Member

    Zuerst mal: Deine Angaben aus den Maileinstellungen sehen vernünftig aus, ich habe jedenfalls nichts festgestellt, das offensichtlich problematisch wäre.

    Nun ja, der Zugangsprovider ist problemloser, weil du dich in der Regel nicht autorisieren musst; der kennt dich aus der Einwahl oder vom DSL her. Und - um nochmal die Briefpost zu bemühen: Wenn du vor deinem Haus so einen gelben Briefkasten hast, fährst du in der Regel auch nicht erst in den Nachbarort, um deine Post einzuwerfen.

    Wenn eine Adresse - aus welchem Grund auch immer - nicht erreichbar ist, müssen dir wohl der .mac wie auch der GMX-Ausgangsserver das mitteilen, insofern verwundert mich das nicht. Aber da du ja sagst, dass die Adressen zu 100% richtig sind...?

    Sind eigentlich die unzustellbaren Mails immer an die gleichen Empfänger, oder kannst du da keine Systematik erkennen?

    Keine Angst, der Daemon tut dir nichts. Das ist kein Teufel, sondern mit "demon" (deutsch Daemon) bezeichnet man einen Prozess der ohne menschliches Eingreifen seine Arbeit verrichtet (einen Mailserver, zum Beispiel).

    Das kann schon sein. Aber die Meldung muss an die Schuladresse deiner Frau gegangen sein, denn das war ja der Absender der Mail, richtig? Kann schon sein, dass GMX mal ein Problem hatte, aber dass GMX und .mac beide gleichzeitig das gleiche Probelm haben ist eher unwahrscheinlich... Mysteriös, würde ich sagen.

    Versuch doch mal, eine nicht zustellbare Mail noch einmal zu schicken, und berichte ob es dann geht. Wenn nicht, kann ich dir ja mal einen Account auf meinem SMTP-Server zu Testzwecken einrichten, mal sehen was dann passiert.

    Schönen Sonntag, Chrsitian.
     
  9. gschwieb

    gschwieb Member

    Hallo Christian,

    gut, dass es nur mittelpraktisch ist, dass meine Mail-Ausgänge bezüglich des .mac Kontos über die USA laufen, leuchtet mir ein. Das werde ich also umstellen. Andererseits kann sich dann der US-Geheimdienst nicht mehr unmittelbar von der Seriosität meiner Mails überzeugen. Aber gut, die anderen Geheimdienste werden es richten. :D

    Eine Systematik bei der Blockierung/Abweisung der Mails habe ich lediglich insofern herausgefunden, dass ausschließlich Probleme bei gmx und web.de - Adressen (in einem Fall war allerdings t-online die -verfehlte- Zieladresse) auftraten.

    Dass der Daemon :teufel: nicht so schrecklich ist, wie sein Name vermuten lässt, war mir bekannt. Aber wenn etwas nicht funktioniert, bietet sich das Namensspiel ja an. Trotzdem vielen Dank für den Trost.

    Das Mysteriöse an der Angelegenheit wird sich wohl nicht so recht aufklären lassen. Ich bringe es nach wie vor mit einem Ausspähen meines (inzw. geänderten) Internetpasswortes in Verbindung, ohne mir recht vorstellen zu können, wie dann jemand mit welchen Hilfmitteln auch immer meine Ausgangsmails dermaßen vervielfältigen konnte, dass dann der Server der Zieladresse eingreifen musste. Dass unsere beiden Computer, die im übrigen unterschiedliche Mail-Adressen angesprochen hatten, gleichzeitig betroffen waren, spricht nach wie vor für diese These. Anders könnte es m. E. nur sein, wenn sich gleichzeitig (über die LAN-Verbindung beider Computer - Sharing ist aber nicht aktiviert) etwas Trojanerähnliches auf beide Geräte gelegt hat. Dann müsste aber das Problem anhalten und eher sämtliche Mailadressen (alle Domains) betreffen.
    Ich habe gerade noch einmal meiner Tochter, die eine gmx-Adresse hat, eine Mail geschrieben. Wenn auch jetzt (wie auch gestern) nichts Böses mehr passiert, hege ich die Hoffnung, dass sich die Sache irgendwie erledigt hat.
    Nochmals Dir vielen Dank für Deine Hinweise.
     
  10. benqt

    benqt New Member

    Auch wenn die Sache hier zumindest vorläufig erledigt zu sein scheint - darf ich aus Gründen der Sicherheit noch fragen ob du die beiden Rechner im WLAN hängen hast, und falls ja: auch per WPA verschlüsselt?


    Gruß
    Markus


    Edit: hatte wohl überlesen, dass die Rechner per LAN miteinander verbunden sind. Ist dennoch WLAN im Spiel?
     
  11. gschwieb

    gschwieb Member

    Nein, die Rechner sind beide über Ethernet an einen mit dem DSL-Modem verbundenen Router angeschlossen. Der Router ist nicht WLAN-fähig, die Computer sind es mangels Airportkarte ebenfalls nicht. Bluetooth haben wir auch nicht. Lediglich die Mäuschen beider Rechner arbeiten kabellos.
     

Diese Seite empfehlen