DHCP, NAT & Co. bei Airport

Dieses Thema im Forum "Hardware" wurde erstellt von loki777, 19. Oktober 2007.

  1. loki777

    loki777 New Member

    hallo!

    ich hab seit gestern nen neuen internetprovider und stehe nun vor einem "kleinen " problem. bisher hab ich ein netzwerk aus 3 pcs und meinem pb und dann noch die psp via airport gleichzeitig am netz hängen und hatte damit keinerlei probleme. bisher hatte ich allerdings auch keine DHCP-Verbindung sondern wählte mich per ppoe (oder wie das heisst) ein.

    mein neuer provider erspart mir zwar das einstellen von benutzerdaten, leider vergibt er aber offensichtlich eine fixe ip. mein airport-dienstprog schlägt zur fehlerbehebung (dhcp hab ich natürlich eingestellt) vor, die einstellung auf "Bridge" zu ändern, was nun zur folge hat, dass das gleichzeitige surfen nicht mehr ordentlich funktioniert.

    mir ist klar, dass mein geschreibe ein wenig wirr klingt - mit computern kannte ich mich eigentlich immer ganz gut aus, aber netzwerke waren NIE so meins (weswegen ich eigentlich auch total auf apple stehe, denn hier bring ichs sogar zum laufen - aber eben leider mit dem blöden nebeneffekt.

    pls help!

    DANKE
     
  2. DominoXML

    DominoXML New Member

    Hi,

    um welche Airport Basisstation handelt es sich? Extreme oder Express?

    Bridging heißt, daß die Wan-Schnittstelle auf die Airport Schnittstelle gelegt, d.h. diese "verbunden" werden. Damit müssten dann alle Rechner bei denen die Airport als Gateway eingetragen ist damit ins Internet kommen.
    Die Airport fungiert als Router und die Clients brauchen die Routeradresse als Gateway.

    Ich habe eine AP Extreme, die als DHCP Server fungieren kann und mehrere Netzwerkanschlüsse besitzt.
    Somit werden den Clients automatisch Adressen zugeteilt (Auch für den dann möglichen internenen Datenaustausch zwischen den Clients).
    Ich weiss nicht ob eine Express das auch kann.

    Gruß

    Volker
     
  3. mac-christian

    mac-christian Active Member

    DHCP ist nicht das Gegenteil von PPoE. Hast du denn bisher immer die PCs einzeln ab- und angesteckt, wenn du mit einem anderen ins Netz wolltest? Das wär mir nach einem halben Tag schon zu viel Aufwand und ich hätte mir schon längst einen Router geleistet. Wenn du eine Airport- oder Airport Extreme-Basis hast, dann hast du bereits einen Router (aber nicht bei der Express).

    DHCP sagt bloss aus, dass der DHCP-Server (meist der Router, kann aber auch ein anderes Gerät sein) die IP-Adressen verwaltet und zuteilt; wenn du DHCP nicht möchtest, musst du dich händisch darum kümmern.

    Wie will dein Provider kontrollieren, ob du berechtigt bist? Das glaub ich einfach nicht. Wenn du eine Airport hast, die du auf "Bridge" stellen kannst, dann ist es eine, die auch Router sein kann.

    Du musst vom Modem mit einem Ethernetkabel zur Airport (WAN-Anschluss), und erst von der Airport (vom LAN-Anschluss) zu den einzelnen Rechnern (mit einem Hub/Switch oder über die Luft, das ist egal). In der Airport-Station musst du deine Zugangsdaten eingeben und in den Computern dürfen sie nicht mehr drin stehen (sondern einfach DHCP oder die fixe private IP muss angegeben sein).

    Selbsterkenntnis ist der erste Schritt zur Besserung... :teufel:

    Man lese die Installationsanleitung des Routers (d.h. der Airport-Basis), darin dürfte alles nötige erklärt sein...

    Christian
     
  4. loki777

    loki777 New Member

    @ Domino

    Ich hab ne Extreme.

    ----------

    @ christian

    ich steck nix an sondern geh per wlan online und das direkt über die einstellungen des airport.

    mein provider hat mir ja das modem zur verfügung gestellt und offensichtlich klappt das ohne pw...

    der letzte tipp??? ist wohl nicht ernst gemeint - das hb ist nicht wirklich umfangreich und hätte ich es nicht gelesen, wär ich jetzt gar nicht im internet. ich hab aber leider dieses restproblem und ich fürchte es liegt an dieser bridge-einstellung.

    trotzdem danke erstmal
     
  5. DominoXML

    DominoXML New Member

    Hi,

    für die Extreme kann ich ohne Probleme Hilfestellung leisten.
    Das Problem ist ehr ein zeitliches, da ich am WE arbeiten werde.

    Sobald ich Zeit habe schau ich mal nach meinen Einstellungen.

    Gruß

    Volker
     
  6. mac-christian

    mac-christian Active Member

    Vielleicht schreibst du mal detailliert auf, was du so alles wie verkabelt und eingestellt hast, und welchen Modells das Modem ist, was der Provider dir als Zugangsdaten mitgeteilt hat, usw., usw. - sonst ist eine Hilfe nicht wirklich möglich.

    Wie ich bereits geschrieben hatte:

    1. Die AExtreme ist ein Router
    2. Du musst die Zugangsdaten nicht im Computer sondern im Router eintragen; der ist dann für die Verbindung zuständig.
    3. Eventuell ist dein Modem gar kein Modem sondern schon ein Modem/Router (evtl. ein "kastriertes" Modell wie die ZyXel xxxME), das max. 4 Geräte verwalten kann.
    4. Falls den Modem ein Modem/Router ist:
    4a) bei kastriertem Modell: Modem/Router die Routingfunktion ausschalten und die AE als Router konfigurieren
    4b) falls "Vollmodell": da kannst du auch die AE auf Bridge stellen und die Routingfunktionen des Modem/Router-Kästchens nutzen - zusätzlich zur vorher erwähnten Variante 4a.

    Doch, das war eigentlich schon ernst gemeint. Ich habe jedenfalls durch Lesen der Handbücher immer wieder mal "Aha-Erlebnisse" gehabt und auch immer wieder dazu gelernt. Klar, nicht jedes Handbuch ist von gleicher Qualität...

    Christian.
     
  7. DominoXML

    DominoXML New Member

    Hi,

    hier mal eine Beispielkonfiguration:

    1. Internetverbindung

    - sollte auf automatisch stehen, d.h. die Basisstation erhält vom Provider die IP-Adresse und den DNS Server.

    2. Funktnetz

    - in deinem Fall darfst Du natürlich nicht 5 GHz eintragen sondern mußt b/g kompatibel einstellen.
    - Bei mir steht der Kanal auf automatisch. Bei dieser Einstellung haben meine Win-Rechner keine Chance zuzugreifen. Für mich ein Sicherheitsfeature, in deinem Fall solltest Du einen festen Kanal wählen. Möglichst aber nicht 10 oder 11, da das die Vorgabe-Einstellungen von weitverbreiteten Geräten wie die von AVM sind. So vermeidest du Störungen.

    3. Netzwerk

    Die Extreme ist als DHCP Server eingerichtet. D.h. sie vergibt den Clients die sich verbinden die IP-adresse automatisch. In meinem Fall eine Adresse von 10.0.1.2 bis 10.0.1.200 während die Extreme selbst auf 10.0.1.1 läuft.

    Fehlerquellen:

    Wenn Extreme nicht grün leuchtet liegt das an der Internetverbindung.

    Du kannst den Status überprüfen indem du die (hier ausgegrauten) Adressen kontrollierst. Wenn hier keine Verbindung besteht sind diese leer oder grau.

    Meistens reicht es, wenn man das Modem des Providers einmal neu startet.
    Dann erhält es eine neue IP für die Internetverbindung und die Extreme handelt eine entsprechende mit dem Modem aus.

    Stehe für weitere Fragen gerne zur Verfügung.

    Gruß

    Volker
     

    Anhänge:

  8. loki777

    loki777 New Member

    hallo volker!

    SUPER DANKE FÜR DIE HILFE und auch die Bilder - so viel hab ich also nicht falsch gemacht - denn eigentlich haben wir die selben einstellungen.

    beim funknetz kann ich mit meinem pb beim reinen 5 ghz auch nicht rein ;o) aber ansonsten haben wir die selben einstellungen.

    wenn ich den bridgemodus auf öffentliche ips umstelle dann ist bei mir beim extreme-netzwerk derselbe ip-bereich als dhcp-bereich definiert (10.0.) den auch modem und eben die extreme selbst nutzen - kann das probleme machen?

    die kontrollleuchte wechselt nur auf gelb wenn ich den bridge-modus verlasse - d.h. dann kommt die airport nicht mehr ins internet.

    lg
    josef
     
  9. DominoXML

    DominoXML New Member

    Sorry muß zum Kunden. Melde mich.
     
  10. mac-christian

    mac-christian Active Member

    Bitte drück dich so aus, dass man weiss was du meinst, und nicht so dass man raten muss.

    So weiss ich immer noch nicht, was du für ein Modem hast (Marke/Modell) und was für Spezifikationen ebendieses hat.

    Im Normalfall bekommst du vom DSL-Anbieter genau eine einzige öffentliche IP-Adresse zugeteilt. Ein Modem hat "vorne" und "hinten" die gleiche IP, es ist nur eine Art "Übersetzer" von der Telefonleitung auf (zum Beispiel) Ethernet oder USB. Wenn du nur ein Modem dran hast, kannst du genau mit einem einzigen Computer ins Netz - und nicht mehr, auch wenn du einen Hub/Switch benutzst - weil nur eine IP-Adresse zur Verfügung steht und deshalb keine Adressierung der Daten an unterschiedliche Geräte möglich ist.

    Ein Router hat "vorne" eine öffentliche IP-Adresse und auf der "hinteren" (= lokalen) Seite einen Bereich mit privaten IP-Adressen (siehe hier für die Definition und die verwendeten Nummernbereiche). Der Router schaut die Datenpakete an und leitet sie im internen Netz weiter oder übergibt sie ans Internet - je nach Nummerierung/Adressierung.

    Wenn du mir also die Fragen in meinem vorhergehenden Beitrag beantwortest, kann ich weitere Tipps geben - sonst muss ich warten, bis meine Kristallkugel aus der Reparatur kommt...

    Christian.
     
  11. MacS

    MacS Active Member

    Mir scheint, dass hier nur von den Routereinstellungen gesprochen wird. Aber, vielleicht liegt der Fehler auch an den Netzwerkeinstellungen am Mac? Mac holt sich die IP auch wirklich vom Router per DHCP? Kannst du die IP in den Netzwerkeinstellungen sehen? Was sagt der Status?
     
  12. mac-christian

    mac-christian Active Member

    Da der Originalfrager nicht sonderlich kommunikativ ist, werde ich mich mal ausklinken - ich führe höchst ungern Selbstgespräche.

    Christian
     
  13. DominoXML

    DominoXML New Member

    Hm, ich hab mir die Posts noch mal durchgelesen und gebe mac-christian Recht bei der Beurteilung, daß das Problem in der Verbindung zum Internet liegt.

    Auch ich glaube, daß Du einen Router und kein reines Modem vor der Extreme hast, zumindest deutet das Verhalten derselben darauf hin.

    Es wäre hilfreich, wenn Du uns verräts um welches Modell und welchen Provider es sich handelt.

    Gruß

    Volker
     
  14. loki777

    loki777 New Member

    also dass ich (wie christian es bemängelt) nicht soooo kommunikativ bin, liegt daran, dass ich momentan nicht soooo viel zeit am pc verbringe.

    dass das problem an der internetverbindung liegt, glaub ich kaum, denn die airport zeigt ja ein grünes licht. so bald ich wieder zuhause bin, schick ich euch noch detailinfos zum modem von Tele 2.

    trotzdem danke erstmal
     
  15. mac-christian

    mac-christian Active Member

    Die Internetverbindung würde vermutlich schon unktionieren, aber nicht in der Konfiguration wie du sie eingerichtet hast - grüne Lichter hin oder her.

    Aber wenn du meinst, dein Glaube helfe dir weiter - bitte, ich will dir nicht im Weg stehen.

    Christian
     
  16. loki777

    loki777 New Member

    Mein Glaube hat geholfen - seit Montag Vormittag funktioniert alles einwandfrei (und ich hoffe, das bleibt so) und ich musste nichts an den Einstellungen ändern. Es geschehen also doch noch kleine Wunder...

    DANKE NOCHMAL AN VOLKER DER MIR WIRKLICH HELFEN WOLLTE



    Und nun noch etwas das ich loswerden will!

    sag mal mac-christian, was bist du eigentlich so aggressiv und negativ?

    * Zuerst mal lässt du den "Na?? schon die Anleitung gelesen?"-Klassiker vom Stapel.

    * Dann maulst Du rum, dass ich ja anscheinend kein Interesse habe, da ich nicht 24 Stunden online bin (man beachte - ich hatte Probleme mit der INternetverbindung!!!)

    * Und jetzt noch die "Glaubensfrage"...

    Ich finde es ja nett, dass Du zuerst helfen wolltest, aber alles andere war hier nicht hilfreich sondern eher eine Frechheit. Überleg vielleicht bevor du das nächste Mal antwortest, ob dir wieder "ein Furz liegt" und lass es dann einfach...
     
  17. mac-christian

    mac-christian Active Member

    O heilige Einfalt - du glaubst, eines deiner Geräte habe dein Flehen gehört und sich überlegt, dass es sich nicht mehr quer stellen möchte...? Dann empfehle ich dir doch, dein Voodoo patentieren zu lassen, das dürfte ein Riesengeschäft werden.

    Ach, es ist eine Frechheit von mir, wenn du auf meine Hilfsversuche nicht eingehst? Du antwortest zwar, aber nimmst weder zu Fragen noch zu Feststellungen von mir irgendwie Stellung. Schön, wenn du meine Hilfe nicht brauchst, ich brauch deine Fragen auch nicht.

    Christian
     

Diese Seite empfehlen