die papierkorb preisfrage

Dieses Thema im Forum "Software" wurde erstellt von applez, 13. August 2003.

  1. applez

    applez New Member

    Halli hallo,

    ich schätze mal, das das thema "ich kann meinen" papierkorb unter X nicht leeren schon endlos durchgekaut wurde, aber der hier will nich...:)
    also, wenn ich auf ner externen platte:

    -mehere "leere ordner" im papierkorb habe
    -die definitiv keine sonderzeichen im namen enthalten
    - alle zugriffsrechte okay sind
    - die dinger nicht geschützt sind (auch keine unterverzeichnisse)
    -und der terminal mit sudo rm -r auch nichts bringt

    und der papierkorb im 9er als leer angezeigt wird
    (nur unter x halt nicht)
    what the hell...

    weiß hier in der letzten instanz jemand noch einen rat? :)

    mfg
     
  2. WoSoft

    WoSoft Debugger

    was sagt denn Cocktail dazu?
    cu
    Peter
     
  3. applez

    applez New Member

    hab ich noch nie vorher benützt, (nur batchmod, ging auch nicht).
    hab jetzt cocktail 2.1 drauf- und was mach ich nu? :)
     
  4. gratefulmac

    gratefulmac New Member

    Was war den in den jetzt leeren Ordnern vorher drin?
     
  5. applez

    applez New Member

    keine ahnung....

    wenn ichs aus dem papierkorb zieh, kopiert es sich nur aufn schreibtisch- lösch ich die kopie, is es doppelt im papierkorb.
    die kopie kann dann allerdings gelöscht werden *kopfschüttel

    mit cocktial komm ich nicht direkt an dateien IM papierkorb ran, oder?
    thanx!
     
  6. gratefulmac

    gratefulmac New Member

    Schau dir mal die Informationen der Ordner im Trash an.
    Genaugenommen deren Eigentümer.
    Möglicherweise ist mit den Rechten da irgendetwas durcheinander geraten.
    Setz dich als Eigentümer ein(lesen&schreiben) und dann kannst Du sie auch löschen.
     
  7. WoSoft

    WoSoft Debugger

    > hab jetzt cocktail 2.1 drauf- und was mach ich nu?

    Unter System "Force empty trash from selected disk" (oder so ähnlich)
    cu
    Peter
     
  8. applez

    applez New Member

    eigentümer bin ich leider schon, damit hab ich angefangen.
    hab auch schon alle eigentümer durch und s unter root probiert.

    cocktail bringt: "unable to empty trash, click to continue" und dat wars :(

    danke trotzdem für den tip!!!
    das programm hat zudem auch so viele nette andere tools :)

    mfg
     
  9. Dradts

    Dradts New Member

    versuchs mal so:
    apple-taste gedrückt halten, die dinger aus dem papierkorb auf den schreibtisch ziehen. dann ohne apple taste wieder zurück in den papierkorb, und dann leeren.
    eventuell klappt das.
     
  10. applez

    applez New Member

    Nö, schade. Danke trotzdem!

    kommt:
    Der Vorgang konnte nicht abgeschlossen werden, da das Objekt_ HFS+ Private Data geschützt ist.

    sagt das jemand was?

    das klingt so verdammt nach zugriffsrechten, aber die sind alle in ordung...denk ich.
    müssten sie nach der batchmod aktion sowieso...

    Der Inhalt meines Papierkorbs hat sich inzwischen durch rein und rausziehen verzehnfacht :)
    hach ja...
     
  11. applez

    applez New Member

    ...und ich kapier echt nic, warum das teil, wenn ich die externe unter dem 9er hochfahr als leer angezeigt wird...
    in x sinds jetzt "schon" 12 MB....
     
  12. Dradts

    Dradts New Member

    Der Papierkorb unter X und der Papierkorb unter OS 9 sind unterschiedliche Ordner! Unter X heißt er ".trashes", unter OS 9 heißt er "Trash". Such mal unter OS 9 nach Deinem 10er-Papierkorb, und lösch dessen Inhalt mit dem OS 9 Papierkorb. Das sollte auf jeden Fall gehen.
     
  13. Dradts

    Dradts New Member

    Der Papierkorb unter X und der Papierkorb unter OS 9 sind unterschiedliche Ordner! Unter X heißt er ".trashes", unter OS 9 heißt er "Trash". Such mal unter OS 9 nach Deinem 10er-Papierkorb, und lösch dessen Inhalt mit dem OS 9 Papierkorb. Das sollte auf jeden Fall gehen.
     
  14. wurzel

    wurzel New Member

    Hallo Applez,

    ich denke, bei deinen "Leichen" ist das system immutable flag gesetzt. Diese Dateien kann man nicht so einfach löschen.

    Öffne ein Terminal und gebe folgenden Befehl ein ls -loa und die entsprechende Datei aus dem Papierkorb in das Terminal per Drag & Drop reinziehen, enter. Jetzt müsstest du ein solchen output sehen:

    -rw-r--r-- 1 user staff schg 48282 Nov 29 2002 <Deine Dateileiche>

    Wenn Du hier "schg" siehst, dann ist für diese Datei das system immutable flag gesetzt.

    Jetzt musst Du ganz stark sein!

    - Schreib dir den genauen Path zu den entsprechenden Dateien auf (evtl. ausdrucken)

    - Boote Dein System in den Single User Mode ( Apfel S beim starten drücken)
    Achtung: Im Single User Mode hat man nur die Amerikanische Tastaturbelegung!

    - Nun folgende Befehle eingeben:
    fsck
    mount -uw /
    autodiskmount
    chflags -R noschg <Path zu Deiner Dateileiche>
    rm -R <Path zu Deiner Dateileiche>

    Mit dem Befehl chflags -R noschg <Datei> löschst Du das system immutable flag, das geht leider nur im Single User Mode (man chflags). Wenn Du das gemacht hast, ist Dein Papierkorb wieder Jungfräulich.

    WARNUNG: Nur machen wenn Du einigermaßen sicher bist, mit dem Terminal! Wenn nicht, dann lieber mit den Dateileichen leben oder mit OS9 probieren.

    Gruß,

    WURZEL
     
  15. applez

    applez New Member

    hi,

    klasse danke!
    da eröffnen sich einem doch in zukunft ganz neue möglichkeiten! :)

    im terminal erscheint leider zuerst:

    [HALs-Computer:~] hal% ls -loa/Volumes/i\ love\ my\ backup/.Trashes/501/gll
    ls: illegal option -- /
    usage: ls [-1ACFLRSTWacdfgiklnoqrstux] [file ...]

    mhm...frauen und technik? ;)
    das problem mit os 9 is, das es den papierkorb (=>externe firewire) als leer anzeigt.
    selbst, wenn ich in x unter root hochfahre ist das teil leer. nur beim starten mit dem admin nicht...

    danke für eure ganze hilfe!!!
    grüßle
     
  16. applez

    applez New Member

    hi,

    klasse danke!
    da eröffnen sich einem doch in zukunft ganz neue möglichkeiten! :)

    im terminal erscheint leider zuerst:

    [HALs-Computer:~] hal% ls -loa/Volumes/i\ love\ my\ backup/.Trashes/501/gll
    ls: illegal option -- /
    usage: ls [-1ACFLRSTWacdfgiklnoqrstux] [file ...]

    mhm...frauen und technik? ;)
    das problem mit os 9 is, das es den papierkorb (=>externe firewire) als leer anzeigt.
    selbst, wenn ich in x unter root hochfahre ist das teil leer. nur beim starten mit dem admin nicht...

    danke für eure ganze hilfe!!!
    grüßle
     
  17. wurzel

    wurzel New Member

    Hallo,

    hinter dem ls -loa musst Du noch ein Leerzeichen setzen und erst dann die Datei per Drag & Drop einfuegen.

    ls -loa /Volumes/i\ love\ my\ backup/.Trashes/501/gll

    Gruss,

    WURZEL

    Nachtrag: Dein Volume heist "i love my backup" ist das eine Platte die nur fuer Backup benutzt wird? Wenn das so ist, koenntest Du die Platte auch platt machen und mit dem Festplatten-Dienstprogramm eine neue Partition erstellen.
    Danach einfach ein neues Backup von dem Original erstellen und der Papierkorb ist wieder...
     
  18. applez

    applez New Member

    nope, die platte war mal für backup vorgesehen, mittlerweile is aber auch wegen platzmangel (trotz 300 GB;) )andres zeug drauf.
    hey, du hattest mit dem immutable flag recht!
    yippie, ein hoffnungsschimmer :)
    probier jetzt den single mode und meld mich dann nochmal.

    grüßle+ megathanx!
    mone

    _______

    [HALs-Computer:~] hal% ls -loa /Volumes/i\ love\ my\ backup/.Trashes/501/gll
    total 16
    drwxrwxrwx 8 hal unknown - 272 Aug 14 01:36 .
    drwxrwxrwx 4 hal unknown - 136 Aug 14 02:27 ..
    -rwxrwxrwx 1 hal unknown - 6148 Aug 14 01:36 .DS_Store
    drwxrwxrwx 3 hal unknown - 102 May 2 17:04 dfw
    drwxrwxrwx 3 hal unknown - 102 May 2 17:04 dgsg
    drwxrwxrwx 3 hal unknown - 102 Aug 14 01:15 fkvbf
    drwxrwxrwx 4 hal unknown - 136 Aug 14 01:15 fkvfgwfwbf
    drwxrwxrwx 2 hal unknown schg 68 Jan 17 2003 ????????????HFS+ Private Data
     
  19. applez

    applez New Member

    ähm...sorry, wenn ich mich so trottelig anstelle: was davon genau ist denn mein pfad? :)
    also was kommt nach

    chflags -R noschg?

    <rwxrwxrwx 2 hal unknown schg 68 Jan 17 2003> ?

    ich finde da nirgens nen verweis auf die externe platte...
    hab bis jetzt im apfel+s mode nur meine platte überprüft. nich dass ich hier alles schrotte :)
     
  20. wurzel

    wurzel New Member

    /Volumes/i\ love\ my\ backup/.Trashes/501/gll

    Das ist dein Pfad, probier mal folgendes im Single User Mode:

    fsck
    mount -uw /
    autodiskmount
    cd /Volumes/*backup/.Trashes/501
    chflags -R noschg gll
    rm -R gll

    Vorsicht Amerikanische Tastaturbelegung:
    - ist gleich ß
    / ist gleich -
    * ist gleich (
    . ist gleich .

    Gruss,

    WURZEL
     

Diese Seite empfehlen