Digitalfilm in QT konvertieren?

Dieses Thema im Forum "Software" wurde erstellt von 6699, 23. Dezember 2003.

  1. 6699

    6699 New Member

    Als stolzer Besitzer einer digitalen Videokamera habe ich natürlich gleich einen Film in iMovie bearbeitet, ging super!

    Nur leider kam eine böse Überraschung, als ich den DV-Stream mit QT Pro als QT-Stream exportieren wollte. Das Bild wurde fleckig und ist im Grunde nicht zu gebrauchen.

    Früher habe ich meine Videoaufnahmen von der Analog-Kamera über Eye-TV importiert (=> mpeg-1), dann über QT Pro auf DV-Stream umgerechnet, in iMovie bearbeitet und wieder als QT-Stream exportiert. Das ging recht gut, kein fleckiges Bild. Allerdings war die Qualität des Ausgangsmaterial natürlich nicht so gut wie bei der Digitalkamera.

    Kann es sein, dass QT Pro mit dem Material meiner Digi-Cam (800.000 Pixel) nicht so recht klarkommt beim Konvertieren?
     
  2. sandretto

    sandretto Gast

    Was für ein QT-Stream? Wie waren deine Einstellungen. Was möchtest du schlussendlich mit diesem Movie machen ? Wieder auf die Videokamera zurückspielen, oder auf der Fesplatte horten, oder eine VCD/SVCD/DVD brennen ?
     
  3. DieterBo

    DieterBo New Member

    wozu umrechnen und wozu was ist QT-Stream????
    Du bearbeitest das Material als DV stream und wenn Du fertig bist spielst du es entweder zurück oder wandelst es in ein Format was Du für andere Medien brauchst SVCD=mpg2, VCD=mpg1, DVD=mpg2

    Mit den Pixeln Deiner Kamera hat das nichts zu tun. Das DV Format ist standartisiert auf 720*576 mit einer Datenrate von 3,6 MB/s.

    WAS WILLST DU EIGENTLICH TUN ??????
     
  4. 6699

    6699 New Member

    Sorry, ich habe mich offenbar nicht so ganz klar ausgedrückt:

    Also, ich habe eine DV-Stream (von der Kamera). Diesen DV-Film habe ich (problemlos) in iMovie bearbeiten können. Ich habe ihn auf die Kamera zurückgespielt und damit gesichtert, damit war erst mal die Welt in Ordnung. Auch der Schritt zu iDVD (und damit zu mpeg-2) war kein Problem, Qualität absolut in Ordung.

    Nun wollte ich den Film auch Leuten auf CD zukommen lassen. Ich bin in iMovie (oder im 2. Versuch in QT Pro, was aber letztlich das Gleiche war) auf "Ablage / exportieren" gegangen und habe dann in dem Fenster: "als Quicktime-Film" gewählt, als Format habe ich "CD-Rom" eingestellt. Das Ergebnis war zwar eine deutllich komprimierte Datei, aber mit sehr bescheidener, eher beschissener Qualität. Auch wenn ich über "eignene Einstellungen" gehe und die Version "Film => QT Film" wähle, ev. sogar in den Optionen unter Kompression eine höhere Qualität einstelle, erhalte ich am Ende ein fleckiges Bild. Ich nehme an, dass bei "Quicktime-Film" ein mpeg-1 Film erzeugt wird, der jedoch dann qualitativ echt schlecht ist.
     
  5. sandretto

    sandretto Gast

    Hattest du das bearbeitete Video wieder mit der Videokamera über iMovie importiert, oder war es immer noch "da" ?

    Beim exportieren mit dem Format "CD-ROM" wird ein QuickTimeMovie mit dem Codec H.263 erstellt, das ist ein optimierter H.261 (ähnlich Mpeg1) Codec. Die Qualität ist aber bei diesem Codec auch bei niedrigen Bitraten ganz OK.

    Also was läuft da schief ? Exportiere einfach mal mit anderen Formaten, z.Bsp. Mpeg4 mittlere Qualität, oder SorensonVideo 3, und vergleiche dann. Brauchst ja nicht den ganzen Film zu exportieren.
     
  6. CosmicAlien

    CosmicAlien New Member

    Erst einmal was prinzipielles, QT ist kein Videoformat.

    mpeg oder divx oder dv oder jpeg sind formate.
    QuickTime ist ein Teil des Betriebssystemes und ist für die Gesamtbearbeitung von Audio und Video da.

    Wenn Du die Voreinstellung "CD Rom" nimmst kommt auch nix Gutes bei raus. Das ist ein sehr sehr niedriger Standard.

    Man muß eh etwas rumprobieren mit den Einstellungen.

    Als Formate kann ich Dir empfehlen:

    mpeg1 = VHS Niveau und recht unscharf, aber kompatibel

    divx = kann bei richtiger Einstellung gutes Bild machen, läuft auf jeder Plattform (sofern der Codec installiert ist, ist beim Mac nicht ab Werk dabei)

    sorenson = guter Codec, halb so gut wie divx, ist beim Mac dabei

    mpeg4 = sehr guter Codec, beim Mac dabei, ähnlich divx

    Zur Datenratenberechnung gibt es eine Faustformel, nicht jedes Format ist da gleich. DV ist fest auf 3.6MB/sek eingestellt. Das ist schon recht viel.

    Bei sorenson kann man Auflösung (x mal y) mal Bilder pro Sekunde, geteilt durch 32500 rechnen. Das ergibt die Datenrate in KB pro Sekunde bei normalem Material. Bei geringer Bewegung, wie bei Nachrichtensprechern etwas weniger, bei viel Bewegung und rauschigem Material (also selbstgedrehtem) auch schon mal das doppelte davon. Ist aber eine gute Ausgangsbasis.

    Beispiel: Der fertige Film soll 384x288 (1/2 PAL) mit 25 fps sein

    384x288x25/32500=85k/sek Datenrate

    Man kann nicht eine beliebige Datenrate einstellun und auf gutes Bild hoffen, zuviel bringt nix, zuwenig macht massiv schlechtes Bild.

    Ich persönlich würde aber eher eine DVD davon machen, sieht einfach besser aus, DVD Brenner vorausgesetzt.

    mpeg1 und mpeg2 Filme (VCD oder SVCD) spielen auch , wenn richtig gemacht, in DVD Spielern.

    Man kann hier 100 Seiten schreiben und immer noch was auslassen, bemüh doch mal die Suchfunktion hier im Forum oder probier einfach mal alle Formate durch.

    Viel Glück !
     
  7. 6699

    6699 New Member

    Danke für Eure Tipps -und erst mal "Frohe Weihnachten"!

    Gestern hielten mich die Vorbereitungen für Heiligabend auf Trab, daher melde ich mich erst jetzt wieder.

    @sandretto:

    Ich habe den Film unter iMovie bearbeitet, er war also "immer noch da". Dann habe ich den Export gestartet. Und zwar erst von iMovie aus. Als die Qualität so schlecht war, habe ich erst mal als DV-Stream exportiert, das ging problemlos. Diesen DV-Film habe ich unter QT gekürzt und dann versucht, den Filmschnipsel unter verschiedenen Formaten zu exportieren. mp-4 war zwar etwas besser als QT, das Problem bestand aber grundsätzlich auch.

    Auch ich habe den Eindruck, dass da was nicht stimmt (habe mir deshalb schon QT 6.5 heruntergeladen, klappt aber auch nicht besser ?!?)

    @ CosmicAlien:

    Mir ist schon klar, dass QT kein Videoformat ist. iMovie oder auch QT Pro bietet aber beim Export an "als Quicktime-Film", darauf habe ich mich bezogen. Gemeint ist damit wohl mpeg-1.
    Dass die Voreinstellung CD-Rom ein eher niedriger Standard ist, damit hast Du sicher Recht. Ich habe dann auch versucht, bei den Optionen von der mittleren Kompression auf eine höhere Qualität zu stellen. Das brachte eine gewisse Verbesserung, das Problem war aber noch da.
     
  8. sandretto

    sandretto Gast

    Hi, jetzt wo mir 6699 einen kleinen Filmschnippsel hat zukommen lassen, kann ich etwas dazu sagen.

    Das Wort "fleckig" weiter oben, hat mich etwas irritiert, und war vielleicht etwas unglücklich umschrieben.

    Das Problem ist folgendes. Fast alle DV-Videokameras nehmen im sogenannten interlace-Modus(Zeilensprung) auf. Dabei werden zwei Halbbilder (Felder) hintereinander geschrieben, die zeitlich um 1/50 sek. versetzt sind. Auf dem Röhrenfernseher angeschaut, sieht man diese 2 Halbbilder als ein ganzes Bild, da jeder hundsgewöhnliche TV diese interlaced-Signale darstellen kann. Sieht man jedoch so ein DV-Movie auf einem Computermonitor an, und die können nur progressive (ein ganzes Bild) Signale darstellen, sind bei stark bewegten Szenen (Sportveranstaltungen), starke Treppeneffekte zu sehen.
    Hier sehr gut umschrieben
    http://www.cine4home.de/knowhow/progressive_scan_heimkino/progressive_scan_heimkino.htm

    In iMovie ist jedoch beim abspielen solcher Zeilenversetzter Signale nichts zu sehen, da diese 2 versetzten Halbbilder automatisch deinterlaced dargestellt werden, ebenso im QuickTimePlayer. Jedoch sind sie beim Import in iMovie gut zu sehen, ausser bei einem belichteten Spielfilm, da dort die Technik des Zeilensprungs nicht zur Anwendung kommt, und die zwei Halbbilder die Uebertragen werden, identisch sind.

    Die DV-Files selber, werden aber nach wie vor interlaced, also mit Zeilensprung gespeichert. Das kann man gut sehen, wenn man bei einem DV-Movie, aufgenommen mit einer Videokamera, in QuickTimePro unter Film > Filmeigenschaften > Video-Spur > Qualität die Checkbox "Hohe Qualität" aktiviert, dann wirkt das Bild sofort etwas schärfer, es ist dann aber auch der Zeilensprung gut sichtbar (Treppeneffekt).

    Exportiert man jetzt so ein DV-Movie in ein anderes Format, egal ob mit iMovie oder QTPro, z.Bsp. nach "Video" oder "Mpeg4", so ist dieser Zeilensprung wieder zu sehen, und wirkt bei schnellen Kameraschwenks äusserst "ätzend", wenn man so ein Movie im QTPlayer ansieht.

    Lösung: Deinterlacen, entfernen des Zeilensprungs. Leider kann QTPro bis dato kein deinterlacing, obwohl gerade bei Version 6.5 eine neue Checkbox "Felder (Deinterlaced)" dazu gekommen ist, die jedoch nirgends dokumentiert ist, und bei mir nach diversen Exportversuchen mit versch. Codecs, auch keine Resultate brachte, Dummy-Funktion ?

    Ein gutes Tool zum wandeln in Mpeg4 und deinterlacen ist die Freeware "OpenShiiva", man beachte die Kommentare... http://www.macupdate.com/info.php/id/11973
    Hat zwar noch ein paar Bugs, ist aber ein Killertool. Frisst unter anderem DV-PAL / YUV / MotionJPEG / VOB. und kann gleichzeitig Audio in das Format Mpeg4-Audio (AAC) komprimieren.

    Uebrigens, der DV-Codec wurde speziell für das ansehen auf einem "normalen" Röhren-TV entwickelt, und die einzelnen Bilder sind leicht komprimiert, lassen sich jedoch gut schneiden und bearbeiten, im Gegensatz zu Mpeg2 und Mpeg4.
     
  9. sandretto

    sandretto Gast

    Nachtrag, wenn man ein QuickTimeMovie exportiert, so sollte man wenn möglich die Originalgrösse (aktuelle Grösse verwenden) beibehalten. Sonst wird skaliert, und das Bild sieht dann oft leicht S******e aus. Wenn man nicht drum rum kommt, die Grösse verändern zu müssen, dann sollte man lieber die Ränder croppen (schneiden), oder das Fenster des QTPlayers auf die gewünschte Grösse aufziehen, und dann neu speichern. Dabei wird die Originalgrösse beibehalten, nur die "angezeigte" Grösse verändert sich ! Croppen kann man mit QTPro und der Maskenfunktion, ist aber etwas umständlich. Viel besser geht das mit OpenShiiva, wo man pixelgenau an jeder Seite schneiden kann.
     
  10. 6699

    6699 New Member

    @ sandretto

    Vielen Dank für die ausführliche Info. So wie Du das Problem mit den Halbbildern beschreibst, liegt es genau daran! Bei schnellen Kamerabewegungen (die gar nicht so furchtbar schnell sein müssen) wird das Bild ruckelig und es entstehen diese "Flecken", wie ich das genannt habe, man kann sicher auch von "umschriebenen Treppenartefakten" sprechen.

    Nun habe ich mir in QT Pro erst einmal unter Filmeigenschaften => Video => Qualität dieses Deinterlacing angesehen. Zunächst hatte ich den Eindruck, dass ein Häkchen in diesem Kästchen des DV-Films vor dem Exportieren etwas bringt, dann hat der mpeg-1 Film aber doch wieder geruckelt uns sah -wie vorher- unschön aus. Offenbar arbeitet diese Funktion in QT noch nicht so, wie sie eigentlich soll.

    Dann habe ich mir OpenShiiva geladen und bin derzeit dabei, ein mp4 von meinem Film zu erstellen, während ich diesen Beitrag schreibe. Das Deinterlacing ist aktiviert, in den Vorschaubildern, die während des Renderns gezeigt werden, sieht die Sache wirklich vertrauenserweckend aus.

    In jedem Fall passt die Erklärung mit den Halbbildern ausgezeichnet zu dem Phänomen, dass dieses Problem nur bei Material aus der Digital-Videokamera auftritt. Verwendet man Analog-Videomaterial, das über Eye-TV importiert und dann mit QT von mpeg-1 auf DV-Stream umgerechnet wird, ist das Bild völlig o.k. Und wenn eben gerade die Digitalkamera mit Halbbildern arbeitet, dürfte es am interlacing liegen.

    Ich frage mich nur, ob Andere, die mit digitalen Videokameras arbeiten nie versucht haben, ihre Filme statt als DV-Stream oder als DVD auch mal als "einfachen mpeg-1" oder auch als "mp-4" Stream zu speichern. Dann wäre das Thema doch bestimmt schon des öfteren hier diskutiert worden?

    Ich melde mich dann jedenfalls noch einmal, wenn mein mp-4 fertig ist, da bin ich mal gespannt......
     
  11. 6699

    6699 New Member

    Also: OpenShiiva liefert bei mir ein tolles Bild, optisch eigentlich nicht zu unterscheiden vom DV-Stream, dabei fast um den Faktor 10 (!) kleiner.

    Allerdings hat die Sache einen Haken: Bei mir läuft OpenShiiva nur, wenn ich Audio nicht encodiere -Sniff!!!

    Sobald ich das Häkchen auch bei Audio mache, ist der Spaß vorbei, die Konvertierung startet nicht mehr.

    Da hilft wohl nur, auf die nächste Version zu warten, denn Stummfilm ist ja auch nicht so toll.
     
  12. sandretto

    sandretto Gast

    Das geht bis dato nur beim anzeigen mit dem QTPlayer und einem DV-Movie. QTPro kann bis heuer nicht deinterlacen beim exportieren.

    Eye-TV deinterlact beim digitalisieren von analog zu digital automatisch. Und wenn das Material dann einmal deinterlact ist, kannst du es in jedes andere Format umcodieren, es bleibt immer deinterlact.

    Die Video-Profis lümmeln in anderen Foren umher:D
     
  13. billy idol

    billy idol New Member

    sehr interessanter thread, hab mir das wichtigste auf einem fresszettel notiert...

    danke, sandretto :)
     
  14. sandretto

    sandretto Gast

    So da bin ich wieder. Habe das obere, lange Posting ergänzt und jetzt noch besser umschrieben.

    Das hängt damit zusammen, das wenn man in iMovie ein Film als "DV-Film (hohe Qualität)" exportiert, die dabei enstehende Tonspur von OpenShiiva nicht gelesen werden kann. Was da iMovie exportiert, kann man schwer nachvollziehen. Es wird zwar vom QuickTimePlayer anstandslos wiedergeben, die Tonspur ist aber genau so gross wie die Videospur:confused:, und mit 3,4MB pro Sekunde auch wahnwitzig gross. Bei den importierten Clips im jeweiligen Projekte-Ordner von iMovie, ist es genau das selbe, riesige Tonspur.

    Abhilfe, beim exportieren aus iMovie, eigene Einstellungen wählen, und da ein Audioformat aussuchen, z.Bsp. "Ohne" oder Mpeg4-Audio (AAC). OpenShiiva kann diese Formate dann lesen.

    Oder noch schlauer, man exportiert gleich die Tonspur im DV-File was im Projekte-Ordner liegt, mit QTPro, und fügt dann diese Tonspur später zu der von OpenShiiva erzeugten Videospur (gleiches DV-File), hinzu. Dann das Ganze als eigenständigen Film sichern. So spart man sich das exportieren des ganzen Filmes aus iMovie heraus !
     
  15. 6699

    6699 New Member

    Hallo sandretto, das ist wirklich unglaublich, Du weißt ja offenbar auf jede Frage eine Antwort! -nur dass ich sie diesmal nicht so ganz verstehe....

    Das Problem mit iMovie und der Einstellung "DV-Film (hohe Qualität)" kann ich nachvollziehen. Wenn ich aber auf "Eigene Einstellungen" gehe, muss ich doch zunächst einmal "Film => DV Stream" auswählen und dann finde ich keinen Weg, das Audio-Format auf AAC oder so zu verändern. Mache ich da was falsch oder habe ich es schlichtweg übersehen? Möglicherweise muss ich auch erst nach QT Pro exportieren und von dort dann weiterbearbeiten???

    Der 2. "schlaue" Weg ist mir noch weniger klar. Mit der "Tonspur im DV-File was im Projekte-Ordner" meinst Du da den Ordner Media, der bei dem iMovie-Projekt angelegt wird? Ich habe da nur einen kleinen Ton-Schnipsel, den ich nachträglich zum Hinterlegen des Abspanns importiert hatte. Vielleicht müsste dazu erst mal den Ton extrahieren. Ob das bei der Vielzahl der Clips, aus denen mein Film besteht, sinnvoll ist, glaube ich aber kaum. Wie man die dann zusammenführt, weiß ich auch nicht. Das kenne ich nur in QT Pro, klappt er meines Wissens da nur mit DV Stream. Ich hätte dann aber eine Video-Datei von OpenShiiva im mp-4 Format.

    Du merkst, in dieser Video-Welt gibt es für mich noch viele unbekannte Ecken. Aber es ist ja auch spannend, "neue Welten zu entdecken, neues Leben und neue Zivilisation"
     
  16. sandretto

    sandretto Gast

    Nein, denn wenn du dies machst, ergibt das wieder diese wahnwitzig grosse Tonspur, die zwar QTPro lesen kann (iMovie benutzt beim Import/Export die QuickTime Bibliotheken), nicht jedoch OpenShiiva !

    Und ausserdem ist bei den Optionen (Button), die NTSC-Norm meistens voreingestellt. In deinem ersten Posting schreibst du
    Falls du nicht aufgepasst hast, hast du damit ein NTSC-DV-Movie ezeugt. Da DV-PAL eine festgelegte Auflösung von 720x576 Pixel hat, jedoch DV-NTSC eine von 720x480 Pixel, wird das Bild runter skaliert, und sieht dann aber wirklich S******e aus, zumal da auch nicht deinterlact wird !:cool:

    Du musst nicht "Film -> DV Stream" wählen, in unserem Fall, sondern "Film -> QuickTime Film". Und du kannst dann sowohl für die Videospur, als auch für die Tonspur, eigene Codecs zum exportieren anwählen. DV-PAL steht da natürlich auch zur Auswahl, genau so wie "Ohne" oder Mpeg4-Audio (AAC) bei der Tonspur.
    Wenn du von der Videokamera in iMovie Clips importierst, dann zu einem kompletten Film zusammen schneidest, liegt alles schon im DV-Format da. Es wäre ja sinnlos, vor allem wenn es ein langer Film ist, alles noch einmal ins DV-Format zu exportieren, da es ja schon so vorliegt. Bei jedem Projekt was man in iMovie eröffnet, wird ein Ordner erzeugt, darin sind in der Regel drei Objekte:

    *Ordner Media mit allen Clips, Uebergängen, Text und Tonspuren, Effekten etc.
    *Die iMovie-Projektdatei selber, mit dem Namen des Projektes
    *Eine QuickTimeDatei, als abhängiger Film, Endung ".mov"

    Das Letzte aber nur, wenn ein Film im Filmbereich (unten) gesichert wurde. Diese "Name des Projektes.mov" Datei, kannst du öffnen (QTPlayer resp. QTPro), und dann als X-beliebige Video, und oder Tonspur exportieren (QTPro) ! Und diese gleiche Datei im Projekte-Ordner, kannst du OpenShiiva verfüttern. Du wandelst also nur die die Videospur mit OpenShiiva zu .mp4, während du die Tonspur mit QTPro ebenfalls zu Mpeg4-Audio (AAC) wandelst. Diese beiden Spuren kannst du ganz easy mit QTPro zusammenfügen. Videospur öffnen, Zeitmarke (Pfeil gegen unten) ganz links, dann Tonspur öffnen und "alles auswählen", dabei wird die ganze Tonspur markiert, dann wieder zur Videospur gehen, und da "Hinzufügen" wählen. Schlussendlich als "eigenständigen Film" sichern.

    Der einfachere Weg, vermutlich aber auch der "längere Weg", aus iMovie heraus alles als DV-PAL mit ("lesbarer", z.B. "Ohne") Tonspur exportieren, und diese erzeugte Datei dann OpenShiiva verfüttern. Was schlussendlich schneller geht, musst du selber ausprobieren.

    Mit ein bisschen Erfahrung in OpenShiiva, kann man tatsächlich das Movie um ca. den Faktor 20 ! kleiner machen, bei unwesentlich schlechterer Qualität.:D
     
  17. 6699

    6699 New Member

    Vielen Dank für die super-ausführliche Erklärung! Ich denke, dass ich diesen Weg umsetzen kann, will es morgen versuchen.

    Auf DV-NTSC bin ich am Anfang tatsächlich hereingefallen und habe mich
    a) über die schlechte Qualität und
    b) über das etwas andere Bildformat gewundert.

    Dann habe ich diesen Fehler aber schnell finden und ausschalten können. Die Sache mit dem interlacing war wesentlich kniffliger, ohne Deine Tipps hätte ich da keine Chance gehabt!

    Daher noch einmal herzllichen Dank für die Unterstützung, Du hast mir enorm weiterhelfen können!
    (Ich melde mich noch einmal, wenn ich Bild und Ton geschafft habe)
     
  18. 6699

    6699 New Member

    Nach mehreren Irrwegen habe ich es nun endlich geschafft: Mein Digital-Video von der Digitalkamera, bearbeitet mit iMovie liegt miit Ton in mp4 vor, der Kompressionsfaktor beträgt knapp 10, die Qualität kann ich am Bildschirm vom DV-Stream eigentlich nicht sicher unterscheiden.

    Damit ist der Weg zum mp4-Video zwar viel aufwändiger als zur DVD, aber es lohnt sich dann, wenn man kleine Dateien möchte. mp4 ist so gut, dass es sich wohl auf Dauer durchsetzen wird (bzw. DivX als MS-Alternative, hier dann der Standard mp4 gehen die Markmacht von MS kämpfen müssen).

    Bei dieser Diskussion habe ich eine Menge gelernt über den Bereich Filmbearbeitung. Die Problematik hat mir aber auch gezeigt, dass hier noch eine Menge Verbesserungsmöglichkeiten bei der Softwareentwicklung -insbesondere auch für Apple- bestehen.

    @ sandretto:

    Im Forum wurde mir schon oft weitergeholfen. Einen Gesprächspartner, der so kompetent und geduldlig gleichermaßen war, habe ich aber bisher noch nicht erlebt! -Danke!!!
     
  19. herrwu

    herrwu New Member

    sandretto, setzen,1
    thx
     

Diese Seite empfehlen