eBay und Safari

Dieses Thema im Forum "Software" wurde erstellt von Ziv-Zocker, 21. März 2004.

  1. Ziv-Zocker

    Ziv-Zocker New Member

    Mal was zum Thema direkt:

    Jemand eine Ahnung, wie ich das hinbekomme, unter Safari V125.1 Produktbilder in eBay zu laden ? Oder mit dem Netscape 7.1?

    Da will man nach Monaten mal wieder was vertickern, und dann funzt das Hochladen nicht ;(

    Zoc
     
  2. Energija

    Energija New Member

    Geht mit Safari nicht.

    Kannst deine Bilder aber auf eigenem Webspace laden und dann verlinken. Must nur den entspechenden HTML-code einfügen
     
  3. Ziv-Zocker

    Ziv-Zocker New Member

    :eek: ...wie kann das sein?

    Edit: Gibts noch einen Kniff? Eigene Webspace steht nicht zur Verfügung ....
     
  4. DieterBo

    DieterBo New Member

    doch Internet Explorer funzt
    :D
     
  5. Ziv-Zocker

    Ziv-Zocker New Member

    ihhh - Microsoft....
     
  6. iLig

    iLig Member

    Hallo, ich hab mit Safari Enhancer das Debugmenu angeschaltet. Dort hat man dann den Menüpunkt "Open Page with" in dem sämtliche auf deinem System installierten Browser aufgeführt sind. Müssen sogar nicht mal im Application Ordner liegen. Netscape 7.1 funktioniert z.B. aber Opera, Camino, Firefox usw. eigentlich auch wenn ich mich jetzt nicht irre. Besonders ärgerlich find ich das, weil das Hochladen von Bildern ja mal ging in Safari bei irgend einer der Betas. Na, auf jeden Fall hat man halt mit dem Debugmenü immer schnell zugriff auf einen anderen Browser sollte er mal nötig sein.
     
  7. Alvysinger

    Alvysinger New Member

    Ja, komisch !
    Hatte erst letzte Woche zwei Artikel eingestellt ! Da hat es funktioniert. Ich dachte die hätten es jetzt endlich nach dem letzten Safari Update geschafft ?!
    Eben versuch ich es..... geht nicht ???
    Also für Ebay wieder Mozilla zur Hilfe rufen !
     
  8. Ziv-Zocker

    Ziv-Zocker New Member

    geht bei mir halt auch nicht .....

    Jo, das löst aber das Problem nicht. ;( Auch dann, so unterstelle ich mal, wird der Netscape das Bild nicht hochladen. Spielt doch imho auch keine Rolle, von wo der gestartet wird, aus dem Dock oder aus dem Debug Menü von Safari enhanced........

    oder doch?
     
  9. smid

    smid New Member

    hats schonmal jemand mit dem neuen firefox probiert?
    den rennt nämlich wie die wutz (schneller als safari)!:cool:
     
  10. Alvysinger

    Alvysinger New Member

    Habe gerade mal dieses sehr nützliche Safari-Spinnensymbol rechts oben angeklick und eine Fehlermeldung an Apple geschickt - vielleicht bringts ja was !
     
  11. fotis

    fotis New Member

    Bitte schaut Euch den thread mal an. Wurde erst am Wochenende gefragt.

    Insbesondere die Antwort von Napfekarl.

    Grüsse, Fotis
     
  12. Alvysinger

    Alvysinger New Member

    Das ist bekannt - mit dem Basis Service - geht aber trotzdem nicht ?! - oder nur manchmal ?!
     
  13. Ziv-Zocker

    Ziv-Zocker New Member

    jau - genau wie Alvysinger sagt: Basispaket ist eingestellt, geht dennoch nicht, insofern ist der Ratschlag von Napfekarl überholt.... :(

    Was mich auch wundert, wenn es hier heißt, mit dem IE würde es gehen - mit dem gehen doch ganz simple Sachen wiederum gar nicht, wie zum Beispiel wenn man nach dem Einloggen sofort auf "Mein eBay" geht, kommt "Diese Seite kann nicht angezeigt werden" Fehlermeldung. In Safari geht das aber....
     
  14. frankwatch

    frankwatch Gast

    was spricht dagegen, wenn der ie nur für ebay bzw. bilder hochladen genutzt wird ?

    klappt perfekt und recht zügig,

    apple ist halt scheinbar nicht in der lage, den safari so zu programmieren, das es geht,

    bitter !!!

    die arbeiten gerade an 10.3.4, damit x.3 noch schneller wird :D
     
  15. Sunshine

    Sunshine New Member

    Also bei mir funktioniert das Hochladen der Bilder mit Safari einwandfrei.

    Ich habe im Debug-Menü von Safari (freigeschaltet mit Safari-Enhancer) ausgewählt, dass sich Safari als Internet Explorer 6 (Debug->User Agent->Windows MSIE 6.0) ausgeben soll. Zusätzlich habe ich noch den Punkt Pop-Ups unterdrücken deaktiviert.

    Mit diesen Einstellungen kann ich jedes Bild von meinem Desktop bzw. einem beliebigen Ordner nach eBay hochladen.
     
  16. kawi

    kawi Revolution 666

    das "bitter" trifft (wiedermal) die falschen.
    das ging alles ganz prima, bevor ebay sein upload script "überarbeitet" hat. Jetzt wird aufgrund einer Abfrage in einem Javascript der safari ausgeschlossen, weil irgendeine Funktion das jetzt für andere Browser "optimiert" wurde, also ein script verwendet wird was nicht mehr auf offene, standardisierte Funktionen zugreift sondern auf browserspezifische.
    bei den einen geht der bilderupload jetzt etws flotter von statten - bei den anderen gar nicht mehr.


    P.S. ich glaube aber es geht trotzdem (zumindest mit der panther Safari version) - und zwar indem man den Einstellungsvorgang OHNE Bild fertigstellt und dann im nachhinein über das nachträgliche bearbeiten erst die Bilder hinzufügt (alles noch vor der veröffentlichung).
    Bei mir hats so jedenfalls irgendwann im Dezember geklappt... (oder hab ich nen anderen browser dafür genommen?? *grübel...)
     
  17. frankwatch

    frankwatch Gast

    "das "bitter" trifft (wiedermal) die falschen.
    das ging alles ganz prima, bevor ebay sein upload script "überarbeitet" hat."

    mit den anderen browsern gehts doch auch, da hat doch ebay auch nichts am script geändert !


    "P.S. ich glaube aber es geht trotzdem (zumindest mit der panther Safari version) - und zwar indem man den Einstellungsvorgang OHNE Bild fertigstellt und dann im nachhinein über das nachträgliche bearbeiten erst die Bilder hinzufügt (alles noch vor der veröffentlichung).
    Bei mir hats so jedenfalls irgendwann im Dezember geklappt... (oder hab ich nen anderen browser dafür genommen?? *grübel...)"

    ich möchte aber nicht rumfummeln, um ein bild hochladen zu können und schon gar nicht darüber grübeln,

    eben doch bitter, kawi, es GEHT mit jedem andern browser, nur NICHT mit safari !!!!!
     
  18. kawi

    kawi Revolution 666

    Und es liegt doch an ebay ;-)

    Ich habe gerade in anderen Foren gelesen das es funktioniert wenn man Safari anweist sich als IE 6 auszugeben (übers debug menü)

    Sich als user Agent IE6 auszugeben legt aber keine Funktionen frei die safari nicht soweiso hätte - es umgeht eine Abfrage auf der website.
    da wird gefragt:
    bist du ein IE6 => dann lade soundso hoch
    bist du ein netscape => dann lade soundso hoch
    bist du ein mozilla/gecko => dann lade soundso hoch.

    das dumme ist das man bei solchen scripts JEDEN browser definieren muss.
    Anstelle einer upload Funktion die bei allen funktioniert. Wenn in dieser Abfrage nun ein browser daherkommt der als userAgent angibt er sei AppleWebkit/khtml trifft keine der Abfragen zu und der Browser wird einfach außen vor gelassen, obwohl er grundsätzlich dazu in der Lage ist die upload Befehle auszuführen - was ja bewiesen wird wenn man sich mit safari mal als IE 6 verkleidet.

    ich kanns grad selbst nichtnochmal nachprüfen, wenn das aber so stimmt, dann ist definitiv ebay dran schuld weil sie a) safari nicht i ihrer bescheuerten Browserabfrage drin haben, die Option also gar nicht existiert und b) überhaupt erst ein uploadscript haben welches eine browserabfrage vorraussetzt.
     
  19. Sunshine

    Sunshine New Member

    Hab ich doch schon bereits vor einer Stunde gesagt. Wenn sich Safari als IE ausgibt und man die Pop-Ups zuläßt, dann funktioniert der Upload einwandfrei.
     
  20. kawi

    kawi Revolution 666

    Eben. Und die Browserabfrage hat ebay verzapft und nicht Apple ;-)
     

Diese Seite empfehlen