Etherneteinstellung MTU ändern

Dieses Thema im Forum "Software" wurde erstellt von wernimac, 21. April 2008.

  1. wernimac

    wernimac New Member

    Hallo zusammen,

    wegen Problemen mit der Homepageseite von Kabeldeutschland.de möchte ich meine MTU (Maximum Transmission Unit) Einstellung von 1500 auf 1492 ändern. Leider gelingt mir dies nicht.
    Ich kann den neuen Wert zwar unter Netzwerkeinstellungen/Weitere Optionen/Ethernet/MTU eingeben und anwenden, aber wenn ich erneut in den Netzwerkeinstellungen Weitere Optionen/Ethernet öffne, sind unter MTU wieder die standardmäßigen 1500 eingestellt.
    Wie kann ich diesen Wert auf 1492 ändern?

    Vielen Dank für Hilfe
    Werner
     
  2. MacS

    MacS Active Member

    Nutzt du einen Router? Dann baut der die Verbindung in Internet auf, also musst du dort die Paketgröße eintragen. Normal ist bei PPPoE immer 1492, für LAN-Verbindung, also Router <-> Mac, sollte immer 1500 stehen. Wahrscheinlich stellt der Mac daher dort auch immer 1500 ein!
     
  3. DominoXML

    DominoXML New Member

    Hi Werner,

    die MTU läßt sich aus welchen Gründen auch immer nur für die Ethernet-Schnittstelle fixieren.

    Bei der Airportverbindung hilft zumindest kurzfristig ein

    sudo ifconfig en1 mtu 1492

    im Terminal. (Wobei en1 meistens die Airport Schnittstelle ist, ansonsten eventuell en2 etc.).

    Leider bleibt diese Einstellung nur bis zum nächsten Booten oder bis Airport deaktiviert und wieder aktiviert wurde.

    Du könntest aber mit dieser Einstellung schon mal testen. Wenn's klappt könnte man überlegen diesen Befahl in ein Startscript auszunehmen.

    Gruß

    Volker
     
  4. wernimac

    wernimac New Member

    Hallo vielen Dank für die schnellen Antworten,

    es geht genau um die Ethernetschnittstelle. Das Modem von Kabeldeutschland hängt genau am Etherneteingang meines MacPro.
    Es funktionieren allen Internetseiten, die mir so einfallen, nur die von Kabeldeutschland geht nicht (mehr).

    Eine kleine Merkürdigkeit gibt es auch noch:
    Wenn ich meine Airport Extreme Basisstation zwischen Modem und MacPro schalte, und das WLAN aktiviere, dann funktioniert die Kabeldeutschland-Seite auf dem PB, das über das WLAN im Internet ist. Nur über das Ethernet des MacPro komme ich nicht auf diese Seite. Daher mein Verdacht nach anderer MTU Größe.

    Habt Ihr vielleicht noch einen Tip
    Danke
    Werner
     
  5. digitalyves

    digitalyves New Member

    hallo,
    habe auch seit einer Woche von KD einen Internet-Zugang.
    Bin zu Beginn nur direkt übers MB ins Netz, jetzt teilen wir uns den Anschluss per WLAN. Ewig ging nix, habe dann im Netzt gelesen dass man die Geräte mal 5 Minuten (Modem und wLAN-Router) ausgeschaltet stehen lassen sollen. Das Modem löscht dann wohl seinen MAC-Adresse-Speicher und dann gings auch endlich. Vorher gings nr per Ethernet, Wlan keine Chance.

    Und Modem zuerst anschalten, 2-3 Minuten warten und dann den Wlan-Router.

    mfg

    Yves
     
  6. DominoXML

    DominoXML New Member

    Hi Werner,

    ich glaube nicht, daß das Problem etwas mit der MTU zu tun hat.

    Entweder wird der Name über DNS nicht aufgelöst, oder Du hast vielleicht aus Versehen mit einem Tool wie Little Snitch die Seite aus Versehen geblockt.

    Mache mal unter Dienstprogramme das Netzwerkdienstprogramm auf und mache mal einen Trace www.kabeldeutschland.de.

    Zumindest müsste der Weg nach draussen dokumentiert werden.

    Übrigens konnte ich den Server nicht pingen. Scheint so zu sein, daß Ping deaktiviert ist.

    Die momentane IP ist 83.169.190.70.

    Solltest Du ein DNS Problem haben, dann müsste ein http://83.169.190.70 die Seite aufmachen.

    Gruß

    Volker
     
  7. wernimac

    wernimac New Member

    Hallo Volker,

    ein DNS Problem habe ich wohl auch nicht; mit Deiner vorgeschlagenen IP Adresse in das URL-Feld von Safari kopiert erreiche ich die Kabeldeutschlands leider auch nicht. Dein Tip mit dem Netzwerkdienstprogramm ist prima. Hab's gleich ausprobiert, aber leider kann ich das ausgegebene Protokoll nicht interpretieren. Vieleicht kannst Du mir dabei helfen?
    Das Protokoll sieht so aus:

    „Traceroute“ wurde gestartet …

    traceroute to www.kabeldeutschland.de (83.169.190.70), 64 hops max, 40 byte packets
    1 10.0.1.1 (10.0.1.1) 0.750 ms 0.423 ms 0.484 ms
    2 91.64.253.152 (91.64.253.152) 5.728 ms 5.549 ms 9.211 ms
    3 91.64.254.94 (91.64.254.94) 8.233 ms 7.904 ms 7.971 ms
    4 83-169-183-118-isp.superkabel.de (83.169.183.118) 7.986 ms 6.657 ms 6.226 ms
    5 88.134.251.2 (88.134.251.2) 15.732 ms 17.736 ms 17.972 ms
    6 83.169.188.254 (83.169.188.254) 15.731 ms 19.268 ms 15.706 ms
    7 83.169.191.29 (83.169.191.29) 16.231 ms 17.744 ms 25.711 ms
    8 * * *
    9 * * *
    10 * * *
    11 * * *
    12 *

    Vielen Dank für Deine Hilfe
    Werner
     
  8. DominoXML

    DominoXML New Member

    Hm, an der Verbindung liegt es nicht, da Du ja raus kommst. Auch die DNS Auflösung klappt.

    Ich vermute die 10.0.1.1 ist deine Airport Extreme.
    Hiernach kommen bereits die Server/Router von Kabeldeutschland.

    Das Einzige was mir jetzt noch einfällt ist, daß Kabeldeutschland ähnlich wie T-Online bestimmte Informationen an die eigenen Server überträgt und hier dann aus welchem Grund auch immer Schluß ist.

    Ich würde mal auf den Vorschlag von digitalyves zurückgreifen.
    Könnte sein, daß dein Book irgendwo noch registriert ist und der Mac Pro nicht als "zugehörig" eingestuft wird.

    Sollte kein Tool wie Little Snitch etc. die Seite blocken sehe ich sonst keinen Grund warum er die Seite nicht aufmachen sollte.
    (Die Seite ist online und mein Safari macht sie auf).
     
  9. wernimac

    wernimac New Member

    ... Ist schon eine komische Sache, ausschalten kann ich mein Modem derzeit nicht, weil ich und meine Frau am PB noch ein bischen surfen wollen. Alle anderen Seiten funktionieren ja.
    Werd's aber morgen mal probieren. Vielleicht hilft das Ausschalten ja.
    Ich werd' berichten ...

    Vielen Dank nochmal
    Werner
     
  10. MacS

    MacS Active Member

    Da dein Mac am Router hängt (Airport Extreme Base = 10.0.1.1), muss hier die korrekte Paketgröße eingetragen werden. Das hat mit dem Mac reichlich wenig zutun! Bei mir ist der Mac auch per Ethernet mit dem Router verbunden und auch bei mir ist MTU auf 1500 eingestellt.
     
  11. wernimac

    wernimac New Member

    Die Kabeldeutschland-Seite funktioniert aber auch nicht, wenn ich den Mac direkt per Ethernet mit dem Kabeldeutschland-Modem verbinde. Alle Seiten funktionieren, nur die von Kabeldeutschland nicht.
    Vielleicht hilft tatsächlich das Modem mal ein paar Minuten ausschalten. Es hat leider keinen Reset-Knopf.

    Ich werd' das Ergenis berichten...

    Vielen Dank für Euer Bemühen
     
  12. wernimac

    wernimac New Member

    Hallo,
    ich bin's wieder mit meinem Kabeldeutschland-Ethernet Problem.
    Ich habe heute mal den ganzenTag das Kabeldeutschland-Modem ausgeschaltet gelassen, damit es eventuell falsch gemerkte Einstellungen "vergisst". Habe das Modem heute abend wieder eingeschaltet, und voller Hoffnung
    www.kabeldeutschland.de
    in die URL-Zeile von Safari eingetippt.

    Leider wieder nichts :-(((( Safari kann die Seite nicht öffnen. Auch mein Mozilla Browser kann's nicht.

    Aber das schönste (wie immer):
    An meinem Powerbook, das über die Airport Extreme über WLAN im Netz ist funktioniert die Seite einwandfrei - wie gehabt.

    Jetzt bleibt wohl nur noch ein Anruf bei Kabeldeutschland. Es sei denn, Ihr habt noch einen Geistesblitz.

    Vielen Dank für Euer Hirnschmalz
    Gruß Werner
     
  13. wernimac

    wernimac New Member

    Hurra, es geht .....

    die Lösung war wohl: Modem eine zeitlang ausschalten und in den Systemeinstellungen habe ich unter DNS-Server 10.0.1.1
    eingetragen. Der Systemeinstellungsdialog schaut jetzt so aus:
     

    Anhänge:

Diese Seite empfehlen