Fehler in den Systemeinstellungen für Hintergründe und Monitore

Dieses Thema im Forum "OS X 10.10 Yosemite" wurde erstellt von Connect2, 2. Februar 2015.

  1. Connect2

    Connect2 New Member

    Hallo liebe Mac Gemeinde,

    ich bin vor kurzem Besitzer eines Macbook Pro Mid 2012 mit 8gb Ram, 256SSD, GeForce, installiert ist die aktuellste Version von Yosemite.
    Ich habe seit kurzem das Problem, dass ich meinen Hintergrund nicht mehr ändern kann. Weder über rechtsklick auf das Bild noch über die Einstellungen. Es kommt dann immer die Fehlermeldung "Fehler in den Systemeinstellungen". Dasselbe passiert, wenn ich unter Einstellungen "Monitore" öffnen möchte =/

    Ich hab bisher versucht irgendwelche Dateien im Cache und der Library zu löschen. Was nun dazu geführt hat, dass ich unter Einstellungen die Optionen Monitor und Hintergründe gelöscht habe...

    Habt ihr vielleicht eine Idee zur Lösung meines Problems?
     
  2. MACaerer

    MACaerer Active Member

    Sind denn im Verzeichnis /System/Library/PreferencePanes noch folgende Dateien vorhanden:
    -DesktopScreenEffectsPref.prefPane
    -Displays.prefPane
    Wenn ja versuche sie mal durch Doppelklick zu starten. Wenn das geht liegt das Problem im Programm "Systemeinstellung", das letztendlich nur eine Benutzeroberfläche für die PrefPanes ist.

    MACaerer
     
  3. Connect2

    Connect2 New Member

    Bei beiden erscheint wieder dasselbe Problem!

    Habe heute Yosemite clean neu aufgespielt, jedoch dann alle Daten von TimeCapsule wiederhergestellt. Problem besteht trotzdem. Und zusätzlich habe ich ein noch viel schlimmeres Problem bekommen: Beim anschließen von USB Geräten gibts ein "wummernden Sound" aus den Lautsprechern und man kann auch nicht mehr richtig schreiben. Ganz komisch =/
     
  4. MacS

    MacS Active Member

    Oh ha, mit dem Wiederherstellen hast du dir den Fehler wieder zurück auf den Rechner geholt und stehst genau dort, wo du vor der Aktion warst! Wenn du solch einen Fehler hast, ist ein Clean-Install sicherlich der richtige Weg (wobei das nur allerletzter Weg seien sollte). Aber dann musst du auch alle Programme neu und von Hand installieren. Alles andere zerstört die Arbeit, weil du korrupte/ defekte Dateien aus dem Backup zurückholst! Du kannst mit TimeMachine nach und nach einzelne Ordner aus deiner Benutzer-Ordner zurückholen, aber immer nur deine Anwenderdaten, wie den iTunes-Ordner, den iPhoto-Ordner und Dokumente, die mit deinen Anwender-Programmen erstellt wurden. Das ist mühevoll, aber nur so entgehst du der Endlosschleife!

    Bevor man aber diesen Aufwand betreibt, sollte man herausfinden, wo der Fehler steckt. Daher würde ich einen 2. Benutzer anlegen und unter diesem Benutzer probieren, ob sich dann immer noch die Einstellungen öffnen lassen. Wenn das doch klappt, dann könnte man im Ordner <Volume>/Libary nach Prefs von den Systemeinstellungen suchen und löschen. Klappt der 2. Benutzer, liegt der Fehler definitiv am <Volume>/Benutzer/<Name>/Library. Der Ordner Library gibt es nämlich mehrmals, einmal für das System und dann für jeden Benutzer.
     
  5. MACaerer

    MACaerer Active Member

    Genau, das war eigentlich der Ansatz der hinter meiner Empfehlung gesteckt hat: Den Fehler suchen und gezielt beheben. Was hilft es wenn man die ganz große Keule auspackt (Neuinstallation) und sich dann das Problem wieder zurückmigriert.

    MACaerer
     
  6. Connect2

    Connect2 New Member

    Vielen Dank für eure Hilfe,
    das mit der Library hab ich versucht und auf Empfehlung ein paar Daten daraus gelöscht, was es nur schlimmer gemacht hat.
    Habe den Cleaninstall erneut durchgeführt und diesmal hat alles geklappt. Installiere jetzt jedes Programm einzeln.

    Es war jedoch so, dass man auf dem Gastkonto den Hintergrund ändern konnte. Fehler lag also definitiv nur in meinem Benutzeraccount.

    Die Sache mit dem USB Fehler ist mir eigentlich zu peinlich...Und zwar habe ich eine Tastatur von Logitech angeschlossen...auf dieser lag jedoch ein Collegeblock, der genau auf die Enter und Pfeiltaste nach rechts gedrückt hat...:embar:
    Somit ist der zweite Fehler auch behoben.


    Vielen Dank für eure Hilfe, ich hoffe der Fehler taucht nun nie wieder auf!
     

Diese Seite empfehlen