Fehler in "über diesen Computer" ?

Dieses Thema im Forum "Software" wurde erstellt von Marcel Hiltrop, 3. Juni 2001.

  1. Marcel Hiltrop

    Marcel Hiltrop New Member

    Vor kurzem ist mir etwas Seltsames aufgefallen.

    Ich habe in meinem G4 (OS 9.1) 384 MB Ram installiert. Dies wird mir unter " über diesen Computer " nach dem Systemboot auch korrekt angezeigt. Wenn ich jetzt aber eine Applikation starte (z.B. Webbrowser o.ä.) und diese irgendwann wieder beende, dann wird plötzlich zu wenig Ram angezeigt. Das OS nimmt dann angeblich ca. 45 MB ein, frei sind dann noch 310-320 MB. Es fehlt also einges !
    Kennt jemand dieses Phänomen auch und kann mir was dazu sagen?

    Marcello
     
  2. charly68

    charly68 Gast

    ist normal, hab jezt aber keine zeit dir das genau zu erklären muss arbeiten.....
    der ram speicher wird fragmentiert und beim beenden von apps nicht wieder zu 100% freigegeben. scheiss os halt. nimm x da ist es anders... :)))))

    charly

    ups..... heute ist aber auch was los.. scheiss wetter... alles bricht zusammen..
     
  3. Olley

    Olley Gast

    hi marcel,
    das liegt daran, daß der Mac den Arbeitsspeicher nicht dynamisch Verwalten kann.also wenn du z.B.

    als erstes Excel (z.b. 10 MB Ram)
    als zweites Filemaker (z.b. 10 MB Ram)
    als drittes Outlook (z.b. 10 MB Ram)

    öffnest ,dann aber Excel beendest gibt der mac die 10 MB Ram nicht mehr frei.

    Hast du das Verstanden?

    Du kannst aber mit Sherlock, wenn du "appsw" eingibst auf deiner HD das AppleScript-Programm "AppSwitcherLowerRight" finden. Wenn du dieses startest werden die Programme in der reihenfolge angezeigt in der du diese gestartest hast.Wenn du diese jetzt in entgegengesetzter Richtung beendest gibt der Mac immer den vom Programm gebrauchten RAM wieder frei.

    Der Finder zeigt die Programme alphabetisch sortiert an, also nicht von oben nach unten oder andersrum beenden sonst hast du wieder den effekt in "Über diesen Computer"!

    Mit dem Tool "A-Dock" geht das auch gut. (Du mußt nur in dem Kontrollfeld von A-Dock unter der Registerkarte "item" "Launch Order" anklicken.

    So ich hoffe das war einigermasen gut erklärt.

    Bye Olley
     
  4. Marcel Hiltrop

    Marcel Hiltrop New Member

    Danke für die Erklärungen!
    Ich hatte mit sowas schon gedacht, allerdings reicht es bei mir schon wenn ich nur eine! App. starte und diese dann wieder beende.
    Der Ram ist weg.Im übrigen finde ich die 45 MB für´s OS extrem wenig -komisch.Naja, was soll´s .ist vielleicht mal wieder so`n Apple- Ding.

    Übrigens: OS X -schön und gut, aber leider läuft da kein HD-Recording Programm, oder gibt`s schon Updates !? Und dann Treiber für den Drucker erstmal , usw, usw....
    Wird wohl noch einige Zeit dauern, bis ich mir X hole.

    Marcello
     
  5. Olley

    Olley Gast

    hi marcel,
    verstehe ich das richtig?
    Du startest eine Applikation, beendest diese wieder und der RAM dieser wird nicht mehr freigegeben?

    Siehst du im Finder (auser dem Finder selbst natürlich) wirklich nur diese eine Applikation?

    Hab ich ja noch nicht erlebt sowas.

    Gruß Olley
     
  6. Marcel Hiltrop

    Marcel Hiltrop New Member

    Doch, dass ist definitiv so.

    Ich starte beispielsweise den Webbrowser ( das Problem tritt unabhängig von der Anwendung auf!!) und wenn ich ihn wieder beende, dann wird der von diesem Programm belegte RAM nicht mehr freigegeben.
    Meinst du es sich könnte eventuell um einen defekten Speicherriegel handeln?

    Habe im 1. und 2. Slot jeweils einen 64 MB Riegel und im 3. einen 256 MB Riegel installiert.Vielleicht liegt es ja auch an der Einbaureihenfolge.Ich habe absolut keine Ahnung!!
     
  7. Olley

    Olley Gast

    hi marcel,
    da hilft nur eins:

    alle bis auf einen riegel ausbauen, starten ausprobieren.
    zweiter riegel dazu starten ausprobieren
    dritter riegel dazu starten ausprobieren.

    die einbaureihenfolge spielt meineswissens dabei keine rolle.

    sind das alles 100mhz-marken-riegel???

    Olley
     
  8. Marcel Hiltrop

    Marcel Hiltrop New Member

    Dann werde ich den Akt bei Gelegenheit durchprozessieren.

    Ja, sind alles 100 Mhz Riegel. Allerdings ist einer ein 322 und die anderen sind 222er.Denke aber nicht, dass es daran liegt.
     
  9. Marcel Hiltrop

    Marcel Hiltrop New Member

    Achso, Marke!

    Also die zwei 64er sind von Gravis, der große ist von dsp-Versand.Da geben die 10 Jahre Garantie drauf. Ich dachte mir, das reicht.
     
  10. Folker

    Folker New Member

    Hallo Marcel,

    das Gesamt-System des Macs hat keine feste Speicherzuteilung wie Anwendungsprogramme (so ungefähr!). Wenn jetzt Programme best. Systembestandteile nutzt (z.B. AppleScript, Quicktime? o.ä.) werden diese erst dann in das System gehieft und der Speicherverbrauch Deines Systems steigt - auf diese Weise kann der RAM-Bedarf des Systems über einen Arbeitstag stetig anwachsen.

    Gruß,
    s.o.
     
  11. Macci

    Macci ausgewandert.

    Es gibt eine Freeware namens MacOSPurge, die dir deinen Ram wieder freiräumt (defragmentiert).
     
  12. Marcel Hiltrop

    Marcel Hiltrop New Member

    Vor kurzem ist mir etwas Seltsames aufgefallen.

    Ich habe in meinem G4 (OS 9.1) 384 MB Ram installiert. Dies wird mir unter " über diesen Computer " nach dem Systemboot auch korrekt angezeigt. Wenn ich jetzt aber eine Applikation starte (z.B. Webbrowser o.ä.) und diese irgendwann wieder beende, dann wird plötzlich zu wenig Ram angezeigt. Das OS nimmt dann angeblich ca. 45 MB ein, frei sind dann noch 310-320 MB. Es fehlt also einges !
    Kennt jemand dieses Phänomen auch und kann mir was dazu sagen?

    Marcello
     
  13. charly68

    charly68 Gast

    ist normal, hab jezt aber keine zeit dir das genau zu erklären muss arbeiten.....
    der ram speicher wird fragmentiert und beim beenden von apps nicht wieder zu 100% freigegeben. scheiss os halt. nimm x da ist es anders... :)))))

    charly

    ups..... heute ist aber auch was los.. scheiss wetter... alles bricht zusammen..
     
  14. Olley

    Olley Gast

    hi marcel,
    das liegt daran, daß der Mac den Arbeitsspeicher nicht dynamisch Verwalten kann.also wenn du z.B.

    als erstes Excel (z.b. 10 MB Ram)
    als zweites Filemaker (z.b. 10 MB Ram)
    als drittes Outlook (z.b. 10 MB Ram)

    öffnest ,dann aber Excel beendest gibt der mac die 10 MB Ram nicht mehr frei.

    Hast du das Verstanden?

    Du kannst aber mit Sherlock, wenn du "appsw" eingibst auf deiner HD das AppleScript-Programm "AppSwitcherLowerRight" finden. Wenn du dieses startest werden die Programme in der reihenfolge angezeigt in der du diese gestartest hast.Wenn du diese jetzt in entgegengesetzter Richtung beendest gibt der Mac immer den vom Programm gebrauchten RAM wieder frei.

    Der Finder zeigt die Programme alphabetisch sortiert an, also nicht von oben nach unten oder andersrum beenden sonst hast du wieder den effekt in "Über diesen Computer"!

    Mit dem Tool "A-Dock" geht das auch gut. (Du mußt nur in dem Kontrollfeld von A-Dock unter der Registerkarte "item" "Launch Order" anklicken.

    So ich hoffe das war einigermasen gut erklärt.

    Bye Olley
     
  15. Marcel Hiltrop

    Marcel Hiltrop New Member

    Danke für die Erklärungen!
    Ich hatte mit sowas schon gedacht, allerdings reicht es bei mir schon wenn ich nur eine! App. starte und diese dann wieder beende.
    Der Ram ist weg.Im übrigen finde ich die 45 MB für´s OS extrem wenig -komisch.Naja, was soll´s .ist vielleicht mal wieder so`n Apple- Ding.

    Übrigens: OS X -schön und gut, aber leider läuft da kein HD-Recording Programm, oder gibt`s schon Updates !? Und dann Treiber für den Drucker erstmal , usw, usw....
    Wird wohl noch einige Zeit dauern, bis ich mir X hole.

    Marcello
     
  16. Olley

    Olley Gast

    hi marcel,
    verstehe ich das richtig?
    Du startest eine Applikation, beendest diese wieder und der RAM dieser wird nicht mehr freigegeben?

    Siehst du im Finder (auser dem Finder selbst natürlich) wirklich nur diese eine Applikation?

    Hab ich ja noch nicht erlebt sowas.

    Gruß Olley
     
  17. Marcel Hiltrop

    Marcel Hiltrop New Member

    Doch, dass ist definitiv so.

    Ich starte beispielsweise den Webbrowser ( das Problem tritt unabhängig von der Anwendung auf!!) und wenn ich ihn wieder beende, dann wird der von diesem Programm belegte RAM nicht mehr freigegeben.
    Meinst du es sich könnte eventuell um einen defekten Speicherriegel handeln?

    Habe im 1. und 2. Slot jeweils einen 64 MB Riegel und im 3. einen 256 MB Riegel installiert.Vielleicht liegt es ja auch an der Einbaureihenfolge.Ich habe absolut keine Ahnung!!
     
  18. Olley

    Olley Gast

    hi marcel,
    da hilft nur eins:

    alle bis auf einen riegel ausbauen, starten ausprobieren.
    zweiter riegel dazu starten ausprobieren
    dritter riegel dazu starten ausprobieren.

    die einbaureihenfolge spielt meineswissens dabei keine rolle.

    sind das alles 100mhz-marken-riegel???

    Olley
     
  19. Marcel Hiltrop

    Marcel Hiltrop New Member

    Dann werde ich den Akt bei Gelegenheit durchprozessieren.

    Ja, sind alles 100 Mhz Riegel. Allerdings ist einer ein 322 und die anderen sind 222er.Denke aber nicht, dass es daran liegt.
     
  20. Marcel Hiltrop

    Marcel Hiltrop New Member

    Achso, Marke!

    Also die zwei 64er sind von Gravis, der große ist von dsp-Versand.Da geben die 10 Jahre Garantie drauf. Ich dachte mir, das reicht.
     

Diese Seite empfehlen