Fenstereinstellung in OS X umsonst??

Dieses Thema im Forum "Hardware" wurde erstellt von Macbudi, 17. Juni 2002.

  1. Macbudi

    Macbudi New Member

    Noch ein Problem...
    Meinem G4 533 Dual interessieren unter OS x keine Fensterdarstellungsoptionen. Wenn ich mein Festplattensymbol öffne und auf Darstellung / Darstellungsoptionen einblenden klicke, wähle ich z.B aus, dass alle Ordner am Raster ausgerichtet werden sollen - doch meinem G4 ist das wurscht - beim nächsten Neustart ist es, als hätte ich diese Voreinstellungen nie getroffen.
     
  2. AndreasG

    AndreasG Active Member

    Such mal im Forum nach "Finder", dann findest Du zu diesem Thema einiges (auch von mir).
    Meine Erfahrung: Einige Fenster "gehören" nicht dem User, sondern dem root. Das sind hauptsächlich die Fenster "OSX-Harddisk", und darin "System", "Applications", "Library" etc. Abhilfe: Unter root einloggen, die Fenster so anordnen, wie man möchte, und fortan behalten sie diese Einstellungen.
    Manchmal verlieren aber auch andere Fenster urplötzlich ihre Settings. Liegt vermutlich am Finder, dem vermutlich schlechtesten OSX-Programm, dass es gibt.

    Gruss
    Andreas
     
  3. XYMOS

    XYMOS New Member

    hi,

    hehe, habe das selbe problem ;-)
    aber erst wieder seit dem update auf 10.1.5...

    -xymos.
     
  4. AndreasG

    AndreasG Active Member

    Stimmt, nach dem Update auf 10.1.5 waren die meisten Fenster wieder durcheinander. Nachdem ich sie unter root wieder positioniert habe, herrscht aber wieder Ordnung wie vorher.

    Andreas
     
  5. cubeATfrankfurt

    cubeATfrankfurt New Member

    Da ich mich nur ungerne als root einlogge, ein anderer Lösungsvorschlag:

    Das Problem sind die unsichtbaren .ds_store - Dateien in jedem Ordner, in denen die Informationen über den jeweiligen Ordner -- d.h. u.a. auch die Fensterpositionen -- gespeichert sind. Eigentümer dieser unsichtbaren Dateien ist normalerweise root.

    Lösung:

    Als ein admin einwählen (root nicht nötig) und im Terminal folgenden Befehl eingeben:

    sudo find / -name .DS_Store -user root -print0 | sudo xargs -0 chmod go=+w

    (in einer Zeile und Leerzeichen beachten!). Es werden mit diesem Befehl alle Schreibrechte an den Dateien .ds_store jedem Benutzer eingeräumt, so daß danach jeder Benutzer seine Fensterpositionen festlegen kann.

    Vergleiche auch: http://forum.macwelt.de/cgi-bin/mac_forum/topic_show.pl?id=27508#199387
     
  6. PeterG

    PeterG New Member

    Bei mir war es vor 10.1.5 falsch und mit 10.1.5 erstmals richtig.
     
  7. Hans.J

    Hans.J Active Member

    Hallo Macbudi,
    Ich weiss nicht, aber ich habe das Gefühl, dass sich die Fenster eine Einstellung am ehesten merken, wenn ich sie mit "Apfel+W" schliesse. Oder bilde ich mir das nur ein?
    Gruss Hans
     
  8. Macbudi

    Macbudi New Member

    Noch ein Problem...
    Meinem G4 533 Dual interessieren unter OS x keine Fensterdarstellungsoptionen. Wenn ich mein Festplattensymbol öffne und auf Darstellung / Darstellungsoptionen einblenden klicke, wähle ich z.B aus, dass alle Ordner am Raster ausgerichtet werden sollen - doch meinem G4 ist das wurscht - beim nächsten Neustart ist es, als hätte ich diese Voreinstellungen nie getroffen.
     
  9. AndreasG

    AndreasG Active Member

    Such mal im Forum nach "Finder", dann findest Du zu diesem Thema einiges (auch von mir).
    Meine Erfahrung: Einige Fenster "gehören" nicht dem User, sondern dem root. Das sind hauptsächlich die Fenster "OSX-Harddisk", und darin "System", "Applications", "Library" etc. Abhilfe: Unter root einloggen, die Fenster so anordnen, wie man möchte, und fortan behalten sie diese Einstellungen.
    Manchmal verlieren aber auch andere Fenster urplötzlich ihre Settings. Liegt vermutlich am Finder, dem vermutlich schlechtesten OSX-Programm, dass es gibt.

    Gruss
    Andreas
     
  10. XYMOS

    XYMOS New Member

    hi,

    hehe, habe das selbe problem ;-)
    aber erst wieder seit dem update auf 10.1.5...

    -xymos.
     
  11. AndreasG

    AndreasG Active Member

    Stimmt, nach dem Update auf 10.1.5 waren die meisten Fenster wieder durcheinander. Nachdem ich sie unter root wieder positioniert habe, herrscht aber wieder Ordnung wie vorher.

    Andreas
     
  12. cubeATfrankfurt

    cubeATfrankfurt New Member

    Da ich mich nur ungerne als root einlogge, ein anderer Lösungsvorschlag:

    Das Problem sind die unsichtbaren .ds_store - Dateien in jedem Ordner, in denen die Informationen über den jeweiligen Ordner -- d.h. u.a. auch die Fensterpositionen -- gespeichert sind. Eigentümer dieser unsichtbaren Dateien ist normalerweise root.

    Lösung:

    Als ein admin einwählen (root nicht nötig) und im Terminal folgenden Befehl eingeben:

    sudo find / -name .DS_Store -user root -print0 | sudo xargs -0 chmod go=+w

    (in einer Zeile und Leerzeichen beachten!). Es werden mit diesem Befehl alle Schreibrechte an den Dateien .ds_store jedem Benutzer eingeräumt, so daß danach jeder Benutzer seine Fensterpositionen festlegen kann.

    Vergleiche auch: http://forum.macwelt.de/cgi-bin/mac_forum/topic_show.pl?id=27508#199387
     
  13. PeterG

    PeterG New Member

    Bei mir war es vor 10.1.5 falsch und mit 10.1.5 erstmals richtig.
     
  14. Hans.J

    Hans.J Active Member

    Hallo Macbudi,
    Ich weiss nicht, aber ich habe das Gefühl, dass sich die Fenster eine Einstellung am ehesten merken, wenn ich sie mit "Apfel+W" schliesse. Oder bilde ich mir das nur ein?
    Gruss Hans
     
  15. Macbudi

    Macbudi New Member

    ... lieber Hans ... von dem mal abgesehen ... hat mein Rechner so manche interessen für sich - genauso wie ich ...
     
  16. Macbudi

    Macbudi New Member

    Herzliches Dank CubeATFrankfurt!
    hat super funktioniert dein Trick!
     
  17. virtualex

    virtualex New Member

    Hallo, etwas aus der Reihe die Frage, aber gibt es nicht eine Möglichkeit, daß sich Browserfenster beim klicken auf den grünen Punkt komplett an die Screengröße anpassen (halt so wie beim PC, daß man nichts mehr von Schreibtischhintergrund sieht)?

    Meines Erachtens immer noch eins der größten Probleme beim Mac, daß man ständig an den Fensterchen rumzupfen muss, um ne ideale Darstellung zu bekommen.

    Beste Grüße, Alex
     
  18. virtualex

    virtualex New Member

    Ist es normal, daß diese Meldung kommt?:

    We trust you have received the usual lecture from the local System
    Administrator. It usually boils down to these two things:

    #1) Respect the privacy of others.
    #2) Think before you type.
     
  19. garymueller

    garymueller New Member

    hi,

    behebt aber folgendes problem nicht:

    wenn ich auf applications clicke, ist immer im fenster der scrollbalken irgendwo ganz unten, da wo ich ihn NIE brauche. ich muss immer erst hochscrollen!

    kann man das auch abstellen?
     
  20. mikrokokkus

    mikrokokkus New Member

    Ja das ist normal - für mich übrigens eine der coolsten Warnmeldungen, die ich bisher an einem Computer zu lesen gekriegt habe.
     

Diese Seite empfehlen