Festplatte geht immer aus...

Dieses Thema im Forum "Hardware" wurde erstellt von Olli S., 15. Januar 2004.

  1. Olli S.

    Olli S. New Member

    Wenn ich längere Zeit den Rechner nicht benutze, dann geht meine Festplatte immer in den Ruheszustand und muss dann bei einem Zugriff erst wieder aufwachen. Das nervt gehörig. Die Option "Festplatte wenn möglich in Ruhezustand versetzen" ist deaktiviert. Wie kommt das ? Und wie ändere ich das, sodass die FP nur dann in den Ruhezustand geht, wenn das gesamte System auch in den Ruhezustand geht.

    Vielen Dank, Olli
     
  2. WoSoft

    WoSoft Debugger

    Ruhezustand heißt auch, dass die Festplatte abgeschaltet wird. Willst dud das nicht, musst du auch "Ruhezustand aktivieren" auf Nie stellen.
     
  3. macixus

    macixus Hofrat & Traktorist

    Das hat er schon gefunden, wie ich seiner Frage entnehmen konnte...:rolleyes:
     
  4. sandretto

    sandretto Gast

    Wenn die Checkbox "Festplatte wenn möglich in Ruhezustand versetzen" aktiviert ist, gehen die Festplatten nach 10 Minuten Inaktivität in den Ruhezustand.

    Geh mal ins Terminal, und gebe man pmset ein, mit Return bestätigen.

    Da kannst du alle Befehle zu den Power Management Settings sehen. Mit pmset -g erscheinen alle aktuellen Einstellungen. Wenn bei "spindown" eine 0 (nie) steht, so gehen die Festplatten nur bei Ruhezustand des Systems schlafen. Mit pmset -a spindown x kannst du die Minutenzahl (x) festlegen, bis die Platten nach Inaktivität schlafen gehen. Bei pmset -a spindown 22 ergäbe das 22 Minuten. Wenn du da etwas ändern möchtest, musst du als Root angemeldet sein.

    Wichtig, egal ob du unter "Energie sparen", oder im Terminal etwas änderst, die Festplatten sollten alle aktiv gemountet sein, damit sie die neuen Settings übernehmen, notfalls Rechner neu starten.
     
  5. Olli S.

    Olli S. New Member

    Cool, danke!

    Also da steht

    Currently in use:
    sleep 60
    autorestart 0
    spindown 180
    womp 1
    ring 0
    dim 19

    Nach 180 minuten gehen die FP in den Ruhezustand ?¿? Aber nach 'ner Zeit müssen die immer wieder hochfahren...Wie kommt sowas ?

    Grüße, Olli
     
  6. sandretto

    sandretto Gast

    Diese Angaben sind normal, da bei spindown, max. 180 Minuten/3 Std., oder eben "Nie" (0) möglich sind. Nicht jedoch Werte dazwischen, also >180 bis unendlich. Der Schieberegler im Kontrollpanel von "Energie sparen", geht auch nur bis 3 Stunden, deswegen.

    Sobald der Regler da die Marke von "Nie" verlässt, verändert sich die spindown-Marke zu 180 Minuten. Ausnahme, wenn die Checkbox "Festplatte wenn möglich in Ruhezustand versetzen" aktiv ist, dann ist da immer 10 Minuten angegeben. Ist aber nicht relevant, da dann die Zeit die bis zum Ruhezustand eingestellt ist, massgebend ist. Und die ist eben zwischen 1 und 180 Minuten einstellbar.

    Wenn du dich nicht getraust mit dem Terminal unter root zu hantieren, es gibt das Tool "Cocktail"...

    http://www.macosxcocktail.com/

    Mit dem kannst du die Spindown-Werte aller Festplatten auf "Never" setzen. Dabei sollten aber alle Festplatten aktiv (nicht geparkt) am Desktop gemountet sein. Das Gleiche sollte aber auch bei der Einstellung "Nie" im Kontrollpanel "Energie sparen" erreicht werden sollen ! Sonst stimmt etwas nicht.
     
  7. Olli S.

    Olli S. New Member

    Vielen Dank, ich versuch´s mal....

    Grüße, Olli
     

Diese Seite empfehlen