Für immer als "root" angemeldet sein?

Dieses Thema im Forum "Hardware" wurde erstellt von sven-o, 1. Oktober 2002.

  1. sven-o

    sven-o New Member

    Houston, wir haben hier ein Problem.....
    Nachdem ich meinen Treiber vom miniVigor aktualisiert habe, kann ich mich nicht mehr als "Normal"-User anmelden. Habe dabei als root von Hand den alten Treiber löschen müssen.
    Nach Eingabe von Name und Kennwort dreht sich einige Sekunden lang der Beachball und das Anmeldefenster erscheint wieder frisch und unberührt. Dabei werden die Kennwörter trotzdem konrolliert, wenn falsches Kennwort, dann das Wackelpudding-Phänomen und Neu-Eingabe. Habe schon die Kennwörter der User zurückgesetzt, neue User angelegt aber nichts zu machen. Nur als Admin und Root wird die Anmeldung erfolgreich durchgeführt
    Bitte verrate mir doch eine/r DEN Unix-Befehl der den Fehler behebt.
    Ach, fsck und Erste-Hilfe habe ich auch schon bemüht.

    Bin für alle Tips dankbar!

    sven-o

    PS.: Bitte lieber großer Unix-Gott, verzichte doch noch einmal auf eine Neuinstallation! Bitte!!!
     
  2. Das Problem kenne ich so nicht.
    Hast du im Admin-Modus einen neuen User versucht anzulegen oder als root?
    Terminal-Eingabe zu diesem Problem weiß ich nicht.
    Nicht viel, ich weiß.
     
  3. sven-o

    sven-o New Member

    Sorry, habe gestern den Rechner ausschalten müssen, weil meine Frau auch einen Scheißtag hatte.
    Ich habe, nachdem ich mich nicht als User anmelden konnte, als Admin einen neuen User angelegt (ganz Mac-like über Systemeinstellungen). Aber auch der neu angelegte User wird anscheinend nicht vom System gefunden. Das Rädchen dreht sich einen Moment und das Anmeldefenster erscheint wieder.
    Ich hatte gestern noch die Idee ob es vielleicht an dem neuen miniVigor-Treiber liegen könnte. Ich kann ihn ja noch einmal löschen...
    Sonst habe ich eigentlich nichts unanständiges gemacht:-(

    Dank und Gruß

    sven-o
     
  4. hofmeyer

    hofmeyer New Member

    ls -la /Users '
    Das gibt Dir ein Listing Deines Deines Users Verzeichnisses aus. Hier ist interessant, was bei deinem Verzeichnis steht., das sollte so aussehen
    drwxr-xr-x 42 username gruppe 1258 Sep 30 22:56 username

    wobei der erst, dritte und vierte Eintrag wichtig sind. Die geben an, wer welche Rechte in dem Verzeichnis haben. Wenn da irgendwan schiefgelaufen ist, kannst Du Dich nicht mehr einloggen, weil dein Userverzeichnis nicht mehr lesbar ist.
    Poste doch mal, was da bei Dir steht. Dann sehen wir mal weiter...

    Friedhelm
     
  5. sven-o

    sven-o New Member

    Danke für die Tips! Die Volume-Zugriffsrechte habe ich nicht überprüfen lassen. Die Einträge des User-Verzeichnisses habe ich mir auch noch nicht anzeigen lassen. Werde ich gleich mal probieren. Kann aber ein wenig dauern, weil ich keinen Fehler machen möchte. Geht das auch als Admin? Möchte so wenig wie möglich als root unterwegs sein. Bin halt ein Schisser!

    Gruß

    sven-o
     
  6. sven-o

    sven-o New Member

    Habe jetzt die Abfragen durchgeführt:

    [localhost:~] admin% id solaf
    uid=504(solaf) gid=20(staff) groups=20(staff)

    [localhost:~] admin% id sveno
    uid=502(sveno) gid=20(staff) groups=20(staff)
    [localhost:~] admin% ls -la /Users

    drwxr-xr-x 27 solaf staff 874 Oct 1 17:06 solaf
    drwxr-xr-x 12 sveno staff 364 Oct 1 17:19 sveno
    Gibt es denn eine Liste mit den Bedeutungen der Ziffern an vierter Stelle?
     
  7. hofmeyer

    hofmeyer New Member

    pwd' überprüfen kannst.

    Mit exit (oder ctrl-d) loggest Du Dich wieder aus.

    Als letztes würde ich mit dem Netinfomanager überprüfen, ob die Einstellungen für die User alle noch o.k. sind. Das Programm liegt unter den Dienstprogrammen. Da sollten unter users die beiden Benuter (neben einigen anderen wie www, mysql, daemin usw) auftauchen. Einfach einen anwählen und die Eigenschaften unten im Fenster überprüfen.

    Friedhelm
     
  8. Dradts

    Dradts New Member

    Könnte es sein, dass vielleicht die Preferences Datei zum loginwindow defekt ist? Weiss nicht genau, wo die liegt, dürfte sich ja aber leicht finden lassen.
     
  9. sven-o

    sven-o New Member

    Tja, ich wollte die Volume-Zugriffsrechte prüfen, habe aber keine Check-Box o.ä. bei Erste Hilfe gefunden. Kann nur ganz normal das Volume prüfen, dann kommt nur ein "appears to be ok" heraus.
    Der Tip mit dem anmelden im Terminal war gut, aber das will er auch nicht machen:

    Welcome to Darwin!
    [localhost:~] admin% su sveno
    Password:
    su: /bin/tcsh: Permission denied
    [localhost:~] admin% su solaf
    Password:
    su: /bin/tcsh: Permission denied
    [localhost:~] admin% pwd
    /Users/admin

    Mit su zum root switchen klappt, auch wieder zurück zum admin. Nur als Normalo will er mich nicht haben.

    Es scheint als liefe es doch auf eine Neu-Install hinaus. Ich war vorhin bei Gravis, um eine ext. HD zu kaufen. Die sind aber mal wieder zu teuer, und handeln wollten sie auch nicht. Also doch online kaufen...
    So lange ich noch als Admin und root reinkomme sollte ich noch backupen.

    Vielen Dank und Gruß

    sven-o (traurig durch die Gegend schleichend)
     
  10. sven-o

    sven-o New Member

    Ach ja, und im Netinfo-Manager sind die User alle hübsch aufgeführt.

    Was soll ich bloß tun????

    sven-o (jetzt zum Admin aufgestiegen)
     
  11. sven-o

    sven-o New Member

    Das könnte sein, aber wie bekommt man sie wieder hin? Ich trau mich nicht so recht die Prefs wie in Classic zu löschen....
    Das könnte ins Auge gehen.

    Dank und Gruß

    sven-o
     
  12. sven-o

    sven-o New Member

    Ich habe mir vorgestern eine externe Festplatte gekauft (war sowieso nötig) und werde mir dann eine Kopie der User-Daten machen. Danach werde ich dann Dradts Tip ausprobieren und die Prefs vom login löschen. Mal sehen, ob dann der Log-in wieder klappt. Werde auf jeden Fall berichten...

    Vielen herzlichen Dank zunächst für die Tips!

    Sven-O
     
  13. Dradts

    Dradts New Member

    Du kannst die Preferences-Datei ja vorsichtshalber mal nur umbenennen. Falls dann an Deinem Mac gar nichts mehr geht, hast Du wenigstens noch die alte Datei und kannst sie wieder in den Originalnamen umbenennen.
    Aber ich glaube nicht, dass es Probleme gibt, wenn Du die Datei entfernst. Schätzungsweise legt loginwin einfach eine neue Preferences Datei an, und das wars.
     
  14. Tomonage

    Tomonage New Member

    hmm, deine gescheiterten anmelde-versuche in er shell sehen so aus, als dürften die benutzer die shell tcsh nicht ausführen.
    über prüfe mal ihre rechte:

    ls -als /bin | grep "tcsh"

    das müsste in etwa so aussehen:

    624 -r-xr-xr-x 1 root wheel 318716 Aug 3 11:32 tcsh

    wichtig sind hier die drei "x" in der zweiten spalte, sind die nicht da kann man als nicht-root die shell und damit macosx nicht benutzen.
     
  15. sven-o

    sven-o New Member

    Hi Tomonage,

    danke für den Tip!

    Ich habe die 'Rechte als admin überprüft:

    Welcome to Darwin!
    [localhost:~] admin% ls -als /bin | grep "tcsh"
    624 -r-xr-xr-x 1 root wheel 318716 Mar 22 2002 tcsh

    also exakt die Werte, die Du als Beispiel angegeben hast. Aber wie bekomme ich die Rechte für die User heraus? Ich kann mich ja nicht als User anmelden!

    Mit den Volume-Zugriffsrechten hat es wohl nichts zu tun? Die hatte ich weiter oben abgefragt.

    Viel Gruß

    Sven-O
     
  16. Tomonage

    Tomonage New Member

    Hi!

    die rechte scheinen zumindest für tcsh richtig gesetzt, die drei "x" bedeuten eXecute-rechte. das erste für root, den besitzer, das 2 für mitglieder der gruppe whell und das dritte für alle anderen.
    daran kann es also nicht liegen, da alle benutzer die tcsh-shell ausführen dürfen.

    ich forsche hier mal noch ein wenig in den login-scripten nach, solange kannst du ja mal den rechner einmal neu starten und apfel+wahltaste gedrückt halten, bis du gefragt wirst, ob du die schreibtisch datei neu anlegen willst, vielleicht hift das ja.
     
  17. Tomonage

    Tomonage New Member

    Hi!

    ich habe mal noch einen tipp:

    starte mal netinfomanager, das programm liegt im utilitiesverzeichnis.
    dort wechsele auf dem pfad users und auf einen der benutzer, die nicht gehen.
    einer der punkte müsste shell sein, steht da /bin/tcsh?? wenn nciht mal eintragen und probierren mit dem anzumelden.
     
  18. sven-o

    sven-o New Member

    Hi Tomonage!

    Also das mit der Schreibtischdatei funktioniert doch eigentlich nur bei Classic, habs trotzdem probiert, aber in X ohne Erfolg (bei Apfel- + Wahltaste)!
    Habe im Netinfomanager nachgesehen:

    bei allen Usern (auch bei denen ich mich nicht anmelden konnte!) steht unter shell:
    /bin/tcsh

    Kann mich aber trotzdem nicht als Normal-User anmelden.

    Habe auch doch schon den Tip von Dradts ausprobiert (die bestellte Festplatte ist noch nicht abgeschickt worden und ich bin einfach ungeduldig) und die loginwindow.plist-Datei umbenannt. meine Befürchtungen traten nicht ein, der Rechner startet noch, die umbenannte Datei wurde ersetzt, die User konnten sich (außer admin und root) immer noch nicht anmelden.

    Tja, und ich habe noch einmal den PRAM resettet (wollte es nur mal erwähnen)

    Vielen Dank nochmals an alle die mich bis jetzt unterstützt haben.

    Viel Gruß

    Sven-O
     

Diese Seite empfehlen