Garamond-Schrift

Dieses Thema im Forum "Software" wurde erstellt von Robert, 30. Januar 2005.

  1. Robert

    Robert New Member

    Auf einer separaten Partition hatte ich das OS 9.2 installiert. Da nun alle benötigten Programme auf OS X v.10.3.7 laufen, schickte ich das OS 9 komplett ins Nirwana, allerdings nicht bevor ich die Zeichensätze auf einem anderen Disk in Sicherheit brachte. Anschliessend kopierte ich eine Auswahl dieser Schriften in /Library/Fonts. Soweit so gut, alles läuft nun bestens auf dem OS X. Mit einer Ausnahme: die Schrift AGaramond will es nicht mehr tun.

    Es ist mir schon klar: es handelt sich um eine Post-Script Schrift, die unter OS 9 ihren Dienst tat. Gibt es nun eine Möglichkeit, Garamond auch unter OS X wieder zu aktivieren? Für eure Ratschläge danke ich im voraus bestens.

    Gruss, Robert
     
  2. Mäkki

    Mäkki New Member

    Die verhält sich zugegebenerweise etwas komisch:
    in Word ganz normal (AGaramond),
    in Quark heißt sie Adobe Garamond,
    in TextEdit auch, erscheint aber ganz unten auf der Liste.
    In Photoshop heißt sie auch so, erscheint aber unter G.
     
  3. teorema67

    teorema67 New Member

    Die Schrift müsste unter OS X anstandslos arbeiten.
    - Outlines UND Bitmaps müssen vorhanden sein.
    - Prüfe doch mit "Schriftensammlung" (= Font Book) oder einem anderen Tool, ob sie nicht deaktiviert ist.
    - Falls sie aktiv ist, könnte z. B. ein ID-Konflikt für die Fehlfunktion verantwortlich sein. Dann könnte ein Tool wie Font Doctor helfen, den Fehler aufzuspüren.

    Meine alten PostScripts funktionieren in X.

    Gruss!
    Andreas
     
  4. teorema67

    teorema67 New Member

    Die PostScripts speichern verschiedene interne Namen für Schnitt, Font, Font Family und was weiss ich noch. Die Programme lesen diese unterschiedlich aus und ordnen die Schriften daher unterschiedlich.
     
  5. Robert

    Robert New Member

    die Garamond-Schriften heissen bei mir:
    - AGarBol
    - AGarBolIta
    - AGarIta
    - AGarReg

    Alle vier werden beim Markieren im Finder als "PostScript Type 1 outline font" bzeichnet und sind zwischen 52 und 56KB gross. Wie du schreibst, müssen Outline UND Bitmaps vorhanden sein. Ich vermute, das die Bitmap-Dateien fehlen. Wo kann ich diese herbekommen?
     
  6. tYPOmAC

    tYPOmAC New Member

    Hallo Robert,

    Wie verwaltest du deine Fonts?
    Via Finder oder?
    Da die Garamond unter OS 9
    noch funktioniert hat, geh ich
    jetzt einfach mal davon aus,
    daß der Font vollständig ist.

    Ich vermute mal, das der
    Font eine Kodierung hat,
    die mit OS X nicht kompa-
    tibel ist. Deswegen bieten
    viele Fonthersteller Updates
    für ihre Fonts an. Informier
    dich mal bei deinem.

    Ansonsten „kann“ man das
    auch selbst machen. Fontlab
    kann sowas zum Beispiel.

    Wenn du irgendwelche
    Adobe-Programme dein
    Eigen nennst, hast du
    noch die Möglichkeit den
    Font wenigstens in diesen
    Programmen zum Laufen
    bekommen. Und zwar
    diesen:
    ~/Library/Application Support/Adobe/Fonts

    Probier mal noch den Font
    gezippt oder gestufft auf
    deine OS X-Partition zu
    kopieren. Oder ausm Zeichen-
    koffer der Schrift alle Bitmaps
    rauskopieren und dann wieder
    zurück. Das geht allerdings
    nur unter OS 9.


    Gruß
    tYPO
     
  7. teorema67

    teorema67 New Member

    Wenn's unter OS 9 ging, mussten auch dort die Bitmaps vorhanden sein. Wahrscheinlich ein File mit dem Koffer-Icon und dem Namen "Adobe Garamond", das für jeden Schnitt so ein bis fünf einzelne Bitmaps in den Grössen 9,10,12,18,24 oder so enthält. Nur OS 9 kann die Koffer öffnen, OS X nicht, aber das ist unerheblich für die Funktion des Fonts.

    Such' doch noch 'mal nach dem Koffer und ziehe den ganzen Koffer in /Library/Fonts.

    Gruss!
    Andreas
     
  8. swissorion

    swissorion meist auf'm MacSofa

    Hat das etwas damit zu tun, dass die AppleGaramond eigentlich schon auf X installiert ist.

    Wo ?

    Hier.......

    /System/Library/CoreServices/SetupAssistant

    nun control-click auf SetupAssistant.app nd dann
    Paketinhalt anzeigen.
    Contents Ordner öffnen
    danach den Resources Ordner öffnen.

    das Ding der Begierde heisst:
    Setup Assistant.dfont

    Umbenennen auf AppleGaramond.dfont
     
  9. Robert

    Robert New Member

    Besten Dank für euer Tipps, aber ich befürchte, dass ich mit dem OS 9 betr. dem Adobe Fonts-Koffer etwas zuviel gelöscht habe. In den Core Services existiert auch kein SetupAssistant.

    Zum Glück habe ich noch das ganze OS 9.2 auf einer CD und werde dieses noch einmal auf die separate Partition installieren und dann schauen, wie es weiter geht.
     
  10. teorema67

    teorema67 New Member

    Hallo Robert

    Die Garamond müsstest du nachinstalliert haben. M. W. beinhaltet 9.2 keine Garamond.

    Garamonds werden mit vielen Adobe Programmen mitgeliefert. Schau 'mal, ob du sie nicht auf irgendeine PhotoShop, PageMaker, InDesign CD findest.

    Gruss!
    Andreas
     
  11. Robert

    Robert New Member

    @teorema67
    Du hast mich auf die richtige Fährte geführt! Auf einer alten CD mit "Adobe PhotoDeluxe 2.0" waren eine ganz Menge Fonts in einem separaten Ordner inklusive der gesuchten Garamond.

    Da ich vermutete, dass die auf OS X installierten Garamond-Schriften defekt oder unvollständig waren, deinstallierte ich sie aus den Fonts-Ordnern und installierte sie neu ab der CD nur in den Ordner /Library/Fonts. Und siehe da, nach einem Neustart war die Welt wieder in Ordnung!

    Nochmals besten Dank für die Hilfe
    Gruss, Robert
     
  12. teorema67

    teorema67 New Member

    Hallo Robert,

    gut dass es läuft. Aber m. W. beinhalten OS X ebensowenig eine Garamond wie OS 9. Wenn du sie hast, musste sie irgendwie manuell in den OS X gekommen sein.

    Gruss!
    Andreas
     

Diese Seite empfehlen