Hab da mal ne Netzwerkfrage!

Dieses Thema im Forum "Software" wurde erstellt von affenschwanz, 5. Januar 2005.

  1. affenschwanz

    affenschwanz @ffenschwanzerl

    Folgendes: Bei mir hängen im Netz 1 Cube, 1 Powermac 7600 und ein G4 350 Mhz.
    Aufm 7600er läuft 8.5 und 9, aufm Cube und dem G4 läuft X.3.7 (immer up-to-date)
    Ich habe allen ne Client-ID vergeben: 192.168.100.2-4
    Und in den FileSharing Einstellungen hab ich folgende Namen: oldmac, tower, cube
    Aufm Cube und dem G4 kann ich über das Menu mit Server verbinden, ohne Probleme die zwei Computer miteinander verbinden mittels der Adresse cube.local oder tower.local
    wenn ich aber oldmac.local eingebe, kann er keine Verbindung zum 7600er aufbauen (selbst wenn ich die Client-ID des 7600er eingeb, findet er nichts).
    Dann gibts noch die Möglichkeit im X über das Icon Netzwerk verbindungen herzustellen:
    Die Verbindung von Cube und G4 funzt auch dort tadellos.. komisch ist aber, dass der 7600er nur wenn er Lust hat, dort auftaucht. Z.B. machte ich vorhin den Test und beim Cube erschien er im Netzwerk-Ordner aber beim G4 nicht. Vom Cube ging die Verbindung vom G4 nicht.
    So, weiss nicht ob ich noch eine Frage formulieren muss.. aber irgendwie ist das doch komisch? Liegt das an den älteren & verschiedenen Systemen? Oder ist vielleicht mein Netzwerk-Anschluss sogar defekt?
    :crazy:
    Für Tipps & Ratschläge bin ich gerne offen!
    edit: Natürlich ist auf allen 3 Rechnern AppleTalk aktiviert. FileSharing natürlich auch!
    Gruss
     
  2. macbike

    macbike ooer eister

    Habs gerade mal bei mir versucht, wenn ich nur die IP des 9er Macs bei "mit Server verbinden" eingebe, geht es ohne Probleme…
     
  3. affenschwanz

    affenschwanz @ffenschwanzerl

    Hast du die Cleint-Id eingegeben?
    Denn meine IP vom 7600er ist nicht ne Local-IP.. und das will ich nicht! Da gehen dann ja alle daten raus und kommen wieder rein.. puuurer Flaschenhals :nick:
    Gruss
     
  4. macbike

    macbike ooer eister

    Das mit dem Flaschenhals müssteste mir mal erklären, soviel versteh ich davon auch wieder nicht. Ich hab bei mir hier DHCP eingestellt, aber auch vorher mit manueller IP hat alles gut geklappt.
     
  5. affenschwanz

    affenschwanz @ffenschwanzerl

    Ok:
    Hab ein Kabelmodem, das arbeitet als Router. Es vergibt allnen 3 Rechnern eine externe IP bzw. öffentliche IP (z.B. 217.254.x.x) interne IPs beginnen immer mit 192.168.x.x
    Das heisst wenn ich die normale IP eingeb, die mir das Kabelmodem-Router-Teil vergibt, dann geht die Anfrage zuerst ins Web raus.. bis dann gemerkt wird, dass ja der Computer daneben eben diese IP hat.. dann kommts zurück und gibt die Anfrage weiter an den Mac.. d.h. Alle Daten gehen zuerst raus ins Netz und kommen dann wieder rein.. und bei meiner Leitung (2000/400 mbits) ist das im Vergleich zum Netzwerk ein Flaschenhals :nick::nick:
    Verstanden?
    Wenn nicht, benutz mal die Forumsuche mit den Stichworten Flaschenhals Netzwerk Kabelmodem.. sollte eigentlich einiges bei rauskommen..
    Gruss
     
  6. Was hast du denn nun dem 7600er für eine IP gegeben?
    Liegt die in deinem Range, den du oben nanntest?
    Wenn ja trage diese doch mal in deine /etc/hosts Datei der X Rechner ein.
    z.B. so:
    192.168.100.4 oldmac
    Schon solltest du unter -> mit Server verbinden->oldmac ene Verbindung bekommen.

    Grüße
     
  7. macbike

    macbike ooer eister

    Aha, so ist das. Die private IP willste aber nicht, oder wie war das. Ich nehme die 192.168.178.x IP (hab aber auch kein Kabelmodem)
     
  8. affenschwanz

    affenschwanz @ffenschwanzerl

    ok.. das mach ich mal..
    Gruss
     
  9. affenschwanz

    affenschwanz @ffenschwanzerl

    "Verbindung fehlgeschlagen
    Keine Antwort vom File Server. Bitte versuchen sie es noch einmal."

    hat nicht funktioniert.. Hab aber bevor ich das gemacht hab geschaut, ob der im Netzwerk-Ordner angezeigt wird.. und dort war er zu sehen.
    Versteh das nicht! Warum ist das so?
    Gruss
     
  10. SC50

    SC50 New Member

    Das kann auch nicht gehen. Die .local Adressen werden über den Rendevous Dienst aufgelöst. Der kann aber nur Adressen auflösen von Rendevous fähigen Rechnern. Um die "oldmac.local" Adressen auflösen zu können, braucht es einen Eintrag in der Host Tabelle.
    Um von dem OS 9 Rechner aus die Adressen auflösen zu können braucht es auch hier eine Host Tabelle.
    Das Format (unter OS9) sieht wiefolgt aus:
    tower CNAME tower.local
    tower.local A 192.168.100.[?]

    Eine andere Möglichkeit ist, du nutzt Appletalk.

    Ps: Bei OS 8/9 sollte Tcp/IP dauerhaft verfügbar sein, nicht nur "bei Bedarf".

    Pps: Auf dem alten Mac sollte die letzte Version des Appleshare IP Client installiert sein.
     
  11. affenschwanz

    affenschwanz @ffenschwanzerl

    also, hab jetzt mal die ip fürn oldmac in der host datei wie oben beschrieben eingetragen.. aber da funzt trotzdem nichts. Vom Oldmac kann ich via NetzwerkBrowser aufn Cube und den G4 zugreifen.. das ist kein Problem.
    Mein Problem ist, dass im Netzwerk-Ordner nur ab und an der oldmac zu sehen is.. und ich via "Mit Server verbinden" keine Verbindung herstellen kann (selbst dann nicht, wenn die Local-IP 192.168.100.3 in der Host datei eingetragen ist.) Das das über Rendevous nicht klappt, versteh ich.. os 9 hat ja noch kein rendevous.. aber sollte dann nicht wenigstens über die LocalIP ne verbindung hergestellt werden?
    Gruss

    Ps: @SC50 : Was sollte ich deiner Meinung nach tun? Beim X was ändern?
     
  12. SC50

    SC50 New Member

    Kann man den den OS 9 Rechner von den anderen aus "pingen"?
    -> terminal -> ping 192.168.100.3
     
  13. affenschwanz

    affenschwanz @ffenschwanzerl

    Also wenn ich das richtig auslese, dann kann ich nicht pingen:
    PING 192.168.100.3 (192.168.100.3): 56 data bytes
    ping: sendto: No route to host
    ping: wrote 192.168.100.3 64 chars, ret=-1
    ping: sendto: No route to host
    ping: wrote 192.168.100.3 64 chars, ret=-1
    ping: sendto: No route to host
    ping: wrote 192.168.100.3 64 chars, ret=-1

    Gruss
     
  14. affenschwanz

    affenschwanz @ffenschwanzerl

    also pingen kann ich ihn über terminal net.. und lustig is, dass jetzt im Menu "Gehe zu" der Punkt Netzwerk grau erscheint.. aber über den Ordner komm ich noch rein...
    ABER: Es konnte mir bis jetzt noch niemand genau erklären, warum ich die Verbindung zum oldmac nur über den Netzwerk Ordner herstellen kann und nicht über das Menu Mit Server verbinden..
    Klaro, die oldmac.local adresse geht wegen dem Rendevous net.. aber warum geht denn die local ip net?! Ich blick da echt nicht durch;(
    Gruss

    Ps: Anhang: Netzwerk-Menu
     
  15. Stopp ma, stopp ma.
    Oben sasgst du doch das du über ein Kabelmodem externe IP's auf den 3 Rechnern zugewiesen bekommst.
    Wieso pingst du dann private an?
    Vieleicht hab ich ja was überlesen, aber so funzt das net.
    :confused:
    Aber du kannst auch in deinem Router sagen: die Netzwerkmaske 217.sowieso ist ein Class-irgedwas Netzwerk und befindet sich nicht im öffendlichen Netz und muss nicht nach draußen geroutet werden.
    Leider bin ich der falsche, und weiss nicht genau wie man solche Routen setzt und definiert.:crazy:
    Da werden sich aber bestimmt welche hier finden lassen, die dir das beschreiben können. :klimper:
    Vieleicht gehts dann so...
     
  16. SC50

    SC50 New Member

    Uppps,

    wie sind die drei Macs denn verbunden?
    Haben sie alle die gleiche Subnet-Mask (255.255.255.0)?
     
  17. affenschwanz

    affenschwanz @ffenschwanzerl

    Ok. nochmal von vorne: Das Cablemodem und die drei Macs hängen an nem 100er Hub. Um mit dem Modem surfen zu können, muss ich in den Einstellungen TCP/IP "DHCP" auswählen. Das Kabelmodem vergibt dann automatisch an bis zu 4 Rechnern die IP-Adressen sowie Teilnetzmaske & Router Adresse. Da kann ich nichts anderes einstellen.
    Bsp: G4: IP: 217.162.x.x
    Teilnetzmaske 255.255.248.0
    Router 217.162.248.1
    Das Feld DNS-Server und domain-Name bleibt leer. Da ich vor zwei Jahren mit PrinterSharing mal ein Problem hatte (war auch hier im Forum zu finden), empfahl mir ein Apple-Mitarbeiter, den Macs DHCP_Client-IDs zu vergeben (so z.b. aufm G4 192.168.100.4). Das habe ich auch bei allen Macs gemacht. Aber am Kabelmodem selber kann ich nichts einstellen.. das ist Fix so. Hab auf alle Fälle keine Infos zu einstellungen bekommen..

    Was mir jetzt aber gerade auffällt ist, dass des Modem den beinden G4 (also Tower& Cube) die gleiche Teilnetzmaske und Router Adresse zuweisst (wie oben erwähnt..) aber dem oldmac gibt es die Maske 255.255.252.0 und die Router Adresse: 217.162.120.1
    Liegt das daran?
    So viel mir ist, kann man bei den Cablecom Modems nichts einstellen - da kann mich aber jeder Schweizer mit Cablecom Erfahrung gerne berichtigen.
    Gruss
     
  18. macbike

    macbike ooer eister

    Wenn die Macs nicht alles im selben Subnet sind, geht die Kommunikation untereinander natürlich auch nicht…
     
  19. affenschwanz

    affenschwanz @ffenschwanzerl

    Aber es geht ja.. halt nur über den Netzwerk Ordner!

    AHA AHA AHA.. kann es sein, da der oldmac nicht die gleiche Subnetzmaske hat, dass es deshalb nicht über mit Server verbinden mit der Local IP verbindet.. und der Netzwerk-Ordner zeigt mir die AppleTalk verbindujngen an?
    Jetzt komm ich dann bald net mehr draus.
    Gruss
     
  20. SC50

    SC50 New Member

    Ah ja,
    da stimmt doch irgenwas hinten und vorne nicht.
    Eine Subnetmask von 255.255.255.248 bedeutet, daß du 8 Adressen zur verfügung hast. Wenn du sagst, daß du nur vier hast ist die Subnetmask 255.255.255.252 richtig.
    255.255.248.0 würde bedeuten, du hättest acht Subnetze mit je 255 Adressen zur Verfügung.
    :confused:
    Aber wie auch immer, ein OS 9 Rechner kann meines wissens micht multihomed sein, da mußt du dann zwischen der "Internet" Konfiguration mit der DHCP Adresse und der "Intranet" Konfiguration mit der 192.168.100.x Adresse umschalten.

    Wenn du nicht wirklich auf jedem Mac eine echte öffendliche IP brauchst, würde ich vorschlagen hinter das Kabelmodem einen Router zu schalten, der intern das 192.168.100.x Netz verwaltet und sich die externe Adresse per DHCP von Modem holt.
     

Diese Seite empfehlen