@ hakru

Dieses Thema im Forum "Software" wurde erstellt von frankwatch, 2. Februar 2004.

  1. frankwatch

    frankwatch Gast

    hi,

    habe folgendes problem:

    habe einen usb-stick, den ich mac hfs+ formatierte, der war vorher DOS-formatiert, jetzt kann ich das ding nicht mehr mounten, übers terminal müßte es aber doch gehen, ich finde den befehl aber nicht in "man mount",

    mit "sudo diskutil list" zeigt mir das terminal folgendes an:

    password:
    /dev/disk0
    #: type name size identifier
    0: Apple_partition_scheme *11.2 GB disk0
    1: Apple_partition_map 31.5 KB disk0s1
    2: Apple_HFS X 11.2 GB disk0s2
    /dev/disk1
    #: type name size identifier
    0: *247.0 MB disk1
    [xxxxx:~] frank%

    ich bräuchte doch einen namen des volumes, damit ich mit dem befehl:

    sudo mount -t ufs /dev/disk1 /users/frank/volumes/???

    vorgehen kann,

    hilf mal bitte,

    gruß

    ps:
    ich kann erst später heute abend wieder rein schauen, bis dann...
     
  2. Geht das nicht mit mit chmod, dem Stick deine Rechte zuweisen? Aber warte mal lieber auf hakru..
     
  3. gratefulmac

    gratefulmac New Member

    Sach mal Frank,

    warum nimmst Du nicht das gute alte Festplattendienstprogramm.
    wenn der Stick am Rechner hängt muß er diesen doch auch sehen.
    -
    was sagt übrigens der System Profiler ?
    er kennt er den Stick ?
     
  4. frankwatch

    frankwatch Gast

    ja, der profiler erkennt den stick,

    und im festplattendienstprogramm wird er auch gesehen, aber ich kann ihn eben nicht mehr formatieren, auf dem desktop erscheint er sowieso nicht.
     
  5. gratefulmac

    gratefulmac New Member

    wenn das Festplattendienstprogram ihn sieht, klick ihn an und gehe oben in der Menüleiste auf aktivieren.
    Dann sollte das Teil wieder auf dem Desktop sichtbar sein.
     
  6. frankwatch

    frankwatch Gast

    "aktivieren" ist grau unterlegt beim anklicken des volumes, da geht nix...
     
  7. hakru

    hakru New Member

    @frankwatch

    ... ich habe mich bislang nicht mit "mounten" via Terminal befasst - bin daher leider nicht die schnelle Hilfe, die Du erhofft hast.

    ich schau' aber mal, ob ich was rausfinden kann ...

    ah ... ja ... hier:

    http://www.macosxhints.com/article.php?story=20031012160404475&query=mount+terminal

    ... der "mount-Point" wird offenbar zuerst über einen "mkdir"-Befehl erzeugt ... damit hast Du dann Deinen gewünschten Namen ...


    hakru
     
  8. frankwatch

    frankwatch Gast

    tja, scheint einfach zu sein, die zwei zeilen und auch logisch, aber nichts passiert, wenn ich es übers terminal eingebe...

    einer noch ne idee ?
     
  9. hakru

    hakru New Member

    wie hast Du denn den USB stick auf hfs+ umformatiert??

    hakru
     
  10. frankwatch

    frankwatch Gast

    *und hoch*

    mensch leute,

    der stick wird im fpdp doch angezeigt, der muß doch im finder irgendwie sichtbar werden,

    egal, ob mit terminal oder einem prog, welche progs gibts denn, um platten zu mounten ?
     
  11. hakru

    hakru New Member

    sorry, bin etwas stur:
    wie hast Du den stick auf hfs+ formatiert ...?

    hakru
     
  12. frankwatch

    frankwatch Gast

    mit dem fpdp -> volume ausgewählt -> jo, und dann als hfs+ partitioniert (weiß der teufel, warum ich das gemacht habe),

    unter apfel-i war das volume vorher "msdos",

    ;(
     
  13. hakru

    hakru New Member

    hab' mir eben nochmal den mount-Befehl in Deinem ersten posting angeschaut:

    sudo mount -t ufs /dev/disk1 /users/frank/volumes/???

    Warum gibst Du "-t ufs" an, wenn Du doch "hfs" formatiert hast??

    Schreib' doch mal bitte EXAKT, welche Terminal-Befehle Du bislang zum "mounten" versucht hast ...

    hakru
     
  14. frankwatch

    frankwatch Gast

    Last login: Tue Feb 3 19:43:32 on ttyp1
    Welcome to Darwin!
    [xxxxx:~] frank% sudo mount -t ufs /dev/disk1 /Volumes/broken
    Password:
    /dev/disk1 on /Volumes/broken: No such file or directory
    [xxxxx:~] frank%

    UND

    [xxxxx:~] frank% sudo mount -t hfs /dev/disk1 /Volumes/broken
    mount_hfs: No such file or directory
    [xxxxx:~] frank%
     
  15. frankwatch

    frankwatch Gast

    nachtrag:

    "-t ufs" ist der befehl zum mounten von externen geräten, laut "man mount".
     
  16. hakru

    hakru New Member

    "-t ufs" soll bei type ufs verwendet werden, Du hast aber doch "hfs" - also versuch mal

    sudo mount -t hfs /dev/disk... /MountpointDir...

    hakru
     
  17. frankwatch

    frankwatch Gast

    habe eben mal von der diskwarrior-cd gestartet, hat auch nichts gebracht,

    was meinst du genau mit ... /MountpointDir ?
     
  18. frankwatch

    frankwatch Gast

    Last login: Tue Feb 3 21:45:03 on console
    Welcome to Darwin!
    [xxxxx:~] frank% sudo mount -t hfs /dev/disk1 /Volumes/K-Won KMC Player Media
    Password:
    usage: mount [-dfruvw] [-o options] [-t ufs | external_type] special node
    mount [-adfruvw] [-t ufs | external_type]
    mount [-dfruvw] special | node

    ich muß "mount" anders verwenden, nur wie ?
     
  19. frankwatch

    frankwatch Gast

    [xxxxx:~] frank% sudo mount /dev/disk1 /users/frank/Volumes
    /dev/disk1 on /users/frank/Volumes: Input/output error
    [xxxxx:~] frank%

    "/dev/disk1 on" --> der stick ist doch da, das zeigt "on" an, aber eben NICHT sichtbar...

    das volume, welches im festplattendienstprogramm gezeigt wird, an welches ich aber nicht rankomme, heißt "K-Won KMC Player Media" !
     
  20. Probier dochmal die Mount-Optionen

    frank% sudo mount -t hfs /dev/disk1 /Volumes/K-Won KMC Player Media mount -t ufs

    Oder nach der Passworteingabe

    mount -t ufs

    Schau doch bitte mal auf die macoshints-Seite, wie man einem Volume Rechte zuspricht.

    Irgendwie muß das schon funktionieren. Das Volume ist ja sichtbar. (ich vermute, daß du für dieses Volume einfach keine Rechte hast)
     

Diese Seite empfehlen