HFS+ Private Data

Dieses Thema im Forum "Software" wurde erstellt von Nusagschon, 7. November 2003.

  1. Nusagschon

    Nusagschon New Member

    Hallo,

    die Datei lässt sich weder über das Terminal löschen, noch mit BatCHmod entsperren. Ich kann die Datei auch nicht aus dem Papierkorb ziehen.

    Natürlich habe ich vorher die Suche bemüht und mich mit den Lösungsvorschlägen abgemüht. Möglich, dass ich was übersehen habe. Kann mir jemand helfen?

    Volker
     
  2. mymy 13

    mymy 13 New Member

    Es gibt da einen Thread, in den du dich mal einlesen müßtest:
    http://forum.macwelt.de/forum/showthread.php?s=&threadid=74403&highlight=hfs

    Das kannst du nur im single user modus + Terminal beheben. Kompliziert, wirst sehen wenn du's liest.

    Unter meinem Namen kannst du auch mal suchen,
    hatte das gleiche Problem, mit fast der gleichen Lösung. Mikrokokkus hat's fast um den Verstand gebracht, mich da durch zu führen. Das habe ich mir damals kopiert:

    >Das "system immutable flag" kann nur im Single-User-Mode entfernt werden.

    Achtung, wichtig!!!
    Dieser Modus läuft mit amerikanischer Tastaturbelegung.
    Das Minus "-" liegt auf dem "ß" (scharfes s).
    Der Schrägstrich "/" liegt auf dem Minus "-"
    "z" und "y" sind vertauscht.
    Leerzeichen sind SUPERWICHTIG. Damit Du sie erkennst, schreibe ich einen Unter_strich! DU musst statt Unterstrich natürlich einen Leerschlag setzen!

    Und jetzt los:
    Starte Deinen Mac im Single-User-Mode neu: Nach dem Startton Apfel+S gedrückt halten, bis Schrift auf schwarzem Grund erscheint.

    Wenn nix mehr passiert und der Prompt erscheint (sh-2.05a#), dann tipp:
    whoami
    Wenn jetzt nicht root erscheint, dann schreib su .

    Schreib
    fsck_-y
    Mach das solange immer wieder bis (sinngemäß) die folgende Meldung kommt:
    The Volume (...) appears to be ok.

    Schreib
    mount_-uw_/

    Wechsle in Dein Homeverzeichnis:
    cd_/Users/michaelstave
    Zur Kontrolle schreib:
    ls_-l (l nicht i)
    Jetzt erscheint eine Liste (fast) aller Ordner und Dateien in diesem Verzeichnis.
    Schrott sollte dabei sein.

    Schreib jetzt:
    chflags_-R_noschg_Schrott
    So, das system immutable flag ist Geschichte.

    Wechsle in den Multi-User-Mode zurück, indem Du
    ctrl+d drückst.

    Melde Dich an und starte das Terminal. Schreib (deutsche Tastaturbelegung!):
    sudo_rm_-r_/Users/michaelstave/Schrott
    Admin-Passwort-Eingabe und gut! <


    Schrott hieß der zu löschende Ordner und bei fsck -y muß bei Panther fsck -f stehen.

    Viel Glück,

    Gruß

    Michael
     
  3. Nusagschon

    Nusagschon New Member

    Hallo,

    die Datei lässt sich weder über das Terminal löschen, noch mit BatCHmod entsperren. Ich kann die Datei auch nicht aus dem Papierkorb ziehen.

    Natürlich habe ich vorher die Suche bemüht und mich mit den Lösungsvorschlägen abgemüht. Möglich, dass ich was übersehen habe. Kann mir jemand helfen?

    Volker
     
  4. mymy 13

    mymy 13 New Member

    Es gibt da einen Thread, in den du dich mal einlesen müßtest:
    http://forum.macwelt.de/forum/showthread.php?s=&threadid=74403&highlight=hfs

    Das kannst du nur im single user modus + Terminal beheben. Kompliziert, wirst sehen wenn du's liest.

    Unter meinem Namen kannst du auch mal suchen,
    hatte das gleiche Problem, mit fast der gleichen Lösung. Mikrokokkus hat's fast um den Verstand gebracht, mich da durch zu führen. Das habe ich mir damals kopiert:

    >Das "system immutable flag" kann nur im Single-User-Mode entfernt werden.

    Achtung, wichtig!!!
    Dieser Modus läuft mit amerikanischer Tastaturbelegung.
    Das Minus "-" liegt auf dem "ß" (scharfes s).
    Der Schrägstrich "/" liegt auf dem Minus "-"
    "z" und "y" sind vertauscht.
    Leerzeichen sind SUPERWICHTIG. Damit Du sie erkennst, schreibe ich einen Unter_strich! DU musst statt Unterstrich natürlich einen Leerschlag setzen!

    Und jetzt los:
    Starte Deinen Mac im Single-User-Mode neu: Nach dem Startton Apfel+S gedrückt halten, bis Schrift auf schwarzem Grund erscheint.

    Wenn nix mehr passiert und der Prompt erscheint (sh-2.05a#), dann tipp:
    whoami
    Wenn jetzt nicht root erscheint, dann schreib su .

    Schreib
    fsck_-y
    Mach das solange immer wieder bis (sinngemäß) die folgende Meldung kommt:
    The Volume (...) appears to be ok.

    Schreib
    mount_-uw_/

    Wechsle in Dein Homeverzeichnis:
    cd_/Users/michaelstave
    Zur Kontrolle schreib:
    ls_-l (l nicht i)
    Jetzt erscheint eine Liste (fast) aller Ordner und Dateien in diesem Verzeichnis.
    Schrott sollte dabei sein.

    Schreib jetzt:
    chflags_-R_noschg_Schrott
    So, das system immutable flag ist Geschichte.

    Wechsle in den Multi-User-Mode zurück, indem Du
    ctrl+d drückst.

    Melde Dich an und starte das Terminal. Schreib (deutsche Tastaturbelegung!):
    sudo_rm_-r_/Users/michaelstave/Schrott
    Admin-Passwort-Eingabe und gut! <


    Schrott hieß der zu löschende Ordner und bei fsck -y muß bei Panther fsck -f stehen.

    Viel Glück,

    Gruß

    Michael
     
  5. Nusagschon

    Nusagschon New Member

    Hallo,

    die Datei lässt sich weder über das Terminal löschen, noch mit BatCHmod entsperren. Ich kann die Datei auch nicht aus dem Papierkorb ziehen.

    Natürlich habe ich vorher die Suche bemüht und mich mit den Lösungsvorschlägen abgemüht. Möglich, dass ich was übersehen habe. Kann mir jemand helfen?

    Volker
     
  6. mymy 13

    mymy 13 New Member

    Es gibt da einen Thread, in den du dich mal einlesen müßtest:
    http://forum.macwelt.de/forum/showthread.php?s=&threadid=74403&highlight=hfs

    Das kannst du nur im single user modus + Terminal beheben. Kompliziert, wirst sehen wenn du's liest.

    Unter meinem Namen kannst du auch mal suchen,
    hatte das gleiche Problem, mit fast der gleichen Lösung. Mikrokokkus hat's fast um den Verstand gebracht, mich da durch zu führen. Das habe ich mir damals kopiert:

    >Das "system immutable flag" kann nur im Single-User-Mode entfernt werden.

    Achtung, wichtig!!!
    Dieser Modus läuft mit amerikanischer Tastaturbelegung.
    Das Minus "-" liegt auf dem "ß" (scharfes s).
    Der Schrägstrich "/" liegt auf dem Minus "-"
    "z" und "y" sind vertauscht.
    Leerzeichen sind SUPERWICHTIG. Damit Du sie erkennst, schreibe ich einen Unter_strich! DU musst statt Unterstrich natürlich einen Leerschlag setzen!

    Und jetzt los:
    Starte Deinen Mac im Single-User-Mode neu: Nach dem Startton Apfel+S gedrückt halten, bis Schrift auf schwarzem Grund erscheint.

    Wenn nix mehr passiert und der Prompt erscheint (sh-2.05a#), dann tipp:
    whoami
    Wenn jetzt nicht root erscheint, dann schreib su .

    Schreib
    fsck_-y
    Mach das solange immer wieder bis (sinngemäß) die folgende Meldung kommt:
    The Volume (...) appears to be ok.

    Schreib
    mount_-uw_/

    Wechsle in Dein Homeverzeichnis:
    cd_/Users/michaelstave
    Zur Kontrolle schreib:
    ls_-l (l nicht i)
    Jetzt erscheint eine Liste (fast) aller Ordner und Dateien in diesem Verzeichnis.
    Schrott sollte dabei sein.

    Schreib jetzt:
    chflags_-R_noschg_Schrott
    So, das system immutable flag ist Geschichte.

    Wechsle in den Multi-User-Mode zurück, indem Du
    ctrl+d drückst.

    Melde Dich an und starte das Terminal. Schreib (deutsche Tastaturbelegung!):
    sudo_rm_-r_/Users/michaelstave/Schrott
    Admin-Passwort-Eingabe und gut! <


    Schrott hieß der zu löschende Ordner und bei fsck -y muß bei Panther fsck -f stehen.

    Viel Glück,

    Gruß

    Michael
     
  7. Nusagschon

    Nusagschon New Member

    Hallo,

    die Datei lässt sich weder über das Terminal löschen, noch mit BatCHmod entsperren. Ich kann die Datei auch nicht aus dem Papierkorb ziehen.

    Natürlich habe ich vorher die Suche bemüht und mich mit den Lösungsvorschlägen abgemüht. Möglich, dass ich was übersehen habe. Kann mir jemand helfen?

    Volker
     
  8. mymy 13

    mymy 13 New Member

    Es gibt da einen Thread, in den du dich mal einlesen müßtest:
    http://forum.macwelt.de/forum/showthread.php?s=&threadid=74403&highlight=hfs

    Das kannst du nur im single user modus + Terminal beheben. Kompliziert, wirst sehen wenn du's liest.

    Unter meinem Namen kannst du auch mal suchen,
    hatte das gleiche Problem, mit fast der gleichen Lösung. Mikrokokkus hat's fast um den Verstand gebracht, mich da durch zu führen. Das habe ich mir damals kopiert:

    >Das "system immutable flag" kann nur im Single-User-Mode entfernt werden.

    Achtung, wichtig!!!
    Dieser Modus läuft mit amerikanischer Tastaturbelegung.
    Das Minus "-" liegt auf dem "ß" (scharfes s).
    Der Schrägstrich "/" liegt auf dem Minus "-"
    "z" und "y" sind vertauscht.
    Leerzeichen sind SUPERWICHTIG. Damit Du sie erkennst, schreibe ich einen Unter_strich! DU musst statt Unterstrich natürlich einen Leerschlag setzen!

    Und jetzt los:
    Starte Deinen Mac im Single-User-Mode neu: Nach dem Startton Apfel+S gedrückt halten, bis Schrift auf schwarzem Grund erscheint.

    Wenn nix mehr passiert und der Prompt erscheint (sh-2.05a#), dann tipp:
    whoami
    Wenn jetzt nicht root erscheint, dann schreib su .

    Schreib
    fsck_-y
    Mach das solange immer wieder bis (sinngemäß) die folgende Meldung kommt:
    The Volume (...) appears to be ok.

    Schreib
    mount_-uw_/

    Wechsle in Dein Homeverzeichnis:
    cd_/Users/michaelstave
    Zur Kontrolle schreib:
    ls_-l (l nicht i)
    Jetzt erscheint eine Liste (fast) aller Ordner und Dateien in diesem Verzeichnis.
    Schrott sollte dabei sein.

    Schreib jetzt:
    chflags_-R_noschg_Schrott
    So, das system immutable flag ist Geschichte.

    Wechsle in den Multi-User-Mode zurück, indem Du
    ctrl+d drückst.

    Melde Dich an und starte das Terminal. Schreib (deutsche Tastaturbelegung!):
    sudo_rm_-r_/Users/michaelstave/Schrott
    Admin-Passwort-Eingabe und gut! <


    Schrott hieß der zu löschende Ordner und bei fsck -y muß bei Panther fsck -f stehen.

    Viel Glück,

    Gruß

    Michael
     

Diese Seite empfehlen