Hilfe !!!!!

Dieses Thema im Forum "Software" wurde erstellt von Tweety, 5. April 2004.

  1. Tweety

    Tweety New Member

    Hallo zusammen,

    ich habe seit etwa einer Stunde ein kleines/ eigentlich sehr großes Problem, und zwar abe ich meinen Bildschirmschoner mit einem Passwort geschützt,
    jetzt kam nach der Passworteingabeaufforderung nur leider ein schwarzer Bildschirm mit folgendem Inhgalt:

    Darwin/BSD (Benutzername.local) (console)
    Login:

    Wenn ich mich jetzt nun Anmelde ( Benutzernamen und Passwort) kommt folgende Meldung,

    Welcome to Darwin!
    Last login...
    Benutzername: benutzername$

    Weis nun jemand, wie ich wieder zu meinem normalen Desktop komme ?
    Danke im Voraus
    Mathias
     
  2. dotcom

    dotcom New Member

    exit eingeben
     
  3. Tweety

    Tweety New Member

    Danke für die Schnelle Antwort, nur wenn ich
    exit

    eingebe erscheint wieder der schwarze Bildschirm mit der Loginaufforderung...
    Auch ein Neustart bringt nichts...

    Mathias
     
  4. gratefulmac

    gratefulmac New Member

    Der Neustart mit gedrückter -alt Taste bringt auch nix ?
     
  5. vf47

    vf47 New Member

    Willkommen in der Welt des Terminals :D

    Bei einem anderen Unix-basierten System würde ich sagen, dass Dein System jetzt so konfiguriert ist, dass es im nichtgrafischen Modus hochfährt. (Unter Linux ist das Runlevel 3) Du bekommst dann einen alphanumerischen Login und die ganze Welt der Kommandozeile steht zu Deiner Verfügung. Du könntest jetzt viel Geld sparen und Deinen grafischen Bildschirm mitsamt der Grafikkarte gegen ein seriell angeschlossenes VT-100 Terminal austauschen.

    Aber Spass beiseite. Ich schaue mal nach, ob es eine Möglichkeit gibt, OS X ohne Aqua zu starten und wenn ja, wie man das wieder rückgängig macht.

    Ich melde mich später noch mal.

    Nicht verzagen.
     
  6. Tweety

    Tweety New Member

    Leider hat es auch mit einem Neustart und gedrückter -alt Taste nicht geklappt...
     
  7. vf47

    vf47 New Member

    Schau mal hier:

    http://hacks.oreilly.com/pub/h/348

    Überprüfe doch mal die Datei /etc/ttys auf den dort gemachten Eintrag. Wenn dort die Zeile
    console "/usr/libexec/getty std.9600" vt100 on secure
    nicht auskommentiert ist, dann erklärt das Dein Problem.

    In diesem File sollte sich eine Zeile wie folgt befinden:
    console "/System/Library/CoreServices/loginwindow.app/Contents/MacOS/loginwindow"

    Was war das eigentlich für ein Screensaver? Irgendwas exotisches oder ein unter OS X mitgelieferter?
     
  8. Tweety

    Tweety New Member

    Danke für die Antwort, es war übrigens der Beachscreensaver, der bei macos dabei ist.
    Auch wenn ich mich jetzt als Computernull oute, wie überprüfe ich die Datei /etc/ttys ?

    Danke im voraus
    Mathias
     
  9. vf47

    vf47 New Member

    Logge Dich bei der alphanumerischen Loginaufforderung ein.

    Gehe mit
    cd /etc
    in das Verzeichnis /etc und tippe dann z. B. folgendes ein:
    more ttys

    Dann müsste eine Bildschirmseite der Datei gezeigt werden. Mit der Taste q brichst Du wieder ab, mit der Leertaste bekommst Du die nächste Bildschirmseite zu sehen.

    Bei mir steht übrigens folgendes gleich auf der ersten Seite in der ttys folgendes drin:

    #console "/usr/libexec/getty std.57600" vt100 on secure[Neue Zeile]
    console "/System/Library/CoreServices/loginwindow.app/Contents/MacOS/loginwindow" vt100 on secure onoption="/usr/libexec/getty std.9600"[Neue Zeile]

    Das [Neue Zeile] stammt von mir, damit der Zeilenumbruch klar ist.
     
  10. swissorion

    swissorion meist auf'm MacSofa

    tippe mal reboot ein und bestätige die eingabe mit dem Zeilenschalter
     
  11. Tweety

    Tweety New Member

    also bei mir erscheint folgendes:

    #console "/usr/libexec/getty std.57600" vt 100 on secure

    console "/System/Library/CoreServices/loginwindow.app/Contents/MacOS/loginwindow" vt100 on secure onoption="/usr/libexec/getty std.9600"

    #tathoe`s only
    #remote "/usr/libexec/getty std.1200" pt on # diagnostcs

    dann folgt ein Text

    und dann

    # Hardwired lines are marked off, by default, so getty(8)
    # System Preferences panel to enable it.
    fax "/usr/bin/fax answer" unknown off

    # Hardwired lines are marked off, by default, so getty (8)
    # is quite when they don`t existt.

    tty00 "/usr/libexec/getty std. 9600" unknown off secure
    tty01 "/usr/libexec/getty std. 9600" unknown off secure
    tty02 "/usr/libexec/getty std. 9600" unknown off secure
    .... bis
    tty07 "/usr/libexec/getty std. 9600" unknown off secure

    ttyp0 none network
    .... bis
    ttyqf none network
     
  12. Tweety

    Tweety New Member

    ich weiß nicht ob das hilft, aber wenn ich folgendes eingebe:

    /System/Library/CoreServices/loginwindow.app/Contents/MacOS/loginwindow

    wird der bildschirm wieder blau, aber es passiert nichts mehr weiter.

    Mathias
     
  13. Tweety

    Tweety New Member

    juhuuuuuuu, der ma startet wieder "normal"!!!!!!!!!!!!!!!!!!!!!

    vor der komandozeile:

    console "/System/Library/CoreServices/loginwindow.app/Contents/MacOS/loginwindow" vt100 on secure onoption="/usr/libexec/getty std.9600"

    hatte sich ein # zeichen "eingeschlichen".

    nach dem entfernen startet der mac jetzt wieder normal "freu".....

    danke nochmal für die hielfe, besonders für den url link.

    nochmals danke
    mathias
     
  14. vf47

    vf47 New Member

    Gerngeschehen.

    Aber wie ist das Kommentarzeichen dahin gekommen?
     

Diese Seite empfehlen