IE unter MacOS versaut mein Webdesign

Dieses Thema im Forum "Software" wurde erstellt von randj, 10. August 2001.

  1. randj

    randj New Member

    Hallo Webdesigners !

    Habe www.aroval.net kreiert und muss feststellen, dass Internet Explorer mir einen Strich durch die Rechnung, äh Site macht...
    Die Site besteht aus einem Frameset, welches wiederum 2 Framesets zusammenfasst.
    (beide "under-framesets" umfassen zwei frames - wobei dies eigenlich keine rolle spielt.)
    Zwischen den Framesets macht mir IE einen weissen Strich und man kann sogar die Navigation "Top" hinunterziehen !!! Kennt jemand dieses Problem - besser noch die Lösung ???
    Mit Netscape ist alles OK, Opera auch (abgesehen von js und css). Unter Windows hat IE kein Problem (ist ja zu hoffen... - "vergisst" Bill jeweils ein paar bugs in den MacOS-Versionen seiner Soft zu entfernen?). Auch unter Linux klappt es mit konquerer, netscape, staroffice...

    schon mal besten Dank für Tips und Tricks

    (Ratschläge wie "nicht mit Framesets arbeiten" und so erspart Euch bitte, habe diesbezüglich bereits genug diskutiert.)

    have a lot of fun
    randj
     
  2. Soundbwoy

    Soundbwoy New Member

    kein problem, du hast innerhab des frameset-tgas zwei kleinigkeiten vergessen. und zwar:

    <html>
    <head>
    <title>- = AROVAL = - </title>
    <meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1">
    </head>
    <frameset rows="125,*" border="0" framespacing="0" frameborder="NO">
    <frame src="UntitledFrame-1.htm" scrolling="NO" frameborder="NO" name="nav" noresize>
    <frame src="UntitledFrame-2.htm" name="con" frameborder="NO" noresize>
    </frameset>
    <noframes>
    <body bgcolor="#FFFFFF" text="#000000">
    </body>
    </noframes>
    </html>
    ----------------------------------------------------------------------------------------------------
    frameborder="NO" gehört nicht nur in die framedefinitionen sondern auch in die des framesets. --> somit ist der weisse balken weg!

    noresize gehört in die definitionen der frames. somit kann der user die grösse nicht verändern.

    das hat mit bugs nichts zu tun, sondern mit einer gewissenhaften interpretation von html ;-)

    ps. schöne site

    grüße soundbwoy
     
  3. goldfinger

    goldfinger New Member

    Mit Frames wirst Du immer Ärger haben.
    Du hast es vollkommen richtig gemacht und ein paar Pixel Luft gelassen.
    Es hat nichts mit Bugs zu tun, sondern mit verschiedenen Auflösungen der Browser. Am besten ist es mit einer geraden Pixelzahl zu arbeiten. Da kommst du immer am besten hin.
    Das Problem hat ja mein Vorgänger schon gelöst.
     
  4. fungerer

    fungerer New Member

    Nur mal so nebenbei: Ich hasse alle Browser... wenn sich die Hersteller doch nur mal auf einen wirklichen Standart bei der Interpretation des Quelltextes einigen könnten...

    Diese Browser Geschichte hat mich schon zahlreiche schlaflose Nächte gekostet :-(

    Gruß, ein Leidensgenosse *g*
     
  5. randj

    randj New Member

    herzlichen dank für Eure Hilfe !

    @fungerer
    nett, dass du mitleid hast. bring zwar nichts und wenn du alle browsers hasst, so solltest du den job wechseln ;-)
    Wie du siehtst habe ich auch etliche probleme mit den diversen browsers & plattformen, aber es gibt lösungen - und leute, die weiterhelfen. ich tus auch im rahmen wo ich "kompetent" bin. für das haben wir die foren.

    bezüglich standard wäre es natürlich cool - da geb ich dir absolut recht - , wenn das W3C da etwas gescheites durchsetzen könnte. aber NS6, welcher diesen richtlinen folgt, beschert uns noch zusàtliche probleme...

    have à lot of fun
    jrandi
     

Diese Seite empfehlen