Im Ruhezustand schaltet das MBP komplett aus

Dieses Thema im Forum "Hardware" wurde erstellt von Michel_38, 12. August 2012.

  1. Michel_38

    Michel_38 New Member

    Hallo Mac Gemeinde,

    hab im Netz leider nicht wirklich was gefunden, deshalb stelle ich meine Frage hier:

    Das MBP meiner Frau (13", 2.4 GHz, Intel Core 2 Duo, Mid 2010, 4GB Speicher) schaltet sich beim aktivieren des
    Ruhezustandes nach ca. 2 Sekunden komplett aus.

    Egal ob ob ich das Display zuklappe, den Ruhezustand Button im Apfel betätige oder den des Ein/Ausschaltknopfes.
    War schon bei 10.7 und hat sich auch in 10.8 leider nichts geändert.

    Pram usw. habe ich schon ohne Erfolg zurückgesetzt :-(

    Für Antworten im voraus vielen Dank.
     
  2. MACaerer

    MACaerer Active Member

    Gehe doch mal ins Terminal (Dienstprogramme) und gib folgenden Befehl ein:
    Code:
    pmset -g | grep hibernatemode
    Angezeigt wir vermutlich ein Wert zwischen 0 und 3.
    "0" ist der Modus mit dem "normalen" Modus
    "1" ist der Tiefschlafmodus, dabei wird der RAM-Inhalt in das Sleep-Image geschrieben und der Mac dann abgeschaltet.
    "3" ist eine Mischung aus 0 und 1
    Ich vermute, dass bei deinem Book der Tiefschlafmodus eingestellt ist. Ändern geht auch mit einem Terminalbefehl oder mit dem DeepSleep-Widget

    MACaerer
     
  3. Michel_38

    Michel_38 New Member

    Hi, entschuldige bitte die späte Antwort.
    hybernatemode ist auf 3.
    Was mich stutzig macht ist, das sleep und display sleep auf 12 steht, bei meinem MBP ist es 0 :-(
     

    Anhänge:

  4. MACaerer

    MACaerer Active Member

    Das passt schon. disksleep 10 und displaysleep 12 sind die Minuten, nach denen die HDD und das Display in Ruhezustand geht. Ersters ist voreingestellt und lässt sich nur über einen Terminalbefehl ändern, letzteres auch über die Systemeinstellung "Energiesparen".
    Andererseits dürfte sich das Book im eingestellten hibernatemode 3 im Ruhezustand nicht ausschalten. Ich kann mir das nicht gut erklären. Mein Empfehlung: Gehe doch mal testweise in den Modus in "0" und schaue was dann passiert. Der Befehl dazu lautet:
    Code:
    sudo pmset -a hibernatemode 0
    Hierzu musst du als Admin angemeldet sein und nach der Eingabe des Befehls musst du das Admin-Passwort (blind) eingeben. Der Modus "3" ist bei einem Book allerdings der Standard-Modus. Macht auch Sinn um bei total leerer Batterie keine Daten zu verlieren.

    MACaerer
     
  5. Michel_38

    Michel_38 New Member

    Hi, im 0 Modus dasselbe Spiel. Angefangen hat das ganze, dass sich das MBP nicht mehr einschalten lies. Nach zig Versuchen ist es dann doch gestartet. Dann hatte es den Akku nicht mehr gefunden und funktionierte nur
    noch über das Netzkabel. Ein ab- und anstecken des Akkus brachte wenigstens einen Teilerfolg und das
    MBP konnte auch ohne Kabel wieder arbeiten. Aber seitdem das merkwürdige Verhalten des Ruhezustandes.
     
  6. Michel_38

    Michel_38 New Member

    Ach ja noch was. Beim einschalten startet das MBP zweimal.
    Erst kommt kurz der Bildschirm, ca. 2 Sekunden wieder Neustart, dann fährt es erst komplett hoch :confused:
     
  7. MacS

    MacS Active Member

    Aha, dann solltest du dir mal die Support-Seiten von Apple in Sachen SMC anschauen. Dieser Controller (früher hieß der mal PMU oder SMU) ist für die Steuerung des Ein- und Ausschaltens, Ruhezustands und bei mobilen Rechnern auch für das richtige Laden zuständig. Setzt mal den SMC zurück. Und, kalibriere den Akku neu, damit dieser korrekt geladen werden kann. Der Ladestrom und die Art, wie geladen wird, hängt immer vom aktuellen Ladezustand ab und ist beim Li-Akku recht aufwendig. Wenn die im SMC hinterlegte Akkukapazität, passt der Ladestrom nicht zum Zustand des Akkus. Damit wird die Lebensdauer veringert und die Anzeige der Restlaufzeit stimmt nicht wirklich.
     
  8. MACaerer

    MACaerer Active Member

    Damit ist klar, dass das Problem mit dem Ruhezustand, bzw. dessen Einstellungen nichts zu zu hat. Die Möglichkeiten der eigenen Problembehebung sind damit schnell erschöpft. Was du vor dem Gang zum Service noch machen kannst ist das Löschen des NVRAM, in dem diverse System-Einstellungen gespeichert sind, sowie Rücksetzen des Systemmanagement-Controllers (SMC). Wie das geht ist bei jedem Mac anders, daher weiß ich es nicht auswendig. Die findest die Anleitungen auf Apple-Supportseiten unter "SMC zurücksetzen".

    Edit:
    Oops, da hinke ich ein bisschen hinterher. Aber besser doppelt als gar nicht


    MACaerer
     
  9. Michel_38

    Michel_38 New Member

    SMC zurückgesetzt nach Apple Anleitung brachte auch kein Erfolg. Vielleicht ist ja nur der Akku hin und verursacht den Mist :confused:
     
  10. MACaerer

    MACaerer Active Member

    Möglich, aber nicht sehr wahrscheinlich, die Symptome wären dann vermutlich anders. Aber das lässt sich einfach ausprobieren, in dem du das Netzteil dranhängst und dann in den Ruhezustand gehst.

    MACaerer
     
  11. Michel_38

    Michel_38 New Member

    Das gleiche Spiel, keine Veränderung.
    Vielleicht bau ich mal den Akku raus und probiere nur mal mit Netzteil.
     

Diese Seite empfehlen