ImageMagick 4.2.9

Dieses Thema im Forum "Software" wurde erstellt von misfit, 3. Juni 2004.

  1. misfit

    misfit New Member

    Hallo Leute,

    hat schonmal jemand von euch die ImageMagick version 4.2.9 auf os x (10.3) installiert? das ist die empfohlene version für typo3. ich habe es mit einer neueren version von entrophy versucht aber das funktioniert nur bedingt. der GIFBuilder funzt nicht mit der neuen version. ein lizenzrechtliches problem. deshalb wird bei typo3 immer 4.2.9 eingesetzt. aber wo bekomme ich die für os x her? und wie wird installiert wenn es keinen installer gibt?
     
  2. RaMa

    RaMa New Member

  3. Achmed

    Achmed New Member

    Die 4.2.9 wird unter osx nicht laufen.
    Nicht mal mit Fink.
    Ich hab einige Zeit verbracht die unter osx zum laufen zu bringen. (Du kannst mir ein aber ein Monatsgehalt sponsoren dann knette ich die Sourcen für osx um).
    Aber typo3 macht unter (zumindest unter meinem g3)
    kein Sinn da die hardware zu lahm ist.

    Die 5er Version von Entropy kannst du nehmen.
    Du mußt halt in der localconf.php die ganzen anpassungen für die 5er machen bzw. im Setup.

    Eine php mit einer gdlib1.8 hab ich hinbekommen. Das reicht immo für den gifbuilder.
     
  4. misfit

    misfit New Member

    ach ist das ärgerlich. ich habe GDlib bundled (2.0.15 compatible) installiert. das kann keine GIf's erzeugen? oder? also performance probleme habe ich eigentlich nicht. auf ibook G4/800 und desktop G4/1 GHZ läuft typo eigentlich recht rund. ärgerlich ist aber das der rich text editor nur mit dem IE auf PC funzt. weil active x und so ... sollen mal ein java basierten RTE rausbringen ... wo bekomme ich denn eine gd lib 1.8 her und das am besten für os x. ohne noch zu kompilieren ....
     
  5. Achmed

    Achmed New Member

    Die gd2 kann keine gifs erzeugen. Wegen lizenzrechtlichen problemen. Für die 1.8 gibts einen patch.
    Mußt halt pngs erzeugen.
    Ohne compilieren wirds nichts mit der gd1.

    Außer es hat jemand in der zwischenzeit eine fertige php bereitgestellt.
    Für den Mozilla gibt es doch ein plugin für typo3. damit steht auch ein editor zur verfügung. wenn auch nicht so funktioniell.
     
  6. misfit

    misfit New Member

    Hallo Leute,

    hat schonmal jemand von euch die ImageMagick version 4.2.9 auf os x (10.3) installiert? das ist die empfohlene version für typo3. ich habe es mit einer neueren version von entrophy versucht aber das funktioniert nur bedingt. der GIFBuilder funzt nicht mit der neuen version. ein lizenzrechtliches problem. deshalb wird bei typo3 immer 4.2.9 eingesetzt. aber wo bekomme ich die für os x her? und wie wird installiert wenn es keinen installer gibt?
     
  7. RaMa

    RaMa New Member

  8. Achmed

    Achmed New Member

    Die 4.2.9 wird unter osx nicht laufen.
    Nicht mal mit Fink.
    Ich hab einige Zeit verbracht die unter osx zum laufen zu bringen. (Du kannst mir ein aber ein Monatsgehalt sponsoren dann knette ich die Sourcen für osx um).
    Aber typo3 macht unter (zumindest unter meinem g3)
    kein Sinn da die hardware zu lahm ist.

    Die 5er Version von Entropy kannst du nehmen.
    Du mußt halt in der localconf.php die ganzen anpassungen für die 5er machen bzw. im Setup.

    Eine php mit einer gdlib1.8 hab ich hinbekommen. Das reicht immo für den gifbuilder.
     
  9. misfit

    misfit New Member

    ach ist das ärgerlich. ich habe GDlib bundled (2.0.15 compatible) installiert. das kann keine GIf's erzeugen? oder? also performance probleme habe ich eigentlich nicht. auf ibook G4/800 und desktop G4/1 GHZ läuft typo eigentlich recht rund. ärgerlich ist aber das der rich text editor nur mit dem IE auf PC funzt. weil active x und so ... sollen mal ein java basierten RTE rausbringen ... wo bekomme ich denn eine gd lib 1.8 her und das am besten für os x. ohne noch zu kompilieren ....
     
  10. Achmed

    Achmed New Member

    Die gd2 kann keine gifs erzeugen. Wegen lizenzrechtlichen problemen. Für die 1.8 gibts einen patch.
    Mußt halt pngs erzeugen.
    Ohne compilieren wirds nichts mit der gd1.

    Außer es hat jemand in der zwischenzeit eine fertige php bereitgestellt.
    Für den Mozilla gibt es doch ein plugin für typo3. damit steht auch ein editor zur verfügung. wenn auch nicht so funktioniell.
     
  11. misfit

    misfit New Member

    hey vielen dank für den tip mit dem mozilla rte. hab ich installiert und ist auf jeden fall eine echte bereicherung für typo3. somit ist man nicht mehr auf das blöde active-x angewiesen um die texte mit einem rte zu editieren.

    super!
     
  12. misfit

    misfit New Member

    Hallo Leute,

    hat schonmal jemand von euch die ImageMagick version 4.2.9 auf os x (10.3) installiert? das ist die empfohlene version für typo3. ich habe es mit einer neueren version von entrophy versucht aber das funktioniert nur bedingt. der GIFBuilder funzt nicht mit der neuen version. ein lizenzrechtliches problem. deshalb wird bei typo3 immer 4.2.9 eingesetzt. aber wo bekomme ich die für os x her? und wie wird installiert wenn es keinen installer gibt?
     
  13. RaMa

    RaMa New Member

  14. Achmed

    Achmed New Member

    Die 4.2.9 wird unter osx nicht laufen.
    Nicht mal mit Fink.
    Ich hab einige Zeit verbracht die unter osx zum laufen zu bringen. (Du kannst mir ein aber ein Monatsgehalt sponsoren dann knette ich die Sourcen für osx um).
    Aber typo3 macht unter (zumindest unter meinem g3)
    kein Sinn da die hardware zu lahm ist.

    Die 5er Version von Entropy kannst du nehmen.
    Du mußt halt in der localconf.php die ganzen anpassungen für die 5er machen bzw. im Setup.

    Eine php mit einer gdlib1.8 hab ich hinbekommen. Das reicht immo für den gifbuilder.
     
  15. misfit

    misfit New Member

    ach ist das ärgerlich. ich habe GDlib bundled (2.0.15 compatible) installiert. das kann keine GIf's erzeugen? oder? also performance probleme habe ich eigentlich nicht. auf ibook G4/800 und desktop G4/1 GHZ läuft typo eigentlich recht rund. ärgerlich ist aber das der rich text editor nur mit dem IE auf PC funzt. weil active x und so ... sollen mal ein java basierten RTE rausbringen ... wo bekomme ich denn eine gd lib 1.8 her und das am besten für os x. ohne noch zu kompilieren ....
     
  16. Achmed

    Achmed New Member

    Die gd2 kann keine gifs erzeugen. Wegen lizenzrechtlichen problemen. Für die 1.8 gibts einen patch.
    Mußt halt pngs erzeugen.
    Ohne compilieren wirds nichts mit der gd1.

    Außer es hat jemand in der zwischenzeit eine fertige php bereitgestellt.
    Für den Mozilla gibt es doch ein plugin für typo3. damit steht auch ein editor zur verfügung. wenn auch nicht so funktioniell.
     
  17. misfit

    misfit New Member

    hey vielen dank für den tip mit dem mozilla rte. hab ich installiert und ist auf jeden fall eine echte bereicherung für typo3. somit ist man nicht mehr auf das blöde active-x angewiesen um die texte mit einem rte zu editieren.

    super!
     
  18. misfit

    misfit New Member

    Hallo Leute,

    hat schonmal jemand von euch die ImageMagick version 4.2.9 auf os x (10.3) installiert? das ist die empfohlene version für typo3. ich habe es mit einer neueren version von entrophy versucht aber das funktioniert nur bedingt. der GIFBuilder funzt nicht mit der neuen version. ein lizenzrechtliches problem. deshalb wird bei typo3 immer 4.2.9 eingesetzt. aber wo bekomme ich die für os x her? und wie wird installiert wenn es keinen installer gibt?
     
  19. RaMa

    RaMa New Member

  20. Achmed

    Achmed New Member

    Die 4.2.9 wird unter osx nicht laufen.
    Nicht mal mit Fink.
    Ich hab einige Zeit verbracht die unter osx zum laufen zu bringen. (Du kannst mir ein aber ein Monatsgehalt sponsoren dann knette ich die Sourcen für osx um).
    Aber typo3 macht unter (zumindest unter meinem g3)
    kein Sinn da die hardware zu lahm ist.

    Die 5er Version von Entropy kannst du nehmen.
    Du mußt halt in der localconf.php die ganzen anpassungen für die 5er machen bzw. im Setup.

    Eine php mit einer gdlib1.8 hab ich hinbekommen. Das reicht immo für den gifbuilder.
     

Diese Seite empfehlen