Installation von MacOS X auf älteren G3s

Dieses Thema im Forum "Software" wurde erstellt von kugelfisch, 23. Dezember 2005.

  1. kugelfisch

    kugelfisch New Member

    Hallo,
    ich versuche (ziemlich erfolglos) MacOS X auf einem G3 (noch so en beiger) zu installieren. Mein Bekannter hat mir die X CD von seinem iMac gegeben. Installation läuft soweit auch ok, nur nachdem er die Installation abgeschlossen hat, sieht er sich nicht in der Lage von der Platte zu booten und nimmt wieder die CD. Alle Versuche ihn zum boot von der Platte zu bewegen sind gescheitert. Die Platte wurde während des Setups platt gemacht und einmal mit UFS und einmal mit HFS+ formatiert. Brachte aber beides nix. Jemand ne Ahnung woran das liegen könnte?
     
  2. Macziege

    Macziege New Member

    Meines Wissens brauchst du Pazifist, um OS X auf ältere Rechner zu installieren. Selbst habe ich das noch nicht genutzt.
     
  3. mac-christian

    mac-christian Active Member

    Oder XPostFacto.

    Christian
     
  4. Dagmar

    Dagmar New Member

    Willst du nur X draufbringen oder mit Classic? :confused: :confused: :xmas:
     
  5. Schlawuzelbaer

    Schlawuzelbaer New Member

    Die Festplatte muss im Format HFS+ sein. Um welche X-Version handelt es sich? Vor der Installation prüfen, ob die Platte in Ordnung ist.
    Was passiert eigentlich beim Start wenn die CD nicht zur Verfügung steht? Bleibt der Bildschirm dunkel?
    Nach der Installation vor dem ersten Start von der Festplatte hilft es wenn man die Rechte repariert. Sollte er hochfahren und hängen bleiben, liegt es nach meiner Erfahrung an den Grafiktreibern, die aus dem Extension-Ordner gelöscht werden müssen (siehe apple support: schwarzer Bildschirm).
    Wenn das alles nicht hilft, muss du es mit Xpostfacto versuchen.
    Ein 9.X System Xpostfacto und das neuste Kontrollfeld "Startvolumen" (aus classic entnehmen) installieren.
    Aber Vorsicht: nicht jede Version ist G3 beige verträglich. Die Version 4 hat mir ziemlich den Rechner "verbogen". Bei mir läuft X.3.9 mit XPF 3.02
    Die 4.er Version scheint ausschlließlich nur für Tiger zu sein.
    Sollte dies auch missglücken, dann musst du alles reseten um in den Urzustand zu kommen.
    Aber es könnte auch nur an einer schwachen Pufferbatterie liegen, das das Startlaufwerk nicht erkannt wird.

    Viel Erfolg
     
  6. Tsujoshi

    Tsujoshi New Member

    Damit wirds nicht gehen. Zumindest nicht ohne Umwege. Die CD ist Rechnerspezifisch.

    Ist es sicher eine CD und keine DVD? HatDein G3 ein DVD-Rom?
     
  7. Eduard

    Eduard New Member

    Und nicht vergessen, die erste Partition der Platte muß unter 8 GB liegen, sonst geht auf dem beigen G3 nichts. Müßte aber eigentlich schon passiert sein, sonst versucht er erst gar keine Installation. Bei mir lief 10.2.8 recht flott auf dem G3 mit 400 MHZ Beschleunigerkarte (vorher 266 er), aber die Installation war ein Graus, blieb öfter dabei hängen.
     
  8. kugelfisch

    kugelfisch New Member

    Hallo,
    erstmal Danke für die zahlreichen Antworten. Die Installation geht ganz normal von statten wie man sich das eigentlich wünscht, beim Neustart kommt dann aber immer :notFound auf dem weißen Hintergrund; irgendwann schaltet er dann auf den grauen Hintergrund um und zeigt mir das Diskettensymbol an. Die Installations-CD ist natürlich original und in der Version 10.0.3
    Mein Mac hat kein DVD-Laufwerk und es ist auch keine DVD, da liegt aber wohl auch nicht das Problem, weil die Installation ja reibungslos klappt. Eine Classic-Umgebung, bzw. MacOS 9(.1) ist nicht installiert.
    Das OS X den Rechner nicht unterstützt kann ich mir aber nicht so recht vorstellen, da es sich ja um eine frühe OS X Version handelt, und das Teil ja auch auf der Liste der unterstützten Computer steht.
    Die Festplatte ist 4,2 GB groß, ist auch noch in Ordnung, daher sollte der Fehler da eigentlich nicht liegen.
    Kann es evtl. sein, dass er die Platte einfach nicht zum booten nimmt? Ich habe in der vorher installierten MacOS 9 Version die CD als Startvolumen eingegeben, da er nicht so recht booten wollte (Die Installation war ziemlich zerschossen).
     
  9. Bornt Identity

    Bornt Identity New Member

    Hi, also der Tipp mit XPostFacto ist super (http://www.opendarwin.org/projects/XPostFacto/). Du solltest auch schauen, wie es um Deinen RAM steht. OSX 10.4 braucht glaub ich min. 256 MB. Hast Du das? Wenn möglich, pack ruhig noch was drauf. Ich habe 384 MB und damit läuft 10.4 naja geht so. Wenn Du darunter gehst, steigt die Wahrscheinlichkeit enorm, das Diskettensymbol zu bekommen. Hört sich banal an, ist aber so. Vielleicht leihst Du Dir einfach erstmal ein bißchen Speicher aus einem anderen Computer zum Test. Das wird bestimmt gehen. Viel Erfolg!

    Der Bornt
     
  10. Schlawuzelbaer

    Schlawuzelbaer New Member

    Wenn du 2 x PRAM 2 Gongs löscht (apfel + alt + p +r) ist dein 1. Startvol wieder die Festplatte. Wenn er schon von 9.x nicht so recht booten wollte, dann ist deine FP defekt oder der Controller. 4 GB sind verdammt knapp.
    Auch wenn die OS X nur 2,5 GB Standard braucht, ist der FP-Platz sehr knapp wegen den Auslagerungsdateien. Kommen noch Auslagerungsdateien von Applikationen hinzu, ist das System langsam bzw versagt den Dienst.
    Für 10.0.1 lohnt sich nicht der Aufwand. Wenn X, dann besorgt dir die Start-CD vom PM G4 10.2.3. Diese Version läuft auf dem G3 ohne Xpostfacto und ohne weiteren Tricks (zumindest war es so bei meinem G3 so)
    Allerdings müsste du dir für die Installation ein DVD-LW ausleihen oder günstig erwerben.
     

Diese Seite empfehlen