iPhoto: Albumproblem

Dieses Thema im Forum "Software" wurde erstellt von macoldie, 29. August 2005.

  1. macoldie

    macoldie New Member

    Warum aktualisiert iPhoto (Version 5.0 unter Tiger) in der Library die Alben nicht?? Aus der Quelle gelöschte Alben sind in der Library nach wie vor vorhanden, neu erstellte werden dagegen nicht angezeigt: muss ich da irgend etwas aktualisieren? Oder wie kriege ich sonst die richtigen Alben über den Finder in den Brennordner?

    Mal wieder ratlos grüßt
    macoldie
     
  2. mac_heibu

    mac_heibu Active Member

    Die Alben, die du unter "Bilder/iPhoto Library/Albums" findest würde ich an diener Stelle NICHT brennen! Das sind lediglich Thumbnails zur Anzeige der Preview-Bildchen in iPhoto (guck mal auf die Größe der Bildchen!).
    Warum das nicht aktualisiert wird oder doch oder vielleicht muss dich eigentlich nicht kümmern. Der Inhalt des Ordners ist im Prinzip für den Anwender völllig unbedeutend, denn die iPhoto-Arbeit erledigt man normalerweise in der Benutzeroberfläche des Programms.
    Dein Problem "Brennordner" lässt sich meines Wissens in Bezug auf iPhoto nicht lösen, denn die Alben werden nicht in Ordnern, sondern in XML-(Datenbank-)Strukturen verwaltet. Eigentlich schade.
    Was natürlich bleibt, ist die Möglichkeit, einen Ordner auf dem Desktop anzulegen, die gewünschten Bilder aus dem iPhoto-Fenster dort hineinzuziehen und diesen zu brennen. Dies geht auch, wenn du die Bilder bei gedrückter Apfel-Taste in den Brennordner legst (er enthält dann nur Aliasse, brennt aber die Originale).
     
  3. alf

    alf New Member

    Vielleicht kleiner Nachtrag: Es gibt inzwischen Version 5.02
     
  4. macoldie

    macoldie New Member

    Danke für die Info - bleibt aber trotzdem merkwürdig, dass die Alben in der Library nicht aktualisiert werden - beim Import von Bildern nach iMovie werden die Ordner dagegen aktualisiert angezeigt - nix verstehen - aber ich weiss ja jetzt, wie's trotzdem geht.

    Und noch ein kleiner Nachtrag - eben nachgeguckt und upgedatet - ist jetzt schon Version 5.04 :))

    "Geholfen" grüßt
    macoldie
     
  5. mac_heibu

    mac_heibu Active Member

    Hallo, macoldie,
    vielleicht hab ich die Lösung. Ich habe gerade eine neue iPhoto-Library (ALT-Taste bei Programmstart drücken) angelegt und mir den neuen Library-Ordner angeschaut. Er enthält KEINEN Albums-Ordner mehr! Ich denke also der Ordner "Albums" samt Inhalt ist ein unnötiges, ärgerlicherweise beim Update-Prozess nicht gelöschtes Überbleibsel aus der iPhoto 4.x-Zeit.
    Bevor man den Ordner aber wegwirft, sollte man erst einen Test an einer Library-Doublette durchführen (Kann ich gerade nicht, muss weg): Library duplizieren, Ordner "Albums" wegwerfen, iPhoto unter Drücken der ALT-Taste starten und die neue Library zuweisen. Was passiert jetzt?
     
  6. mac_heibu

    mac_heibu Active Member

    Also, ich habs eben selbst probiert.
    Ich habe meine iPhoto-Library dupliziert und aus dem Duplikat folgende Dateien gelöscht:
    - den Ordner "Albums"
    - iPhotoLock.data
    - Library.cache
    - Library.data
    (Die letzteren 3 Dateien habe ich gelöscht, weil deren letztes Änderungsdatum irgendwann im Jahr 2003 lag.)
    Danach iPhoto mit gedrückter ALT-Taste gestartet und die "operierte" Library ausgewählt. Alles läuft absolut rund!
    Ich denke, mein Verdacht hat sich bestätigt: Das Update auf iPhoto 5 hat die nicht mehr benötigten Datenstrukturen der früheren Version(en) nicht gelöscht.
    Ich möchte niemanden animieren, die i.g. Dateien zu löschen – schließlich stören sie nicht und schließlich erzähle ich hier seit Jahren jedem, der es hören will oder nicht: "Finger weg von der Library!"
    Das Ganze soll nur die eingangs gestellte Frage klären, warum neue Alben nicht im "Albums"-Ordner aufgeführt werden: Diese Datenstruktur wird offenbar nicht mehr benötigt und liegt nur noch als Leiche im Library-Ordner.
     

Diese Seite empfehlen