Iphoto keine Bilder nur gestrichtelte Rechtecke?

Dieses Thema im Forum "Software" wurde erstellt von metallman, 13. September 2008.

  1. metallman

    metallman New Member

    Hallo,
    in meinem Iphoto tauchen keine Bilder mehr auf. Man sieht nur noch gestrichelte Rechtecke. Lediglich bei schnellem durchscrollen lassen sich noch Fotos erkennen. Auch bei Doppelklick erscheint nur noch dieses Rechteck mit einem Ausrufungszeichen in der Mitte.
    Aber in der Iphoto Libary sind die Bilder noch alle drin. Weiß jemand was hier passiert ist?
     
  2. bikie54

    bikie54 New Member

    Kenne bei meinem iPhoto ein ähnliches Problem: Die Bilder sind zwar als Thumbnail vorhanden, beim "aufklicken" erscheint das Bild einen Sekundenbruchteil und dann kommt das schwarze Ausrufezeichen. Auch in der Library sind die Bilder nicht mehr vorhanden. Interessanterweise tritt das Phänomen nur bei einem meiner beiden Fotoapparate auf.
     
  3. metallman

    metallman New Member

    In der Libary sind alle Bilder da, sowohl im Ordner Orginal wie auch modified.
     
  4. bikie54

    bikie54 New Member

    Schön wär's, wenn die Bilder in vorhanden wären. Sie sind es eben nicht.
     
  5. bikie54

    bikie54 New Member

    Die Bilder sind in der Tat noch vorhanden "Spotlight" findet sie, einfach in einem andern Ordner, als dem, in dem es in iPhoto angezeigt wird.
    Was meine Einschätzung von iPhoto einmal mehr bestätigt: Das Programm ist überfordert, sobald man viele Bilder ablegt (Habe über 14 000 Bilder drin). Darum: Wirklich wichtige Aufnahmen lege ich in Ordnern ab, die ich selber anlege und importiere sie über das Programm "Digitale Bilder". So bleibt die Ordnung erhalten. Beim Update auf iPhoto 8 (Version 7.0.1) von iPhoto 7 wurden schon alle sorgfältig erstellten Ordner in "Ereignisse" umbenannt und nun sind die Bilder völlig chaotisch in den "Ereignissen" verstaut.
     
  6. mac_heibu

    mac_heibu Active Member

    biki54, mit Verlaub, was du sagst ist Quatsch.
    1. Nenne uns deine iPhoto-Version. Für manche iPhotoo-Versionen können die Bilder von Spotlight nicht gefunden werden, das sie in einem sog. Package und nicht mehr wie früher in frei zugänglichen Ordnern verwaltet verwaltet werden.
    2. Wenn die Bilder tatsächlich im einem falschen Ordner sein sollten, ist nicht iPhoto überfordert, sondern ganz eindeutig der Anwender der Programms.
    3. Verwaltet iPhoto deine Bilder oder du selbst?
    4. Wenn keine Thumbnails angezeigt werden empfiehlt sich zunächst einmal das hier beschriebene Vorgehen:
    http://forum.macwelt.de/forum/showthread.php?t=690408
    bikie54 würde ich dringend empfehlen, einen andere Bildverwaltungssoftware als iPhoto zu nutzen. Wer nicht bereit oder in der Lage ist, sich mit der Arbeitsweise eines Programms auseinanderzusetzen, sollte es lieber lassen. ("Ereignisse" und "Ordner" sind 2 völlig verschiedenen Paar Stiefel und die werden weder "völlig chaotisch" noch überhaupt von iPhoto in irgendeiner Weise "umbenannt". Aber das wäre eine andere Diskussion. Um hier weiter zu kommen , müsste man sich erst mal schlau machen, was "Ordner", "Ereignisse", "Filme" und "Alben" sind.)
     
  7. bikie54

    bikie54 New Member

    Sorry, aber ich weiss schon, wie iPhoto funktioniert.

    Zum Problem: Da werden bei den Thumbnails Bilder in einem Ordner (iPhoto Slang "Ereignis" angezeigt. Beim Anklicken kommt dann das grosse schwarze Ausrufezeichen. Ueber Spotlight habe ich die Bilder dann gefunden (iPhoto zeigt immerhin deren Bezeichnung/Nummer an). Und in der Tat, das Bild war in einem andern Ordner (Ereignis) vorhanden. Dort wird es aber nicht als Thumbnail angezeigt.

    Und wenn du's nicht glaubst, dass es so ist, dann komm bei mir vorbei und schau dir das Ganze an.
     
  8. mac_heibu

    mac_heibu Active Member

    So, wenn du Bescheid weißt, dann sag uns mal, wo genau die Bilder bzw. die Thumbnails liegen oder wo genau sie deiner Meinung nach liegen sollten …
     
  9. bikie54

    bikie54 New Member

    Damit es klar wird (ich verwende iPhoto 08, Version 7.01):

    Die Thumbnails und alle Infos (Format, Aufnahmedatum, Nummer usw) sind beispielsweise im Ordner (Ereignis) genannt Deutschland. Die Bilder dazu sind aber effektiv im Ordner genannt Frankreich. Mittels Spotlight kann man die Bilder suchen gehen, da man ja den Namen kennt und dann wird auch der Pfad angezeigt. Oeffnet man dann in iPhoto den Ordner Frankreich, sind die Bilder aber nicht sichtbar, da keine Thumbnails vorhanden sind. Wenn man aber direkt in den Ordner geht, sieht man die Bilder und kann sie auch öffnen (z.B. mit Vorschau).

    Vermutlicher Grund: Es scheint, dass es sich bei den Bildern, die dieses Problem aufweisen, um Bilder handelt, die ich von einem Ordner in einen andern verschoben habe (etwa von Deutschland nach Frankreich). Der Fehler tritt aber nicht jedes mal auf. Bei mir kam er bis jetzt auch nur bei Bildern vor, die ich mit der Nikon Coolpix S10 gemacht habe. Aufnahmen mit Nikon D80 oder Nikon D300 kennen bis jetzt dieses Problem bis jetzt nicht. Wobei, es tritt auch nicht jedes mal auf.

    Das Verschieben klappt zwar vermeintlich (Bilder und Thumbnails liegen im neuen Ordner und die Bilder lassen sich auch öffnen). Wird iPhoto aber geschlossen und später wieder geöffnet, sind die Thumbnails wieder im alten Ordner (beispielsweise Deutschland), die Bilder dazu aber im neuen Ordner (beispielsweise Frankreich).

    Alles klar?
     
  10. mac_heibu

    mac_heibu Active Member

    … also doch: genau wie ich sagte: Du solltest dich mit der Arbeitsweise von iPhoto und der genauen Bedeutung der Begriffe Ordner, Ereignisse etc vertraut machen.
    Nach zig Beiträgen in diesem Forum habe ich keine Lust mehr, das alles nochmals wiederzukäuen – vor allem nicht, wenn wir der mal zuallererst aufs das Programm geschimpft wird, wenn das eigentliche Problem vor dem Rechner sitzt.
    Aber vielleicht findet sich ja ein anderer Geduldiger.

    Nur so als kleine Hilfestellung, wonach du suchen könntest:
    - Offenbar hast du iPhoto so eingestellt, dass es nicht selbst, sonder du die Ablageorte der Bilder verwaltet – eine zentrale Information, die du hier ruhig explizit weitergeben könntest.
    - Wenn du aus deinen händisch angelegten Ordnern Bilder an einen anderen Speicherplatz verschiebst – was soll iPhoto dann tun?
     
  11. bikie54

    bikie54 New Member

    Ich geb's auf, dieser Tonfall ist nur zum kotzen:
    Ich habe keinen einzigen Ordner selber angelegt, sondern, schön brav, iPhoto alles machen lassen.
    Du kannst dir deine besserwisserischen Kommentare sparen. Mir auf jeden Fall reicht's.

    Oder wenn du doch alles weisst, dann kannst du mir sicher erklären, warum iMovie auf meinem Mac nicht läuft, obwohl alles brav von Grund auf richtig installiert (das alte iMovie HD, das ich daraufhin wieder installiert habe, läuft dagegen wunderprächtig.

    Wie gesagt ich kann auf diese besserwisserischen Kommentare verzichten.
     
  12. metallman

    metallman New Member

    Das hilft mir jetzt nicht wirklich weiter!?
     
  13. bikie54

    bikie54 New Member

    Ich vermute, dass es bei iPhoto in der Tat ein Problem mit der Koordination zwischen Thumbnails und Photo gibt. Thumbnail und Bild werden voneinander abgespalten. Aber wie sich das beheben lässt? Da kann möglicherweise nur der Apple-Gott helfen.
     
  14. mac_heibu

    mac_heibu Active Member

    @ bikii: Du schreibst: "Vermutlicher Grund: Es scheint, dass es sich bei den Bildern, die dieses Problem aufweisen, um Bilder handelt, die ich von einem Ordner in einen andern verschoben habe (etwa von Deutschland nach Frankreich)." Und dann "Ich habe keinen einzigen Ordner selber angelegt"
    Wo kommen die Ordner "Deutschland" und "Frankreich" her, wenn du sie nicht angelegt hast?
    Dass ein Anwenderproblem vorliegt, nehme ich auf Grund deiner Beschreibungen an.
    Ein Beispiel:
    Du schreibst: Öffnet man in iPhoto den Ordner "Frankreich" so sind die Bilder nicht sichtbar. Wenn man direkt in den Ordner geht, sieht man die Bilder. Wenn ich diese Aussage richtig verstehe, dann warst du warst offenbar im Datenbank-Pakage von iPhoto. Hast du dort Bilder hin- und herkopiert? Und: Was verstehst du unter "Ordnern direkt in iPhoto"? Hier gibt es Ereignisse und Alben. Ordner sind in diesem Kontext nur Sammlungen von Alben.
    Ich kann nur wiederholen: Wenn du nicht klar sagst, was du meinst bzw. getan hast, kann man nicht helfen.
    Ach ja: Mein "Ton" ist eine Sache. Ein andere ist es, wenn hinter jedem Problem gleich ein Fehler des Programms vermutet wird. iPhoto soll "überfordert" sein? Glaubst du wirklich, dass allein du bisher auf diesen "Fehler" gestoßen bist? Derartiges noch nirgendwo sonst gehört.
    Ich kann dir nicht auch nicht sagen, warum iMovie nicht läuft. Du hast es bisher ja nicht mal für nötig gehalten, uns zu sagen, was für einen Mac du hast.

    @ metallman: Hast du mal mein Posting oben gelesen? Der Link dort beschreibt eine mögliche Problemlösung.
     
  15. bikie54

    bikie54 New Member

    Ich hab soeben das ganze Problem nochmals beschrieben, da hat der Upload ins Forum nicht geklappt. Ich mag's nicht mehr machen. Nur in Kurzform:
    Bilder werden ab Fotoapparat in Ereignis geladen und Ereignis "Deutschland genannt. Tage später werden Fotos ab Fotoapparat geladen und das Ereignis "Frankreich" genannt. Ein paar der Bilder werden anschliessen per drag and drop nach "Deutschland" verschoben. Klappt bestens, lassen sich gross anschauen.

    Tage später: Vorführung des Ereignisses "Deutschland". Die aus "Frankreich" importierten Bilder sind aber nicht da, nur die Thumbnails und die Bildinfos. Spotlight findet die Bilder zu den Thumbnails dann (wieder) im Ereignis "Frankreich). Thumbnails dazu sind aber im Ereignis "Deutschland".
    Problem tritt nur bei Fotos am Nikon s10 auf, nicht bei Bildern ab Nikon D80 und D300.

    Weiter Update von iPhoto '08 Version 7.01 auf 7.1 wird zwar angeboten, Update klappt aber nicht (schon mehrmals versucht). Die Updates aller andern Programme funktioniert aber.

    Benutze ein Macbook Pro, und OS 10.5.4 (demnächst 10.5.5)

    iPhoto und das nicht funktionierende iMovie stammen von der selben CD Rom, die allerdings, so die Ueberprüfung, fehlerfrei sein soll).

    Noch Fragen, oder ist jetzt alles klar?
     
  16. bikie54

    bikie54 New Member

    @mac_heibu und Konsorten:
    Schon toll: Erst rummeckern, das Problem auf den auch so unfähigen User schieben (Ja, ich weiss was ein DAU ist). Und dann, wenn die ach so Siebengscheiten das x Mal beschriebene Problem endlich begriffen haben, glänzen sie durch schweigen. Vielen Dank also. Ich hab's begriffen.

    P.S. Ich habe schon einen Verdacht, wo die Probleme herrühren: Ich vermute, dass meine MacbookPro irgendwo einen kleinen Hardware Fehler hat, der sich aber nur vereinzelt auswirkt. Aber um das zu testen, müsste ich meine Gigabites runterladen die Hardware testen und dann alles wieder hochladen. Das ist mir, ehrlich gesagt, zu aufwändig.
     
  17. mac_heibu

    mac_heibu Active Member

    Jetzt wirds aber lustig!
    Hast du nicht oben geschrieben "Ich mag nicht mehr!"?
    Wer nicht will/mag, der hat schon …
     
  18. edwin

    edwin New Member

    Mich würde dieser Hardwarefehler interessieren.
     
  19. arnbas

    arnbas New Member

    Ich geh mal nicht von einem Hardwarefehler aus und auch nicht vom DAU.
    Denn bei mir zeigt iPhoto 8.0.3 den gleichen Fehler. Erst dachte ich, es wären jpgs, die in einer bestimmten Form abgespeichert wurden (die mit Grundlinie optimiert abgespeichert wurden), habe aber auch Bilder, die nicht so abgespeichert wurden, deren Thumbnail funktioniert und in der großen Ansicht das Ausrufezeichen zeigen. Hier sind es tatsächlich fast ausschließlich die hochformatigen Bilder(jpg), die von iPhoto automatisch gedreht wurden. Nach erneutem Import wieder in Ordnung, aber für wie lange?
    Ich lasse übrigens die Originale nicht in die iPhoto-Mediathek kopieren, sondern nur verwalten, einfach weil ich nicht alle Bilder doppelt auf der Platte haben will, bei über 20.000 doch schon einige GigaByte.
    Diese Festplatte ist nur für die Fotos da und die Ordnerstruktur bleibt nach dem jeweiligen Import in iPhoto unverändert, da wird weder in die Mediathek eingegriffen, noch werden die entsprechenden Dateien hin oder hergeschoben. Es muss etwas anderes sein, was iPhoto durcheinander bringt.
     
  20. Chrigu

    Chrigu New Member

    Auch bei mir kommen bei zwei (von etwa 74) Ereignissen plötzlich nur noch schwarze Flächen und Fragezeichen. Nun habe ich mit der Suche dieses Thema gefunden. Zur Polemik in den Beiträgen äussere ich mich nicht; sie lösen das Problem nicht.

    Seit wann habe ich diese Erscheinung? Ich habe die iPhoto Library aus dem Ordner "Bilder" in den Ordner "Dropbox" verlegt. Der Fehler liegt allerdings kaum bei Dropbox. Wie gesagt: 72 Ereignisse mit über 3400 Bildern sind einwandfrei; zwei Ereignisse mit zusammen etwa 80 Bildern erscheinen aber nur schwarz, ebenso die einzelnen Bilder (mit grossem Ausrufezeichen). Die Anzahl Bilder innerhalb der beiden Ereignisse wird, wie bei allen anderen auch, korrekt angezeigt. Die Bilder müssen also vorhanden sein. Nur: Wie kann ich sie wieder sichtbar machen. Dazu gibt dieser Thread leider keine Auskunft.

    In Beitrag 6 von mac_heibu ist ein Link, der mir vielleicht helfen würde. leider funktioniert bei mir dieser Link nicht. Kann mir jemand helfen?

    Danke
    Chrigu
     

Diese Seite empfehlen