iworks läuft nicht mehr

Dieses Thema im Forum "Software" wurde erstellt von ekaat, 28. Februar 2005.

  1. ekaat

    ekaat ich bin auf dem sofa

    weder keynote noch pages.
    verabschieden sich beide sofort beim start. g5 dual 2
    hab schon 2x neuinstalliert, vorher mit suchen alle komponenten gelöscht. auch die zusätzlichen schriften entfernt. rechte repariert.

    auf dem tibook 400 läuft es problemlos und die geräte sind nicht vernetzt.





    :confused:
     
  2. Macziege

    Macziege New Member

    Vielleicht ist ja eine Schrift nicht da, die von iWorks gebraucht wird!
     
  3. Macci

    Macci ausgewandert.

    tippe auch auf deaktivierte oder "zusammengeführte" Schriften...
     
  4. mkummer

    mkummer New Member

    Wie sieht es mit dem Löschen der plist Files aus - iWork legt da welche im Prefs-Ordner sowohl des Home Directorys als auch im normalen Library Ordner ab.

    Wenn das nicht hilft, sollte man die DS stores mal löschen (mit einem Utility wie Xupport).

    Mit den Schriften glaube ich weniger, denn wenn er schon 2x neuinstalliert hat, sollten die notwendigen ja da sein. Man kann ja mal auf Doubletten im Programm Schriftsammlung schauen...
     
  5. ekaat

    ekaat ich bin auf dem sofa

    alle tipps befolgt, es läuft nicht! ;(
     
  6. mkummer

    mkummer New Member

    Habs gerade nochmal probiert - auf meinem G5 2 dual läuft Pages - fehlende Schriften führen zu einer Meldung aber keinem Programmabsturz.

    Leider keine Hilfe von mir - ich täte mal in den Apple Discussions schauen, ob sich da was findet. So isoliert kann das Problem ja eigentlich nicht sein.

    Hast Du schon mal einen neuen User eingerichtet und es mit dem probiert?
     
  7. ekaat

    ekaat ich bin auf dem sofa

    nee, hab ich noch nicht. ich bekomme demnächst aber eine 2. festplatte und dann installiere ich sowieso alles neu.

    ist natürlich unbefriedigend, wenn man die ursache nicht findet. )-:
     
  8. stocky2605

    stocky2605 New Member

    Dienstprogramme / Konsole aufrufen, vielleicht wirst Du aus den dortigen Meldungen schlau, auch mal beim Starten von iWork beobachten.
     
  9. ekaat

    ekaat ich bin auf dem sofa


    ===== Mon Feb 28 2005 ===== 19:34:10 Europe/Copenhagen =====
    2005-02-28 19:34:35.962 Pages[5754] An uncaught exception was raised
    2005-02-28 19:34:35.962 Pages[5754] *** -[NSCFArray addObject:]: attempt to insert nil
    2005-02-28 19:34:35.962 Pages[5754] *** Uncaught exception: <NSInvalidArgumentException> *** -[NSCFArray addObject:]: attempt to insert nil


    :confused:
     
  10. stocky2605

    stocky2605 New Member

    OS X ist up2date?
     
  11. ekaat

    ekaat ich bin auf dem sofa

    ja!

    geht immer noch nicht, alles andere aber normal. :confused:
     
  12. mkummer

    mkummer New Member

    Nun probiere doch einen neuen User einzurichten. Wenn es mit dem geht, liegt es definitiv an irgendwas in Deinem Homedirectory und nicht am System
     
  13. ekaat

    ekaat ich bin auf dem sofa

    na guuut! :D
     
  14. ekaat

    ekaat ich bin auf dem sofa

    so, jetzt hab ich einen neuen benutzer angelegt.
    das programm startet auch und scheint auch zu funktionieren, es behält aber die seriennummer nicht. muss ich bei jedem programmstart neu eingeben.
     
  15. mac_heibu

    mac_heibu Active Member

    "behält aber die seriennummer nicht. muss ich bei jedem programmstart neu eingeben"
    Das ist logo. Die SN wird nur dann gespeichert, wenn du das Programm als Admin installiest und zum ersten Mal startest, um es zu serialisieren.
     
  16. ekaat

    ekaat ich bin auf dem sofa

    alles klar, danke.

    aber den fehler hab ich immer noch nicht gefunden.
     
  17. stocky2605

    stocky2605 New Member

    Nun, wenn es mit einem User geht und mit einem anderen nicht, dann ist doch alles klar -> es liegt am User :)

    Ich würde im Terminal das Homedirectory durchsuchen:

    find . -name "*pages*" -print

    und

    find . -name "*keynote*" -print

    In der Hoffnung, dass da irgendetwas altes auftaucht.
    Oder: es ist eine Unverträglichkeit mit einem anderen Programm/Tool. Ich würde in den Startobjekten alles rausnehmen, was nicht zum System gehört und dann nochmal testen.

    Ich hatte vor kurzem das Problem, dass iCal nicht zu aktualisieren ging (via Software Update). Hab ewig gesucht, bis ich es gefunden hatte: MenuCalendarClock (das war ein Hinweis auf den Support Seiten von apple.com), Programm beendet und schon ging der Update.
     
  18. turik

    turik New Member

    Habe aufmerksam mitgelesen, weil ich das Progi nächstens für einen Vortrag kaufen und erstmals installieren will.
    Frage: Funktionierte denn iWorks überhaupt jemals zuvor auf dem Gerät, bevor Dein Problem auftauchte, oder war das anlässlich der Erstinstallation schon so?

    Gruss nach Norden!
    Hier ist auch saukalt!
    Schlimmer als wie auf 'ner Dezember-Fahrt im Weidling auf dem Zürichsee.
    :)
     
  19. ekaat

    ekaat ich bin auf dem sofa

    ...und immer noch nicht zugefroren?

    das programm lief vorher astrein und läuft auf meinem tibook auch immer noch.
    ich hab auch nichts verändert und bin deshalb so ratlos. da ich aber eine zweite festplatte bestellt habe, auf die mein hauptsystem soll, mache ich mir keine großen gedanken, ich installiere dann sowieso alles neu. :rolleyes:

    auf der anderen seite ist es natürlich immer nett, wenn man den fehler findet.
     
  20. Falls es Dich beruhigt: ich habe hier das selbe Problem auf meinem G4 1,25 dual. Von einem Tag auf den anderen läuft es nicht mehr. Fall Du was findest, bitte melden, ich suche natürlich auch.
     

Diese Seite empfehlen