Java 1.3.1 und 1.4.2 und 1.5 und...

Dieses Thema im Forum "Software" wurde erstellt von Micha.G, 21. Mai 2005.

  1. Micha.G

    Micha.G New Member

    Hallo zusammen !

    Folgende Frage: Ich habe eine Java-Applikation, die standardmäßig auf Java 1.3.1 zurückgreift.
    Für dies Programm gabs aber jetzt ein Update und jetzt läufts auf dem Mac nicht mehr richtig. Es wurde rausgefunden, daß durch Löschen der 1.3.1 Version aus dem Library/Frameworks Ordner, das Programm gezwungen ist, Java 1.4.2 zu benutzen und dann funktioniert es wieder.

    Irgendwie hab ich ein unwohles Gefühl dabei, einfach was aus dem Frameworks Ordner zu löschen und wollte fragen:
    Gibt es eine Möglichkeit, eine Java Applikation zu zwingen, eine bestimmte Java Version zu benutzen ? (hab Tiger)

    Danke
    Micha
    :)
     
  2. TomPo

    TomPo Active Member

    Also in Tiger liegen die Java-Versionen aber nicht mehr in irgendeiner Library, sondern direkt im "System" > Library > Frameworks > JavaVM.framework > Versions > 1.3.1/1.4.2.
    Und um von dort etwas löschen zu können, werden dir in der Regel die entsprechenden Rechte fehlen. Ausser Du hast dich zum Root gemacht. Was ich mal nicht hoffen will.

    Ich habe auch einige Apps die unter Java laufen, aber in Tiger bisher damit noch keinerlei Probleme gehabt. Weder mit NeoOffice, eDonkey, LW etc etc.
     

Diese Seite empfehlen