JavaScript für MacOS 8.1

Dieses Thema im Forum "Software" wurde erstellt von esox, 16. August 2002.

  1. esox

    esox New Member

    Ich arbeite noch mit MacOS 8.1 und nun benötige ich immer häufiger beim Surfen mit dem IE 5.0 oder 5.1 JavaScript. Wo ist da eine lauffähige Version downloadbar?
    Evtl. auch direkt an: a0275454@addcom.de
     
  2. carlo

    carlo New Member

    Meinst du java oder javascript?

    JS kannst du im browser unter den voreinstellungen oder optionen oder wie das in dt. version heißt aktivieren (unter der kategorie web content, vermute web inhalt auf dt.)

    Wenn es um java geht bin ich bei 8.1 überfragt, ist schon so lange her...
    Aber wenn du mal auf den apple-seiten nach "java" suchen tätst, würdest bestimmt fündig (vor allem in der neuesten version).
    Gucke aber grad mal eben auf der 8er cd nach...moment...

    Ah, da ham wirs ja: OS8>softwareinstallationen>MAcOS Runtime for JAva> installer

    Gruß,
    carlo
     
  3. esox

    esox New Member

    Hallo Carlo,

    zunächst einmal Danke für dein schnelles Feedback.

    Ich habe JavaScript gemeint und die Voreinstellungen (dt. = IE 5.0) oder Preferences (engl. = IE 5.1) stimmen, also JavaScript ist aktiviert. Ich hatte MacOS Runtime 2.0 von der CD installiert und habe mir 2.1.4 aus dem Internet besorgt und installiert.

    Leider alles ohne Erfolg und meine weitere Suche auf den Apple- und MacWelt-Seiten hat halt nichts ergeben. Wir brauchen jetzt auch nicht über den MS-Bullshit diskutieren. Fakt ist halt leider, daß 90% (oder mehr) mit MS-Produkten arbeiten.

    Konkret ist mir momentan eine Online-Bewerbung nicht möglich!

    Vielleicht ist es Dir ja möglich, vielleicht hast Du Kontakte, vielleicht reichen Deine Englisch-Kenntnisse um doch noch eine Lösung zu finden.

    Würde mich über ein erneutes Feedback sehr freuen.

    Harald (hc)
     
  4. carlo

    carlo New Member

    Wenn das so ist, brauch ich mehr infos: Was genau willst du machen, das nicht funktioniert?
    Was sagt Mozilla zu der problematischen Seite (wenns denn eine ist?)
    Gruß
    carlo

    PS: Bin eigentlichganz einvertanden mit dem IE , aber das ist eine andere baustelle. Schön ist jedenfalls , dass der IE sogar auf seiten von MS teilweise mit scriptfehlern aussteigt...
     
  5. esox

    esox New Member

    Also ich will es mal versuchen. Auf einer Website eines großen Unternehmens klicke ich den Link "Online-Bewerbung" an. Nach der Weiterleitung auf eine Hinweisseite und der Anwahl eines weiteren Links werde ich aber darauf aufmerksam gemacht, "Ein Skriptfehler ist aufgetreten. Einige Skripts der betreffenden Seite werden möglicherweise nicht richtig ausgeführt. Sollen die Skripts der betreffenden Seite fortgesetzt werden." und es tut sich nichts mehr, aber auch gar nichts. Dabei ist es völlig egal ob ich den IE 5.0 oder 5.1 verwende. So weit reicht mein englisch noch.

    Was sagt Mozilla? Meinst Du die Java-Nachriften, die ich nachfolgend einmal kopiert habe?

    7/4/2000 @ 16:0:18
    Java Exception: java.lang.NumberFormatException - null
    Stack Trace:
    java.lang.NumberFormatException: null
    at java.lang.Integer.parseInt(Integer.java)
    at java.lang.Integer.parseInt(Integer.java)
    at DynaButtons.init(Compiled Code)
    at com.apple.mrj.JManager.JMAppletViewer_OLD.doAppletInit(JMAppletViewerOld.java)
    at com.apple.mrj.JManager.JMAppletViewer_OLD.setState(JMAppletViewerOld.java)
    at com.apple.mrj.JManager.JMViewerEvent.post(JMAppletViewerOld.java)
    at com.apple.mrj.JManager.AVDispatcherThread.run(JMAppletViewerOld.java)

    An exception occurred: java.lang.NumberFormatException: null for null
    7/4/2000 @ 16:1:9
    Java Exception: java.lang.NullPointerException -
    Stack Trace:
    java.lang.NullPointerException
    at java.awt.Window.postWindowEvent(Window.java)
    at java.awt.Window.dispose(Window.java)
    at java.awt.Frame.dispose(Frame.java)
    at com.apple.mrj.JManager.JMAppletViewer_OLD.setState(JMAppletViewerOld.java)
    at com.apple.mrj.JManager.JMViewerEvent.post(JMAppletViewerOld.java)
    at com.apple.mrj.JManager.AVDispatcherThread.run(JMAppletViewerOld.java)

    Meine Konfiguration:
    PowerMac G3/233 DT
    System 8.1
    64 MB RAM
    JavaScript 1.03
    JavaScript.component 1.3
    MRJ Enabler 2.2.4
    (bei der Installation von dem Download "MRJ 2.1.4" meldet der "Aktualisierer" die Installation von "MacOS Runtime for Java 2.2.4" und des "Apple Applet Runner")
    InternetExplorer 5.1 engl. (oder 5.0 dt.)

    Danke schon jetzt. Ist ja gar nicht so selbstverständlich, daß sich jemand eines solchen Problems wirklich annimmt. Es ist ein Problem, es sind einfach inzwischen zu viele Seiten für den IE optimiert oder gar daruf abgestimmt. Qaulitätskontrolle gibt es in vieln Unternehmen offensichtlich nicht mehr.

    Beste Grüße
    hc

    Anmerkung: Kann die Sache erst frühestens am Montag weiter bearbeiten.
     
  6. carlo

    carlo New Member

    Hi nochmal,

    das klingt für meine laienhaften ohren nach einer kombination von zwei problemen, die sowohl mit JS als auch mit einem java-applet zu tun hat.
    Leider ist es tatsächlich so, dass die js-implementation in den IE für mac (win kann ich nicht beurteilen) mangelhaft ist.
    Hast du virtualPC oder einen echten pc zur verfügung? Dann probier es mal damit. Ist zwar gegurke, aber wenns akut hilft...
    Kannst du mal eine andere systemversion testen? 8.6 oder ein 9er system?
    Habs nicht genau mehr im überblick, aber probier mal:
    MRJ cache löschen
    MS Internet Cache löschen
    MacJava Prefs löschen
    alle im Prefs-Ordner im Systemordner.

    Wenn das nicht hilft, mal andere browser testen.

    Wenn das auch nicht hilft, woanders bewerben... ;-))

    Cu Montag - schönes WE!
    carlo
     
  7. esox

    esox New Member

    Ich arbeite noch mit MacOS 8.1 und nun benötige ich immer häufiger beim Surfen mit dem IE 5.0 oder 5.1 JavaScript. Wo ist da eine lauffähige Version downloadbar?
    Evtl. auch direkt an: a0275454@addcom.de
     
  8. carlo

    carlo New Member

    Meinst du java oder javascript?

    JS kannst du im browser unter den voreinstellungen oder optionen oder wie das in dt. version heißt aktivieren (unter der kategorie web content, vermute web inhalt auf dt.)

    Wenn es um java geht bin ich bei 8.1 überfragt, ist schon so lange her...
    Aber wenn du mal auf den apple-seiten nach "java" suchen tätst, würdest bestimmt fündig (vor allem in der neuesten version).
    Gucke aber grad mal eben auf der 8er cd nach...moment...

    Ah, da ham wirs ja: OS8>softwareinstallationen>MAcOS Runtime for JAva> installer

    Gruß,
    carlo
     
  9. esox

    esox New Member

    Hallo Carlo,

    zunächst einmal Danke für dein schnelles Feedback.

    Ich habe JavaScript gemeint und die Voreinstellungen (dt. = IE 5.0) oder Preferences (engl. = IE 5.1) stimmen, also JavaScript ist aktiviert. Ich hatte MacOS Runtime 2.0 von der CD installiert und habe mir 2.1.4 aus dem Internet besorgt und installiert.

    Leider alles ohne Erfolg und meine weitere Suche auf den Apple- und MacWelt-Seiten hat halt nichts ergeben. Wir brauchen jetzt auch nicht über den MS-Bullshit diskutieren. Fakt ist halt leider, daß 90% (oder mehr) mit MS-Produkten arbeiten.

    Konkret ist mir momentan eine Online-Bewerbung nicht möglich!

    Vielleicht ist es Dir ja möglich, vielleicht hast Du Kontakte, vielleicht reichen Deine Englisch-Kenntnisse um doch noch eine Lösung zu finden.

    Würde mich über ein erneutes Feedback sehr freuen.

    Harald (hc)
     
  10. carlo

    carlo New Member

    Wenn das so ist, brauch ich mehr infos: Was genau willst du machen, das nicht funktioniert?
    Was sagt Mozilla zu der problematischen Seite (wenns denn eine ist?)
    Gruß
    carlo

    PS: Bin eigentlichganz einvertanden mit dem IE , aber das ist eine andere baustelle. Schön ist jedenfalls , dass der IE sogar auf seiten von MS teilweise mit scriptfehlern aussteigt...
     
  11. esox

    esox New Member

    Also ich will es mal versuchen. Auf einer Website eines großen Unternehmens klicke ich den Link "Online-Bewerbung" an. Nach der Weiterleitung auf eine Hinweisseite und der Anwahl eines weiteren Links werde ich aber darauf aufmerksam gemacht, "Ein Skriptfehler ist aufgetreten. Einige Skripts der betreffenden Seite werden möglicherweise nicht richtig ausgeführt. Sollen die Skripts der betreffenden Seite fortgesetzt werden." und es tut sich nichts mehr, aber auch gar nichts. Dabei ist es völlig egal ob ich den IE 5.0 oder 5.1 verwende. So weit reicht mein englisch noch.

    Was sagt Mozilla? Meinst Du die Java-Nachriften, die ich nachfolgend einmal kopiert habe?

    7/4/2000 @ 16:0:18
    Java Exception: java.lang.NumberFormatException - null
    Stack Trace:
    java.lang.NumberFormatException: null
    at java.lang.Integer.parseInt(Integer.java)
    at java.lang.Integer.parseInt(Integer.java)
    at DynaButtons.init(Compiled Code)
    at com.apple.mrj.JManager.JMAppletViewer_OLD.doAppletInit(JMAppletViewerOld.java)
    at com.apple.mrj.JManager.JMAppletViewer_OLD.setState(JMAppletViewerOld.java)
    at com.apple.mrj.JManager.JMViewerEvent.post(JMAppletViewerOld.java)
    at com.apple.mrj.JManager.AVDispatcherThread.run(JMAppletViewerOld.java)

    An exception occurred: java.lang.NumberFormatException: null for null
    7/4/2000 @ 16:1:9
    Java Exception: java.lang.NullPointerException -
    Stack Trace:
    java.lang.NullPointerException
    at java.awt.Window.postWindowEvent(Window.java)
    at java.awt.Window.dispose(Window.java)
    at java.awt.Frame.dispose(Frame.java)
    at com.apple.mrj.JManager.JMAppletViewer_OLD.setState(JMAppletViewerOld.java)
    at com.apple.mrj.JManager.JMViewerEvent.post(JMAppletViewerOld.java)
    at com.apple.mrj.JManager.AVDispatcherThread.run(JMAppletViewerOld.java)

    Meine Konfiguration:
    PowerMac G3/233 DT
    System 8.1
    64 MB RAM
    JavaScript 1.03
    JavaScript.component 1.3
    MRJ Enabler 2.2.4
    (bei der Installation von dem Download "MRJ 2.1.4" meldet der "Aktualisierer" die Installation von "MacOS Runtime for Java 2.2.4" und des "Apple Applet Runner")
    InternetExplorer 5.1 engl. (oder 5.0 dt.)

    Danke schon jetzt. Ist ja gar nicht so selbstverständlich, daß sich jemand eines solchen Problems wirklich annimmt. Es ist ein Problem, es sind einfach inzwischen zu viele Seiten für den IE optimiert oder gar daruf abgestimmt. Qaulitätskontrolle gibt es in vieln Unternehmen offensichtlich nicht mehr.

    Beste Grüße
    hc

    Anmerkung: Kann die Sache erst frühestens am Montag weiter bearbeiten.
     
  12. carlo

    carlo New Member

    Hi nochmal,

    das klingt für meine laienhaften ohren nach einer kombination von zwei problemen, die sowohl mit JS als auch mit einem java-applet zu tun hat.
    Leider ist es tatsächlich so, dass die js-implementation in den IE für mac (win kann ich nicht beurteilen) mangelhaft ist.
    Hast du virtualPC oder einen echten pc zur verfügung? Dann probier es mal damit. Ist zwar gegurke, aber wenns akut hilft...
    Kannst du mal eine andere systemversion testen? 8.6 oder ein 9er system?
    Habs nicht genau mehr im überblick, aber probier mal:
    MRJ cache löschen
    MS Internet Cache löschen
    MacJava Prefs löschen
    alle im Prefs-Ordner im Systemordner.

    Wenn das nicht hilft, mal andere browser testen.

    Wenn das auch nicht hilft, woanders bewerben... ;-))

    Cu Montag - schönes WE!
    carlo
     
  13. esox

    esox New Member

    VirtualPC oder einen "echten" PC habe ich leider nicht zur Verfügung. Eine höhere Systemversion schwebt mir schon lange vor, für den konkreten Anlaß ist es dann aber wohl zu spät. Zudem muß ich noch klären, was mit meinem Mac noch so alles möglich ist (G3/233, 64 MB RAM).

    Cache und Preferences löschen hatte ich natürlich schon versucht.

    Woanders bewerben ... Muß ich wohl, ist aber halt auch keine Dauerlösung.

    Die Bewerbung bin ich inzwischen auf normalen Weg (e-mail) losgeworden. Aber jetzt kommts: Habe es mal mit Netscape 4.76 probiert, da funktioniert auch dieses Online-Formular.

    Ist halt alles nicht befriedigend.

    Danke (trotzdem)
    Kannst Dich ja vielleicht noch mal melden.

    hc
     
  14. carlo

    carlo New Member

    Ha, zu spät!

    Hatte schon angefangen, dir von meinem erfolg mit dem alten NS zu schreiebn, da seh ich dein postign. So weit so gut, aber vielleicht sollten die ihr online formular mal überareiten (oder liegts an den browsern? Glaub ich nicht, habe 5 verschiedene durchprobiert und nur einr hat funktioniert...)

    Gruß
    Carlo
     
  15. carlo

    carlo New Member

    Zu dem anderen thema: der 233er ist doch für das meiste wunderbar; spiele halt nicht und so. Was er bräuchte wäre ordentlich ram (bis zum anschlag am besten) und ne flotte platte. Mit 512 Ram und ner quicken 60 gb platte hüpft mein imac 233 wie ein junges reh...

    Nochn gruß
    carlo
     
  16. esox

    esox New Member

    Die Sache ist halt, sich bei einem IT-Unternehmen bewerben und zuallererst an der Website rummäkeln. Zumal man ja nach deren Meinung von einem anderen Stern (Mac) kommt.

    Ansonsten können wir diesen Thread glaube ich schließen. Bleibe aber dabei: 1. MS = Bullshit (muß mit dem aber leider meist arbeiten) und 2. die Situation (manches geht einfach nicht) ist unbefriedigend. Hoffentlich wird es nicht noch schlimmer, sonst müßte man ... Den Gedanken spinne ich jetzt mal nicht weiter.

    Beste Grüße
    hc
     
  17. esox

    esox New Member

    Einfach eine Frage der Finanzierbarkeit. Kannst Du mir da eine ungefähre und unverbindliche Zahl nennen. Dabei bitte auch daran denken, daß ich auch noch einen neuen Drucker benötige, arbeite nämlich tatsächlich noch mit dem StyleWriter II. Wo und wie schließe ich den so ein USB-Teil an?

    Hoffe ich werde jetzt nicht unverschämt, wenn ich gleich wieder einen ganzen Rattenschwanz an Fragen dranhänge.

    Beste Grüße
    hc
     
  18. carlo

    carlo New Member

    1 Neue (d.h. zusätzliche) Platte 60 gb ca. 90-110 EUR
    je nach hersteller und größe und geschwindigkeit (5400 umdrehungen dürfte für deinen rechner reichen)
    2. 2x 256 mb Ram : 2x 50 EUR
    3. ggfls ne usb Pci-Karte ca 40 EUR (interne steckkarte für USB-geräte, benötigt wenigstes system 8.6 soviel ich weiß)
    4. System 8.5/6 oder 9 mal bei ebay gucken (kleines geld)
    (8.5 habe ich noch hier liegen...räusper...update von 8.5 auf 8.6. ist kostenlos).

    Wenn du einen neuen drucker willst, was ich verstehen kann (habe meine Stylie 2 neulich eingemottet), guck doch mal bei ebay nach einem gut erhaltenen laser mit apple-seriell-anschluss, die sind recht günstg, weil alles "neuerdings" auf usb setzt. Ggfls. wär einer mit ethernet-schnittstelle günstig, weil an anderen rechnern weiterverwendbar.

    Soviel auf die schnelle.
    Ob sichs lohnt hängt natürlich davon ab, was du mit der kiste anstellen willst.
    Gruß,carlo
     
  19. esox

    esox New Member

    Wieviel (von mir aus auch direkt an hclarner@addcom.de) willste denn für 8.5? Wo kriege ich 8.6 her?

    Ansonsten halt ... die Finanzen!

    Mit dem Drucker muß ich mir echt was überlegen, aber den Ethernet-Schnittstelle dichtmachen? DSL? Laser seriell? Wie lange kriege ich da überhaupt noch Kartuschen?
     
  20. carlo

    carlo New Member

    Hallo nochmal,
    also wegen der ethernet-schnittstelle würd ich mir keine sorgen machen - hängste einfach einen hub zwischen rechner, drucker und dsl-modem und gut ist.
    Die frage der lieferbarkeit von toner kann ich nicht beantworten, hatte jedenfalls nie ein problem auch für alte (6 jahre+) drucker nachschub zu bekommen. Häufig sind die patronen für die älteren apple-laser eh dieselben wie für drucker anderer hersteller (hat dann nichts mit der schnittstelle zu tun). In meinen LW 12/640 PS gehören z.b. die gleichen kartuschen wie in einen ibm network-printer. Die gibt s in jedem büromarkt (zumindest zu bestellen).
    Gruß,
    carlo
     

Diese Seite empfehlen