kein Euro-Zeichen in 9.2

Dieses Thema im Forum "Software" wurde erstellt von Marrakesch, 14. Januar 2002.

  1. Marrakesch

    Marrakesch New Member

    Ich habe das Problem, daß mein Mac in allen Programmen kein Euro-Zeichen zeigt, allerdings auf dem Desktop funktionierts. Wahrscheinlich habe ich eine Voreinstellung vergessen. Kann mir jemand helfen?
     
  2. MacJoerg

    MacJoerg New Member

    s dann ausdrucke ist's dann doch
    der Euro.

    Gruss
     
  3. Folker

    Folker New Member

    Also, noch mal ganz langsam - das EUR-Zeichen ist ein Zeichen eines Zeichensatzes. Da dieses EUR-Zeichen eine relativ neue Erfindung ist (ä, ö, ü oder auch ß sind viiieeel älter!) ist es leider so, dass ältere Schriften (diese Dateien im Zeichensatz-Ordner im Systemordner) einfach kein EUR-Zeichen besitzen - fuck! Mit neueren, insbesondere die mit dem System (9.x) installierten, Schriften gibt es kein Problem. Ältere Postscript-Fonts (Zeichensätze) kennen dagegen den Euro i.d.R. nicht - nochmals fuck. Auch Drucker mit eigenen Zeichensätzen stellen oftmals ein Problem dar.

    Also, wenn auf dem Bildschirm kein EUR-Zeichen (Option-E auf der Tastatur) zu sehen ist - Zeichensätze im Ordner Zeichensätze im Systemordner checken - wenn hingegen auf dem Bildschirm das EUR-Zeichen dargestellt wird aber im Druck fehlt - Drucker-Zeichensätze checken (die in dem Drucker geladen sind).

    Wenn nun allerdings das EUR-Zeichen in Deiner Geldbörse fehlen sollte - ja, da kann auch ich nicht helfen *g*

    Gruß,
    Folker
     
  4. Marrakesch

    Marrakesch New Member

    Schöne Antwort, aber wie erklärst du mir dann das Phänomen, daß mein Klammeraffe (alt-l) über die Tastatur funktioniert, das Euro-Zeichen (alt-e) aber nicht?
     
  5. Manfred_B

    Manfred_B New Member

    :)

    Der kompetenten Erklärung von Folker ist glaube ich nichts mehr hinzuzufügen, außer meinem Statement. ;-)
     
  6. MacJoerg

    MacJoerg New Member

    s mit 'ner anderen Tastatur probieren?

    Gruss
     
  7. Folker

    Folker New Member

    Das mag an dem verwendeten OS liegen! Das EUR-Zeichen ist der ASCII 219 (Dezimal). Mit System 9.1 ist es Option-E - selbst auf den beigen G3-Rechnern. Wann dieses Feature implementiert wurde kann ich nicht sagen! Mit einem Rechner mit OS 9.1 und einer aktuellen Schrift (wähle mal "Geneva") ist es Option-E.

    Gruß,
    Folker

    PS: PopChar light ist auch da hilfreich&
     
  8. KetelTon

    KetelTon New Member

    Hi Folker,
    habe Deine Ausführungen zum Thema "¬ +@" mit Interesse
    gelesen. Vielleicht kennst Du Dich auch mit folgendem Problem aus:
    Die aktuelle Tastaturbelegung (Mac OS 9.1) funktioniert mit meiner alten
    ADB-Tastatur ohne Murren auf meinem alten PPC 9500, sobald ich
    allerdings eine USB-Tastatur, egal ob original vom iMac oder
    Macally-iWebkey, benutze (logischerweise hat der 9500 kein onboard USB,
    sondern eine PCI-Karte), gerät die Belegung durcheinander.
    Dann wird das @ von shift-2 ausgel;st und noch viel mehr lustige
    Sachen... Keine Angst, ich bin nicht mit einem mal unter die Legasteniker
    gefallen! Aber ich w[_te gern, ob es eine L;sung g'be... Jetzt doch
    wieder die ADB-Taste!
    Danke im Voraus von einem alten Schwartauer an unsere Kreisstadt:)
    Gruß
    Andreas.
     
  9. Folker

    Folker New Member

    Moin Andreas,

    habe Dir ja schon 'ne Mail geschickt - darin steht:
    wenn ich an meiner Tastatur die Belegung U.S. auswähle finde ich das @ Zeichen auf Shift-2! Das ergibt auch noch weiteren lustigen Zeichensalat zB. wird aus y ein z und umgekehrt.
    Wie das nun mit der PCI-Karte zusammenhängt weiß ich so aus der Ferne (eher Nähe *g*) auch nicht - rufe doch mal das Kf Tastatur auf und wähle 2 Belegungen aus, Deutsch und U.S. Du erhälst dann in der Menuleiste oben rechts ein kleines Tastaturmenu (kleines Fähnchen) und überprüfe die aktuelle Belegung nach Wechseln der Tastatur (Achtung, ADB nur bei ausgeschaltetem Rechner umstöpseln - ansonsten droht [kann, nicht muß] ein defekter ADB-Chip!)

    Gruß,
    Folker

    PS: Wow PM - ihr habt ja plötzlich ein ¬-Zeichen im Forum - RESPEKT! ;-)
     
  10. KetelTon

    KetelTon New Member

    Hallo Folker,
    vielen Dank erstmal. Der Tip mit den 2 Belegungen hat leider nichts geändert, anscheinend wird über die USB-Schnittstelle automatisch auf die US-Belegung zugegriffen, obwohl nur "deutsch" ausgewählt ist. Vielleicht der USB-Treiber? Hat sonst jemand ähnliche Probleme/Lösungsvorschläge?
    Danke im Voraus!
    Gruß Andreas.
     

Diese Seite empfehlen