?Kodierungen bei Adobe GoLive?

Dieses Thema im Forum "Software" wurde erstellt von GeorgStieler, 28. September 2001.

  1. GeorgStieler

    GeorgStieler New Member

    Hallo,

    ich soll eine Homepage, die mit MS Frontpage erstellt worden ist, auf einen Server hochladen. Nachdem ich das mit GoLive gemacht habe, zeigt es mir jetzt aber alle ä, ö, ü, ß-Buchstaben falsch an, als Komma, Gänsefüsschen oder so.
    Wenn ich die entsprechenden Dokumente mit GoLive öffne, wird gefragt, ob der Computer sie mit der aktuellen Codierung GL-Western (ISO-8859-1) öffnen soll.
    Wenn ich das tue, zeigt er mir alles korrekt an, beim Hochladen der selbe Fehler. Die einzige Möglichkeit: Ich lösche jedes der oben genannten Zeichen, schreibe es nochmal hin, und speichere das Dokument samt Änderungen.
    Geht das nicht auch einfacher???
     
  2. Convenant

    Convenant Haarfestiger

    Ich glaube am einfachsten ist es wenn du vor dem Upload einfach das html-Dokument mit einem handelsüblichen Editor öffnest (vielleicht BBEdit lite)
    http://www.barebones.com/products/bbedit_lite/lite-download.html

    und dann von hand per suchen und ersetzen

    ä mit ä
    ü mit ü
    ö mit ö
    ß mit ß

    oder geht das vielleicht sogar schon in der Quelltextansicht von Golive?!
     
  3. henningberg

    henningberg New Member

    Das geht auch mit "suchen-ersetzen" in GoLive. Du solltest nur jedes mal bestätigen.
     
  4. Convenant

    Convenant Haarfestiger

    Ach, und wenn es Dich interessiert, den gleichen Spass hast Du beim importieren von Tabellendaten in Dreamweaver. (Nicht dass es jetzt wieder heisst: Pah, dann nimm doch einfach den Dreamweaver, der is viel besser denn GoLive)
     
  5. tazmandevil

    tazmandevil New Member

    das Problem hat auch nix mit GoLive oder Dreamwaver zu tun, sondern ganz einfach mit der Frechheit Microsofts, mittels Frontpage eine andere Sonderzeichen-Methode einzuführen, als sie w3c konform eigentlich wäre!.... *die a.....*... statt ein Encoding am Seitenanfang machen sie (wie aus Word gewohnt) bei jedem Sonderzeihen spezielle Tags hin (die Volldeppen!!!!!!!!!!!)

    (wie in "jedem" (!) MS-Programm sind auch in Frontpage kleine "Fallen" eingebaut, um eine Bearbeitung mit "fremden" Computersystemen zu "behindern"!!! so! und nicht anders, gehört das ausgedrückt! bei mir helfen da auch keine Ausreden und Beteuerungen von MS mehr, die dagegen argumentieren. Ich sehe Täglich die Schwierigkeiten, die sie den plattformübergreiffenden Usern zumuten! Und da zeigt sich, dass MS alles andere als in der Lage ist, einen gültigen Standard zu unterstützen (ausser ihre eigenen, aber selbst da gibt es eine Menge "bugs" (wie es jahre danach immer heisst)!))

    hab auch meine probleme eine FP-Webseite zum Mac zu "konvertieren".....

    Microsoft gehört abgeschaffft!!! Und dass Frontpage Scheisse ist, wissen inzwischen auch einige Webdesigner! (zum glück)
     
  6. Convenant

    Convenant Haarfestiger

    >Und dass Frontpage Scheisse ist, wissen inzwischen auch einige Webdesigner!

    Frontpage - Webdesigner...

    Na das widerspricht sich eh selbst!

    Und beim Tabellendatenimport nach Dreamweaver den ich meine sind ganz gewöhnliche Tab-separierte Tabellendaten, wo einfach die Umlaute nicht im Quelltext umgesetzt werden, sondern als ä (ü,ö ...) übernommen werden.
     
  7. hannibal

    hannibal New Member

    Golives Suchfunktionnen sind ziemlich gut.
    Du kannst sowohl im Layoutmodus, als auch im Quelltextmodus suchen und ersetzten.

    Als erstes in diesem Fall würde ich mal mit verschiedenen isos rumprobieren und mir dann mal genauer die Webeinstellungen ansehen in Golive.
    Wenn das alles nix hilft, dann eine Website anlegen mit den zu bearbeitenden Dateien.
    Dann den Suchdialog holen "In Dateien suchen" aufpoppen.
    Alle Dateinen in das untere Fenster ziehen.
    Dann wird in nur in all diesen Dateien gesucht.
    Dann ein Beispiel-htm öffnen zB im Quellmodus und die besagten Frontpage Sonderzeichen kopieren und entsprechen im Suchdialog einsetzen.
    Bevor Du mit der Methode etwas ersetzt, würde ich erst mal auf "alles suchen" klicken, damit Du weißt ob das auch noch woanders auftuacht und überhaupt.
    Dann das Ersetzten unbedingt erst mal nur an einem einzelnen Doc ausprobieren.
    Dafür nur die Checkbox für "In Dateien suchen" deaktivieren und es an dem Beispiel ausprobieren.
    Wenn das alles hingehauen hat ( auch im Expolorer kucken), dann erst wieder einchecken und "alles ersetzen" klicken.
    Siehe da, es ist dann in allen Dateien geändert.
    Ziemlich mächtige Funktion.
    Hat mir schon unendlich hohe Stundenlöhne verschafft.

    Grüße
     

Diese Seite empfehlen