Lahmer Appstore mit fehlerhaften Bildaufbau

Dieses Thema im Forum "Software" wurde erstellt von Goeplix, 11. Januar 2014.

  1. Goeplix

    Goeplix New Member

    Ein "Hallo" ins Forum,

    eigentlich wünsche ich keinem Mac-User, dass er unter nachfolgendem Problem leidet, aber vielleicht hat trotzdem jemand eine Lösung.

    Mein Problem seit dem Wechsel auf Mountainlion:

    Der Programstart des Appstores dauert unendlich lang (10 min sind keine Seltenheit). Auch das Navigieren im Store nervt mit langen Wartezeiten und macht keinen Spaß mehr. Bei einem App-Download jedoch läuft alles wunderbar mit normalen Downloadzeiten. Auffällig ist, dass bei 80 % der Programmstarts der Appstore einen fehlerhaften Bildaufbau darstellt. Im Anhang ein Screenshot der "Kategorie"-Seite im Appstore, auf welchem dann auch die Verlinkung in die einzelne Kategorie nicht mehr funktioniert.

    Den Anhang $Bildschirmfoto 2014-01-11 um 11.34.38.png betrachten

    In der Google-Suche "Langsamer Appstore" habe ich die Empfehlung gefunden, in der Schlüsselbundverwaltung unter dem Reiter "Zertifikate" die CRL (Certificate Revocation List) auf "Aus" zu stellen. Dieser Tip scheint bei einigen Usern zum Erfolg geführt zu haben, bei mir jedoch ist keinerlei Veränderung im Verhalten des Appstores festzustellen.

    Ich freue mich über Beiträge von Leidensgenossen und Problemlösern!

    Gruß
    Steve Göplix
     
  2. MacS

    MacS Active Member

    Was ist mit Safari, hat Safari auch Probleme? Hintergrund, beide Programme nutzten das Webkit zur Darstellung von HTML. Und auch der AppStore basiert darauf. Daher würde ich Safari zurücksetzen. Und das geht direkt in Safari.
     
  3. Goeplix

    Goeplix New Member

    Anhänge:

  4. MacS

    MacS Active Member

    Lösch mal die Pref-Datei in /Library/Container/com.apple.appstore/Conatiner.plist. Eventuell auch den ganzen Ordner com.apple.appstore.
     
  5. Goeplix

    Goeplix New Member

    Sorry MacS,

    einen Ordner "com.apple.appstore" habe ich nicht. Auch keine Preferences "Container.plist" oder einen Ordner "Container".
    Oder muss ich da versteckte Dateien sichtbar machen? :confused:

    Gruß

    Steve Göplix
     
  6. MacS

    MacS Active Member

    Bist du auch im richtigen Library-Ordner, den in DEINEM User-Verzeichnis! Solche Einstelllungs-Daten werden nämlich User-bezogen abgespeichert und nicht global für alle User!

    Ja, der Ordner ist unsichtbar und wird mit gedrückter alt-Taste und "Gehe zu"-Menü im Finder geöffnet!
     
  7. Goeplix

    Goeplix New Member

    Hallo MacS,

    also ich habe jetzt in meinem Benutzerordner auch den Library-Ordner gefunden. Dort gibt es einige "com.apple. …"-Ordner, die auch jeweils eine Container.plist-Datei beinhalten. Aber einen Ordner "com.apple.appstore" gibt es auch hier nicht (vgl. beiliegender Screenshot mit allen "com.apple. …"-Ordnern, die in der Library zu finden sind.

    Den Anhang $Bildschirmfoto 2014-01-13 um 18.27.30.png betrachten

    Ich hoffe, ich nerve nicht!

    Gruß
    Steve Göplix
     
  8. MacS

    MacS Active Member

  9. Goeplix

    Goeplix New Member

    Hallo MacS,

    so langsam nähern wir uns der Lösung:

    In meinem Preferences-Ordner findet sich ein Dokument "com.apple.appstore.plist" und eine Ausführungsdatei "com.apple.appstore.plist.lockfile". Beide löschen? Kann ich da was kaputt machen?

    Gruß
    Steve Göplix
     
  10. MacS

    MacS Active Member

    Nein, kaputt geht nix, aber wenn du ein Backup hast, dürfte die Frage überflüssig sein, denn per Backup kannst du alles schnell wieder reparieren!
     
  11. Goeplix

    Goeplix New Member

    Hallo MacS,

    nach dem Löschen der Appstore-Preferences startet das Programm deutlich schneller und mit der normalen Oberfläche.
    100% zufrieden bin ich noch nicht; unter Snowleopard war das Programm agiler, aber immerhin rauche ich jetzt in den Wartezeiten spürbar weniger.

    Dir ein großes "Danke"!

    Steve Göplix
     

Diese Seite empfehlen