Langsames Classic

Dieses Thema im Forum "Software" wurde erstellt von bambuu, 11. Februar 2004.

  1. bambuu

    bambuu New Member

    Hallo Forum,

    Folgende Probleme und Fragen: Mit Panther habe ich eigentlich keine Probleme, alle Programme laufen reibungslos. Nur habe ich auf der Classic-Partition ein Programm (Fotostation), das leider noch nicht unter Panther läuft, auf das ich aber angewiesen bin. Und dieses Prog. wird immer wie langsamer, auch wenn ich keine anderen Progs. (weder Classic noch Panther) offen habe. Ich gehe doch recht in der Annahme, dass die Speicherverwaltung über Panther läuft ( im Apfelmenu unter OS 9 bekomme ich beim Versuch, die Speicherzuteilung zu erhöhen die Meldung, dass dieses Kontrollfeld nicht von Panther unterstützt werde)?!
    Meine Frage: Legt Panther irgendwo Informationen ab, die ein Classic-Programm betreffen und die nach und nach das betroffene Programm langsamer machen können, also den CPU übermässig belasten?? Und kann man eventuell diese "Bremser" löschen?? Dieses Programm ist insofern speziell, als dass es unter OS9 nirgendwo im Systemordner irgendwelche Dateien schreibt (also keine Präferenzen etc) und auch keine Systemerweiterungen, Bibliotheken oder Kontrollfelder benötigt ausser einer Erweiterung namens OT Lib Wrapper.

    Danke für Eure Ideen.

    bambuu
    G4, 800MHZ, 1.25GB RAM, MacOS10.3.2:confused:
     
  2. Macci

    Macci ausgewandert.

    In den Systemeinstellungen/Classic/Erweitert kannst du dir den Speicher anschauen, der aktuell von Classic und Classic-Programmen verbraucht wird.

    aber hast du dir schonmal iView Media angeschaut?
    http://www.iview-multimedia.com/

    Das läuft unter Panther und kann alles, was Fotostation auch kann - nur besser!
     
  3. bambuu

    bambuu New Member

    Das hab ich auch schon bemerkt, der Wert bleibt immer in etwa gleich, nur läuft das Programm einfach immer zäher. @macci: sieht wirklich interessant aus, nur muss ich momentan bei Fotostation bleiben, weil wir ein ganzes Netzwerk darauf aufgebaut haben...
     
  4. bambuu

    bambuu New Member

    Hab das Problem gefunden: Fotostation legt in seinem Ordner auf Classic die Thumbnails und Previews der Original-Dateien ab und das Programm lädt diesen cache in den Arbeitsspeicher. Die Grenzwerte waren ganz einfach zu hoch eingestellt... So wurden ganz einfach 500MB in den Arbeitsspeicher eingelesen und benutzt, was OSX dazu veranlasste, virtuellen Speicher zu generieren und die ganze Chose so zu verlangsamen. Die CPU war bis zu 92% dadurch beansprucht. Cache löschen und alles funzt prächtig...

    Im Mai gibt's Fotostation für OSX, Freude herrscht...
    :cool:
    bambuu
     
  5. Macci

    Macci ausgewandert.

Diese Seite empfehlen