Linux und Apple Bootstrap

Dieses Thema im Forum "Hardware" wurde erstellt von henningberg, 19. April 2002.

  1. henningberg

    henningberg New Member

    Sorry, daß diese Mail etwas länger wird, ich denke aber, es kann bei der Fehlerfindung nicht schaden.

    Ich habe Mandrake Linux installiert und jetzt ein Problem mit dem Bootloader. Davor die Mac-Platte partitioniert und 3,6 GB unformatiert für Linux übriggelassen. Der Installer hat diesen freien Disk-Space auch erkannt und Linux da rein installiert. Dabei erhielt ich folgende Fehlermeldung:
    "Die Installatiuon des BS-Starters schlug fehl. Folgender Fehler trat auf: ybin: Error in /etc/yaboot.conf: no entry for `macosx´ found, but default is set to `macosx`.
    <OK>"
    Darauf habe ich Sachen gemacht, von denen ich leider nicht mehr weiß, welche das waren :-0.
    Jedenfalls wollte er anschließend nicht starten.
    Ich habe also brav nach Handbuch beim Neustart Apple-Alt-O-F gedrückt und
    " setenv boot-device hd:10, \:tbxi" Enter eingegeben.
    10 scheint die richtige Partitionsnummer zu sein, den nach einem Neustart wurde ich von folgendem Dialog begrüßt:
    "First Stage GNU/Linux Bootstrap
    Press
    l for Linux
    m for macos
    x for macosx
    c for cdrom
    o for open firmware
    Boot: _"
    Wenn ich l eingebe, startet Linux - so weit, so gut.
    Gebe ich x ein, versucht er sich kurz mit dem Booten von X, dann sieht es aus, als bräche der Bildschirm zusammen und es erscheint wieder der Text "Boot: _"
    Gebe ich m ein, startet - Mac OS X (!). Obwohl Classic auf der gleichen Partition installiert und bootfähig ist.
    Das dümmste daran ist, das die Option "X" meine Standard-Option ist. Ich muß also bei jedem Start dabeisitzen und rechtzeitig meinen Buchstaben eingeben, statt mich darauf verlassen zu können, daß mein Default-System startet.
    Zur Lösung könnte ich nur noch raten:
    1.) Ich drücke beim Neustart Apple-Alt-O-F und gebe
    " setenv boot-device hd:xyz, \:tbxi" Enter ein, wobei xyz die diversen Partitionsnummern sind
    2.) Ich öffne die Datei /etc/yaboot.conf: und tippe ein, was Du mir sagst, damit er wieder einen entry for `macosx´ finds
    3.) Neuinstallieren und auf eine Eingebung hoffen
    4.) oder was?

    Vielen Dank für Eure Hilfe,
    Henning
     
  2. PeterG

    PeterG New Member

    Ich habe vor kurzen auf meinem G4 zu Testzwecken Yellow Dog Linux installiert und habe bei yaboot als Standard-System Linux angegeben. Dann habe ich neu gestartet und die Wahl-Taste gedrueckt, die OS X-Partition ausgewaehlt und unter OS X die OS X-Partition als Startvolume festgelegt. Er startet wie gewohnt OS X. Wenn ich dann mal Linux brauche, wieder beim Neustart die Wahl-Taste gedrueckt halten und von der Linux-Partition booten oder unter OS X die /boot-Partition (die hiess da untitled) als Startvolume auswaehlen.
     
  3. henningberg

    henningberg New Member

    Probiere ich gleich heute Abend aus. Wie stellst Du das denn bei Yaboot ein?Fürchte aber, das klappt nicht, denn mein PB G3 ohne FireWire ist zwischen 9 und X resistent gegen die Wahltaste beim Booten.
    Trotzdem Danke,
    Henning
     
  4. henningberg

    henningberg New Member

    Morgen,
    das hat leider nicht geklappt.
    Du kannst unter OS X die Linux-Partition als Startvolume auswählen? Bei mir wird sie gar nicht erkannt? Wioe hast Du sie denn formatiert?
    Grüße,
    Henning
     
  5. PeterG

    PeterG New Member

    Das Yellow Dog Linux hat mir empfohlen, drei Partitionen anzulegen:

    /swap (virtueller Speicher)
    / (Root-Verzeichnis)
    /boot (fuer Bootloader)

    Letztere Partition ist HFS-formatiert, wird aber nicht automatisch gemountet. Wenn man DiskUtility startet kann man sie sehen (heisst "untitled").
    Ich glaube, die konnte man als Startvolume auswaehlen.
     
  6. henningberg

    henningberg New Member

    Hm..., kann ich leider nicht. Macht aber nix, das kann ich ja in Linux.
    Wie tauschst Du denn Dateien aus mit dem Mac?
    Meine bisher einzige Idee ist, ein altes Wechselplattenteil zu reaktivieren und als UFS zu formatieren.
    Henning
     
  7. henningberg

    henningberg New Member

    Sorry, daß diese Mail etwas länger wird, ich denke aber, es kann bei der Fehlerfindung nicht schaden.

    Ich habe Mandrake Linux installiert und jetzt ein Problem mit dem Bootloader. Davor die Mac-Platte partitioniert und 3,6 GB unformatiert für Linux übriggelassen. Der Installer hat diesen freien Disk-Space auch erkannt und Linux da rein installiert. Dabei erhielt ich folgende Fehlermeldung:
    "Die Installatiuon des BS-Starters schlug fehl. Folgender Fehler trat auf: ybin: Error in /etc/yaboot.conf: no entry for `macosx´ found, but default is set to `macosx`.
    <OK>"
    Darauf habe ich Sachen gemacht, von denen ich leider nicht mehr weiß, welche das waren :-0.
    Jedenfalls wollte er anschließend nicht starten.
    Ich habe also brav nach Handbuch beim Neustart Apple-Alt-O-F gedrückt und
    " setenv boot-device hd:10, \:tbxi" Enter eingegeben.
    10 scheint die richtige Partitionsnummer zu sein, den nach einem Neustart wurde ich von folgendem Dialog begrüßt:
    "First Stage GNU/Linux Bootstrap
    Press
    l for Linux
    m for macos
    x for macosx
    c for cdrom
    o for open firmware
    Boot: _"
    Wenn ich l eingebe, startet Linux - so weit, so gut.
    Gebe ich x ein, versucht er sich kurz mit dem Booten von X, dann sieht es aus, als bräche der Bildschirm zusammen und es erscheint wieder der Text "Boot: _"
    Gebe ich m ein, startet - Mac OS X (!). Obwohl Classic auf der gleichen Partition installiert und bootfähig ist.
    Das dümmste daran ist, das die Option "X" meine Standard-Option ist. Ich muß also bei jedem Start dabeisitzen und rechtzeitig meinen Buchstaben eingeben, statt mich darauf verlassen zu können, daß mein Default-System startet.
    Zur Lösung könnte ich nur noch raten:
    1.) Ich drücke beim Neustart Apple-Alt-O-F und gebe
    " setenv boot-device hd:xyz, \:tbxi" Enter ein, wobei xyz die diversen Partitionsnummern sind
    2.) Ich öffne die Datei /etc/yaboot.conf: und tippe ein, was Du mir sagst, damit er wieder einen entry for `macosx´ finds
    3.) Neuinstallieren und auf eine Eingebung hoffen
    4.) oder was?

    Vielen Dank für Eure Hilfe,
    Henning
     
  8. PeterG

    PeterG New Member

    Ich habe vor kurzen auf meinem G4 zu Testzwecken Yellow Dog Linux installiert und habe bei yaboot als Standard-System Linux angegeben. Dann habe ich neu gestartet und die Wahl-Taste gedrueckt, die OS X-Partition ausgewaehlt und unter OS X die OS X-Partition als Startvolume festgelegt. Er startet wie gewohnt OS X. Wenn ich dann mal Linux brauche, wieder beim Neustart die Wahl-Taste gedrueckt halten und von der Linux-Partition booten oder unter OS X die /boot-Partition (die hiess da untitled) als Startvolume auswaehlen.
     
  9. henningberg

    henningberg New Member

    Probiere ich gleich heute Abend aus. Wie stellst Du das denn bei Yaboot ein?Fürchte aber, das klappt nicht, denn mein PB G3 ohne FireWire ist zwischen 9 und X resistent gegen die Wahltaste beim Booten.
    Trotzdem Danke,
    Henning
     
  10. henningberg

    henningberg New Member

    Morgen,
    das hat leider nicht geklappt.
    Du kannst unter OS X die Linux-Partition als Startvolume auswählen? Bei mir wird sie gar nicht erkannt? Wioe hast Du sie denn formatiert?
    Grüße,
    Henning
     
  11. PeterG

    PeterG New Member

    Das Yellow Dog Linux hat mir empfohlen, drei Partitionen anzulegen:

    /swap (virtueller Speicher)
    / (Root-Verzeichnis)
    /boot (fuer Bootloader)

    Letztere Partition ist HFS-formatiert, wird aber nicht automatisch gemountet. Wenn man DiskUtility startet kann man sie sehen (heisst "untitled").
    Ich glaube, die konnte man als Startvolume auswaehlen.
     
  12. henningberg

    henningberg New Member

    Hm..., kann ich leider nicht. Macht aber nix, das kann ich ja in Linux.
    Wie tauschst Du denn Dateien aus mit dem Mac?
    Meine bisher einzige Idee ist, ein altes Wechselplattenteil zu reaktivieren und als UFS zu formatieren.
    Henning
     

Diese Seite empfehlen