Mac erhält IP-Adresse, trotzdem kein Internetzugang möglich.

Dieses Thema im Forum "Software" wurde erstellt von cord-aob, 18. Juli 2009.

  1. cord-aob

    cord-aob New Member

    Hallo Liebe community

    Ich hab folgendes Problem: seit dem Gewitter gestern ging das Internet nicht mehr richtig. Ich habe den Anbieter informiert und dieser hat nen Server resetten lassen. Seither geht das Internet am Laptop meiner mitbewohnerin wieder, nur meines halt Garnicht mehr. Ich habe also mich etwas belesen und anschliessend geprüft, ob ich vom dhcp-Server immer brav neue IPs bekomme. Dies ist auch der Fall, nur gelange ich nicht ins Internet mit der Begründung:

    "Ethernet hat eine selbst zugewiesene IP-Adresse und kann möglicherweise nicht auf das Internet Zugreifen."

    Ich hoffe jemand hat nen Geistesblitz und kann mir helfen.

    Vielen dank im vorraus.
    Cord
     
  2. geebee

    geebee New Member

    Probiere doch einmal einen Ping auf den Router und auf das Modem abzusetzen - dann wäre einmal sicher gestellt, das dein Netzwerk funktioniert.

    Geht so: Terminal öffenen: dann "ping xxx.xxx.xxx.xxx
    wobei xxx.xxx.xxx.xxx für die TCP Adresse des Gerätes steht das du pingen möchtest
    Die Antworten kanst du dann mit CRTL & C abbrechen

    Wenn dein Netzwerk funktioniert, ist noch lange nicht gesagt, dass du auch ins Internet kommst - kontroliere auch ob du die richtigen DNS Adressen zugewiesen bekommst.
     
  3. MacS

    MacS Active Member

    Irrtum! Wie die Fehlermeldung dir sagt, hat dein Rechner eben doch keine IP bekommen und der Mac hat sich daher kurzerhand eine eigene Adresse zugeteilt. Die aber passt nicht in den Nummernbereich, den der Router vergibt. Meist dürfte die selbst zugeteilte Adresse mit 168.x.x.x beginnen, während der Router meist eine 192.x.x.x vergibt.

    Kontrolliere die Verbindung. Ist Kabel OK? Oder hat vielleicht der Ethernet-Port deines Macs durch das Gewitter einen Schuss bekommen? Erscheint der noch im SystemProfiler?
     
  4. cord-aob

    cord-aob New Member

    Sowohl Ethernet-Port als auch Airport werden angezeigt und beide sind als "verbunden" gekennzeichnet. Ich hab das mit dem Airport auch mal versucht, da kommt die selbe Fehlermeldung.

    Außerdem lief das Internet ja nach dem Gewitter noch. Erst nachdem der Anbieter heute Mittag unseren anschluss resettet hat, geht nichts mehr.

    Zum dns-Server: da hab ich Nummer für

    - primär: 192.168.1.1
    - sekundär: 62.53.180.102
     
  5. MacS

    MacS Active Member

    Die DNS-Server wollte ich jetzt nicht wissen, sondern die IP des Routers (wird 192.168.1.1 sein, der Router ist dann DNS-Proxy) und die deines Macs. Diese muss dann auch mit 192.168.1.x anfangen, wobei x nicht 1 und nicht 254 und 255 lauten darf.
     
  6. cord-aob

    cord-aob New Member

    Zu meiner Schande muss ich zugeben, das ich keine Ahnung hab wo ich die herbekomme, die dns-Adressen hab ich bei meiner MitBewonherin Abgelesen und da hat mich mir so ziemlich alles genau angeschaut und nichts weiter gefunden.

    Konnte mir aber Vorstellen das ich die ip des routers mir vom Anbieter geben lassen muss, bzw das es schon die oben genannte ist. Aber woher bekomm ich die vom Mac? Bzw was soll ich dann machen?
     
  7. cord-aob

    cord-aob New Member

    Ne zusätzliche Info. Hab das gerät mal angepingt und von den packeten die losgeschickt wurden sind 100% verloren gegangen...
     
  8. MacS

    MacS Active Member

    Nein, der Provider kann dir auch nicht die LAN-IP deines Routers oder Macs nennen, denn die liegen im privaten Netz, Der Router hat allerdings auch eine WAN-IP, die der Provider dynamisch vergibt, also bei jedem Verbindungsaufbau des Routers bekommt der eine neue! Was "hinter" dem Router im lokalen Netz passiert, kann und darf dem Provider nicht interessieren. Ein Router ist ein Bindeglied zwischen weltweitem Netz und dem lokalen Netz, erkennbar auch am IP-Adressbereich, denn der 192.168er Adressbereich ist ausschließlich für lokale Netze reserviert
     

    Anhänge:

  9. yew

    yew Active Member

    Hi MacS
    normalerweise wird aber vom System eine 169.254.x.x Adresse vergebeen (APIPA = Automatic Private IP Adressing).

    Kämpfe gerade hier in der Firma mit dem gleichen Problem.

    Fakt ist, dass der Rechner keine Adresse per DHCP bekommt und sich dann selber eine zuweist. Im Moment hilft bei mir nur die Vergabe einer statischen Adresse. Das Problem liegt aber definitiv beim Router. Vielleicht dort einen kompletten Reset machen.
    Hier in der Firma ist die Sachlage noch etwas komplizierter, da mehrere Router installiert sind, aber das ist ein anderes Thema.

    Gruß yew
    aus Istanbul
     
  10. MacS

    MacS Active Member

    Danke yew, so genau wusste ich das nicht, aber das ist das übliche Verhalten (fast) aller Betriebssysteme, selbst unter 9 war mir das aufgefallen, wenn sich der alte Router mal wieder aufgehängt hatte.

    Solange Client und Router nicht im gleichen Nummernbereich liegen, werden die Datenpakete vom Client auch nicht über den Router ins Internet und zurück transportiert.

    Was auch seien kann: der DHCP-Server im Router ist so konfiguriert, dass er nur einen eingeschränkten Bereich vergibt. Ist der Bereich erschöpft, werden keine weiteren IPs vergeben. Abhilfe könnte sein, den Router mal neu zu starten.
     
  11. mac-christian

    mac-christian Active Member

    Also beim Mac gehst du wie folgt vor:

    Apfelmenü -> Systemeinstellungen -> Netzwerk -> Ethernet *
    oder
    Apfelmenü -> Systemeinstellungen -> Netzwerk -> Airport -> Konfigurieren... *

    (* je nach Verbindungsart... wenn du dein Mac per Kabel mit dem Router verbunden ist, ist es Ethernet, wenn drahtlos, dann Airport).

    Dann gehst du auf den Reiter "TCP/IP" und sagst uns, was dort eingestellt ist.

    Und vielleicht noch, was deine Mitbewohnerin für Einstellungen hat. Wenn es ein Mac ist, weisst du ja, wie es geht. Bei Windows:

    - Ein DOS-Fenster aufmachen und eingeben:

    ipconfig /all (Entertaste)

    Dann solltest du etwa eine Nachricht bekommen die so aussieht wie diese:

    Code:
    Windows-IP-Konfiguration
     
     Hostname. . . . . . . . . . . . . : TESTPC
     Primäres DNS-Suffix . . . . . . . :
     Knotentyp . . . . . . . . . . . . : Hybrid
     IP-Routing aktiviert. . . . . . . : Nein
     WINS-Proxy aktiviert. . . . . . . : Nein
     
    Ethernetadapter LAN-Verbindung:
      
     Verbindungsspezifisches DNS-Suffix: t-online.de
     Beschreibung. . . . . . . . . . . : Intel(R) PRO/100
     Physikalische Adresse . . . . . . : 00-0C-B1-2E-D5-E2
     DHCP aktiviert. . . . . . . . . . : Ja
     Autokonfiguration aktiviert . . . : Ja
     IP-Adresse. . . . . . . . . . . . : 192.168.168.20
     Subnetzmaske. . . . . . . . . . . : 255.255.255.0
     Standardgateway . . . . . . . . . : 192.168.168.1
     DHCP-Server . . . . . . . . . . . : 192.168.168.1
     DNS-Server. . . . . . . . . . . . : 192.168.168.1
     Lease erhalten. . . . . . . . . . : Dienstag, 30. August 2005
     Lease läuft ab. . . . . . . . . . : Dienstag, 30. August 2005
    
    Christian
     
  12. cord-aob

    cord-aob New Member

    vielen dank für diese sehr genau Erklärung. Ab so Schlimm ist mein Wissenstand nicht^^

    Also der stand der Dinge:

    - sowohl Ethernet als auch Airport bestätigen mir eine verbindung
    - im tcp/ip Fenster hab ich zuerst ipv6 deaktiviert, weiterhin hab ich im
    Ipv4 Bereich dhcp ausgewahlt ( er sollte also selber eine ip holen)
    - dns-Server und router laufen unter 192.168.1.1
    -Teilnetzmaske: 255.255.255.0
    -Problem sind halt die ip-Adressen die er auswählt, wenn ich das richtig verstanden hab ( danke an die gute Vorarbeit von macS und den anderen): er gibt mir Zahlen wie
    Zb.: 169.254.180.184 welche für das eigene kleine Netzwerk sind.
    - nach einem "ping-Test" im Terminal weis ich das 100% der Packet verloren gehen
    - meine mitbewohnerin kann ich leider zur Zeit nicht damit belästigen, die ist weg. Aber da sie beteuerte: nichts an ihren Windows extra eingestellt zu haben, wird wahrscheinlich ein ähnliches Bild, wie deines erscheinen.

    Hoffe das hilft
     
  13. yew

    yew Active Member

    Hi
    wie wir es eben schon vermutet haben.
    Deswegen sollst du als allererstes mal den Router resetten. Wenn das nicht hilft, bleibt momentan wohl oder übel nur die Möglichkeit, mit der statischen Adressenvergabe.
    Das heißt, du legst dir eine eigene Konfiguration an, in der du dir eine eigene Adresse aus dem korrekten Bereich 192.168.1.x vergibst. 1 ist aber schon für den Router reserviert.

    Gruß yew
    aus Istanbul
     
  14. cord-aob

    cord-aob New Member

    das hab ich schonmal versucht mit: 192.168.1.11 aber so komm ich auch noch rein.
    Die Zahl muss ich ja auch irgendwie den router verdeutlichen. Aber ich kann mich nicht einwahlen.

    Bevor ich schon wieder vergesse zu schreiben: den router hab ich schon öfters restettet und hab dann sogar darauf gewartet bis alles online war, bevor ich den Mac hochgefahren habe.
     
  15. yew

    yew Active Member

    Hi
    ein Versuch wäre es auch wert, beim Router DHCP auszuschalten, das ganze zu sichern, und dann wieder DHCP einzuschalten und ebenfalls wieder zu sichern.

    Die nächste Punkt wäre zu prüfen, ob die aktuellste Firmware beim Router installiert ist und gegebenfalls hier ein Update zu machen.
    Einen zweiten Router hast du wahrscheinlich nicht, ob mit dem das gleiche Problem auftritt, oder?

    Welches Betriebssystem hast du auf deinem Rechner installiert?

    Eine zweite Konfiguration für das Netzwerk zu erstellen ist eigentlich kein Problem.

    Gruß yew
    aus Istanbul
     
  16. MacS

    MacS Active Member

    Da es sowohl mit Airport als auch Ethernet zum gleichen Fehler kommt, vermute ich das Problem schon am Router. Hängt noch ein Switch zwischen Mac und Router? Hast dz den auch schon mal resettet.? Ansonsten müsstest du dir mal die Router-Konfiguration kontrollieren (DHCP). Oder hat der Router durch das Gewitter gelitten? Steckt doch einfach mal das Ethernet-Kabel zu deinem Rechner um...
     
  17. cord-aob

    cord-aob New Member

    hab ich schon hinter mir, ich mit einem defintiv funktionstuechtigen, zum Zeitpunkt des Gewitters unangeschlossenen, Kabel alle 4 Ethernet Eingänge getestet.
    Weitere switches haben wir nicht.
    Ich habe geprüft ob meine Mac-Adresse evtl gesperrt ist -negativ.
    Ich habe auch versucht über das Terminal Mit "sudo Serveradmin Stop dhcp" und "Start dhcp" das ganze mal zu resetten ging aber nicht, das Terminal wollte kein Passwort annehmen.
    Außerdem über libary->preferences->systemconfiguration die .plist Dokumente gelöscht. Das hat aber auch nicht gebracht, spätestens heute Abend hab ich zugriff auf ein anderes Netz. Sollt dann also Wissen ob es nen schaden am Mac oder router ist.
     
  18. yew

    yew Active Member

    Hi
    du meinst 4 Ethernet Ausgänge. Der Router hat normalerweise nur einen Eingang ;-)

    Mac-Adrdessenfreigabe im Router kontrollieren, war schon mal nicht schlecht, können wir also als Fehlerquelle ausschalten.

    Mit dem Terminal kenne ich mich leider nicht aus, da sind andere Spezialisten gefragt.

    Aber nochmals auf ein älteres Posting zurückzukommen. Du schreibst:
    >>das hab ich schonmal versucht mit: 192.168.1.11 aber so komm ich auch noch rein.
    Die Zahl muss ich ja auch irgendwie den router verdeutlichen. Aber ich kann mich nicht einwahlen<<

    Hast du jetzt durch die manuelle Addressvergabe ins Internet einwählen können oder nicht??
    Was meinst du auch noch mit >> muss ich ja auch irgendwie dem Router verdeutlichen< ??

    Normalerweise ist die Netzwerkkonfiguration (Ethernet, Airport...) auf automatisch eingestellt, also du bekommst eine IP per DHCP zugewiesen. Klar, du kannst die Einstellung ändern auf manuell, ist aber umständlich.
    Besser ist, du legst dir dazu eine neue Umgebung an. Kann ich dir momentan nur erklären, wie es unter 10.4.11 funktioniert. Bei 10.5 müsste ich auch erst nachsehen.

    Wenn du mehrere Konfigurationen (Umgebungen) hast, brauchst du dann nur unter Apfelmenü>Umgebung>neue Konfiguration auswählen und das war's. Dauert keine 2 Sekunden.

    Eine neue Konfiguration (Umgebung) erstellst du so:
    Systemeinstellungen>Netzwerk>Umgebung>neue Umgebung>Benennung der neuen Umgebung>Konfigurieren>TCP/IP>manuell>... und dann vergibst du dir eine statische IP>dann auf "Jetzt anwenden" und eine neue Umgebung ist erstellt.

    Da ich selber sehr viel unterwegs bin, habe ich mir für sehr viele Hotels, in denen es notwendig ist, eigene Umgebungen angelegt. Brauch nur noch die Umgebung auswählen, anstatt jedes mal die Konfiguration zu ändern. Die Auswahl der Umgebung hab ich dir ja schon gesagt, geht dann über Apfelmenü>Umgebung

    Vielleicht bringt es auch was, mal den Kanal zu ändern.

    Was ist übrigens im Routermenü bei DHCP für eine Release-time eingestellt?

    Der Router merkt sich deine MAC-Addresse und vergibt dir dann per DHCP eine freie Addresse. Angenommen, du hast gestern 192.168.1.3 bekommen, dann kriegst du die gleiche IP wieder innerhalb der eingestellten Release-time. Ist diese Zeit überschritten, bekommst du die nächste freie IP und das kann eine ganz andere als vorher sein.
    Wäre möglich, dass gerade diese IP die du die ganze Zeit bekommst, Probleme macht. Vielleicht geht es ja per DHCP aber mit einer anderen Addresse. Deswegen auch der Vorschlag mit einer statischen Addresse, dann umgehst du das Problem mit der automatischen Vergabe einer möglicherweise nicht einwandfreien IP.

    Wie sowas passieren kann, kann ich dir leider nicht erklären, aber ich habe festgestellt, dass es teilweise besser ist, man vergibt die Addresse statisch, also manuell.

    Ich hoffe, das war jetzt nicht zu viel für dich ;-)



    Gruß yew
    aus Istanbul
     
  19. mac-christian

    mac-christian Active Member

    Sorry.

    169er-Adressen sind APIPA / selbst zugewiesene Adressen. Die gibts, wenn der Verbindungsaufbau zum DHCP-Server nicht klappt. Mit solchen Adressen wirst du nie ins Internet oder auch nur zum Router kommen. 169er Adressenn sind _nicht_ die Norm für ein internes Netzwerk.

    Verwundert mich nicht, 169.x.x.x ist nicht im gleichen Netz wie 192.168.x.x.
    Hat der Router eine Zugriffsbeschränkung nach MAC-Adresse?

    Christian
     
  20. cord-aob

    cord-aob New Member

    Hihi...ne, alles ok^^

    Komisch, hab die Statische verteilung schonmal Versucht. Auch die neue Umgebung. Aber ich bin echt nicht auf die Idee gekommen, das einfach zu Kombinieren^^

    hab das jetzt mal getan und mit 5 verschieden kummen zwischen 1 und 200 getestet, aber es läuft nicht.

    Also auf den router einwahlen kann ich mich nicht.
     

Diese Seite empfehlen