Mac Pro – Hängt bei Neustart / Spotlight funktioniert nicht

Dieses Thema im Forum "Software" wurde erstellt von kochenlinus, 31. Dezember 2006.

  1. kochenlinus

    kochenlinus New Member

    Habe festgestellt, dass mein Mac Pro, wenn ich neu starte, hängen bleibt. Er fährt runter und beim Neustart bleibt der Schirm schwarz. Dabei klingt es, als suche er im DVD Laufwerk nach einer DVD. Und dies stundenlang, wenn ich nicht mittels langem Drücken des Einschaltknopfes ausschalte.
    Das Komische: Wenn ich normal einschalte, startet der Mac auch völlig normal. Der Fehler taucht also nur auf, wenn das Teil aus laufendem Betrieb heraus neu gestartet werden soll, also leider auch bei Installationen und ähnlichem.
    Als Startvolumen ist das interne Laufwerk definiert. Rechte sind repariert. PRAM löschen geht nicht, weil er sich bei drücken der PRAM Tastaturkombination ebenso aufhängt, wie bei einem Neustart.
    Der Fehler tauchte glaub ich nach einem Update auf 10.4.8 zum ersten Mal auf. Zumindest hab ich’s da das erste Mal bemerkt. Also Neuinstallation (10.4.7), und was ist? Keine Änderung. Der Fehler besteht weiterhin. Firmware ist aktuell, Laufwerk laut Dienstprogramm in Ordnung. Jetzt weiß ich mir keinen Rat mehr.
    Gleichzeitig bemerkte ich, dass Spotlight nicht mehr funktioniert. Nach der Neuinstallation funktionierte es, allerdings nur bis zum ersten Aufhänger nach Neustart. Danach war Essig. Spotlightindex löschen mittels Terminal hat nichts gebracht. Onyx auch nicht. In den Systemeinstellungen für Spotlight lassen sich auch keine Ordner mehr definieren, in denen nicht gesucht werden soll (Privatsphäre). Apple F Suche funktioniert allerdings noch. Fragen über Fragen. Hat jemand eine Idee? Das Teil ist übrigens ein Refurbished Model, 2,66 GHZ, 2 GB, Airportkarte.
     
  2. ghostgerd

    ghostgerd New Member

    vielleicht mal en hardware test laufen lassen
    irgendwo muß ja der wurm drinnen sein
     
  3. TomPo

    TomPo Active Member

    >Das Teil ist übrigens ein Refurbished Model

    Ist denn der Grund für das 'Refurbished' bekannt (welcher Defekt lag vor)?
    Wenn das Logicboard das Problem war, und genau dieser Fehler tritt nun erneut auf, glaube ich nicht, dass AHT diesen Fehler auch aufzeigt. Aus diesem Grund würde ich nie ein solches Produkt kaufen, sei es noch so günstig.

    Ich würde zunächst mal den Pro komplett herunterfahren. Einige Minuten warten, einschalten und unmittelbar danach die PRAM-Tastenkombination drücken und festhalten. Abwarten was dann passiert. Löscht er nun das PRAM?

    Helfen könnte auch ein reboot mit gedrückter SHIFT-Taste, und auch dabei beobachten, wie sich der Mac verhält. Der Startvorgang dauert hierbei u.U. deutlich länger.

    Booten in den Single User Modus und ein fsck laufen lassen. Eventuell sind hier wichtige Systemdateien unbrauchbar/defekt, dann reparieren. Notfalls mehrfach laufen lassen. Ein fsck sollte man ruhig gelegentlich mal ausführen.
     
  4. Macziege

    Macziege New Member

    Hallo kochenlinus und willkommen im Forum.

    Du schreibst leider nichts über Deine Erfahrungen mit Mac's.

    Nach Deiner Beschreibung sieht es für mich eher aus, als hättest Du wichtige Systemdateien innerhalb des Mac's verschoben oder gelöscht.
     
  5. kochenlinus

    kochenlinus New Member

    Danke erst mal für Eure Antworten.
    Ich arbeite schon länger mit MACs (seit Os 8.6) und bin, denk ich, nicht ganz unbeleckt. Allerdings kann man viele Erfahrungen mit Power PCs nicht einfach auf Intel MACs übertragen.
    Ich denke übrigens nicht, dass Systemdateien gelöscht worden sind, wie gesagt, der Fehler trat direkt nach einer sauberen Neuinstallation wieder auf. Nur System, sonst nix. Werde Singel User Harddiskcheck laufen lassen und dann mal Bericht erstatten.
    Gibt es beim Intel Mac eigentlich eine Möglichkeit wie beim Power PC, über eine Art Open Firmware den PRAM zu löschen? Die herkömmliche Art versagt nämlich, wie eingangs beschrieben.
    Im Apple Store versichterte man mir übrigens telefonisch, dass die Refurbished Geräte technisch Neugeräten entsprächen und mit neuen Komponenten ausgestattet sind. Wenn alles nicht fruchtet, muss ich das Teil wohl einschicken.
     
  6. mac_the_mighty

    mac_the_mighty New Member

    Refurbished Geräte kann man immerhin in den ersten zwei Wochen zurück geben, wenn sie einen Defekt aufweisen. Wenn der Zeitraum vorbei ist, wird wohl eine Reparatur anstehen, sollte ein Hardwaredefekt vorliegen.

    Vielleicht hilft auch ein Reset des SMC etwas:
    http://docs.info.apple.com/article.html?artnum=304123

    Viel Erfolg!
     
  7. kochenlinus

    kochenlinus New Member

    Erst mal frohes Neues alle zusammen!
    Kleine Zwischenstandsmeldung:
    Der Mac bootet wieder korrekt. Nach nochmaliger Neuinstallation und dreimaligem PRAM löschen bleibt er (hoffentlich) nicht mehr hängen. Warum das PRAM sich auf einmal löschen ließ... keine Ahnung.
    Spotlight und Apfel F funktionierten nach der Neuinstallation. Dann neu gestartet, Spotlight funktionierte nicht mehr. Spotlight sucht einfach nicht. Index per Terminal erneuert, Index per "Ordner in Privatspäre ziehen Methode" erneuert, Single User fsck durchgeführt, Rechte repariert, Hardwaretest durchgeführt (noch in Zusammenhang mit der Boot-Geschichte). Dann neuen Benutzer angelegt: Hier funktioniert Spotlight. Neustart, Spotlight funktioniert jetzt auch beim neuen Benutzer nicht mehr! Jetzt kommt's: Nochmal Cleaninstall. Absolut jungfräulich, keine "Fremddateien", keine anderen Programme. Nichts angeschlossen, außer Bildschirm, Maus und Tastatur. Spotlight funktioniert. Nach Neustart wieder Essig. Hä? Was soll das sein? Kann es unter Umständen damit zusammen hängen, dass ich den Mac nach dem Ausschalten mittels Steckerleiste immer vom Netzt trenne? Kann ich mir zwar nicht vorstellen, aber reagieren die Teile da vielleicht empfindlich? Irgeneiner eine Idee? Bin mit meinem Latein jetzt völlig am Ende.
    Ach ja, wenn Spotlight einen neuen Index anlegt und ich in die Lupe klicke, meldet es auch, dass es einen neuen Index erstellt und ich mit voraussichtlich 16 Minuten Wartezeit rechen muss. Dann springt die Anzeige plötzlich auf 6 Sekunden, rödelt ein bisschen und das wars. Das Ganze dauert kaum eine Minute.
     
  8. kochenlinus

    kochenlinus New Member

    Zweiter Nachtrag.
    Die Sache mit dem Neustartfehler lag mit großer Wahrscheinlichkeit an zwei nachgerüsteten 512 MB Speicherbausteinen der Firma ONE, die ich im Web gekauft hatte und die Infineon Chips beinhalten sollen. Nach dem Ausbau der Riegel bootet der Mac wieder ganz normal. Werd wohl andere einbauen müssen.
    Die Spotligtsache wird hingegen immer kurioser. Nach endlosem Ausprobieren hab ich festgestellt, dass die Datei Library/Preferences/SystemConfiguration/preferences.plist für den Fehler verantwortlich ist. (Im Wurzelverzeichnis, nicht im User Ordner)
    Lösche ich die Datei, funktioniert Spotlight und Apfel F nach dem Neustart wieder. Nehme ich allerdings irgendeine Netzwerkeinstellung vor (egal, was), wird die Datei vom System wieder erzeugt und nach dem nächsten booten ist es wieder Essig mit Spotlight und Apfel F. Wie gesagt, das alles bei einem frisch installierten System! Hat einer vielleicht ähnliche Erfahrungen? Bin mal gespannt, was der Apple Support dazu sagen wird.
     
  9. kochenlinus

    kochenlinus New Member

    Es liegt an Ethernet! Folgender Fehler tritt reproduzierbar auf.
    Der Pro Mac (10.4.7) läuft, ich stecke ein Ethernetkabel in einen der Ports und verbinde den Pro Mac mit meinem Powerbook. Die Verbindung steht, ich kann aufs Powerbook zugreifen. Spotlight funktioniert.
    Ich melde das Powerbook wieder vom Mac Pro ab, in dem ich das Festplattensymbol auswerfe und starte den Mac Pro neu. Das Kabel bleibt dabei in beiden Rechnern stecken. Jetzt funktioniert Spotlight nicht mehr. Ich kann auch nicht mehr vom Mac Pro auf das Powerbook zugreifen. Versuche ich es trotzdem, hängt sich der Finder auf. Drehender SAT Ball bis zur Unendlichkeit.
    Das einzige, was jetzt hilft: Ethernetkabel ziehen, und neu starten. (Das oben beschrieben Löschen der Datei preferences.plist erübrigt sich auf diese Weise)
    Nach Neustart ohne Kabel funktioniert Spotlight wieder. Ich könnte jetzt wieder einstecken und die Verbindung herstellen u.s.w.
    Das würde aber bedeuten, dass ich jedes Mal, wenn ich eine Verbindung per Ethernet herstellen möchte, dass Kabel einstecken und anschließend wieder ausstecken müsste...
    Es ist dabei völlig unmaßgeblich, mit welchem Rechner ich die Verbindung herstelle, bzw. was für ein Kabel ich benutze. (Hab mehrere ausprobiert) Auch ist es egal, ob der Gastrechner eingeschaltet ist oder nicht. Sobald ein Ethernetkabel in der Buchse steckt und mit einem anderen Rechner verbunden ist, funktioniert Spotlight nach einem Neustart nicht mehr und eine Verbindung über Ethernet ist nicht mehr möglich. Allerdings nur, wenn eine Direktverbindung per Ethernet zwischen zwei Macs oder Mac und PC erfolgt. Über einen Router und Airport gibt’s keine Probleme.
    Aber jetzt kommt's! Ich hab dieselbe Prozedur mal mit meinem Powerbook probiert, also mit vertauschten Rollen. Und siehe da: Der Fehler taucht auch auf meinem Powerbook (10.4.8) auf! Hab's dann mit meinem dritten Mac versucht, einem iMac G5 (10.4.8). Resultat: das Selbe! Hardware ist also definitiv unbeteiligt.
    Bug im System? Es muss doch möglich sein, eine Ethernetverbindung zwischen zwei Rechnern physikalisch bestehen zu lassen, wenn man die Rechner ausschaltet. Selbst Win98 kann das.
    Einer 'ne Idee? Der Apple Support grübelt auch schon.
     
  10. Nille

    Nille New Member

    leider keine Idee...
    aber wie bekommt man das denn wieder heil, wenn man den Fehler einma gemacht hat?
    Bei mir ist es heute passiert, dass nen Ethernet Kabel rausgerutscht ist, während ich im Internet war.
    Durch die fehlende Verbindung hat sich Firefox aufgehängt, was dann den ganzen Mac mitgerissen hat....

    Und nun geht Spotlight nicht mehr. Aber nun habe ich irgendwie nicht ganz rauslesen können, wie man das einmal repariert. Ich habe nun nicht lust, mein System neu zu installieren...
     
  11. kochenlinus

    kochenlinus New Member

    Hallo.
    In Deinem Fall würd ich erst mal den Spotlight Index neu anlegen. (Wie das geht steht hier mehrfach im Forum - mal suchen)
    Wenn's nix bringt und Du eine ähnlich harte Nuss am Start hast wie ich, versuch mal, die Datei Library/Preferences/SystemConfiguration/preferences.plist zu löschen, bzw. auf den Desktop zu ziehen (hab ich oben beschrieben) und dann neustarten. Allerdings musst Du dann Deine Netzwerkeinstellungen neu eingeben.
    Falls das auch nicht fruchtet - wilkommen im Club!
    Die Jungs vom Apple Support (freundlich, kompetent und interessiert) meinten übrigens zu meiner großen Freude, sie könnten den Ethernet-Spotlight Fehler bei sich reproduzieren, wenn einer der verbundenen Computer einen User mit einem Umlaut im Namen hat. (Ist bei mir so)
    Hab darauf alle Umlaute im Usernamen ersetzt. Leider keine Besserung. Aber die Jungs von Apple bleiben am Ball.
     

Diese Seite empfehlen