MacBook Air mit Wlan-Problem

Dieses Thema im Forum "Hardware" wurde erstellt von Chrigu41, 27. April 2015.

  1. Chrigu41

    Chrigu41 Member

    Seit einiger Zeit dauert es Minuten, bis ich mit meinem MacBook Air ins Netz komme. Der Mac ist relativ neu und alle Programme sind stets auf dem aktuellen Stand.

    Eigenartig ist folgendes: Im Haus habe ich einen guten Router und besten sowie schnellen Empfang. Meine Frau kann mit ihrem iMac sofort nach dem Aufstarten mailen und surfen. Das kann ich ebenfalls mit iPhone und iPad. Am Netz liegt es also nicht, offensichtlich auch nicht an der Verbindung zu meinem MacBook. Bestätigt finde ich das in meinen Netzwerkeinstellungen, die melden "WLAN ist mit X verbunden und hat die IP-ASdresse Y".

    Dennoch: Öffne ich Safari und gebe eine Adresse ein, dann bleibt der Fortschrittsbalken nach etwa einem Viertel stecken. Auch mailen kann ich vorderhand nicht. Erst nach einigen Minuten setzt sich der Fortschrittsbalken fort. Ab nun ist surfen und mailen kein Problem. Schliesse ich den Deckel des MacBooks bzw. unterbreche ich die Arbeit am Gerät für einige Zeit, dann geht das Theater wieder von vorne an.

    Es muss also am MacBook Air liegen, denn eine Verbindung steht, wird aber offenbar anfangs regelrecht ausgebremst. Da auch Mail betroffen ist, liegt es nicht am Broswer, denn neben Safari verhält sich Firefox gleich. Irgend ein verdächtiges Programm habe ich auch nicht geladen. (Einen Virenscanner habe ich nicht installiert. Kurzzeitig hatte ich Avira, diesen aber nach ein paar Tagen meines Erachtens vollständig gelöscht.)

    Wer, wo, was ist der Bremsklotz? Wer kann mir helfen?

    Danke, Chrigu
     
  2. mac-christian

    mac-christian Active Member

    Hast du irgendwas neues installiert (oder was de-installiert), was die Änderung hätte hervorrufen können?

    Marke / Modell des Routers?

    Und das MacOS - hat das eine Versionsnummer?

    Bitte definiere Y (und die Netzmaske, die dazu gehört), sowie die IP-Adresse (nach innen) deines Routers. Systemeinstellungen -> Netzwerk -> WLAN -> Weitere Optionen -> TCP/IP
    Den Anhang $Bildschirmfoto 2015-04-27 um 17.09.58.jpg betrachten

    Es gibt durchaus Router, die maximal eine bestimmte Anzahl von Teilnehmern "bedienen" können. Bekannte Beispiele waren die Zyxel PxxxME, die konnten nur 4 IP-Adressen bedienen.

    Christian
     
  3. Chrigu41

    Chrigu41 Member

    Lieber Christian, Du machst es mir schwer. Also:

    - Neuinstallation oder De-Installation: So genau kann ich das nicht sagen. Gemäss Programmordner: nein. Aktualisiert vermutlich den Flash Player von Adobe.

    - Marke/Modell des Routers: absolut neuster Router von Swisscom. Aber der kann es vermutlich nicht sein, weil iPad, iPhone und Mac meiner Frau ja einwandfrei gehen. Es liegt somit eher an meinem McBook Air.

    - Mac OS: 10.10.3

    -"bitte definiere...":

    Den Anhang $Bildschirmfoto 2015-04-27 um 18.47.25.png betrachten

    Bemerken möchte ich noch:
    1. Bis vor kurzem hatte ich nie Probleme (in der Regel sind auch höchstens zwei Geräte gleichzeitig im Netz)
    2. Auch nach einem Neustart bei gedrückter Umschalttaste verhält es sich wie beschrieben.

    Chrigu dankt

    Nachtrag
    Und hier noch als Nachtrag das identische Bild auf dem iMac meiner Frau:

    Den Anhang $Doris.png betrachten
     
  4. MacS

    MacS Active Member

    Lösch mal die WLAN-Einstellungen und richte die Einstellungen neu ein. Könnte Wunder wirken. Auch das Passwort im Schlüsselbund löschen.
     
  5. Chrigu41

    Chrigu41 Member

    Jetzt bin ich aber überfordert. Wie und wo lösche ich die WLAN-Einstellungen? - Und wo im Schlüsselbund kann ich das Passwort (welches?) löschen?

    Und noch eine Frage: Gibt es nicht in der pers. Library unter Prefs diverse Internet-plist. Was ist damit (Anhang)?

    Den Anhang $plist.png betrachten

    Aber es ist schon spät. Das mache ich morgen. Danke und gute Nacht
    Chrigu
     
  6. MacS

    MacS Active Member

  7. Chrigu41

    Chrigu41 Member

    Das habe ich nun so gemacht, MacS, und ich denke, dass ich es richtig gemacht habe. Gebracht hat es aber nichts. Im Unterschied zu den anderen Geräten warte ich mit meinem MacBook Air minutenlang, bis Mail und Safari reagieren, obwohl das WLAN gemäss "Netzwerk" (Systemeinstellungen) von Anfang an mit dem Router verbunden ist.

    Bin ich einmal im Netz, dann läuft es flüssig; aber unterbrechen darf ich diese Tätigkeit nur für kurze Momente, sonst bleibt alles wieder minutenlang stehen.

    Wo, zum Teufel, liegt der Hund?
    Das fragt Chrigu

    Nachtrag: Ich habe den Mac nun einmal mit dem Gast-Account gestartet. Surfen geht sofort. Hilft diese Erkenntnis weiter?
     
  8. MacS

    MacS Active Member

    2 Versuche zur Einkreisung des Problems fallen mir ein:
    1. Öffne die Netzwerkeinstellungen und schicke den Rechner in den Ruhezustand. Was passiert, sobald der Rechner aufwacht? Hat der Rechner nach dem Aufwachen eine gültige IP? Sonstige Auffälligkeiten?

    2. Schau dir - oh Graus - die geloggten Meldungen in der Konsole an. Alle Einträge nach dem "wake up", die auf WLAN, WiFi oder Airport hindeuten, sind von Bedeutung. Gibt es evtl. Fehlereinträge? Ich weiss, die Konsole ist für reine Anwender ein Graus, aber dort könnten die entscheidenden Hinweise kommen. Sollte man immer mal zu Rate ziehen und nicht sofort entnervt aufgeben...

    Grundsätzlich kann es auch sein, dass einfach der im MacBook verwendete WiFi-Chipsatz und der im Router sich nicht so ganz mögen und mehrere Anläufe für den Verbindungsaufbau brauchen. Und was auch ein Problem seien kann: gibt es in der Nachbarschaft weitere Netze, die auf gleichen oder benachbarten Kanälen funken. Auch wenn iMac das Problem nicht hat, so kann schon geringfügig Änderungen der Position große Wirkung haben.
     
  9. mac-christian

    mac-christian Active Member

    Mh - Swisscom ist nicht grade bekannt dafür, dass sie die besten Router haben. Aber normalerweise funktionieren sie auch.

    Das glaube ich dir nicht. iPhone, iPad und Co. fragen nicht ob du sie ins Netz lassen willst - die verbinden einfach, wenn ihnen danach ist. Ausserdem hast du evtl. noch andere Geräte, an die du grade nicht denkst (netzwerkfähige Drucker, z.B.).

    Du kannst ja mal im Router schauen, wie viele Geräte angemeldet sind über WLAN und wie viele über Kabel. Allerdings kann ich dir nicht sagen, wie du das bei einem Swisscom-Router machen musst...

    Die Einstellungen sehen jedenfalls in Ordnung aus. Kannst du dein MacBook Air mal an einem anderen WLAN ausprobieren? Ist das Verhalten dann gleich, oder läuft es besser?

    Christian
     
  10. Chrigu41

    Chrigu41 Member

  11. MacS

    MacS Active Member

    Da sehe ich nicht wirklich was von Airport und Fehler. Ich sehe nur, dass "callservicesd" 5 mal vergeblich versucht zu starten. Dazu habe ich Google angeworfen und das hier gefunden: https://discussions.apple.com/thread/6629829

    Schau mal, wie der BSD-Gerätename von der WLAN-Karte (bzw. Airport) ist. Müsste "en1" z.B. sein. Das findest du unter dem Systemprofiler: Den Anhang $Bildschirmfoto 2015-04-28 um 20.55.32.png betrachten
    Und dann nochmals den Logfile nach der Schnittstelle und Fehler durchsuchen.
     
  12. Chrigu41

    Chrigu41 Member

    Langsam stosse ich an meine Grenzen... Zunächst musste ich herausfinden, was der Systemprofiler ist. Dann glaube ich ihn gefunden zu haben. Hier ein Bild:

    Den Anhang $BSD Gerätename.png betrachten

    Nur sagt mir das überhaupt nichts. Und den Satz "Und dann nochmals den Logfile nach der Schnittstelle und Fehler durchsuchen." verstehe ich ganz einfach nicht.

    Ich glaube, ich gebs auf und lebe damit, dass ich jedes Mal Minuten warten muss, bis ich ins Netz komme. Als Rentner habe ich ja Zeit...

    Apple macht es einfachen Anwendern nicht leicht: Zu jedem Programm, zu jeder Aktion, zu jeder Einstellung sind unzählige Dateien an unzähligen Orten abgelegt. Wer so am Berg steht wie ich derzeit, der hat letztlich nur die Möglichkeit, alles platt zu machen und vollständig neu zu installieren. Aber diesen Aufwand scheue ich, zumal ich zwei oder drei Programme habe, die teuer und in der von mir verwendeten (älteren) Version vermutlich nicht mehr erhältlich sind.
     
  13. MacS

    MacS Active Member

    Aha, also en0 ist der Gerätenamen für die WLAN-Schnittstelle. In der Konsole dürfte dann unter en0 die Einträge gesucht werden, die auf Error oder auch Warning beinhalten. Wenn du da nicht fündig wirst, weiss ich auch nicht weiter. Wie ist das denn beim Neustart? Auch so mühevoll?
     
  14. Chrigu41

    Chrigu41 Member

    Also, lieber MacS, ein letzter Versuch:

    Nach der Mittagspause (nach 13 Uhr) habe ich den Deckel des MacBook Air geöffnet und wollte umgehend ins Netz. Das hat wieder gedauert. Nach langem Warten und endlich Netzverbindung habe ich dann in der Konsole nach "en0" gesucht. Das Log-File hänge ich hier als PDF an. Dabei fällt mir das Wort "Warning" auf, aber mir sagt das nichts. Lässt sich daraus etwas ableiten?

    Danke, Chrigu

    Den Anhang $Alle Meldungen.pdf betrachten

    Wenn keine Indizien vorhanden sind, überlege ich mir allen Ernstes nun doch einen Clean-Install. Ich habe ja alles(!) doppelt gesichert (Time Machine und CCC). Also Festplatte löschen, Yosemite neu installieren und dann alle Programme sauber neu installieren (die meisten aus dem "App Store"; hoffentlich auch iPhoto).

    Ich denke, dass ich den reinen Datenordner sowie allenfalls die beiden Ordner Musik und Bilder, ohne Müll mitzuschleppen, einfach kopieren kann. Vor allem - und hier scheint der "Hund" zu liegen - werden dann die vielen Library-Ordner völlig neu eingerichtet. Davon verspreche ich mir die Lösung.

    Vor zwei Dingen habe ich etwas Respekt:
    - wo sind die Daten des Schlüsselbunds gespeichert? Wie heisst die Datei?
    - wo sind die Mail-Accounts gespeichert und wie heisst die Datei? So muss ich zumindest diese heikle Aufgabe nicht machen.

    Anleitungen, wie man den Mac dafür vorbereitet, hat es im Netz genug.

    Gruss, Chrigu
     
  15. MacS

    MacS Active Member

    Zunächst verwirrt mich, ich suche in deinem Listing "System sleep" bzw. "System wake-up"?! Wo wacht der der Rechner in deinem Listing auf? Was ich auch sehe, gibt es wohl Probleme mit Bonjour. Davon wurde und wird schon in anderen Foren diskutiert. Ich würde daher erstmal die Füße still halten und 10.10.4 warten.

    Wenn du einen Clean Install machen willst, dann ist dein Ansatz schon richtig. Bei iPhoto allerdings wirst du das nicht mehr (ziemlich unverständlich übrigens) aus dem AppStore laden können. Da musst du eines deiner Backups bemühen.

    Die Nutzerdaten würde ich nach der Installation des Programms aus dem TM-Backup zurückholen. Da du bei TM direkt in die Ordner navigierst, wo die Daten/Dateien stehen, kannst du dir durch zurückgehen in der Zeitachse die Daten ausfindig machen.
     
  16. Chrigu41

    Chrigu41 Member

    Im Netz habe ich angefügte Notiz gefunden, die von mehreren Lesern als erlösende und zuverlässige Lösung taxiert worden ist. Nun habe ich es auch gewagt, selbst wenn allseits vor Änderungen im Library-Ordner gewarnt wird. Und siehe da: Es ist offensichtlich die Lösung! Für wie lange, dass weiss ich nicht, aber im Moment jedenfalls habe ich keine Wlan-Probleme mehr mit meinem MacBook Air.

    Danke an alle, die sich zu diesem Thema engagiert haben, Chrigu

    Den Anhang $Wlan-Problem.png betrachten
     

Diese Seite empfehlen