Macbook pro und Windows XP problem

Dieses Thema im Forum "Software" wurde erstellt von maczucker, 1. Juni 2007.

  1. maczucker

    maczucker New Member

    Hallo,

    ich hab ein Problem. Ich wollte Windows xp nochmal neu aufspielen, hab cd eingelegt, formatiert und dann hat er die windows dateien auf die platte kopiet. Alles gut. Sobald ich neugestartet habe kommt ein schwarzes bild mit der Meldung:

    windows could not start because the following file is missing or corrupt: hal.dll

    Ich dachte, die cd hätte nicht ordentlich auf die Platte kopiert also habe ich nochmal formatiert. Hatte aber leider nichts gebracht. Immer noch dieselbe Meldung.

    Kennt jemand das Problem und konnte es beheben?

    Kann mir bitte jemand weiterhelfen?

    Liegt es evt an Bootcamp? An der Partition??
     
  2. TomPo

    TomPo Active Member

    >Sobald ich neugestartet habe ...

    Vielleicht liegt es genau daran ...
    denn idR startet Bootcamp das Win-System von selbst (nach Kopieren der Installationsdateien), wobei anschliessend die eigentliche Installation nahezu von selbst abläuft. Mit dem Kopieren alleine ist noch keine Install. getan.
    Oder die Boot-CD ist defekt?!
     
  3. DominoXML

    DominoXML New Member

    Hi,

    auf deiner XP-CD muß explizit "enthält SP2" stehen, sonst kommen je nach Version (SP1, SP1A etc.) die unterschiedlichsten Meldungen, daß was nicht gefunden wurde.

    Gruß

    Volker
     
  4. maczucker

    maczucker New Member


    Lies doch mal genau was ich geschrieben habe!
    Und ja es enthält SP2!
     
  5. DominoXML

    DominoXML New Member

    Sorry,

    wer lesen kann ist klar im Vorteil.
    Ich geh mal googeln.

    Gruß

    Volker
     
  6. DominoXML

    DominoXML New Member

    Hi,

    von den MS-Supportseiten:

    Ursache
    Dieses Verhalten kann auftreten, wenn eine oder mehrere der folgenden Bedingungen erfüllt sind:
    • Der Wert Default im Abschnitt [Boot Loader] der Datei "Boot.ini" fehlt oder ist ungültig.
    • Windows XP ist nicht in dem Verzeichnis installiert, das in der Datei "Boot.ini" angegeben ist.
    • Die Datei "Ntoskrnl.exe" fehlt oder ist beschädigt.
    • Der Partitionspfad in der Datei "Boot.ini" ist nicht korrekt festgelegt.
    • Es liegt ein allgemeiner Hardwarefehler vor.


    Wie bist Du genau vorgegangen? Vielleicht können wir es zusammen hinkriegen.

    Gruß

    Volker

    P.S. Persönlich tippe ich auf die Boot.ini. Hierzu folgeder Link.

    http://pcsupport.about.com/od/fixtheproblem/ht/repairbootini.htm
     
  7. maczucker

    maczucker New Member

    Auch ich habe gegoogelt,

    habe aber gelesen dass man die boot.ini datei selbst auf den Pfad C: kopieren solle. Aber auch das soll angeblich nicht helfen. Man sollte vorher das wiederherstellungsprogramm von xp starten und bootcfg /rebuild eintippen etc.

    Aber das hat alles nicht geholfen. Das erste mal wo ich xp installiert hatte, hatte ich das problem überhaupt nicht. Konnte xp einwandfrei installieren.

    Nun kann ich nichts mehr machen, und ich weiß auch nicht woran das genau liegt........
     
  8. DominoXML

    DominoXML New Member

    Wollen wir's Schritt für Schritt zusammen Versuchen?

    Was kam bei bootcfg /rebuild? Was sagt fdisk?
     
  9. maczucker

    maczucker New Member

    Wie willst du schritt für schritt versuchen?

    Hast du selbst ein MBP? Hast du dasselbe Problem?
     
  10. DominoXML

    DominoXML New Member

    Nein, nen iMac C2D und min. 100 Win-Installationen "auf dem Buckel".

    Momentan hab ich nur ne Vermutung:

    Boot Camp ist lediglich ein "Enabler" damit Windows sich installieren läßt.
    Der Mac hat bekannlich kein BIOS, deshalb muß mittels Boot Camp die Installation vorbereitet werden.

    Ich vermute, daß hier bereits das Problem liegt und die Partition / Festplatte Win XP nicht bekannt ist.

    Deshalb der Vorschlag von Anfang an.

    Wenn ich Recht habe, dann solltest Du erst mal folgende Schritte ausführen:

    1. Mac OS Starten und Boot Camp auf die neueste Version Updaten, sofern noch nicht geschehen.

    2. Nachdem Boot Camp aktualisiert ist bitte mit dem Assistenten die Win Partition löschen, neu Booten und dann den Assistenten neu Ausführen.
    Wenn die BootCamp aktualisiert hast brenne bitte auch eine neue Treiber-CD.

    Danach mittels Assistent neu Starten.

    Wenn von dieser Seite alles OK ist und die Installation immer noch nicht funzt, dann liegen wir definitiv auf der Windows-Seite.

    Dazu dann später mehr.

    Gruß

    Volker
     
  11. maczucker

    maczucker New Member



    Ok danke, ich teste das mal, dann berichte ich nochmal hier wenns geklappt hat.
     
  12. maczucker

    maczucker New Member

    hab wieder ein kleines problem,

    hab bootcamp gestartet und ich wollte auf die andere partition installieren, aber momentan ist nur das andere laufwerk zu sehen das von osx. im festplattendienstprogramm ist das andere laufwerk für xp zu sehen. Nun wollte ich formatieren so dass ich auf das laufwerk für xp installieren kann.

    nun kommt da eine fehlermeldung wie:


    Sicheres Löschen des freien Speichers fehlgeschlagen

    Das sichere Löschen des freien Speichers ist mit folgendem Fehler fehlgeschlagen:

    Ein Medium mit Mount-Point wird benötigt.


    Was kann ich da machen?
     
  13. DominoXML

    DominoXML New Member

    Hi,

    schön und nicht schön. "Schön" weil hier, wie vermutet, das Problem mit der Windows Installation liegt.

    Unschön, da so eine zerschossene Partitionstabelle erst mal repariert sein will.

    Ich les mal nach. Hast du eine Möglichkeit deine OSX - Partition zu sichern bzw. zu klonen? mach mal ein Backup zur Sicherheit.

    Kann passieren, daß beim Reparturversuch danach gar nichts mehr geht und wir beide Systeme neu aufsetzen müssen.

    Denke darüber nach und melde mich in einigen Minuten.


    Volker

    P.S. Bin eh noch am Programmieren und schätze bis 1:00 verfügbar.
     
  14. maczucker

    maczucker New Member

    Hm ich habe nicht wirklich lust ein backup zu machen weil das recht lange dauert. Ich finde das muss doch echt nicht sein. Irgendwie muss das doch gehen..... :frown:
     
  15. DominoXML

    DominoXML New Member

    Riskant, aber auf deine Verantwortung......

    Hoffentlich wird dann aus :frown: nicht :cry:

    Hab nen Lösungsansatz. Auf eigene Gefahr......
     
  16. DominoXML

    DominoXML New Member

    Wie ist der Status der Partition? Leer, ntfs formatiert? hast du nen screenshot vom Festplattendienstprogramm?

    Eigentlich sollte der Bootcamp Assistent folgende Möglichkeiten anbieten:

    1. Treiber CD brennen
    2. Installation Starten
    3. Partion löschen und und beide Partionen wieder zusammen fügen

    (zumindest sinngemäß, ein formatieren der Partition ausserhalb des Bootcamp-Assistenten oder der XP-Installationsroutine halte ich nicht für Praktikabel. Ehr schon ein löschen der XP-Partition.
     
  17. maczucker

    maczucker New Member

    So, es hat sich jetzt endlich erledigt. Also ich bin so vorgegangen:

    Ich habe das alte boot camp gestartet und von da aus die Partition von xp gelöscht und zusammengefügt. Dann habe ich das alte boot camp gelöscht und die neue drauf gemacht und gestartet. Und eine neue partition angelegt und die neuen treiber gebrannt und von boot camp neugestartet in die xp installation.

    Habs formatiert und neu aufgespielt. Es funktioniert jetzt ohne probleme.

    Vom festplattendienstprogramm xp löschen geht nicht. Man macht das alles über bootcamp.

    Puh war das eine lange schweinerei.

    So und ich denke das müsste bei dir auch ohne probleme funktionieren.

    Das alte OSX ist noch da.
     
  18. DominoXML

    DominoXML New Member

    Good Job und gute Nacht.

    Hab noch ein halbes Stündchen drauf gepackt.

    Verwendest Du eigentlich die neuen ATI Treiber speziell für Bootcamp?

    Sollen doppelt so schnell sein.

    Gruß

    Volker

    http://www.macwelt.de/news/346040/index.html

    P.S.: Ich habe schon länger kein Boot Camp mehr im Einsatz deshalb kein Problem mit. Muß daran arbeiten klarer zu Formulieren.
     
  19. maczucker

    maczucker New Member



    Ich hab das mal installiert als du es erwähnt hattest. Aber ob das wirklich einen Unterschied gibt? Habe ich noch nicht getestet.

    Nun es läuft alles wunderbar. Am besten immer mit Boot Camp partitionieren und windows installieren. Sonst geht das schon mal gar nicht. ;)
     

Diese Seite empfehlen