mime codierung

Dieses Thema im Forum "Software" wurde erstellt von apfiputz, 5. November 2001.

  1. apfiputz

    apfiputz New Member

    wollte ein imehl mit jpeg bildchen an pcs verschicken (hab outlook express, windows codierung). kam nicht an.
    habs in ein gif verwandelt... traraa.... kam an. aber nicht bei allen.
    bei einem, ders nicht bekam (UTA) stand im quelltext, daß das mime format nicht unterstützt wird.
    wie krieg ich das jetzt hin, daß alle das bildchen kriegen und gleich im imehlprogramm sehen (also nicht gestufft oder so).
    und was bitte is mime, außer irgendein codierungsdings?
     
  2. DonRene

    DonRene New Member

    hi

    da musst du garnix machen, einfach apple double lassen, das sollte gehen. ich mach da nie was dran und noch nix gehört das meine pc freunde das net sehen können

    rene
     
  3. MACrama

    MACrama New Member

    meine antwort war dir wohl net gut genug??? *hmpf*

    *grins*

    ra.ma.
     
  4. airwalk

    airwalk New Member

    Beim Verschicken von Mails mit Attachement per Outlook kommt es immer wieder vor, daß der Empfänger eine leere Mail erhält (egal, welchen Emailer dieser benutzt). Das ganze passiert beim Versenden von Mails mit der deutschen Outlook Version.
    Der Grund:
    Die Mail wird von Outlook im MIME-Format kodiert. Für den Mailtext und für
    das Attachement wird jeweils ein eigener MIME-Abschnitt in der Mail angelegt. Für ältere Emailer, die diese Abschnitte nicht erkennen, wird ein alternativer Text (in klassischer Art) vorangestellt, der darüber informiert, daß diese Mail im MIME-Format vorliegt, und daher evtl. etwas komisch aussehen könnte. Diesen Text sehen nur Leute mit veralteten Emailern. Und genau in diesem Info-Text liegt der Fehler! Der Text lautet nämlich folgendermaßen:

    > Diese Nachricht ist im MIME-Format. Da Ihr Mailreader dieses Format nicht unterstützt, könnte diese Nachricht ganz oder teilweise unlesbar sein.

    Der Fehler daran sind nun die deutschen Umlaute! Outlook kodiert diese nicht richtig, sondern verschickt sie "wie sie sind". Und solche Zeichen sind nicht in Emails erlaubt, und so mancher Mail-Server verschluckt sich dann an dieser Mail. Dabei tritt ein weiterer unglücklicher Zufall auf: Wenn der Mailserver das oberste Bit des Zeichens "ö" (am Mac hat es den Wert 154) abschneidet (da nur 7 Bit Zeichen erlaubt sind), so kommt dabei das Zeichen mit dem Wert 26 heraus. Dummerweise ist das das "EOF"-Zeichen (End-Of-File), und daher wird genau an dieser Stelle vom so manchem Mailserver das Ende der Mail erkannt.
    Die Mail kommt dann beim Empfänger ziemlich leer an ...

    Die Lösung des Problems ist ganz einfach:

    Man muß Outlook Express auf ResEdit ziehen und dann die "TEXT"-Resourcen öffnen. Dort öffnet man die Resource mit Titel "MIME Preamble" und ersetzt dort die Umlaute "ü" und "ö" z.B. durch "ue" und "oe". Danach funktioniert wieder alles.

    (Eine bessere Lösung wäre, wenn Microsoft die MIME-Preamble ebenfalls korrekt kodieren würde, wie es ja bei der restlichen Mail gemacht wird. Naja...)

    Das ganze bezieht sich auf Outlook Express 5 Macintosh Edition in deutscher Version genauso wie auf Entourage für Mac. Den Bugfix macht man am besten an einer Sicherheitskopie von Outlook.
    Alles ohne Gewähr.

    it's just so easy!
     
  5. DonRene

    DonRene New Member

    das mit entourage und en umlauten hab ich auch schon gehört.
    wie ist das mit oe 5.02? ist das problem da weg. ich hatte nämlich noch nie welche beim verschicken

    rene
     
  6. airwalk

    airwalk New Member

    ist auch so ... kann sein dass du noch die probs hattest beim verschicken ... kommt drauf an, über welche servers deine e-mail geht, bis sie zum empfänger gelangt. eben, auf die server kommt es drauf an.
     
  7. DonRene

    DonRene New Member

    ja das weiß ich das es auf die server ankommt ob die mails so ankommen wie sie sollen. wobei aber z.b der t-online mail server oder der verwendete standard prädestiniert dafür sein soll das mails nicht so ankommen wie sie sollen.

    mit macnews.de und mac.com funzt das vei mir bis jetzt ales wunderbar. wichtigere dinge sollte man ohnehin stuffen vor dem verschicken
     
  8. apfiputz

    apfiputz New Member

    danke jungs! oh mann, ich hab noch nie mit resedit rumgepfuscht. zeit wirds!

    @macrama: wollte doch nur eine 2. meinung hören.... :) *entzückendlächel*
     
  9. DonRene

    DonRene New Member

    versuch es doch einfach mal mit dem messenger vom ns naviagor vielleicht funtzs ja oder nimm eudora kostet auch nix. www.eudora.com

    bevor du dir mit res edit einen abbrichst ;-)

    rene
     
  10. apfiputz

    apfiputz New Member

    das eudora gfallt ma nicht. is mir irgendwie unsympatisch. weiß nicht warum.
    außerdem pfusch ich gern irgendwo rum! kann ja nix passieren. notfalls setz ich halt den mac neu auf... ;-)
    netscape muß ich mir noch anschaun. aber ich find den ie doch so hübsch...
    brauch aber ja nur den messenger verwenden.
     
  11. DonRene

    DonRene New Member

    bei versiontracker gibt es seit heute ein neues powermail, das is fast so wie oe.

    mir gefällt eudora auch nicht ;-)

    rene
     
  12. apfiputz

    apfiputz New Member

    oh, prima, werd ich ausprobieren!!!

    da fallt ma ein... hat das ganze eigentlich was damit zu tun, ob das bildchen als cmyc oder als rgb abgspeichert wurde? kann das sein?
    es is nämlich mal als rgb jpeg gangen, als cmyc aber nicht.
     
  13. MACrama

    MACrama New Member

    hi

    windosen können nur rgb pictures aufmachen, es sei den die haben photoshop...

    ra.ma.
     
  14. apfiputz

    apfiputz New Member

    uuuuups!
    so was blödes aber auch....
    ;-)
     

Diese Seite empfehlen