mldonkey für Fortgeschrittene

Dieses Thema im Forum "Hardware" wurde erstellt von baltar, 8. Februar 2003.

  1. baltar

    baltar New Member

    Man will 10 oder 100000 Server Connecten, weniger eMule User Upload Slots zur Verfügung Stellen oder einfach nur 500
    OvernetClients Connecten bwz. einfach nur bei den eMule Usern nicht auf Platz 999 landen u.s.w. u.s.w.
    Mit den Fertig Kompilierten mldonkey ist das nicht Möglich.

    Die letzte CVS mldonkey Version ist drausen, warum noch auf eine Downloadseite warten??

    Von mldonkey liegt wie von vieler guter Unix Soft der Quellcode vor.
    D.h. Alles ist auch OHNE Programmierkenntnisse machbar.

    Voraussetzung:

    mldonkey sollte laufen.
    Overnet sowieso!
    Prefereces Optimierung sollte auch kein Thema sein.
    Die Donkey_Gui Installation unter X (xfree86 oder X11 von Apple) war leicht nachvollziehbar.
    Unterm Strich: Man ist ein Dau wie ich!
    Wenn man diesen "Level" *Buntie Klickie* Erreicht hat :) kann man Sofort loslegen!

    Auf geht es:
    Man braucht ocaml-3.06 und lablgtk.
    Bei http://caml.inria.fr/ocaml/distrib.html gibt es die 1 X Klick Installation u. lablgtk lasse
    ich beim Kompilieren Automatisch laden.....
    Also auf ocaml.pkg Klicken u. Installieren.

    Terminal Starten u. Zielpfad auswählen wo der Ordner mldonkey erstellt werden soll.
    (Natürlich sollte man Online sein :))) )
    Dann:
    cvs -d:pserver:anoncvs@subversions.gnu.org:/cvsroot/mldonkey login
    (password: einfach enter drücken)
    Dann
    cvs -z3 -d:pserver:anoncvs@subversions.gnu.org:/cvsroot/mldonkey co mldonkey

    Nun hat man den Ordner mldonkey erzeugt.
    Dort kann man im Ordner donkey die Daten *.ml leicht Editieren u. an die Eigenen Bedürfnisse anpassen.
    Das erste mal alles einfach mal so lassen!
    Ist man Ferig.
    ./configure --enable-batch --enable-checks
    Eingeben im mldonkey Ordner (online sollte man sein da lablgtk nachgeladen wird)
    dann
    make depend
    danach
    make
    Eingeben.
    Das wars schon.
    Jetzt hat man SEINE Eigene mldonkey Version basierend auf der letzten CVS!

    Wie immer viel Spaß.

    Link: http://mldonkey.org/ Dort gibt es immer gute Infos u. Postings zu dem Thema.

    MfG
     
  2. mikropu

    mikropu New Member

    baltar! Oh gott ... jetzt geht das wieder los. ;))

    na gut - ich werde gleich ins X gehen und das mal probieren.
    Und natürlcih werde ich schon bei schritt 1 verzweifeln und die welt verfluchen... hrhrhr.

    bis bald :p

    putte
     
  3. charly68

    charly68 Gast

    sind die alten dl futsch oder kann ich die dann noch benutzen?? dann warte ich erstmal mit dem fummeln und basteln *g*
     
  4. baltar

    baltar New Member

    Die alten Downloads sind NIE futsch solange du die files.ini temp u. Incoming Ordner Kopierst!

    Man muß ja auch nicht den alten Esel Ordner überschreiben. Seine Eigene Version kann man ja mit kopierten temp, Incoming u. files.ini Dateien nutzen.

    @mikropu: Wie bei einem Spiel geht es immer weiter! Wer Spielt einen Level 2 oder sogar 10X ??? :))

    MfG
     
  5. charly68

    charly68 Gast

    fuzzt , nur mit den alten dl files nicht. da schmiert das teil ab.
     
  6. baltar

    baltar New Member

    Bisher hatte ich da keine Probs.

    Wie schmiert ab? Welche Fehlermeldung?

    MfG
     
  7. charly68

    charly68 Gast

    kaum zu glauben aber wahr. mit bus error.
     
  8. baltar

    baltar New Member

    Welche Version von mldonkey nutzt du?

    Mfg
     
  9. charly68

    charly68 Gast

    MLDonkey 2.02-9
     
  10. baltar

    baltar New Member

    Also, welche DL Files von welcher Version funktionieren nicht mit Version -9 ???

    Stehe da gerade etwas auf dem Schlauch :)

    MfG
     
  11. charly68

    charly68 Gast

    also temp,incoming ordner und die datei filie.ini rüber kopiert. neue version gestartet und bus error.
     
  12. baltar

    baltar New Member

    Achso die neu kompilierte, ja hatte ich auch aber wie oben geschrieben:
    ./configure --enable-batch --enable-checks
    sollte diesen fehler verhindern!

    MfG
     
  13. charly68

    charly68 Gast

    das hab ich ja gemacht. trotzdem bus error.
     
  14. baltar

    baltar New Member

    Nutzt du die letzte DevTools vom Dez 2002?

    MfG
     
  15. charly68

    charly68 Gast

    nein, eine version davor die mit den dual 867 ausgeliefert wurde.
     
  16. baltar

    baltar New Member

    Da kommst du wohl nicht ums Neuladen rum.

    MfG
     
  17. charly68

    charly68 Gast

    bin schon dabei. alten dl weggeworfen. alles neu rein. in 5 min bin ich fertig. was solls.
     

Diese Seite empfehlen