Modem Sharing

Dieses Thema im Forum "Software" wurde erstellt von Macci, 17. November 2004.

  1. Macci

    Macci ausgewandert.

    Es geht ums ganz normale 56k.
    (keine Kommentare dazu :tongue: )

    Also: iMac hängt an der Telefondose
    PB hängt über Ethernet am iMac (später natürlich über Airport)
    iMac kann mit Remote Desktop fernbedient werden.
    Also möchte ich die Internetverbindung fürs PB nutzen.
    iMac 192.168.0.2
    PB 192.168.0.1

    Beim iMac Internetfreigabe für Ethernet-verbundene Macs freigegeben.
    Am PB den iMac als Router in den Ethernet-Einstellungen angegeben.

    Funktioniert aber nicht. Geht das nur mit DSL?
     
  2. 1zip

    1zip New Member

    hehe...gefunden...aber da bin ich wohl nicht der richtige...werd mir das aber mal merken...:party:
     
  3. graphitto

    graphitto Wanderer

    Hi macci,

    schön, das ich dir auch mal helfen kann.

    Also, die I-Net-Freigabe macht nix anderes als eine bestehende Internetverbindung freizugeben.
    Heißt also, du mußt erst mit dem iMac online gehen um dann die Verbindung vom PB aus zu nutzen. War es das?

    gruß
     
  4. Macci

    Macci ausgewandert.

    Nee, das wars nicht. Ich hab mir das so vorgestellt: vom PB aus über Remote Desktop den iMac einwählen lassen (funktioniert) und die dann bestehende Verbindung am PB nutzen (funktioniert nicht).
     
  5. graphitto

    graphitto Wanderer

    Hmm, und was passiert, wenn du versuchst die Verbindung zu nutzen? Irgendeine Meldung o.ä.?

    gruß
     
  6. Walter Mehl

    Walter Mehl New Member

    Sollte es an der FIREWALL liegen? :eek:

    Damit das funktioniert, muss am iMac die Firewall deaktiviert (nicht empfehlenswert) oder die entsprechenden Ports offen sein, sprich: 80 für http, etc. pp...

    Cheers,

    Walter Mehl, Macwelt
     
  7. Macci

    Macci ausgewandert.

    Klar. Keine Verbindung...(hab das jetzt nicht wörtlich vor mir....aber Safari kann den Server nicht finden. Am iMac kann ers.
     
  8. Macci

    Macci ausgewandert.

    Ahja, das werd ich heute abend mal ausprobieren...also am besten Websharing aktivieren, das müsste dann ja Port 80 sein. Aber wieso er das nicht automatisch macht, wenn ich die Funktion "Internet gemeinsam nutzen" aktiviere...
     
  9. Ghostuser

    Ghostuser Active Member

    Hallo Macci

    Ich nehme an, dass bei der manuellen Konfiguration der Ethernet-Schnittstelle das Subnet korrekt definiert ist (255.255.255.0 oder kleiner).

    Hast du auch den DNS deines Providers im PB und iMac richtig konfiguriert?

    Gruss GU
     
  10. Macci

    Macci ausgewandert.

    Subnet ist okay.
    DNS? Brauch ich doch am iMac auch nicht...:eek:
    (Analogmodem - gibts da ne DNS, von der ich was wissen müsste?)
     
  11. Walter Mehl

    Walter Mehl New Member

    Weil Mac-OS X so sicher ist, dass es als Router genau nix weiterleitet :D

    Wenn Apple da die Ports aufmachen würde, hätte die Firma morgen in den USA einen Schadensersatzprozeß an der Backe, wetten? :rolleyes:

    Es kann auch am DNS liegen, ggf. solltest Du noch mal bei Deinem Provider nach einer gültigen IP-Adresse des DNS-Servers fragen (nur zur Sicherheit) und die am Powerbook eintragen oder halt mal mit einer IP-Adresse surfen, z. B. http://217.110.95.60 :)

    Cheerio,

    Walter
     
  12. graphitto

    graphitto Wanderer

    Die Provider-DNS hat nix mit oder ohne Modem zu tun. Die hat der Provider immer. Wenn es allerdings am iMac ohne Eintrag läuft, brauchst du sie auch am PB nicht.

    Schau noch mal in den Sharing Einstellungen nach. Irgendwo da hängt es. Was hast du denn alles aktiviert?

    gruß
     
  13. Macci

    Macci ausgewandert.

    Also die Einstellungen sind so wie oben beschrieben, Subnetz 255.255.255.0
    Der iMac als Router angegeben.
    Am iMac Internet freigegeben für alle Ethernet-angeschlossenen Rechner.
    Ich kanns aber erst heute abend ausprobieren, hab den iMac nicht dabei ;)
    Die DNS müsste doch nach erfolgter Einwahl am iMac abzulesen sein, oder?
     
  14. kawi

    kawi Revolution 666

    also ich habe auf dem mac der nicht direkt online geht immer einen DNS Eintrag in den Systemeinstellungen. So geht das auch. Sopnst sucht der die DNS auf dem als Router angegebenen Rechner und wenn dieser auch keinen hat sucht der sich blöd.
    Es sei denn du konfigurierst den zweiten mac nicht per hand vergebenen IP Adressen sondern per DHCP dann holt er sich die Daten automatisch vom ersten rechner der die Internetverbindung zur Verfügung stellt.
     
  15. kawi

    kawi Revolution 666

    Wenn du über DHCP die rechner verbunden hast - ja.
    Wenn du über manuelle Konfiguration die rechner verbunden hast - eigentlich nicht. (imho) In dem Fall will der rechner doch alles vorgekaut kriegen.
     
  16. Ghostuser

    Ghostuser Active Member

    Hallo Macci

    Der iMac wählt sich via ppp bei deinem Provider ein. Er sollte eigentlich die Angabe für den DNS so bekommen. Das PB weiss jedoch nichts davon. Es sollte aber wissen, wo es einen DNS zum Auflösen von Hostnamen bzw. einer URL finden kann.

    Wenn du am PB mit DHCP arbeiten würdest, so bekäme es die IP-Adresse des DNS automatisch. Ich weiss jedoch nicht, ob du den iMac dazu bringen kannst als DHCP-Server zu arbeiten. (Du kannst allenfalls versuchen die Ethernet Konfigurationen von iMac und PB auf DHCP zu stellen. Wielleicht arbeitet der iMac mit freigegebenem Internetzugriff auf der Ethernet Schnittstelle als DHCP-Server. Habe sowas jedoch nie probiert.)

    Gruss GU
     
  17. Macci

    Macci ausgewandert.

    DHCP - gutes Stichwort. Landet glatt auf der Aufgabenliste für heute abend.
     
  18. Walter Mehl

    Walter Mehl New Member

    Ich trau' es mir kaum zu sagen: Terminal

    Aber es geht auch mit dem Netzwerk-Dienstprogramm am iMac - unter "Lookup" einen Servernamen eingeben z.B. www.macwelt.de Option "dig" statt "nslookup" verwenden und auf Lookup klicken -> dann steht bei mir in der Antwort:

    ;; Query time: 15 msec
    ;; SERVER: 192.168.11.16#53(192.168.11.16)
    ;; WHEN: Wed Nov 17 13:38:41 2004
    ;; MSG SIZE rcvd: 104

    Die fette Zeile ist bei mir (also Macwelt-intern) die gesuchte IP des DNS-Servers.

    Cheers,
    Walter
     
  19. Macci

    Macci ausgewandert.

    Na da werd ich heute abend mal die Funzeltasten benutzen...das wäre ja gelacht :D
     
  20. Macci

    Macci ausgewandert.

    Okay, das funzt jetzt...war einfach in den Netzwerkeinstellungen des iMac noch auf Ethernet, nicht auf Modem gestellt *stirnpatsch*...aber welchen Port muss ich für Mail freigeben? So ganz ohne FW will ich denn doch nicht unterwegs sein ;)
     

Diese Seite empfehlen