MySQL-Datenbank startet nicht mehr

Dieses Thema im Forum "Software" wurde erstellt von graphitto, 3. September 2005.

  1. graphitto

    graphitto Wanderer

    Hallo Experten,

    ich habe hier das WebServerXKit in der aktuellen Version 1.1 installiert.
    Darin enthalten sind u.a. Apache 2.0.54 und MySQL 4.1.12.

    Seit zwei Tagen startet nun die MySQL-Datenbank nicht mehr. Weder automatisch beim Systemstart noch von Hand.

    Die letzten Änderungen, die ich am System vorgenommen habe, waren die Installation des Safari-Updates 1.3.1 und des Securitiy-Updates 7/2005 für Panther.

    Apache meldet übrigens im error_log:
    [Sat Sep 03 14:01:22 2005] [alert] (EAI 7)No address associated with nodename: mod_unique_id: unable to find IPv4 address of "emac"
    Configuration Failed

    Bereits gemacht habe ich eine De- und Neuinstallation des WebServerXKit, inkl. Zugriffsrechte-Reparatur.

    Hilft alles nix, der Datenbank-Server startet nicht.

    Auf dem Powerbook, ohne Safari- und Security-Update läuft dagegen alles ganz normal.

    Hat einer ne Idee, was ich noch machen kann?

    gruß
     
  2. Hallo

    Habe auch Panther laufen.
    Versuch mal Terminal: sudo apachectl graceful
    Adminpasswort eingeben.

    Kannst du dein MySQL-Passwort setzen?

    Gruss
    G
     
  3. graphitto

    graphitto Wanderer

    Hallo gratis,

    hab das im Terminal getestet, das sagt httpd gracefully started. Bringts also auch nicht.

    Hier mal die emac.local.err Datei aus dem mysql-Ordner:

    050903 14:01:19 mysqld started
    050903 14:01:20 [Warning] Setting lower_case_table_names=2 because file system for /usr/local/mysql/data/ is case insensitive
    050903 14:01:22 [ERROR] Can't start server : Bind on unix socket: Permission denied
    050903 14:01:22 [ERROR] Do you already have another mysqld server running on socket: /tmp/mysql.sock ?
    050903 14:01:22 [ERROR] Aborting

    050903 14:01:22 [Note] /usr/local/mysql/bin/mysqld: Shutdown complete

    050903 14:01:22 mysqld ended

    Es scheint so, als ob irgendein anderer Prozess oder Dienst den Unix-Socket blockiert, beziehungsweise ich plötzlich keine Rechte mehr dafür habe?

    Beim Passwort setzen meldet er auch einen Fehler.

    gruß
     
  4. Ich würde mit der Panther-CD booten und das MySQL-Passwort setzen (vor der Installationsroutine im Menu zu finden).
     
  5. graphitto

    graphitto Wanderer

    Sorry, aber wie soll das Datenbank-Passwort von der CD gesetzt werden können? Und was hat das mit dem Nicht-Starten der DB zu tun?

    gruß
     
  6. Falls du mit der Panther-CD startest, dann findest du im Menü Diskutility und Passwörter setzen. Das Nichtstarten der DB ist dann vielleicht weg. Mehr kann ich leider auch nicht sagen.
     
  7. graphitto

    graphitto Wanderer

    Wider besseres Wissen hab ich jetzt von CD gestartet. Das Setzen des DB-Passworts ist dort definitiv nicht möglich. Aber ums Passwort geht es ja eigentlich auch nicht, das kann nun mal nur bei gestartetem Server gesetzt werden.

    Trotzdem danke für dein Bemühen.

    gruß
     
  8. Wo ist er eigentlich, wenn man ihn braucht? :frown:
     
  9. fantomac

    fantomac New Member

    Bei solchen Antworten muss ich mich immer hinterfragen ob es nicht manchmal besser ist zu sagen: ich hab in dem Bereich wenig Ahnung und gib da mal lieber keinen Senf dazuab. Was hat den der Apache damit zu tun wenn die Mysql nicht mehr läuft? Wenn dann noch der Tip kommt mit der CD die Passwörter zu ändern ist es nicht mehr sehr weit zusagen: Installier mal deinen Rechner neu.

    Zum Problem:
    050903 14:01:22 [ERROR] Do you already have another mysqld server running on socket: /tmp/mysql.sock ?

    Schau mal in dem Tmp Ordner ob die datei dort vorhanden ist.
    Das sollte dich einen Schritt weiter bringen.
    Und es könnte vielleicht klappen wenn die datei gelöscht werden würde, wenn sie vorhanden ist.
     
  10. graphitto

    graphitto Wanderer

    hallo fantomac,

    das problem wird immer interessanter. glücklicherweise habe ich zwei rechner (emac und powerbook) zur verfügung. auf dem powerbook läuft die datenbank, auf dem emac nicht. die mysql.sock ist auf dem powerbook vorhanden, auf dem emac aber nicht. ob es hilft die datei vom PB auf den emac zu kopieren?

    gruß
     
  11. graphitto

    graphitto Wanderer

    Zitiere mich mal selber. Es hilft nicht. Langsam werd ich ratlos. :angry:

    gruß
     
  12. fantomac

    fantomac New Member

  13. volkspost

    volkspost New Member

    Moin Graphitto!
    Mal ne Frage vorab.
    Laufen auf dem Powerbook dieselben Versionen von Mac-OS X und MySQL?
    Nutzt Du mit der neuen Version bereits existierende Datenbanken mit Tables?

    Ich hab unlängst online zu dem Thema was gelesen, glaub ich.
    Das lower_case-Feature bei MySQL wurde mit Version 4.0.6 oder so eingeführt und macht ab 4.0.17 die genannten Probleme. Es soll eigentlich bei Betriebssystemen, die nicht case-sensitive sind (also "dokument.txt" und "duCUMENt.txt" als ein und denselben ansehen), damit verbundene Probleme ausschalten, dazu gehört Panther.
    So ist für MySQL immer ein Unterschied zwischen meinTable und meintable vorhanden, für HFS+ unter Panther aber nicht.
    MySQL setzt deshalb den Wert auf 2 (alle Tablenamen werden als kleingeschrieben angenommen). Du hast vermutlich einen Table, der gemischt geschrieben ist, wie fast alle User (zum Beispiel adressID). MySQL sucht aber nach adressid und findet nix.
    Nun könnte man meinen, in der my.cnf das Problem mit "set-variable =
    lower_case_table_names=0" zu lösen, also bei den Tables case-sensitive zu arbeiten. Leider übernimmt MySQL das nicht. Dazu gibt es ne Menge Bug-Reports.

    Ich bin mir zwar nicht ganz klar, wie dieses bekannte Problem mit Deiner Intallation zu tun hat, vermute dort allerding den Knackpunkt.

    volkspost
     
  14. graphitto

    graphitto Wanderer

    Morgen fantomac,

    die Rechte waren entscheidend. Ich hab den tmp-Ordner jetzt für »Andere« auf »lesen und schreiben« gesetzt und die DB startet wieder. Danke.

    Bleibt die Frage, wieso die Rechte dort verstellt waren? Ich rühre solche Ordner für gewöhnlich nihct an.

    gruß
     
  15. volkspost

    volkspost New Member

    Moin Graphitto,
    prima, dass es jetzt wieder bei Dir läuft.
    Hab gerade mal bei bugs.mysql.com nachgeschaut. Das Problem (socket und nicht starten) scheint aufzutauchen, wenn ein MySQL-Update unter Mac-OS X durchgeführt wird, Zitat "This is happening because the pre/post installation scripts in the installer are only running before and after fresh installs, not when installing an upgrade."
    Mehr findest Du unter http://bugs.mysql.com/bug.php?id=11380

    Viele Grüße
    volkspost
     
  16. @volkspost. Ich verstehe die 2. Zeile nicht:

    $ cd /usr/local/mysql
    $ ./scripts/mysql_install_db --rpm
    $ chown -R mysql data

    Thx. G
     
  17. graphitto

    graphitto Wanderer

    Moin Volkspost,

    die Frage ist, was für ein Update sollte das gewesen sein? Das könnte dann ja nur ein Bestandteil des Safari- oder des Security-Updates gewesen sein?
    Schon komisch.

    Was deinen ersten Post angeht, das lower-case-Problem kenne ich, darum ging es aber auch nicht, sonder um die nachfolgenden access denied-Fehler. Trotzdem Danke.

    Mein Problem ist allerdings erst teilweise gelöst. Jetzt startet zwar der DB-Server, aber die Anwendungen, z. B. phpMyAdmin verweigern den Zugriff wegen falscher SQL-User-Angaben. Nun hab ich die MySQL-User allerdings über phpMyAdmin angelegt und die Passworte durchaus im Kopf. Nur komme ich nicht mehr ran.
    Hast du da eine Idee?

    gruß
     
  18. Ich würde die 'MySQL.prefPane' installieren. Ist ein Teil aus folgendem Download und tut dem System bestimmt nicht weh: http://www.serverlogistics.com/mysql.php#download

    In der Anlage siehst du wie du damit das Passwort setzen und MySQL initialisieren kannst. Very Apple-like gemacht. :D
     

    Anhänge:

  19. graphitto

    graphitto Wanderer

    Danke gratis,

    aber das Problem besteht darin, das ich a) ein solches PrefPane mit dem WebserverXKit bereits habe und vor allem b) das es nicht um das root-Passwort für die Datenbank, sondern um die User-Accounts in der Datenbank geht. Die hatte ich vorher gesetzt und komm nun nicht mehr ran.

    gruß
     
  20. Das war lapitar bemerkt. :confused: und ich habs überlesen. Sorry.
     

Diese Seite empfehlen